Posts by synth

    Jopp, wird dann via Cronjob gestartet ... muss noch ein paar Sachen "überlegen"


    Das py-Script hier ist ein RSS-Downloader für einen Online-Video-Recorder ... youTV ...
    der Part funktioniert mittlerweile sehr gut ... wird so lange ich über die grafische Oberfläche arbeite halt noch von Hand gestartet.
    Da ich den Pi aber auch nicht andauernd neu starte ... egal.



    Nächster Schritt ist das Ein- und Ausschalten einer externen HDD (sowie ich sie gemountet bekomme, siehe Pi2 Raspbian + 3TB HDD?), sowie das verschieben der Videos auf diese HDD ... aber im großen und Ganzen steht hier der Code so weit schon, muss noch ein paar Parameter bestimmen und für die Ausgabe auf einer Digit-Anzeige coden ... aber so langsam wirds. :)


    Mein py-Script zur Kontrolle ob mein Internetzugang funktioniert und Protokollierung, wenn er nicht funktioniert (um meinem Anbieter ans Schienbein zu pinkeln) funktionierte bis auf Kleinigkeiten auf Anhieb. :)


    THNX, LG synth

    all right ...


    sudo lsusb:

    Code
    pi@myPi:~ $ sudo lsusb
    Bus 001 Device 005: ID 0bda:0109 Realtek Semiconductor Corp.
    Bus 001 Device 004: ID 24ae:1004
    Bus 001 Device 008: ID 13fd:1240 Initio Corporation
    Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
    Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


    sudo blkid:

    Code
    pi@myPi:~ $ sudo blkid
    /dev/mmcblk0: PTUUID="3e7fd08e" PTTYPE="dos"
    /dev/mmcblk0p1: SEC_TYPE="msdos" LABEL="boot" UUID="EC6A-A252" TYPE="vfat" PARTUUID="3e7fd08e-01"
    /dev/mmcblk0p2: UUID="23c4ddbc-85fa-4cea-b96b-edae0bb138c9" TYPE="ext4" PARTUUID="3e7fd08e-02"
    /dev/sda1: LABEL="64GB_Hybrid" UUID="D62E96D12E96A9CF" TYPE="ntfs"
    /dev/sdb: PTTYPE="PMBR"



    sudo fdisk -l:


    Verwendet wird das aktuelle "Jessie" auf einer 8GB microSD.
    Gerne würde ich natürlich die HDD mit einer durchgehenden Partition verwenden. Ausserdem ist ein 64gb-USB-Stick (hier 64GB_Hybrid) angesteckt.


    Danke! ;)

    Ich habs nicht zum Laufen bekommen ... :(
    macht aber auch im Moment nix mehr ... so weit läuft alles was ich brauche und ich werde demnächst auf eine reine Ausführung ohne grafische Oberfläche umsteigen. :)
    THNX

    Hallo Ihr Lieben,
    erstmal ... Frohe Ostern ...


    Jetzt aber zum Thema ...
    ich verzweifel so langsam ...
    ich habe eine 3TB-HDD, welche ich an meinem Pi2 anschließen möchte, aber egal was ich mache, ich bekomme sie nicht gemountet.


    Weder mit einer 3TB-Partition (NTFS), noch mit einer 1,8TB + Rest-Partition ...



    Ich habe so ziemlich alles versucht, was ich finden konnte.
    Hat jmd. einen Tip für mich?


    THNX, LG synth


    Probiert habe ich u.a.:
    http://www.axllent.org/docs/view/auto-mounting-usb-storage/
    http://jankarres.de/2013/01/ra…usb-festplatte-einbinden/
    http://devtidbits.com/2013/03/…ith-to-your-raspberry-pi/
    + ein paar mehr

    Also ich hab heute Nacht einen Gedankenblitz gehabt ...


    Vorweg, ich nutze das Android-Tool "Raspicast", um auf meinem Pi runter geladene Videos anzuschauen. Funktioniert hervorragend!


    Jetzt ist mir heute Nacht aufgefallen, dass das Tool via ssh auf den Pi zugreift und auch die gesamte Verzeichnisstruktur anzeigt. Also, könnte es ja ein Tool geben, mit dem ich via SSH mein Laufwerk einbinden kann ... und das ist/war die Lösung.


    Ich habe zwei Tools gefunden, mit welchen das Ganze möglich ist.
    - SSHFS-Manager
    - Swish


    Ich habe den SSHFS-Manager ausgewählt, weil er nicht erst komplette Files kopieren muss (z.B. Videos) - wie Swish - sondern diese direkt abspielen kann.


    Hier ein Artikel zu dem Thema: linuxundich.de


    Link: SSHFS-Manager
    Link: Swish


    Wichtig, beide werden nicht mehr entwickelt. Habe heute früh SSHFS getestet und es scheint sehr stabil zu laufen. Einziges Manko, es mountet das SSH-Laufwerk nicht wieder automatisch, wenn ich den Pi neu starte. Hierzu muss man den Manager dann ggf. einfach von Hand beenden und neu starten.


    Vorteile:
    - Der Pi wird nicht mit dem Samba belastet
    - Nicht jeder kann auf das Netzlaufwerk, es wird über Benutzerkennung und benötigte Software "gesichert".


    Nachteile:
    - Nicht jeder kann auf das Netzlaufwerk, es wird über Benutzerkennung und benötigte Software "gesichert".


    Für mich ist das aktuell die ideale Lösung. ;)
    LG synth

    Hm ... hört sich gut an, bekomme swat leider nicht installiert ...

    Code
    Package swat is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    E: Package 'swat' has no installation candidate


    Habe mich dazu entschlossen mich nochmal in Ruhe über die Samba-Referenzen her zu machen ... und dann nochmal los zu legen.

    Hallo Ihr Lieben,
    gibt es eigentlich eine Möglichkeit eine Konsole automatisiert nach dem Autostart hoch zu fahren und dort einen Befehl (python-Script) auszuführen?


    Später soll der Pi automatisch in die Konsole und nicht mehr in den x-Server starten, im Moment benötige ich aber den x-Server noch und somit wäre ein Autostart des Scripts in die Konsole gut.


    THNX, LG synth

    Der ist vorher gar nicht da gewesen ... erst seit ich Samba aufgesetzt habe ist er im Netzwerk auffindbar. :)
    Auch ein Win-Reboot (2 Rechner + 2 Android-Geräte) ändert das nicht.


    EDIT:
    Hab mal die "Diagnose" durch laufen gelassen ...
    "Gefundene Probleme:
    Die Verbindung wird vom REmotegerät bzw. der Ressource nicht akzeptiert."



    EDIT2:
    Vllt. hilft das ja weiter ... habe via ssh keinen Zugriff mit dem user "PCUSER" auf den Ordner "/media/USB-Stick"
    Nur wie bekomme ich es jetzt hin, dass pcuser und pi (beide in der Gruppe pi) darauf zugreifen dürfen?

    Hallo Ihr Lieben,
    ich habe jetzt schon diverse Links durch, hier im Forum und auch über google, aber ich komme nicht weiter.


    Ich habe Raspbian Jessie frisch aufgesetzt.


    Jetzt Samba angefangen zu installieren ...



    Ich finde meinen Pi zwar jetzt in der Workgroup, aber kann nicht mit dem user pcuser drauf zugreifen. Die Kennwörter im Win-System und im Pi sind für pcuser selbstverständlich identisch.


    Habe es genauso eingerichtet, wie bei meinem "alten" System, welches allerdings kein jessie, sondern wheezy war.


    Hat jmd. einen Tip?
    THNX, LG Ralf aka synth

    Frisch aufgesetzt hatte ich ihn nicht, sind halt ein paar Testdateien und ein Script, welches ich zum Laufen bekommen habe drauf. Müsste jetzt das Script zwar nochmal neu abändern (in der Hoffnung, dass ich das hin bekomme) ... na ja ... werde wohl nicht drumrum kommen. :(


    EDIT: Habe radikal das Image platt gemacht und neu angefangen ... zuvor meine Scripte noch runter gezogen.

    Hab ich natürlich vergessen zu schreiben ... den "Trick" hab ich schon probiert ...
    Tastaturlayout ist korrekt, wenn ich ein falsches Kennwort nutze gibt es auch die Meldung, dass das falsch ist, das Kennwort ist richtig u. richtig geschrieben ... wie gesagt ... Bildschirm wird schwarz und dann geht es zurück zum Login, als hätte ich garnix eingegeben.

    Hallo Ihr Lieben,
    ich bin gerade am verzweifeln.


    Habe ein Raspbian (das aktuelle) eingerichtet.


    Login auf Grafische Oberfläche, automatischer Login.
    Ändere diesen Login via raspi-config auf Konsole mit automtischem Login ...
    ändere erneut via raspi-config auf die Grafische Oberfläche mit automatischem Login ...


    Jetzt werde ich mit grafischer Oberfläche zum Login aufgefordert ...
    User: pi
    Kennwort: raspberry


    Es erscheint keine Meldung, dass das Kennwort falsch wäre ... nach dem Bestätigen wird der Bildschirm kurz schwarz, danach habe ich wieder das Login-Fenster.


    mit root ... selbes Spiel.


    Ich weiss nimmer weiter.
    THNX, LG synth

    Hallo Ihr Lieben,
    ich bin gerade unsicher, ob ich auf dem richtigen Weg bin.


    Aktuell starte ich meinen Pi2 in die grafische Oberfläche.
    Dort starte ich via LX-Terminal mein python-Script. Im Terminal wird nun alles, was das Script ausgibt angezeigt.


    Jetzt habe ich das einfach mal umgestellt, nicht in den X-Server gestartet und versucht das python-Script in der Konstole zu starten.
    Ergebnis: Der angesteckte USB-Stick wurde nicht unter "/media/pi/USB-Stick" gefunden. (Das python-Script greift auf diesen zu.)


    Muss ich jetzt meinen USB-Stick manuell mounten, oder hab ich irgendwo einen Denkfehler ...!?
    THNX, LG synth



    PS: Ich hab bisher nur in der grafischen Oberfläche gearbeitet, allerdings viel mit dem LX-Terminal

    So, ganz banaler Fehler ...
    Danke erstmal framp ... Du hast zwar nicht die Lösung gehabt, aber meinen Denkprozess angekurbelt ...


    ich hatte (hab natürlich nicht mehr dran gedacht) irgendwann mitten in der Nacht mal die Datenbank-Datei selber von Hand erzeugt ... hat logischer Weise nicht die passenden Rechte ... somit ist er da "gegen" geknallt ... hab ihn die Datei jetzt einfach nochmal selber erstellen lassen ... et voilà ... es läuft.


    *KopfGegenDieWandHau*


    Sorry für die Umstände und Danke für die Mühe!