Posts by noobee

    japp, ich hab gefühlt bereits alle escape sequenzen probiert. deine zwei oberen bringen den fehler: ERROR at line 1: Unknown command '\''. egal ob mit einem oder 2 Hochkomma.


    ich hab im netz noch gefunden, dass es mit \042 auch gehen könnte. also so hier:

    Code
    mysql -D DBname -u root -pgeheim -e "INSERT INTO hardware (serial) VALUES ("\042$serial\042"); "


    das gibt zwar keinen fehler, schreibt mir aber den wert 42042 in die DB. ich geb hier mal die komplette bash an


    Bash
    #!/bin/bash
    
    
    serial=sudo cat /proc/cpuinfo | grep Serial | tr -d " " | cut -d ":" -f 2
    #echo $serial
    mysql -D DBname -u root -pgeheim -e "CREATE TABLE IF NOT EXISTS hardware (id INT NOT NULL AUTO_INCREMENT, serial varchar(55), PRIMARY KEY (id) );"
    mysql -D DBname -u root -pgeheim -e "INSERT INTO hardware (serial) VALUES ("$serial"); "

    also wenn ich den befehl

    Code
    mysql -D DBname-u root -pgeheim -e "INSERT INTO hardware (serial) VALUES ('45636463e'); "

    exakt so in der konsole ausführe, passt alles wqunderbar. dann steht in meiner tabelle auch der wert "45636463e" drin. es liegt also nur an der variable. da mach ich immer den fehler

    Dein $serial besteht aus mehreren "Worten" durch Leerzeichen getrennt ...Das müsste dann vermutlich mit maskierten, einfachen oder auch doppelten Hochkommas umschlossen werden.


    nein, es steht nur ein langer string drin. aber selbst mit hochkomma hat es nicht gefunzt. weder einfache noch doppelte. der eintrag in der tabelle war immer leer.


    ich hatte auch schon mit \042 getestet. auch ohne erfolg


    in $serial würde das drin stehen: 00215846325156alux


    die spalte heißt übrigens serial und die variable aus bash heißt auch $serial

    ich bin grad am verzweifeln, da ich nicht die richtige escape-sequenz finde. der INSERT befehl geht einfach nicht. folgender code:



    Bash
    #!/bin/bash
    
    
    serial=sudo mache was
    #echo $serial
    
    
    mysql -D DBname -u root -pgeheimespw -e "CREATE TABLE IF NOT EXISTS hardware (id INT NOT NULL AUTO_INCREMENT, serial varchar(55), PRIMARY KEY (id) );"
    mysql -D DBname -u root -pgeheimespw -e "INSERT INTO hardware (serial) VALUES ("$serial") ;"



    auch ein

    Quote

    mysql -D DBname -u root -pgeheimespw -e "INSERT INTO hardware (serial) VALUES ("[font="Consolas, Menlo, Monaco,"]${serial}") ;"[/font]


    [font="Consolas, Menlo, Monaco,"]geht nicht[/font]

    so ein 3V EMagnet kann ich doch dann direkt an den Pi anschließen und saft auf den entsprechenden GPIO Pin legen, richtig? Dann müsste der doch magnetisch werden... Das wäre ja genau so, wie ich es mir vorgestellt habe :)


    PS: Um was für Stärken geht es denn hier? Reden wir von Magneten, die viele Ampere Strom brauchen?


    https://www.amazon.de/Elektromagnet-haltenden-Elektromagneten-Aufzug-Elektromotor/dp/B008OENGU0/ref=sr_1_1?ie=UTF8&qid=1473430077&sr=8-1&keywords=elektromagneten (Affiliate-Link)
    ich dachte ja nur an diesen kleinen hier. der hat Eingangsspannung: 12V DC / Stromaufnahme 0,33 A / Stromverbrauch: 4W. Kann ich den auch mit einem Akku/Batterien schalten? Oder ist das schon zu viel, so dass ich definitiv mehr als nen Akku brauch? Sorry, aber ich kenn mich da eher noch nicht so aus. Anfangs sollte das alles mal mit Akku laufen. Aber das kann ich mir wohl ausm Kopf schlagen.


    Der Magnet hat übrigens ne Haltekraft von 11lbs / 5Kg. Wenn weniger Haltekraft auch weniger Ampere bedeutet, reichen mir auch 2kg

    Mahlzeit @ Bastler :thumbs1:,


    ich hoffe, dass mich jetzt keiner schlägt. Ich hab da mal eine Frage. Ich hab bei Amazon nach Elektromagneten gesucht. Jedoch konnte ich dort nur welche finden, die mit 12V betrieben werden müssen. Nun schafft der Pi ja nur 5V. Da wäre meine Frage, ob es überhaupt Elektromagneten für den Pi gibt.


    Da ich kein Elektriker bin, habe ich also null Plan von sowas. Jemand ne Idee, wie man das Problem trotzdem lösen könnte.


    Da ich noch zwei andere Ideen habe mit dem Elektromagneten, möchte ich vom Thema ElMag erstmal nicht weggehen... Bevor wieder Fragen kommen, ob das Projekt nicht auch anders geht :fies: :fies:

    Gibt es für den Pi3 eine Art Übersicht, welche Argumente in der config.txt und cmdline.txt genutzt werden können?
    Sicher gibt es die meist genutzten über google zu finden... Ich hätte aber eben auch gerne die eher "unbekannteren", falls es noch mehr gibt :s :s

    Quote

    Du hast nun auf Wlan0 eine feste IP und am Kabelanschluss deine Router auf einer anderen IP hängen??


    japp,
    Wlan0 = 192.168.200.1, fest gesetzt.
    Eth0 = 192.168.2.107 (automatisch vom Router)


    Quote

    Du kannst die IP des Wlan's vom Mobile anpingen??


    anpingen vom Handy? Also ich sehe auf meinem Handy den Wlan-AccPoint. Wenn ich auf verbinden gehe, bekommt das Handy aber keine IP zugewiesen.

    nein, das einzige was ich geändert habe ist: "sudo update-rc.d hostapd enable"
    da ich "wusste", dass dieser befehl nicht funzt, hatte ich den damals schon nicht benutzt. jetzt habe ich den aber eingegeben. das ist die einzige Änderung


    EDIT:
    Ok, da war ich etwas voreilig. Also der AccPoint erscheint nach dem reboot nun doch. Nur Verbindung bekomme ich mit keinem Handy mehr

    leider geht AccPpint nicht mehr.


    hostapd status sagt:

    Code
    hostapd.service - LSB: Advanced IEEE 802.11 management daemon
     Loaded: loaded (/etc/init.d/hostapd)
     Active: active (exited) since Mo 2016-08-04 02:09:55 CEST; 1min 59sec ago
    Process: 538 ExecStart=/etc/init.d/hostapd start (code=exited, status=0/SUCCESS)
    
    
    Aug 04 02:09:55 Test hostapd[538]: Starting advanced IEEE 802.11 management: hostapd failed!


    ich sehe dieses mal mein AccPoint auch nicht mehr kurz. Vorher hatte ich den AccPoint nach nem reboot des Pi3 wenigstens noch kurz aufm Handy sehen können

    So, also. Jetzt hab ich erstmal meinen alten Pi3 in der Mitte zerknickt, um n bissi Frust abzulassen -.-


    Also nochmal von vorne. Es ist jetzt nach ne reboot alles soweit schick. Eth0 hat die 192.168.2.107 (mit EthKabel), Wlan0 hat nun auch die gewünschte 192.168.200.1 (ohne Kabel :D )


    zu deinen Fragen


    Ich hoffe das du den intregierten Wlanadapter des Rpi3 nutzt??

    na logo ;)


    Hast du auch ein Netzwerkkabel dran??

    japp


    Aber egal, wenn du den ACC auf Wlan machen willst, musst du eine feste IP auf Wlan haben. Und das hat, wie schon geschrieben, erstmal nicht mit den gewünschten Diensten zutun.

    ok, nun hab ich die auch


    Zwischenstand nun:
    nach dem 4. reboot sind die IPs immer noch vorhanden. Das wäre also soweit schonmal schick. Ich sehe den AccPoint nach dem manuellen "sudo service hostapd restart" auch, es kann aber keine IP bezogen werden. Es scheint, als wären wir zusammen auf dem richtigen Weg :-p

    mhh, naja. aber die Eintragungen in der "/etc/network/interfaces" brauchte ich ja eigentlich, um den AccPoint erfolgreich zu betreiben. Da kann ich also nix ändern. Und die Eintragungen in der "/etc/dhcpcd.conf" haben nix gebracht. Also es gab zwar keine Probleme, es gab aber eben auch nicht die erhoffte feste IP für Wlan0 :(

    boah, verdammt :( ich glaub, jetzt hab ich alles zerschossen. welche ist denn die richtige datei, mit der ich die IP des WLAN0 einstelle?


    Ich hab jetzt in der /etc/udhcpd.conf folgendes stehen:

    Code
    start 192.168.200.20
    end 192.168.200.254
    
    
    opt dns 192.168.200.1
    option subnet 255.255.255.0
    opt router 192.168.200.1


    dann in der /etc/network/interfaces

    Code
    iface lo inet loopback
    iface eth0 inet dhcp
    
    
    allow hotplug wlan0
    iface wlan0 inet static
    address 192.168.200.1
    netmask 255.255.255.0


    und nun soll ich auch noch in der /etc/dhcpcd.conf das hier eintragen?

    Code
    interface wlan0
    static ip_address=192.168.200.1/24
    static routers=192.168.1.1
    static domain_name_servers=192.168.200.1
    option noipv6


    Da bin ich n bissi überfordert. Ich hab ja nun teilweise IPs doppelt drin stehen. So wird Wlan0 nach dem reboot übrigens nicht erkannt. Ich muss also wieder händisch "sudo ifconfig wlan0 192.168.200.1" machen :(