Posts by noobee

    also eigentlich habe ich in der /etc/networks/interfaces eine feste IP für wlan0 vergeben. Die ist aber nach nem reboot nicht mehr vorhanden. Ein ifconfig zeigt, dass es wlan0 nicht gibt. Deshalb hatte ich das händig über sudo ifconfig wlan0 192.168.xxx.1 eingegeben. Ich dachte, das geht auch über rc.local - tut es nun aber nicht.
    Jetzt leuchtet mir aber auch ein, warum u.U. hostapd nicht geht. Sicher deshalb, weil wlan0 keine IP hatte, denn über /etc/networks/interfaces ging es ja nicht.
    Ok, ich stelle also nach jedem reboot die IP neu ein, restarte udhcpd und hostapd und dann gehts. dies gilt es mittels rc.local zu automatisieren.
    udhcpd und hostapd mittels rc.local kann nicht funktionieren, da ich vorher (am liebsten über rc.local) erst die IP von wlan0 festlegen muss :helpnew: :helpnew:

    ui, ja. also die Ausgabe von demesg (kannte ich vorher nicht) ist zu lang, um sie zu posten.
    und hostapd status sagt:

    Code
    hostapd.service - LSB: Advanced IEEE 802.11 management daemon
      Loaded: loaded (/etc/init.d/hostapd)
      Active: active (exited) since Mo 2016-08-01 22:37:55 CEST; 1h 10min ago
     Process: 7078 ExecStop=/etc/init.d/hostapd stop (code=exited, status=0/SUCCESS)
     Process: 7084 ExecStart=/etc/init.d/hostapd start (code=exited, status=0/SUCCESS)
    
    
    Aug 01 22:37:55 Test hostapd[7084]: Starting advanced IEEE 802.11 management: hostapd failed!


    und direkt nach nem redtart von hostapd:

    Code
    hostapd.service - LSB: Advanced IEEE 802.11 management daemon
      Loaded: loaded (/etc/init.d/hostapd)
      Active: active (exited) since Mo 2016-08-01 22:37:55 CEST; 1h 12min ago
     Process: 7078 ExecStop=/etc/init.d/hostapd stop (code=exited, status=0/SUCCESS)
     Process: 7084 ExecStart=/etc/init.d/hostapd start (code=exited, status=0/SUCCESS)
    
    
    Aug 01 22:37:55 Test hostapd[7084]: Starting advanced IEEE 802.11 management: hostapd failed!


    es ist hilfreich mal zu posten, wie du die Services startest.


    Also, mein erster Versuch war in der .xsession der Eintrag "sudo service hostapd restart" - ohne Erfolg.
    Dann in die rc.local der Eintrag "sudo service hostapd restart" geht auch nicht. Bzw. scheint es ja kurz zu gehen, dann wird aber exited...




    Und hast du mal in den Logdateien bzw. journalctl befragt??


    nein, wie kann ich das am Besten tun? Also ich meine so, dass es ein verwertbares Ergebnis gibt :daumendreh2: :daumendreh2:

    Hallo@community,


    ich habe nach der Anleitung http://www.forum-raspberrypi.d…kalem-webserver-betreiben einen AccPoint erstellt. Nach jedem reboot sehe ich auf dem Handy kurz den AccPoint vom RPi3. Jedoch verschwindet der sofort wieder. Ich muss jedes Mal ein
    sudo service hostapd restart / sudo service udhcpd restart eingeben, damit mein AccPoint läuft. Diese Eintragung habe ich bereits gemacht: sudo update-rc.d hostapd enable + sudo update-rc.d udhcpd enable.


    Falls es eine Rolle spielt: der RPi3 startet ohne Login. Ich lande also in der Konsole ohne AutoLogin. Ist auch so gewollt :rolleyes: Oder geht der AccPoint nur, wenn man sich eingeloggt hat? Das wäre ärgerlich :helpnew:


    EDIT:
    mittels "sudo systemctl list-utils -t service" sehe ich, dass bei beiden (hostapd und udhcpd) folgerndes steht: loaded active exited
    Warum sind denn beide beendet? Wieso laufen die nicht mehr?

    Quote

    Bevor ich dazu noch mehr texte wäre für mich wichtig zu wissen welche Dateien du in /etc/ verändern willst?


    mhh, das wären gleich mehrere:
    /etc/udhcpd.conf
    /etc/network/interfaces
    /etc/hostapd/hostapd.conf
    im Moment würde ich die 3 Dateien alle in die visudo eintragen, um www-data die Rechte zu gewähren

    Mahlzeit,


    wie es der Titel schon sagt... Ich möchte mittels meiner Webanwendung (also als user "www-data") in den Ordner /etc ein paar *.conf Dateien löschen/erzeugen/befüllen. Scheinbar hat der user "www-data" aus Sicherheitsgründen keine Rechte, dies zu tun. Wie kann ich für o.g. Aktion die Rechte einräumen?


    EDIT: eine Möglichkeit wäre doch, im Ordner /var/www/html/ eine test.sh zu erstellen. Dann mittels visudo folgenden Eintrag:

    Code
    www-data ALL=NOPASSWD: /var/ww/html/test.sh


    Gibt es da sicherheitsrelevante Aspekte, welche dagegen sprechen? Bzw. könnte man diese Art über visudo evtl. sicherer machen? Oder ist das schon "recht sicher" :helpnew: :helpnew:

    moin@community,


    ich habe mich mal in den manpages von fbi umgeschaut. dort gibt es keine option, das gewünschte bild für eine bestimmte dauer anzeigen zu lassen.


    folgende versuche habe ich getestet:

    Code
    /usr/bin/fbi -T 1 -noverbose -a /etc/splash.jpg

    --> zeigt das bild für knapp 1sec an


    meine idee: ich kopiere das bild und nenne sie splash1.jpg, ..., splash4.jpg

    Code
    /usr/bin/fbi -T 1 -t 10 -noverbose -a /etc/*.jpg

    --> alle 5 bilder (*.jpg im ordner /etc/) werden ignoriert
    "-t 10" bedeutet, dass es ein übergang von 10sec zwischen den bildern gibt. dieser ist jedoch schwarz. ich habe also 10sec einen black screen und danach keine der splash.jpg gesehen - auch nicht das erste splash.jpg
    "--timeout" ändert nichts, ist wohl das selbe wie "-t"


    Code
    /usr/bin/fbi -T 3 -noverbose -a /etc/splash.jpg


    zeigt mir den splashcreen wieder für knapp ne sec an, mehr nicht - ich hab in der boot.txt (oder war es die config.txt) "tty 3" eingetragen, deshalb dachte ich, ich teste mal "fbi -T 3" :(


    hier nochmal das ganze script, wo ich den splashscreen nutzen wollte:

    boah spitze. die lösung war mal wieder total einfach :(
    so, wie kkopi es geschrieben hat. Der Fehler war die fehlende Klammer. Die war vorher noch da, hab ich aber dann bei dem Befehl mit c&p verloren. Damit hatte ich dann wohl 2 Fehler. Datenbankname stand vorher auch noch an der falschen Stelle. Dann hab ich DBname umpositioniert - nur leider ging es trotzdem nicht (eben wegen der Klammer).
    Wenn nur alles so einfach zu lösen wäre. Da das nur ein erster Test war, wird jetzt umgebaut auf mysqli mit Variablen. Und immer mit dem Wissen, nach stundenlangem Coden die Zahlen nicht mehr von den Buchstaben unterscheiden zu können... Vllt tut ne Pause doch mal gut :thumbs1: :thumbs1:


    Ihr seid die Besten, Dankööö :bravo2: :bravo2: :bravo2:


    EDIT: warum shell_exec() und nicht exec() ? Mhhh, gibt es gute Gründe dafür? Ist es vllt. schneller, sicherer, fehlertoleranter, einfacher ?? Ich lass mich da gern beraten :shy: :shy:

    moinmoin@community,


    mal wieder eine Frage von mir. Ich versuche mittels shell_exec eine Tabelle in einer DB anzulegen. Mein aktueller Code macht dies jedoch nicht so recht.


    Code
    $string = "mysql -D DBname -u DBuser -pDBpass -e \"CREATE TABLE testtabelle(id INT NOT NULL AUTO_INCREMENT, PRIMARY KEY ( id );\" ";
    $cmd = escapeshellcmd($string);
    $test = shell_exec($cmd);
    echo $test;


    seltsamerweise funzt der selbe Code, wenn ich mir nur die Tables anzeigen lassen will.


    Code
    $string = "mysql -D DBname -u DBuser -pDBpass -e \"show tables\" ";
    $cmd = escapeshellcmd($string);
    $test = shell_exec($cmd);
    echo $test;


    Ich frage mich nun, warum ich keine Tabelle damit erzeugen kann. Mein CREATE-Statement ist nicht falsch. Ich habe es auch als root getestet. Hat also auch nix mit Rechten zu tun. Gibt es andere Probleme, die ich hier vergesse?


    Die Eingabe direkt in der Konsole bringt aber auch keinen Erfolg:

    Code
    mysql -D DBname -u DBuser -pDBpass -e "CREATE TABLE testtabelle(id INT NOT NULL AUTO_INCREMENT, PRIMARY KEY ( id );"

    Nabend @community,


    danke für die saubere Anleitung. Bei mir funzt scheinbar alles. Aber eben nur scheinbar. Mein Pi3 bekommt immer die IP 169.254.20.36 zugewiesen, obwohl es doch die 192.168.0.1 sein müsste. Alle Eintragungen sind gemacht, mit dem Handy kann ich mich auch ins neue WLAN des Pi3 einwählen :thumbs1: Aber die index.php kann ich nicht abrufen :s Es sieht so aus, als sei der Pi3 nicht erreichbar ?!?


    ok, 1. Fehler gefunden. Mein Pi3 speichert die IP nicht. "sudo ifconfig wlan0 192.168.0.1" bleibt so lange zugewiesen, bis ein reboot kommt. dann ist die IP 169.254.20.36. Danach geht dann auch "sudo service hostapd restart" nicht mehr. Ich muss also nach jedem reboot erst die IP zuweisen und dann "hostapd restart" und "udhcpd restart" machen.


    2. Fehler: ich komm nur mit dem einen Handy drauf. Das zweite funzt nicht mehr :s ich hab aber 192.168.0.2 - 192.168.0.254 zugelassen

    Quote

    Um den Pi über GPIO mit Strom zu versorgen bieten sich dir genau zwei Pins an.


    mhh, sind das die beiden 3,3V Pins oder die beiden 5V Pins?


    Quote

    Dies könnte man aber durch eine externe Absicherung ( z.B. Sicherung / Polyfuse bzw. TVS Diode ) verhindern.


    Ahh ja, Polyfuse hab ich in dem Zusammenhang bei Google auch schon gelesen. Da werd ich mich mal mit beschäftigen. Danke

    Moin@community :thumbs1:


    ich hätte da mal ne grundsätzliche Frage zur Stromversorgung des Pi 3 über GPIO. Im Anhang hab ich n Bild aus dem Forum angehängt, nur zum Verständnis.
    Da ich noch unbeleckt bin was das Thema "Basteln mit dem Pi" angeht, mal ein paar Fragen.
    - Ich hab bei Google gelesen, dass es grundsätzlich keine Rolle spielt, welche Pins den Strom aufnehmen. Ich kann mir nicht vorstellen, dass das wirklich egal ist. Stimmt das?
    - Gibt es eine Art "Standardanschlussschema", wie man den Pi 3 am Besten über GPIO mit Strom versorgt?
    - der Verbraucher (Pi 3 + Zubehör) zieht ja nur so viel Strom, wie er braucht. Lege ich jetzt die gewünschten 5V 2,1A an, ist soweit sicher alles i.O. Was aber, wenn durch Spannungsspitzen kurzzeitig (oder im worst case auch über längere Zeit) mehr anliegt? Also mehr als 5V bzw. 2,1A? Da die Sicherung (welche es wohl beim Anschluss über MicroUSB gibt) ja praktisch nicht vorhanden ist, muss ich mir gedanklich schon ein kleines Feuerchen auf meinem Schreibtisch vorstellen :D ??