Posts by Vagabund

    Hey,


    wenn ich dich richtig verstehe willst du den Strom welcher für den Motor notwendig ist über die GPIO schalten.
    Dies kannst du über ein Relais und/oder Transistor lösen, abhängig von deinem speziellen Anwendungsfall. Lies dich einfach mal dazu ein.


    cheers,
    Vagabund

    Hey,


    den Fehler kriegst du wahrscheinlich weil hyperiond bereits läuft. Dieser wird beim Booten automatisch gestartet.


    Code
    ps ax | grep hyperion


    Dort siehst du dann welche Instanzen von hyperion laufen.
    Prüf mal bitte ob bei deiner Verbindung der gemeinsamen Masse (GND) zwischen PI und LED alles stimmt.


    Mit Bild meinte ich eigentlich ein Foto.
    Zusätzlich musst du nichts einstellen in OSMC.


    cheers,
    Vagabund

    Hey,


    verstehe ich es richtig dass du ein funktionierendes Ambilight-System hattest, und nun nur den RPI ausgetauscht hast? Hast du OSMC komplett neu aufgesetzt?
    Ein Bild von deinem Aufbau wäre hilfreich bei der Problemdeutung.


    cheers,
    Vagabund

    Hey,


    in Anbetracht der Tatsache dass einige Leute ihre Ambilight-LED ohne Probleme über die Pins auf dem Board betreiben bezweifle ich dass du großartig Probleme haben solltest genug Energie über diese zu erhalten.
    Ich hab meine Ambilight-LEDs auch über die 5V Pins betrieben, allerdings ist mein 4A Netzteil zu schwach um den PI und die LEDs gemeinsam zu versorgen.


    cheers,
    Vagabund


    Wenn man mit dieser Vorgehensweise Probleme mit einem Linux-System zu beseitigen pflegt, dann kann man auch direkt Windows nutzen.


    Und zu dem Thema "dist-upgrade" musst Du mich noch aufklären: Wie genau öffnet man damit die Büchse der Pandorra? Weil es Pakete entfernt?


    [...]
    Sollten config.txt und cmdline.txt im /boot/ Verzeichnis sein?


    Jo. Falls du auf deiner SD-Karte nur raspbian installiert hast und nichts weiter kannst du deine cmdline.txt wie folgt erzeugen:


    Code
    sudo su
    echo "dwc_otg.lpm_enable=0 console=ttyAMA0,115200 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline rootwait" > /boot/cmdline.txt


    Danach mal rebooten.


    Das ist mit ziemlicher Sicherheit der Fall.


    Starker Beitrag - hilft ihm sicher bei der Lösung seines Problems.

    Hey,


    hast du irgendwann mal Veränderungen im Verzeichnis /boot durchgeführt? An der cmdline.txt/config.txt? Die Datei kernel.img evtl. ersetzt?
    Dein Problem ist, dass du allem Anschein nach den aktuellen Kernel 4.1.6 installiert hast - jedoch Kernel 3.6.11 gebootet wird.


    Probier mal Folgendes Paket zu installieren um die Module für Kernel 3.6.11 zu erhalten:

    Code
    $ sudo apt-get install linux-headers-3.6-trunk-rpi


    Was steht in deiner config.txt/cmdline.txt? Welche Ausgabe erhältst du von:


    Code
    ls -l /boot/


    cheers,
    Vagabund

    Hey,


    schonmal probiert alle Einträge für HDMI auszukommentieren in der Config und den PI dann zu starten? Eigentlich sollte er dann selbst mit dem Fernseher alles ausbaldowern.
    Am Fernseher oder anderem Monitor bringt der PI per HDMI ein Bild?


    cheers,
    Vagabund

    Hey,


    ich habe ihn jetzt mit einem anderen Programm zum Laufen bekommen:


    Die nötige Bibliothek installieren:

    Code
    wget http://www.airspayce.com/mikem/bcm2835/bcm2835-1.45.tar.gz
    tar xzf bcm2835-1.45.tar.gz
    cd bcm2835-1.45
    ./configure
    make
    sudo make install


    Das Programm:

    Code
    sudo apt-get install subversion
    svn checkout http://rpi-rc522.googlecode.com/svn/trunk/ rpi-rc522-read-only
    cd rpi-rc522-read-only/rc522
    gcc config.c rfid.c rc522.c main.c -o rc522_reader -lbcm2835
    ./rc522_reader -d


    Damit kann ich RFID-Tags auslesen. Allerdings weiterhin nicht mit dem Python Script - auf welchem ich gerne aufbauen würde.
    Hat jemand vielleicht eine Idee, wo das Problem mit dem Python-Script liegt?
    Funktioniert es bei den Leuten die es damals ans Laufen bekommen haben immer noch?

    Hey,


    habe meinen (allerersten) PI samt Zubehör selbst vor Kurzem dort bestellt. Bin sehr zufrieden mit dem Shop, der Versand war rasch und sehr gut verpackt.
    Einzig das HDMI-Kabel welches man dazubestellen konnte lässt etwas arg an Qualität zu wünschen übrig. War jedoch bei 1,79€ für 1,8m absehbar.


    Wie man, trotz eigener Fehler und ohne jeglicher Gewährung einer angemessenen Bearbeitungsfrist, so sehr in Panik verfallen kann inklusive negativer Schlussfolgerungen ist mir nicht nachvollziehbar...


    cheers,
    Vagabund

    Hey,


    ein Linux System neu zu starten, ohne dass etwas am Kernel oder anderen grundlegenden Systemrelevanten Dingen geändert wurde, ist äußerst sinnlos.
    Diese Windows Angewohnheit sollte man schnellstmöglich ablegen.
    Wenn dein Downloadprogramm es "dankt" (auf welche Art und Weise?), dann ist es wohl schlampig programmiert.
    Schonmal probiert einfach nur dieses Downloadprogramm zu beenden und erneut aufzurufen?


    cheers,
    Vagabund

    Hey,


    laut https://www.raspberrypi.org/documentation/remote-access/ssh/ ist der ssh service per default eingeschalten, sollte also laufen.
    Häng den pi per Netzwerkkabel an deinen Router und er sollte sichper DHCP automatisch eine IP holen und dann über s Netzwerk erreichbar sein.


    Ansonsten ne Linux live-cd oder und Stick mit nem live image besorgen und von diesem booten. Dann die SD Karte einstecken, mounten und die Änderungen vornehmen.


    Cheers,
    Vagabund


    PS: probier mal Alt+F2 am Pi. Falls raspbian mehrere Terminals hat, sollte er aufs zweite switchen

    Hey,


    wie genau hast du denn dieses Startbild erscheinen lassen?
    Über SSH solltest du dich über das Netzwerk einloggen und entsprechende Fehlerbehebung betreiben können, auch wenn der Startbildschirm dein reguläres Terminal blockiert.


    cheers,
    Vagabund

    Hey,


    das Tilde-Zeichen steht unter Linux für das home-Verzeichnis des Users. Wenn du dieses nicht eingeben kannst/siehst liegt ein Problem mit deinem Zeichensatz von der Eingabe oder dem der Darstellung vor.


    Workaround: Ersetz das Tilde Zeichen durch den absoluten Pfad zu deinem Homedir.
    Um den Pfad zu erfahren gib einfach folgende Befehle ein:

    Code
    cd
    pwd


    cheers,
    Vagabund