Posts by madman


    Danke für die Antwort!
    Vorweg: Das Wasser was gepumpt wird soll später auch trinkbar sein! Also sollen gesundheitsschädliche Beschichtungen vermieden werden.




    Also im letzten Thread wurde von chromschwefelsäure-behandeltem Glas gesprochen, dass hydropber sein soll als PTFE.
    Ich glaub die fallen dann doch raus und ich bleib bei den PTFE-Schläuchen.


    Das ganze ist ein Studienprojekt. Es wird von meiner Uni-Werkstatt erstellt.


    Ich dachte durch den Druck den der Schrittmotor aufbringt um den unteren Teil an den oberen Teil zu pressen, würde das ganze geschlossen sein.
    Eine Dichtung wäre vermutlich dennoch etwas sinnvoller.


    Ich weiß nicht wie praxistauglich es ist, aber könnte man die Aluminium-oberfläche nicht einfach PTFE-beschichten und das ganze wäre weitestgehend hydrophob?
    Wie wird das in der Praxis gemacht? Ich kann mir vermutlich nicht einfach nen PTFE-Spray kaufen und das in den Behälter sprühen oder?


    Das mit dem Infusionsbesteck überleg ich mir nochmal. Daran hatten wir ganz zu Beginn des Projektes schon gedacht.. Ist an irgendwas gescheitert.. Aber ich schaus mir nochmal an. Danke für den Hinweis.


    Danke für den Hinweis.
    Es geht aber bei meinem Aufbau darum, dass sehr günstige Pumpen verwendet werden bei denen der Druck sehr schwanken kann. Das ist bei den Dosierventilen nicht möglich, da brauchst du einen konstanten Druck um relativ genau messen zu können.


    Ein Megaliter ist schon mal ne Hausnummer. Was für Schrittmotore und Getriebe nutzt du da?


    Hab ich mir noch keine Gedanken zu gemacht. Für meine Projekte bisher hab ich immer die 5 Euro 28BYJ-48 Schritt motoren genommen. Ist hierfür zu ungenau.
    Ich hätte am liebsten eine Universallösung bei dem Schrittmotor, da ich mehrere von den gezeigten unteren Behältern in einer Reihe habe und somit dann z.B. 5 obere Behälter aufeinmal durch einen Schrittmotor schließen/öffnen kann.
    Ich glaube das beste wäre den unteren und oben Behälter an einer Gleitführung zu verbinden, damit die Behälter sich immer gleich treffen.


    Ich habe mich jetzt nochmal bei den Schrittmotoren informiert. Scheint alles preislich relativ gut umsetzbar zu sein. Solange ich einen Schrittmotor nehme der stark genug ist um die unteren Aluminiumbehälter nach oben zu pressen (und die Leitungen kurz genug/nicht defekt sind), kommt es hier ja zu keinen Schrittfehlern - oder?

    Hey,
    es geht wieder um ein Pumpenprojekt. Es soll sich um eine Abfüllstation handeln die relativ genau 1ml aufnehmen (im geschlossenen Zustand) und diese 1ml weiterleiten lassen kann (im offenen Zustand)
    Ich würde mal gerne hören was ihr von meiner Idee haltet, da ich das ganze nächste Woche fräsen lassen möchte.


    geschlossener Zustand:


    offener Zustand:



    Der untere Teil ist beweglich und lässt sich durch einen Schrittmotor nach oben schieben. Der obere teil ist fest.



    Das schwarze und das orangene sind behälter.
    Der schwarze Behälter ist durch eine Verankerung (Gelb) festgemacht, welche den Behälter in der Position halten soll.
    Der schwarze behälter ist oben und unten offen (also eigntl. einfach nur ein Loch).
    Das blaue sind Schläuche durch die Wasser fließt.
    Das grüne Teil soll überfließendeswasser davon abhalten in den Behälter zu fließen.



    Das ganze rote teil ist komplett ausgefüllt. Das rote Teil ist an den orangenen Behälter festgemacht.


    Die Idee ist folgende:
    1. Der untere Behälter wird durch einen Schrittmotor an den oberen Behälter gepresst.
    Nun ist der Behälter geschlossen. (siehe Bild "geschlossener Zustand")
    2. Wasser fließt durch den oberen Schlauch in den schwarzen Behälter.
    Der rote Kegel hindert das Wasser am rausströmen
    3. Das Wasser welches über den Rand des schwarzen Behälters fließt wird durch die grüne Abfangvorrichtung aufgefangen. Es fließt ab.
    4. Ist der Behälter gefüllt, fließt keint Wasser mehr durch den oberen blauen Schlauch
    5. Der Schrittmotor an dem unteren Behälter lässt den unteren Behälter nach unten verschieben. (siehe Bild "offener Zustand")
    6. Das Wasser fließt nun aus dem schwarzen Behälter in den orangenen Behälter.
    7. Das Wasser fließt in den blauen unteren Schlauch und wird dort hinbefördert wo es hin soll.


    -> Es wurde exakt die Wassermenge befördert die in dem oberen Behälter passen.
    Das Volumen des oberen Behälter umfasst 1ml (der Kegel wurde aufaddiert).


    Ziel: Es soll möglichst genau 1 ml gepumpt werden und es soll en möglichst wenig Verluste/Rückstände auftreten


    Ein paar praktische Fragen:
    1. Muss an den unteren blauen Schlauch noch eine Pumpe um die Flüssigkeit weiterpumpen zu lassen? Ich habe mir überlegt einfach eine Glaskapillare zu nehmen und dann den Auffang-Behälter unter die Vorrichtung zu stellen.
    2. Mein Plan war es das ganze aus PMMA fertigen zu lassen. Die aus der Werkstatt meinten es wäre für sie wesentlich einfacher das ganze aus Aluminium zu machen.
    Laut google ist Aluminium wegen der chemischen Beständigkeit sogar besser.. Gibt es hier irgendwelche Probleme die entstehen können? Die Flüssigkeit soll am besten nicht mit den Behälter chemisch reagieren. Aber die Flüssigkeit muss am Anfang eh durch eine normale 5 Euro-Pumpe. Die Pumpe wird wahrscheinlich darüber entscheiden welche Stoffe in den Behälter kommen können und welche nicht.
    3. Wenn das ganze aus Aluminium gefertigt wird, müssen die Behälter irgendwie beschichtet werden o.ä.? Es sollen keine Wassertropfenrückstände im Behälter zurückbleiben.
    4. Mir bereitet das dranpressen der unteren Vorrichtung an den oberen Behälter ein wenig Kopfzerbrechen.. WIe kriegt man das durch einen Schrittmotor am besten hin, ohne dass der Schrittmotor zu stark/schwach den unteren Behälter an die Vorrichtung presst. Ist ggf. irgendeine Abdichtung notwendig, damit kein Wasser ausfließt?
    5. Die Flüssigkeit wird sich oben am Behälter häufen. Lässt sich das irgendwie verhindern? Ich möchte eine möglichst geringe Ungenauigkeit erreichen. Eine Überlegung war es, die obere Öffnung auf die gleiche Größe des oberen Schlauches anzupassen um einen möglichst geringen Raum für die Häufung der Flüssigkeit zu schaffen.. Kann man ggf. durch spezielle Kanten des Behälters das Häufen der Flüssigkeit verhindern?

    ChrisvA Das ist eine gute Idee!
    Daran hatte ich auch schon gedacht, dass Problem war, dass der Sensor zu leicht ist. Das Kabel hat sich in dem Rohr breit gemacht (so zickzack-mäßig) und der Sensor ist nicht weiter nach unten gefahren. Ich habe bisher nie an ein Gewicht gedacht, dass man an den Sensor packen kann - oder ich erinner mich nicht mehr an den Versuchsaufbau. Wenn das Gewicht es schafft das Kabel zu führen, dann würde das mit dem Rohr auch funktionieren.


    Ich habe morgen wieder die Möglichkeit den Sensor zu sehen. Ich werde mal schauen ob das ganze mit einem Gewicht praktisch möglich ist.


    hamyam, ich mache morgen ein Foto und lad das hier hoch

    Hey doing! Danke für die Antwort.
    Das Kabel ist fest an den Sensor gebunden. Ich müsste das Kabel komplett entfernen und dann ein neues Kabel verlöten. Würd ich vermutlich noch hinbekommen, aber wenn ich mich an meine Kopfhörer erinner die ich früher immer verlötet habe, dann belass ich es das Kabel lieber doch so wie es gerade ist. Das ganze Teil soll langfristig funktionieren, hab da nicht so da beste Bauchgefühl, wenn ich das selbst verlöte.


    Ich glaube das mit der Lichtschranke macht das ganze ein wenig zu komplex. Auf dem Behälter sind verschiedenste Schläuche angebracht und der Sensor wird vermutlich nicht immer an der gleichen Stelle hinabgelassen, sondern schwenkt ein wenig umher (durch Luftzüge/Vibration etc. es arbeiten gleichzeitig andere Pumpen/Motoren an der Konstruktion)
    Ne ich habe einen PH-Wert-Sensor welcher in den Behälter gelassen werden soll - nach der Messung soll er wieder hinaufgezogen werden - dann wird ein Auffangbehälter über den Behälter geschoben (in welchem eine Aufbewahrungsflüssigkeit ist) und dann wird der Sensosor in den Auffangbehälter gelassen. Also leetztendlich soll es sich um ein automatisiertes System handeln welches den PH-Wert von einer Flüssigkeit in einem Behälter misst.

    Andreas danke für die Rückmeldung.
    Das Kabel ist wirklich extremst spröde und hart, da muss ich wahrscheinlich ein sehr schweres Massestück nehmen damit das Kabel gespannt ist. Ich werde das aber mal testen.


    Es geht um ca. 80cm. Bei dem Behälter handelt es sich um einen handelsüblichen 1L Messbecher, also muss der Sensor nicht exakt auf die gleiche Stelle treffen, aber sollte eben noch bei gleichbleibender Schrittzahl im Behälter landen.
    Das mit dem Linearschlitten sieht zwar sehr gut aus, aber ist preislich nicht in meinem Budget. Der entsprechende kabbellose Sensor kostet 60 Euro. Ich versuche durch den Aufbau den Kauf des kabbellosen Sensors zu umgehen.


    edit: Wobei ich gerade sehe dass eine Miniaturgleitführung (http://www.leschhorn.de/de/art…g_drylin%C2%AE_n/10127644) preislich noch in Ordnung wäre.. Aber praktisch ist dass ja identisch mit meinem zweiten Aufbau..

    Hey,
    vielleicht hat jemand eine intelligentere Idee mein aktuelles Problem zu lösen.
    Es geht um folgendes:
    Ich habe ein sprödes Kabel an dem ein Sensor hängt. Ich möchte den Sensor gesteuert über einen Schrittmotor hinablassen und hinaufziehen. Wichtig ist natürlich dass es eine konstante Schrittzahl bleibt.


    Hier mal eine kleine Zeichnung wie das ganze Ausschaut:


    rot ist der Schrittmotor, orange ist der Sensor.
    Folgende Sachen habe ich ausprobiert und sie funktionieren nicht:
    1) Das spröde Kabel kann nicht an um den schwarzen Stab gewickelt werden. Beim Auf und ablassen varrieren die Schritte bis der Sensor am Boden ist massiv, da dass Kabel so uneben ist.


    2) Der Sensor kann nicht an ein Seil festgemacht werden welches heraus/herabgelassen wird. Die Idee war, dass der Sensor an einem Seil festgemacht wird, und das spröde Kabel oben über dem dem schwarzen Stab liegt. Da das Kabel aber viel zu uneben ist, verschiebt der Sensor sich massiv und trifft nur mit Glück das Ziel.
    Wenn das spröde Kabel nicht direkt über dem Sensor angebracht ist, wird der Sensor nicht gerade hinabgelassen sondern verschiebt sich beim Ablassen eben in die Richtung wo das Kabel ist


    Aktuelle Idee:
    BIld:

    (hab leider ne schlechte Farbe ausgewählt.. bei dem neuen blau hinzugefügten handelt es sich nicht um ein Kabel sondern um einen festen Stoff z.B. einem Metall/Kunststoff o.ä.)
    Das spröde Kabel ist oben über dem Stab angebracht. Der Sensor wird an einem Kabel festgemacht und gleichzeitig an eine Vorrichtung angebracht, welche den Sensor in die richtige Richtung führt.
    Das Problem beim heraufziehen ist nun, dass dieses spröde Kabel in alle Möglichen Richtungen gehen kann und irgendwo in der Luft schweben wird. Das spröde Kabel wird beim heraufziehen nicht erneut um den schwarzen Stab gewickelt sondern fliegt da oben in der Luft rum..


    Dieses blöde spröde Kabel verhält sich halt nicht berechenbar und schweift in alle mögliche richtungen ab. Bin am überlegen einen Sensor ohne Kabel zu kaufen.. die sind leider bloß ein wenig teurer..
    Hat irgendwer eine intelligentere Idee das umzusetzen?


    edit: Vielleicht könnte man das Kabel auch irgendwie durch die braune Vorrichtung mit nach unten fahren lassen und das Kabel dort anbringen:

    OK, danke für die ganzen Hinweise.
    Biegen wird vermutlich nicht klappen aufgrund der Maximalmaße der Fräse, kann ich aber nochmal konkret in der Uni nachfragen.
    Dann verwerf ich mal schnell wieder die Idee mit dem alleinigen Kleben.. Hat sich um ehrlich zu sein auch nicht so wirklich stabil angehört.


    Werd mir die gennanten Optionen (Plexiglasstab,Winkel,..) mal alle genauer anschauen und dann überlegen welches die Beste für das Konstrukt ist.
    Danke!

    Ja, genau an den Winkel hab ich schon gedacht und so würd ich es vermutlich auch machen. Ich frage mich halt nur ob das wirklich notwendig ist, da ich mich mit Plexiglasverklebungen nicht auskenne und nicht weiß wie stabil das wird. (ohne so einen Stahlwinkel sieht das ganze natürlich schöner aus)
    Wenn beispielsweise so Plexiglasstühle ausschließlich geklebt werden, dann würd eine Verklebung bei mir auf jeden Fall reichen.


    Nehmen wir anstatt meinem Motor ein 1KG-Gewicht. Also wir haben jetzt ein Plexiglasscheibe auf dem Boden und eine im 90 Grad hochkant angeklebte Plexiglasscheibe auf welche ein 1KG Gewicht gelegt wird. Würdet ihr neben dem Kleben auch einen Stahlwinkel anbringen oder reicht das Verkleben? Das Konstrukt soll unbewegt mehrere Jahre so stehen bleiben.

    Hey,
    in meinem aktuellen Projekt muss ich eine Plexiglasscheibe hochkant an der anderen Kante anbringen, so dass diese einen rechten Winkel bilden. An der Plexiglasscheibe die hochkant aufgestellt ist, soll ein kleiner Elektromotor angebracht werden.


    Die Scheiben sollen eine Dicke von ca. 5mm haben und es geht um einen kleinen 6V Motor.. Ich hab ein wenig Angst, dass ich das ganze Klebe und es letztendlich dann nach ein paar Monaten abfällt.


    Ich erstelle gerade die technische Zeichnung. Theoretisch wäre es auch möglich das ganze Konstrukt (breite: ca. 50 cm, höhe: ca. 20cm, tiefe: ca. 10cm) aus nem ganzen Plexiglasblock fräsen zu lassen, anstatt zwei Scheiben die ich dann zusammenkleben muss.. Weiß nicht, ob die aus meiner Uni es aber zulassen dass ich so ein riesen Block da für sowas reinpacke.. Klingt auch ein wenig eher nach einem Overkill für die Problemstellung.


    Ich habe mich noch nie mit Plexiglas und dem Kleben von Plexiglasscheiben auseinandergesetzt. Glaubt ihr für das Konstrukt reicht das einfache Kleben mit nem speziellen Plexiglaskleber, oder sollte man da doch lieber noch irgendwelche Schrauben/Schaniere anbringen?
    Das wird vermutlich zu Beginn alles bombenfest halten, ich weiß jedoch nicht, ob das in ein paar Monaten noch hält oder alles in sich ineinander fällt..


    Wie machen die Leute das mit den Plexiglasstühlen? Sind die geklebet ?

    Andreas ich danke dir für deine Mühe!
    Ich habe jedoch schon sehr viel Zeit in meinen aktuellen Aufbau reingesteckt und auch der Programmierteil steht schon zum großen Teil. Ich versuch das einfach mal und schaue wie genau das wird. Dein Aufbau ist wahrscheinlich um Welten besser, jedoch hatte ich selbst bei meinem aktuellen Aufbau schon massive Probleme nur eine Plastikschale durch einen Schrittmotor verschieben zu lassen. So etwas wie ein Roboterarm liegt dann doch über meinem technischen Knowhow..


    Danke aber auch für den Tipps bzgl. der Schläuche und dem behandeltem Glas. Werde das in den Aufbau mit einbauen.

    Überprüf mal ob curl aktiviert ist.
    Gib die phpinfo(); aus und such nach curl. Wenn es nicht enabled ist, musst du das noch in der phpconfig machen (für ein tutorial siehe google..) Ob das mit dem eigentlichen Problem zusammenhängt kann ich dir aber nicht sagen.

    Hallo! Danke für die Antworten!
    Ich habe mich glaub ich falsch ausgedrückt oder ich stehe ein wenig auf dem Schlauch (haha) :D
    Der 1ML-Behälter soll genau* 1 ML enthalten und es sollen insgesamt genau 1ML gepumpt werden. Also der 1ML-Behälter soll mit 1ML Wasser komplett befüllt werden und dann soll die Pumpe auch den kompletten Behälter auspumpen (1ML).
    Insgesamt ist das Ziel, dass ich fixe verschiedene Behälter-Größen (z.B. 1ML,5ML,50ML..) einsetzen kann und dann nach belieben z.B. 123ML Pumpen lassen kann.
    Also in diesem Beispiel würde der 1ML Behälter 3x verwendet werden, der 5ML-Behaelter 4x und der 50ML-Behaelter 2x.


    Ich will das ganze Konstrukt im Privatbereich einsetzen, also wenn ich einen Fehler bis 10% erreiche (also z.B. anstatt 1,0ML -> 1,1ML)bei dem 1ML-Behälter erreiche, ist das alles noch im grünen Bereich.
    Mit hilfe der von dir angesprochenen abperlenden Materialien wird man vermutlich relativ wenig Verlust beim Pumpen erhalten. Nur was innerhalb der Pumpe haftenbleibt kann ich hier leider nicht beeinflussen, sollten aber weit weniger als 10% sein.
    Dann bleibt noch das Problem, den Behälter mit exakt 1ML zu befüllen, ohne dass die Pumpenleistung hier große Unterschiede macht.


    Das mit der Waage war ganz zu Beginn auch meine Idee, aber es gibt anscheinend keine genauen Waagen für die Raspberry bzw. für meinen Geldbeutel die für Langzeitmessungen geeignet sind. Da soll es zu starken Schwankungen kommen und Komplikationen bzgl. des Eichens usw. geben.


    *mit "genau" ist 1ML +-10% gemeint.

    Hallo Andreas! Danke für die Antwort!
    1. Ich werd mir für den nächsten Aufbau dann einen PTFE-Schlauch holen. Ich habe einfach den dünnsten handelsüblichen Schlauch aus dem Baumarkt genommen.


    Die Idee mit der Pipette ist sehr gut, jedoch will ich mich nicht im mikroliterbereich sondern ab 1ML bewegen.
    Wenn wir uns meinen Aufbau anschauen und den komplett mit PTFE-Schlaüchen oder Glasröhren bewerkstelligen, sind hier dann dennoch Schläuche in Kappilardurchmesser notwendig?


    Was mir bei meinem jetztigen Aufbau aufgefiel, ist, dass beim Auffüllen des 1ML-Behälters unterschiede auftreten können. Je nach dem wie stark das Wasser hineingepumpt wird usw. Hierfür habe ich noch keine Lösung gefunden.

    Hallo, ich habe ein Problem mit meinem Projekt.
    Ich will einen Behälter auffüllen lassen durch Pumpe A und den Behälter durch Pumpe B auspumpen lassen.
    So weit so gut. Der Behälter soll bloß exakt 1 ml groß sein und die herausgepumpte Wassermenge soll auch exakt 1ML sein.


    Ich habe jetzt schon einen Prototypen gebaut der das ganze halbwegs zuverlässig schafft.



    Das schwarze soll der große Behälter sein, dass rote ist der kleine 1ml-Behälter. Links sieht man den Motor welcher die Flüssigkeit in den roten Behälter pumpt und rechts sieht man den Motoren der die Flüssigkeit aus dem kleinen Behälter an den Bestimmungsort pumpt.


    Das ganze habe ich so schon nachgebaut und es funktioniert auch. Wie man sich jedoch denken kann, ist es nicht sonderlich genau.. der Motor schafft es nicht 100% der Flüssigkeit weiter zu pumpen und es bleiben Rückstände im Schlauch.
    Wenn ich das ganze jetzt dann 5x hintereinander durchführe, hat man da Abweichung, da die Rückstände vom 1. Pumpvorgang beim 2. Pumptvorgang mitgepumpt werden usw. Um möglichst genaue Ergbenisse zu erhalten muss ich den rechten Motor immer auf 100% laufen lassen und am besten auch immer mind. 15 Sekunden um möglichst viele Wasserrückstände im Schlauch mitzupumpen.. Das ganze ist jedoch extremst ineffizent... von den 15 Sekunden werden geschätzt 90% des Wassers in den ersten 3 Sekunden gepumpt und der rest ist quasi fast ein Leerlauf.
    Das ganze soll auf einem mechanischen Prinzip basieren. Also nicht so etwas wie "90 ml/Minute" -> 1,5ml/Sekunde..



    Ich überlege mir gerade einen Aufbau welcher das Problem der Genauigkeit löst.
    Meine beste Idee ist folgender Aufbau:

    Die Pumpe Links bleibt.. Die Pumpe rechts wird möglichst nach unter den Behälter gestellt.
    In den 1Ml-Behälter wird unten eine Öffnung angebracht, die direkt an den Anschluss der Pumpe liegt und durch einen weiteren Motor (auf der grauen scheibe) geöffnet/geschlossen wird.
    Jetzt wird der kleine Behälter gefüllt, wenn er voll ist, wird die untere Öffnung geöffnet und die zweite Pumpe pumpt die Flüssigkeit dorthin wo sie hin soll (mit möglichst steilem Winkel).


    Mir fällt aber absolut keine sichere Methode für die Öffnung des 1ML-Behälters sein, die sicher durch den zweiten Motor gesteuert werden kann, ohne dass da Flüssigkeit durchläuft. Ich hab als ertes einfach an ein Kunststoff-plätchen gedacht, dass durch ein Zahnrad verschoben werden kann. aber mir scheint das nicht dicht genug zu sein.
    Die Methode die mir eingefallen ist, wäre mit einem Schrittmotor eine Platte an den 1ML-Behälter-Boden zu drücken und dann ggf. zu öffnen. Bloß wird die Konstruktion irgendwie extrem kompliziert, weil die Flüssigkeit ja in einen 3mm-Schlauch abfließen soll.. Müsste dann also unter den 1Ml-Behälter noch einen Behälter basteln, welcher den 1ML-Behälter mit dem 3mm Schlauch verbindet und gleichzeitig durch ein Stab eine Platte den den 1ML-Behälter presst..
    Würde dann in etwa so aussehen:



    Also der rote Behaelter erfasst genau 1ML.
    Unter dem Behaelter ist eine Platte (grau) welche an den Schrittmotor(rechts, blau) befestigt ist.
    In dem Bild befindet sich der 1ML-Behaelter im offenen Zustand. Im geschlossenen Zustand, presst der Schrittmotor die Platte an den 1ML-Behaelter.
    Im offenen Zustand strömt das Wasser durch den Anschluss(schwarz) in den Schlauch(gelb) und der Motor pumpt das ganze dann weiter wo es hin soll..



    Hat irgendwer einen einfacheren Aufbau? Der ganze Aufbau soll nämlich nicht so extrem in die Höhe wachsen und ich möcht möglichst wenig Motoren direkt unter dem 1ML-Behaelter anbringen

    Fehlalarm.. alles zurück..


    Es hat sich exakt in dem Moment als ich den DC-Adapter erneut eingestekt habe anscheinend ein Kabel gelöst. Also ist das Relaisboard kurz aufgeleuchtet, dann ist anscheinend ein Kabel locker geworden und alles ist abgeschmiert. Sah so als, als wär irgendwas durchgebrannt.. und da man das MCP durch i2cdetect nicht mehr gefunden hat, dachte ich, ich müsste es beerdigen :D



    Dennoch danke!


    Und ja, die Dioden sind im L298-Board..

    Hey,


    mein Aufbau war folgender:
    5V/GND von Raspi an Relaisboard
    die 4 IN-Pins über 10k Widerstand an die MCP.


    Jetzt hab ich einen DC-Adapter. Der Minuspol des DC-Adapter ist immer an jeweils eines der Relaisöffnung geschlossen (so dass jedes Relais an den Minuspol angeschlossen ist). Nun ist der Polpol des DC-Adapters jeweils an einen L298-Modul angeschlossen und das wiederrum ist an den anderen Port des Relais angeschlossen.


    Kurz-gesagt: MCP steuer Relaisboard. Relaisboard hat einen eigenen Stromkreis mit L298-Modul.


    Aus welchen Gründen auch immer ist der Motor vom L298 nie angesprungen, also habe ich die mein DC-Adapter höher gestellt (von 3,5V stufenweise auf 12V)
    Irgendwann ist meine MCP durchgebrannt. Relaisboard funktioniert noch, L298 funktioniert noch und Motor funktioniert auch noch..
    Wie kann das sein? Der Stromkreis hat doch gar nichts mit der MCP zu tun. Die MCP schaltet doch nur..


    Im Übrigen hat sich herausgestellt, dass der Motor nicht lief, weil der DC-Adapter zu wenig Strom liefert.. hab jetzt den direkten Anschluss (L298/DC-Adapter und Raspberry(ohne MCP)) mit einem stärkeren Adapter getestet und es funktioniert.. Ein rätsel bleibt mir, warum meine MCP durchgebrannt ist.. Kann das einer vielleicht lösen?


    Ich werd den Aufbau jetzt nochmal mit einer neuen MCP testen.. vielleicht bin ich mit den Adapter-Pins irgendwie an die MCP gekommen oder so..