Posts by Nelloz

    Guten Tag zusammen und schon mal ein schönes Wochenende gewünscht.:)


    auf meinem Android-Smartphone läuft per SSH zum Raspberry Pi 3B+ (Raspbian) das Programm Raspicast, welches Streams/Dateien an den per HDMI am PI angeschlossenen TV castet.


    Für youtube-Videos funktioniert das einwandfrei. Für ALLE anderen Dateien, die auf dem Smartphone liegen (auch .jpg) geht es gar nicht.


    Testaufbau:

    - Raspberry Pi 3B+ Raspbian frisch aufgesetzt und upgedated, SSH eingerichtet, Standard Pi-user gegen einen anderen ausgetauscht

    - omxplayer am Pi ist die neueste Version

    - Pakete nachinstalliert:

    Code
    sudo apt-get install libjpeg8-dev libpng12-dev


    - eine normale test.jpeg auf dem PI im home-Ordner abgelegt

    - per SSH vom Smartphone aufgerufen

    Code
    omxiv /home/user/test.jpeg

    zeigt problemlos das Bild am TV an.

    - dasselbe Bild auf dem Android-Device abgespeichert wird unter Android im Programm Raspicast als Vorschau angezeigt, aber beim anklicken passiert nichts am TV.

    - wie gesagt, Youtube-Videos lassen sich über dieselbe App wunderbar casten.


    vom Wunsch, auch Videos vom Device casten zu können, bin ich damit noch meilenweit entfernt.

    übrigens bringt das Abspielen eines Videofiles, welches auf dem PI liegt eine Fehlermeldung:

    Code
    omxiv /home/user/test.avi

    --> "unsupported image"


    Hat evtl. jemand eine Idee, wie ich die Anzeige von Files auf dem Handy doch über die App an den TV gecastet bekomme?

    Weiß evtl. jemand, ob das Nichtabspielen des Videos auf ein codecproblem oder auf eine Fehleinstellung des omxplayers hinweist?

    Gibt es neben den oben geschrieben Bildpaketen für Videos auch noch spezielle Pakete, die zur Nutzung des omyplayers installiert werden müssen?


    Lieben Dank an alle und viele Grüße :danke_ATDE:


    Tobi

    Guten Morgen Andreas,



    bei make -j5 blieb er diesmal bei 47% stecken (statt bei 86%).
    Habe ihn über Nacht auf der anderen Karte nur mit make durchlaufen lassen. Das hat wieder geklappt.
    Ich werde das nochmal auf meinem Ubuntu-System ausprobieren.
    Jedenfalls ist das gewünschte Ergebnis auf dem Pi jetzt da :)


    Viele Grüße


    Tobias


    Hallo Andreas,


    d.h. bei -j5 werden dann 4 Kerne benutzt?
    Ich kann das ggf. morgen nochmal mit der anderen Karte probieren.
    Im Moment bin ich allerdings froh, dass es nun erstmal so geklappt hat.


    Bei meinem Glück lässt sich das auf der schnelleren Karte morgen aber nicht reproduzieren (auf Holz klopf).


    Ich melde mich nochmal nach dem Versuch.


    Grüßle

    Erledigt


    Offenbar kam es beim Kompilieren mit den vorhandenen 4 Kernen zu irgendwelchen Artefakten.
    Statt mit 4 Kernen (make -j4) kam es bei der Wiederholung mit nur einem Kern (make) nun zu keinem Problem.


    Vielen Dank an die Beteiligten und noch schöne Ostern!


    LG, Tobias


    Danke trotzdem! Mal sehen, ob ich da noch was finde.
    Schöne Ostern!

    Danke RTFM! Mach' ich.
    Automatisch zusammengefügt:[hr]
    Danke Andreas! auch nicht in der Kirche heute? :)


    ich suche gerade das richtige File.


    Gefunden habe ich:


    /home/pi/opencv-3.0.0/build/Makefile:


    Das scheint aber nur ein Config-File zu sein. Meinst Du das?