Posts by tyrann619

    agent47


    Mal ne kleine Frage :)


    Wäre es möglich, in dem SHC webinterface einen Bereich einzubauen indem man ganz allgemein ssh befehle und/oder .sh scripte ausführen kann?
    Quasi nur ein Eingabe-Feld mit Pfad und ein Knopf mit Start.. und das als Liste.
    Damit könnte man die Funktionalität extrem erweitern.
    -In meinem Fall könnte ich so meine Relaiskarte steuern die 8 versch. Sachen schaltet
    -Eigene Scripte Manuel ausführen etc.
    --(anstatt immer ssh zu öffnen die befehle Einzugeben -> Auszuführen(besonders mit smartphone ist das lästig))


    Will das nicht von dir "fordern" das einzubauen aber vllt. schaff ich das ja hiermit auf deine ToDo liste !? :)

    Also die F7 / 0 geht bei mir seit dem Letzen update...
    Versuch mal wie bei meinem Beitrag #892 das per SSH direkt mit dem Pilight befehl zu schalten...
    Das MUSS erstmal funktionieren..
    wenn nicht musst mal in der Pilight-Documentation nachsehen bzw. vllt auch mit dem anderen 0 /14 rev3_switch probieren
    sonst kann SHC auch nichts machen

    rmjspa
    Wenn du die Steckdosen mit der Fernbedienung schalten kannst, dann schneide doch einfach den Sendevorgang mit pilight mit und lese die entsprechenen Daten ab..
    Oder versteh ich da was falsch an deinem Problem..?

    Ich bekomme genau den gleichen Fehler wie JamesTM.
    Aber der war auch vor dem Update schon da.
    Hatte das jetzt schon 2 mal. Der kommt ohne überhaupt was zu machen.
    Hatte das 2 mal neuinstalliert, eingerichtet und dann vom strom getrennt.
    Am nächsten Tag wo ich wieder den RPi angesteckt habe war der fehler da..
    Bei einem normalen reboot bleibt aber alles gut..
    kann es sein, dass einfach vom Strom trennen diesen fehler auslöst?

    agent47
    Auch ich bedanke mich für die schnelle Antwort und möchte dir hier auch gleich ein Lob für dieses Projekt aussprechen.
    Das man so etwas unentgeltlich macht ist NICHT selbstverständlich. Dafür: Respekt


    Zurück zu meinem Problem:
    Ich habe es jetzt nochmal probiert indem ich bei System Code: 0 und bei Geräte Code: F7 bzw "F7" eingetragen habe.
    Auch andersrum (System Code: F7 bzw "F7" Geräte Code:0) funktioniert es leider noch nicht.
    Der Schalt-Server wird als "Läuft" angezeigt und auch sonst habe ich mich bei der Installation an deine Anleitung gehalten.
    Gibt es vllt. irgend eine Debugg-Datei wo steht, welche befehle ausgeführt werden?
    In meiner sudoers steht auch:
    www-data ALL = NOPASSWD: /usr/local/bin/pilight-send


    Per SSH direkt kann ich die Steckdose mit:
    sudo pilight-send -p rev2_switch -i F7 -u 0 -t
    sudo pilight-send -p rev2_switch -i F7 -u 0 -f


    aus und anschalten
    wobei -t ausschaltet und -f an, obwohl es laut Pilight genau andersherum sein müsste.
    Aber das ist ein Pilight bug
    (vllt. ne kleine reverse-funktion? :) )


    Fürs nächste Update wäre es schön, noch die
    Doppelbelegung von Systemcode(unit) und Gerätecode(id)
    mit anzugeben :)

    jsp-email
    Funksteckdose REV (v2)
    Ich probiere auch gerade diese Steckdosen zum laufen zu bringen,
    aber das geht bei mir auch noch nicht.


    Mit Pilight selbst funktioniert es!
    Vllt. liegt es daran, dass diese Steckdosen KEINEN
    systemcode und unitcode haben. Aber nur das kann man im SHC eingeben.


    Denn bei pilight direkt muss man das eintragen
    [code=php]"id": [{
    "id": "id der Steckdose",
    "unit": 0
    }],[/php]
    wobei bei id noch unterschieden wird in Dec und Hex wie es aussieht.
    bei mir funktioniert es mit pilight zb. nur bei
    "id": "F7",
    aber NICHT bei: "id": "id": F7,
    Aber ganzzahlige Ids wiederum nur ohne "

    Vielen Dank für eure Antworten. ssh zugriff habe ich leider keinen.
    Ich hatte damals so ein schönes script für Dropbox was automatisch die daten hochläd und ältere automatisch löscht.. dachte sowas geht auch mit seafiles..


    Ok also muss ich warscheinlich die daten per FTP herunterladen..
    Da ich Python o.ä was Linux betrifft nicht kann wollte ich noch fragen, ob es da schon fertige sachen gibt die ich noch anpassen kann oder irgendwelche tutorials...


    MFG

    Hallo, ich habe auf meinen RPi Seafiles als Cloudservice installiert
    und kam nun auf die Idee, den RPi als Backupserver für meine Websites zu verwenden.


    In der Suche habe ich dazu nichts gefunden und deswegen frage ich nun mal hier nach.


    Also.. Ich habe bei einem Webhoster Webspace gemietet und eine Website erstellt.
    Die ist soweit fertig, nur eine Backuplösung habe ich noch nicht.
    Bis jetzt erstellt ein PHP-Script aller 24h ein Backup der Seite und speicher es NOCH lokal.
    Nun möchte ich den RPi für die Speicherung einsetzten, damit ich bei totalem Datenverlust auf dem Webspace noch backups auf dem RPi habe.


    Nun hatte ich mir schon ein bisschen was überlegt und bin auf 2 Varianten gekommen:
    1. Der RPi lädt die Daten vom Webspace runter (nachdem die Backups fertig sind) oder
    2. Ein PHP-script läd ,wenn das Backup fertig ist, die Daten in meine Seafiles Cloud hoch


    Nun die Frage: Was ist die bessere Variante und wie realisiere ich das am besten.
    Habe zu beiden Möglichkeiten nichts weiter gefunden.
    (Bin Linux und PHP anfänger)


    MFG

    liegt das am Unmounten, dass der Ordner bleibt?
    Windows macht doch das auch ohne Probleme, und da Linux mehr Möglichkeiten bietet muss das doch auch möglich sein?!
    Oder reicht es den Ordner nach dem rausziehen automatisch zu löschen?Wenn ja wie geht das?

    danke für eure hilfe.. Ist das auch möglich das automatisiert zu machen.. Sprich Plug and Play? Will nicht jedes mal den SSH client aufmachen zum Mounten/Unmounten

    Hallo, ich benutze mein RPi als Downloadserver, welche auf einen USB stick die Datein lädt.
    So nun habe ich 2 Probleme:
    1. Beim Anstecken des USB Sticks sehe ich ihn in Filezilla nicht(SFTP), erst nachdem ich per VNC auf dem Desktop des RPi "Open in File manager" angeklickt und im File Manager auch ausgewählt habe erscheint er.
    2. Wenn ich den USB Stick raus ziehe verschwindet der Ordner nicht. Wenn ich ihn dann wieder reinstecke wird er "USBSTICK_" benannt. Der richtige Ordner "USBSTICK" ist dann auf der SD Karte..

    inhibit interface error: Failed to connect to the D-Bus session daemon: Unable to autolaunch a dbus-daemon without a $DISPLAY for X11
    main interface error: no suitable interface module
    main interface error: no suitable interface module
    main libvlc error: interface "globalhotkeys,none" initialization failed
    main libvlc: VLC wird mit dem Standard-Interface ausgeführt. Benutzen Sie 'cvlc', um VLC ohne Interface zu verwenden.
    qt4 interface error: Could not connect to X server
    skins2 interface error: cannot initialize OSFactory
    [cli] lua interface: Listening on host "*console".
    VLC media player 2.0.3 Twoflower



    Ich würde es gerne mit GUI ausführen. vllt. weiß ja jemand was man bei diesen Fehlern machen kann?

    Hallo, ich möchte diverse Internetradios ala Technobase über den RPi "empfangen".
    Ich habe mit den VLC player rausgesucht, da ich diesen auch per Androidsmartphone steuern kann.
    Nach der installation via apt-get kann ich ihn nicht starten.
    Weiß einer warum?


    Vllt. gibt es auch eine alternative die ich per Android fernsteuern kann?

    Danke für die schnelle Antwort. Also die restlichen MB habe ich in der datenträgerverwaltung gefunden, jedoch kann ich sie nicht wieder zusammenfassen. Ich hab 3,63 nicht zugeordneten speicher und 56mb FAT Primäre partition. Diese kann ich nicht löschen und auch nicht vergrößern. Und mit dem nicht zugeordneten speicher kann ich auch nichts machen außer die Eigendschaften anzeigen lassen.
    Gibs ein Programm das das richtig kann?
    PS: USB Image Tool erkennt auch nur die 56mb

    Hallo, ich habe mein 4GB SDHC Karte per USB Image Tool beschreiben.
    Nun wollte ich die SD Karte mit einem anderes OS beschreiben. aber die 4GB Karte ist nur noch 50MB groß.
    Zumindest wird sie so im Arbeitsplatz angezeigt. Ich kann auch nur diese 50MB formatieren.
    Wie bekomme ich meine restlichen 3950 mb wieder?