Posts by Heinrich

    Na, das'n Korken:

    Ich wäre ja nie wie reto auf die Idee gekommen,

    nen Phasenprüfer an den Raspi zu halten, aber er hat Recht:

    Ich habe hier das original würfelförmige Raspinetzteil mit der Himbeere.

    Erst habe ich das Teil in die Mehrfachsteckdose gesteckt,

    in der einen Hand die Erde des abgezogenen Steckers des Netzteiles,

    andere Hand: Fingerspitze auf Kontakt des Phasenprüfers, Prüfspitze

    an den Schutzkontakt einer leeren 230V Buchse -und das Ding leuchtet wirklich!

    -schwach, aber durchaus sichtbar.


    ps.:


    Scheint also normal :)

    Quote from _deets_

    Wenn das inzwischen so gut funktioniert, ist das ja fein. Dann ziehe ich meine Aussage zurueck, und behaupte das Gegenteil.

    tja, habs gerade mit dem aktuellen Raspberry Pi OS getestet:

    Anmelden geht, ausgesuchter Film fängt sogar an zu laufen, dann:

    "Entschuldigen Sie bitte die Störung" ....

    "Fehlercode M7701.1003"

    und man möge die Komponente "Widevine Content Decryption Module" updaten.


    Ich mach das auf dem Raspi nicht, aber so schlecht siehts nicht aus, das da auch zum Laufen bringen zu können.

    Quote

    Wie ist das eigentlich wenn ich nen Lautsprecher direkt mit dem entsprechenden Pin verbinde? sollte nach meiner meinung ja trotzdem Ton bringen, wenn auch qualitativ nicht so dolle. Oder liege ich da falsch?

    Schon, aber das ist gefährlich.

    Der nackte Pin sieht dann einen Widerstand von 8 oder gar 4 Ohm am Ausgang.

    -Bei den größeren und neueren Raspis hast Du vor dem Klinkenanschluß

    noch ne kleine, aktive Impedanzwandlung-

    Beim Zero überforderst Du den GPIO, für den ist das fast ein Kurzschluß.

    Mehr als 1 oder 2mA darf man da nicht ziehen.

    Sehr kurzzeitig im Millisekundenbereich vlt. etwas mehr.

    Sollte der Gleichspannung von 3,3V an 4 Ohm führen, würde der Widerstand ganze

    0,8Ampere ziehen und das macht den Pin sicher kaputt!

    Mit nem Vorwiderstand von jeweils 1000Ohm währe das OK,

    aber das wäre dann auch sehr leise.


    Äh...

    Wir reden doch über den Rpi Zero W ?

    Das Signal kommt an GPIO-Pin12 und GPIO-Pin13 per Default raus.

    Auf dem Pfostenstecker sind das die physikalischen Pins 32 und 33,

    Masse hole ich von Pin 39.

    -bei mr läufts.

    Na sicher,

    da hatte ich mir ja das hier:

    dtoverlay=pwm-2chan, pin=18, func=2, pin2=13, func2=4

    zusammengereimt und das hat ja auch etwa ein Jahr lang gut funktioniert,

    auf "pin18" und "pin13", wie es zur Option steht.

    Und nach dem Update war Tutenblasen.


    Bischen rätselhaft scheint mir die Aussage:

    "So be careful mixing audio and PWM."

    Audio ist doch "PWM" .

    "Delta Sigma" ist doch nur ne schickere Form davon,

    aber im Prinzip bleibts doch so, das ein GPIO Pin nur "an" und "aus" kann.

    ?

    Tjaaa, das wars.

    Wie im letzten Posting beschrieben.

    Das hier in der /boot/config.txt:

    dtoverlay=pwm-2chan, pin=18, func=2, pin2=13, func2=4

    funktioniert nicht mehr nach dem letzten großen Dezemberupdate.

    Ich habe alle bezüglichen Einträge in der config.txt, sowie

    zusätzliche in der cmdline.txt wieder gelöscht.


    Der Eintrag lautet nun:


    # Sound on Pi Zero W:

    dtparam=audio=on

    dtoverlay=audremap, swap_lr=off

    audio_pwm_mode=2


    Entsprechend der erwähnten Beschreibung kommen per Default

    die PWM-Signale nun aus GPIO-Pin12 und GPIO-Pin13.


    Das hat also alles null und nichts mit Pulseaudio, Jack oder Alsa zutun.

    mpg123 läuft wieder brav und ohne Meckern, wie vorher.

    Nur hat das alte Overlay "pwm-2chan" offensichtlich keine Funktion mehr.


    UFFF!

    Hi stefankoelle,

    sei erstmal willkommen hier & hab' Dank.

    Hab's gerade getestet:

    "snd_bcm2835.enable_headphones=1" in der /boot/cmdline angefügt,

    sogar nochmal ein neues Update aufgespielt, aber der Ordner /dev/snd

    bleibt, wie oben beschrieben, quasi leer.

    Vlt. funktioniert ja das ganze Overlay (dtoverlay=pwm-2chan, pin=18, func=2, pin2=13, func2=4)

    nicht mehr.

    Hab auf Deine Anregung hin noch diesen Parameter ergoogelt:

    snd_bcm2835.enable compat alsa=1

    -der macht auch nix.

    aplay -l sagt weiterhin nur: "keine Soundkarten gefunden."


    Erlich gesagt verstehe ich auch nicht, warum Alsa auf einmal wegen Pulseaudio nicht mehr funktionieren soll.

    Dieses Pulseaudio ist doch sowieso nur wie ein Kropf, der da angepfropft ist.


    nochn p.s.


    Habe gerade noch das hier:

    ...hier:

    https://www.raspberrypi.org/forums/viewtopic.php?t=273646

    -gefunden.

    Sieht aus, als ob es in der /boot/overlays/README steht

    & ich probier 's Morgen mal aus.

    Heinrich Mal eine Zwischenfrage.. Was ist bei Deinem Zero nach dem Update die AUsgabe von uname -r?


    wellnestom Was ist bei Dir die Ausgabe von uname -r?


    Bei einmal Bild und einmal Ton würde ich das erstmal ausschließen. ;)

    Der Zero ??

    Da gucke ich keine Videos drauf, aber gut:

    Linux Deepthought 5.4.79+ #1373 Mon Nov 23 13:18:15 GMT 2020 armv6l GNU/Linux


    Quote from wellnestom

    Gibt's eine Möglichkeit von Pulse zurück auf Alsa?

    Da würde ich lieber erstmal nicht dran drehen, wenn Du keine Neuinstallation riskieren möchtest.

    Übrigens: SMPlayer wäre auch noch'n Tip für 's Videogucken,

    das ist ein Frontend für den Mplayer und den bringt der auch gleich mit.

    Den fand ich weniger zickig als VLC.

    Kann sein, daß der omxplayer das neue pulseaudio nicht mag,

    das ist doch ein Shellprogramm, das auch ohne Xserver läuft.


    Bei vlc kannst Du mal mit den Video-Ausgangstreibern probieren,

    der müßte auch eine opengl-Ausgabe haben.

    Unter den Videoeinstellungen gibt es da etliche Möglichkeiten.

    Ansonsten alle mal durchprobieren.

    Zum Gag und falls es den noch gibt, probier mal "asciiart" :)


    Falls das alles nicht will, gibt es noch den mplayer.

    Wenn mir das hier zu dem Nebenthema abschließend noch gestattet ist :) :

    Es ist nicht Alsa, OSS oder Pulseaudio.

    Wenn alle gut funktionieren: Super!

    Aber, wie hyle schon sagt: Das Hin und Her ist Schite!


    Was die zwei Desktops betrifft:

    Im Prinzip läuft soweit auf meinem Raspi4 was Laufen soll nach dem Update

    und mit den mehreren Desktops werde ich es halt nach weiteren Updates immer wieder mal versuchen,

    ich weiß ja nun, wie mans macht und vor allem:

    Wie mans wieder zurückstellt. :)

    Danke nochmal.

    Buster64 wäre wohl der Overkill für einen Raspi Zero,

    der braucht sicher keine 64Bit.

    Das ist ja genau der Spagat, den man mit Raspi-OS machen möchte:

    Die Eierlegende Wollmilch-Desktopsau auf der einen Seite, die ich ja -nebenbei-

    auch schon für recht gelungen halte und dann den €5,- Zero in dessen

    Hardwareregistern (GPIO, RS232 z.B.) man als ambitionierter Hobbyist noch stochern können soll.

    Für alles eins... so richtig paßt das nicht mehr.

    Meine Güte, warum sollte der Kram mit Pulseaudio nicht funktionieren? Muss man halt vielleicht ein paar Kleinigkeiten anpassen. Ich hatte schon von mir aus seit langem ALSA durch Pulseaudio ersetzt. Aber das scheint ja hier ein absolutes No Go zu sein. Am besten alles so lassen wie 2012 oder 2013 als der Raspi herauskam ... :-/

    läuft das denn ohne X?

    Ich brauche ne simple Audioausgabe über die GPIO eines headless Pi Zero W

    Ob das Alsa, OSS oder sonstwas ist, ist mir schietewurscht,

    wichtig ist nur, daß das mit dem nächsten Update nicht verschwindet.

    Auf die Winzdinger kommt mir schon wegen MIDI/Audio Latenzen kein Desktop,

    den ich ja sowieso nicht sehen kann und will:

    Telnet oder ssh ist da die Wahl zum Einstellen, die Verbindung läuft dann über "aseqnet".

    Hi Repa,

    ich danke Dir, aber ich hab den Zero jetzt erstmal beiseite gelegt.

    Nach dem letzten 2020 Update scheint ja einiges, was Audio betrifft

    dank "pulseaudio" nicht mehr recht zu wollen.

    Ich hol nochmal tief Luft und schau mir dann mal wieder Arch an,

    das scheint mir für die kleinen, älteren und die Zero-Raspis langsam

    wesentlich besser geeignet zu sein.