Posts by ait

    ist doch schon seit 2016-11-25 drin


    Code
    1. 2016-11-25:
    2. * SSH disabled by default; can be enabled by creating a file with name "ssh" in boot partition
    3. * Prompt for password change at boot when SSH enabled with default password unchanged
    4. * Adobe Flash Player included

    Moin,

    es ist der gleiche slot wie bei dem RPI3.

    Der Slot ohne Feder wurde laut der Foundation eingeführt weil bei dem Modell mit Feder

    öfter Fehler auftraten und es relativ viele Reklamationen deswegen gegeben hat.

    Moin,

    heute gefunden:

    Vivaldi Web browser released for Raspberry Pi


    https://www.raspberrypi.org/magpi/vivaldi/


    in der Installationsanleitung

    Code
    1. cd Downloads/
    2. wget https://downloads.vivaldi.com/stable/vivaldi-stable_1.13.1008.34-1_armhf.deb
    3. sudo apt install vivaldi-stable_1.13.1008.34-1_armhf.deb

    muß der volle Pfad oder ./ vor vivaldi-stable_1.13.1008.34-1_armhf.deb

    angegeben werden.

    Läuft bei mir auf dem Raspi 3, nicht auf dem Zero.

    Es gibt auch Module mit 3 Anschlüssen.


    Allerdings hat jar recht,

    Quote

    Ein gutes Foto oder mehrere wo alles zu erkennen ist hilft auch, manchmal ist es nur ein falsches Kabel, eine doofe Lötstelle

    dann sieht man wie es wirklich ist, alles andere sagt nur aus wie es sein soll, oftmals ist es aber nicht so.

    Moin,

    Quelle: https://github.com/raspberrypi…ster/boot/overlays/README

    ich würde das so interpretieren dass für jeden Pin der als onewire benutzt wird ein Eintrag mit der entsprechenden Pinnummer in config.txt enthalten sein muß.


    z.B.:

    Code
    1. dtoverlay=w1-gpio,gpiopin=24,gpiopin=4


    Hab ich aber nicht selber getestet.

    Moin,

    ich habe mal diese:

    https://www.ebay.de/itm/SX1278…ksid=p2057872.m2749.l2649

    getestet.

    Allerdings nicht im urbanen Umfeld.

    Sender und Empfänger hatte ich mit einem einfachen Draht (Lambda/4) als Antenne betrieben.

    Der Sender war hinter geschlossenem Fenster im ersten Stock plaziert.


    Die Reichweite betrug in Fahrradlenkerhöhe ca. 1 Km bei stabilen Empfang, wobei ca. 300m ländliche Bebauung (Dorf) und

    Bewuchs waren, der Rest war relativ frei.

    Ich hatte zeitweise auch bis 4 Km Empfang wenn ich den Empfänger hochgehalten (ca. 2,2m) habe .

    Bei uns ist es relativ flach.

    Sender auf etwa 22m über Meer , Empfänger 15 m ü.M bei 1 KM Entfernung.

    Bei 4 KM Entfernung Empfänger 10 m ü.M.


    Ach ja, bei 433Mhz

    Moin,

    das hast Du gelesen/berücksichtigt?:

    Quote

    The installation expects a Pi with working network and ssh. It is tested with Raspbian Stretch Lite. For now the Full version is not working somehow.... So use the lite image!

    Hast Du die Hardware getestet?

    Quote

    How to test a DHT11, DHT22 or AM2303 sensor

    After installation of TerrariumPI there is a folder called 'Adafruit_Python_DHT' in the 'pi' user home folder. Enter the examples folder for a simple test script.

    1. cd ~/Adafruit_Python_DHT/examples
    2. ./AdafruitDHT.py 22 24
    3. Temp=21.6* Humidity=70.6%

    Where value 22 is one of: 11 for DHT11 sensor, 22 for DHT22 sensor and 2302 for AM2303 sensor. And 24 is the value of the pin number in BCM mode https://pinout.xyz/

    If the output is out of range, for example humidity is above 100%, this is an indication that the sensor is not working properly and can have a hardware failure. This has to be solved first before using it with TerrariumPI.

    ist der GND-Anschluß des Sensors mit GND des Raspis verbunden?

    Scheinbar weiß die Raspberrypi Foundation auch nicht immer alles.

    In dem i. vorherigen Post erwähnten Thread schreibt jamesh ( Principal Software Engineer at Raspberry Pi (Trading) Ltd.)

    in seinem letzten Post:

    Das wollte ich selbst ausprobieren.


    Also hab ich ein "frisches" Raspbian Stretch (2017-11-29) genommen.

    1 * In raspi-config erstmal meine normalen Einstellungen (Password/Boot in Textconsole/Location Options/SSH)

    vorgenommen.

    2 * Nach dem reboot apt-get Update/upgrade.

    3 * HDMI-Monitor und original RPI-Display an DSI angeschlossen

    4 * in raspi-config den Grafiktreiber aktiviert
    5 * reboot

    und tatsächlich , auf Monitor + Display erscheint die Textconsole.

    6 * "startx" eingeben -> kein Bild mehr auf Monitor + Display, eine parallel laufende SSH-Verbindung reagiert auch nicht mehr

    7 * Brutal rebootet (Power abgeschaltet)

    8 * in raspi-config -> Booten in Desktop aktiviert

    9 * reboot

    10 * Desktop erscheint auf HDMI und DSI, auf DSI kopfüber -> keine Bedienung möglich , läßt sich auch nicht mehr anpingen

    11 * Brutal rebootet (Power abgeschaltet)

    12 * HDMI/DSI kein Bild -> keine Bedienung möglich , läßt sich auch nicht mehr anpingen


    MIST - ALLES AUF ANFANG


    Raspbian neu installiert,

    Schritt 1-5 wiederholt, diesmal allerdings gleich "Booten in Desktop" aktiviert und in "Memory Spilt" der Grafik 128 MB spendiert

    * HDMI/DSI kein Bild -> keine Bedienung möglich , läßt sich auch nicht mehr anpingen

    * Brutal rebootet (Power abgeschaltet)

    * HDMI/DSI kein Bild -> keine Bedienung möglich , läßt sich auch nicht mehr anpingen
    * Brutal rebootet (Power abgeschaltet)

    und plötzlich geht es , der Desktop erscheint auf HDMI + DSI

    * hab dann versucht den Browser zu öffnen

    Desktop friert ein, keine Bedienung möglich , läßt sich auch nicht mehr anpingen

    * ich hab für erste aufgegeben


    FAZIT: es ist mit dem neuen Grafiktreiber theoretisch möglich DSI und HDMI gleichzeitig zu bedienen,
    allerdings hat der Grafiktreiber noch Fehler und Raspbian stürzt ab.
    Der Treiber wird ja auch noch als "experimentell" deklariert


    NACHTRAG: nach mehrmaligen "harten reboots" lief der Desktop auf Beiden,
    es ließ sich sogar der Browser öffnen.

    Das System ist aber unstabil, es läuft manchmal, manchmal stürzt es wieder ab.