Posts by ait

    Moin.

    Quote

    Schade, hat bei mir nicht funktioniert. Ich vermute, dass ich beim vielen Herumprobieren irgenetwas verstellt habe. Meine Datei ...alsa-base.config sieht nun so aus:


    Sieht genau so aus wie meine,
    finde keinen Unterschied.


    Gruß Ait



    Nachtrag: Du schriebst


    Quote

    Das Mikro geht alleine einwandfrei, in Kombination mit der Soundkarte der gleiche Effekt wie bei RP.


    Meintest Du damit dass das Mikro am Mac mit deiner USB-Soundkarte auch nicht funktioniert hat?
    Dann würde ich entweder auf Steckerprobleme tippen oder vermuten dass der Mikrofoneingang deiner Soundkarte
    nicht empfindlich genug für ein dynamisches Mikro ist.

    Hallo Daniel ,




    das Display startet nicht wieder wenn von selbst wenn es aus- und wieder
    eingeschaltet wird.
    Der Raspi initialisiert es beim booten.
    Beide müssen gleichzeitig angeschaltet werden.



    Es gibt aber jetzt die Möglichkeit die Hintergrundbeleuchtung aus und wieder einzuschalten.
    Es ist in der neusten Software implentiert.


    Siehe dazu den Thread im englischen Forum.


    Selber hab ich es noch nicht ausprobiert. Ich weiß auch nicht ob es mit einem
    sudo apt-get upgrade
    getan ist oder ob ein
    sudo rpi-update nötig ist.


    Anschalten soll dann so gehen:

    Code
    echo 0 > /sys/class/backlight/rpi_backlight/bl_power


    ausschalten

    Code
    echo 1 > /sys/class/backlight/rpi_backlight/bl_power


    Lies es am besten in dem oben genannten Thread nochmal nach.


    Gruß Ait



    Nachtrag: Die Befehle müssen als root (sudo echo 1..................) ausgeführt werden


    Nachtrag 2: Ich habs selber ausprobiert:
    1.) es ist ein sudo rpi-update nötig.
    2.) bei mir hat es erst funktioniert nachdem ich mich mit "sudo su" zum "root"
    gemacht habe. "sudo echo 1 > /sys/class/backlight/rpi_backlight/bl_power "
    ging nicht.




    Also

    Code
    sudo su


    dann

    Code
    echo 1 > /sys/class/backlight/rpi_backlight/bl_power

    So, es hat mir keine Ruhe gelassen und habe es selber nochmal ausprobiert.


    Ergebniss in kurz: In ähnlicher Konfiguration funktioniert es bei mir mit einem dynamischen Mikro.
    Die Niederfrequenz wird in xoscope auf einem Raspi B angezeigt.


    In lang:


    Mikro: Monacor DM 70 (dynamisches Mikro)
    Noname USB-Soundcard (war ganz billig - ca. 2-3 Euro)


    Ein ziemlich aktuelles Raspbian (Jessie)
    Linux debian 3.2.0-4-686-pae #1 SMP Debian 3.2.41-2 i686 GNU/Linux


    Ich habe:


    In /etc/modprobe.d/alsa-base.conf

    Code
    sudo nano /etc/modprobe.d/alsa-base.conf



    die Zeile

    Code
    options snd-usb-audio index=-2


    in


    Code
    options snd-usb-audio index=0


    geändert
    und die Zeile

    Code
    options snd_bcm2835 index=1


    darunter eingefügt


    xoscope + jaaa installiert (wobei jaaa wahrscheinlich nicht benötigt wird)


    Dann xoscope gestartet.
    xscope meckert rum: "no data source"


    darum

    Code
    sudo apt-get install alsa-oss


    alsa-oss installiert


    wenn xoscope mit

    Code
    aoss xoscope


    gestartet wird funktioniert bei mir die Anzeige
    des Mikosignals in xoscope.


    Eventuell mit alsamixer den Aufnahmepegel hoch stellen.


    Bei mir war die Kombination Mikro, Klinkenadapter (von 6,5 auf 3,5 mm) und die 3,5mm Klinkenbuchse
    in der (billigen)USB-Soundkarte
    ziemlich wackelig und produzierte Aussetzer.

    Moin,
    dein Mikro ist ein dynamisches Mikro.
    Wikipedia (https://de.wikipedia.org/wiki/Soundkarte#Mikrofoneingang)
    schreibt dazu:

    Quote

    Quote


    Mehr dazu siehe unter oberen Link.
    Gruß Ait



    Nachtrag: Wenn Du hast setz ein Mischpult davor oder benutze ein USB-Mikrofon.
    (Warum zum Teufel erscheint der Link 2 mal?)

    Moin,
    der serielle Port wird zum anzeigen der Kernel messages benutzt.
    Wenn Du den Port für Deinen Gebrauch freischalten willst
    versuche mal mit
    sudo raspi-config
    das Konfigurationsmenue aufzurufen. Dort kannst Du
    unter dem Menüpunkt:
    8 Advanced Options
    den Unterpunkt
    A8 Serial Enable/Disable shell and kernel messages on the serial connection
    aufrufen und den seriellen Port für
    Deine Benutzung freischalten.
    Also bei
    Would you like a login shell to be accessible over serial?
    mit "Nein" antworten.


    Sollte eigentlich helfen falls ich Dich richtig verstanden habe.


    Ait


    Hallo,
    mit einer weißen Folie wird es wohl nicht funktionieren
    Guck mal hier:
    https://www.raspberrypi.org/bl…haunted-mansion-portrait/
    da wurde mit Spiegelfolie gearbeitet.
    Anleitung und Teileliste findest u unter:
    http://www.brandonetto.com/Gracey_%20Parts_%20List.pdf


    Gruß Ait

    Der Raspi weiß garnichts.
    Der Strom der durch diesen Stromkreis fließt hängt von der Größe des Vorwiderstands und der Größe
    des Innenwiderstands der LED ab.
    (außerdem noch vom Innenwiderstand der Stromquelle, den wir hier der
    Übersichtlichkeit wegen vernachlässigen).


    Eine LED die bei 1,1 Volt leuchtet (gibs die überhaupt?) hat einen anderen Innenwiderstand als
    eine die bei 2,2 Volt leuchtet, deshalb fließt bei gleichem Vorwiderstand ein anderer Strom durch den Kreis.


    Der Innenwiderstand eines Halbleiters ist nicht linear und muß im Datenblatt nachgesehen werden.


    Kennlinie LED


    Zu einer bestimmten Spannung an einer LED (zb. 3,3V) gehört immer ein bestimmter Strom (z.B 5 mA),
    er wird bei 3,3V immer gleich sein und kann nicht verändert werden ohne dass sich die Spannung an der LED ändert.

    Hallo,
    ich habe das gleiche Display.
    EIn Image kannst Du unter http://pan.baidu.com/s/1sjuo6nV downloaden.
    Den Link habe ich vom Verkäufer.
    Allerdings ist der Download oftmals sehr langsam und bricht auch manchmal ab.
    Es kann auch vorkommen dass sich die Seite nicht vollständig öffnet, dann später nochmal probieren.


    Ait


    Edit: das Image heißt " rpi_35_B_B+_PI2.rar" , das mußt Du mit unrar entpacken und dann wie das Raspbian Image
    (unter Linux mit dd ) auf die Karte packen.


    Alternativ kannst Du dort auch die Datei " LCD_show.tar.gz " runterladen.
    Mit "tar -xzf LCD_show.tar.gz" entpacken, dann in den Ordner "LCD-show " wechseln und den Befehl
    "sudo ./ LCD35_v1 " ausführen, dann installiert er einen angepassten Kernel samt Modulen und Config.Dateien.
    Der Raspi rebootet nach der Installation von selber und das Display funktioniert dann.


    Hast Du parallel dazu einen HDMI Monitor angeschlossen zeigt dieser die ganze Zeit während der Raspi läuft ein großes Viereck mit den Regenbogen.


    DerOmxplayer funktioniert auf den 3.5 Display nicht. Hast DU aber parallel einen HDMI Monitor angeschlossen so
    wird die Ausgabe des Omxplayers dort angezeigt.




    Ich habe übrigens zwei von diesen Displays, ein davon ist fehlerhaft. Man muß es beim booten stark zusammendrücken, sonst zeigt es nur einen weißen Bildschirm.



    "

    Hallo,
    soviel ich weiß kannst Du die ganze Prozedur (den seriellen Port freimachen) auch mit "raspi-config" machen.
    In

    Quote

    8 Advanced Options Configure advanced settings"]


    den Menüpunkt

    Quote

    A8 Serial Enable/Disable shell and kernel messages on the serial connection


    aufrufen und bei

    Quote

    Would you like a login shell to be accessible over serial?

    "NEIN" anklicken.


    Dann werden automatisch die entsprechenden Dateien editiert.


    in cmdline.txt steht dann:

    Quote

    dwc_otg.lpm_enable=0 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline rootwait


    Hier ist "rootwait" noch mit drin. Ob das wichtig ist kann ich Dir allerdings auch nicht sagen.


    Wenn das geklappt hat brauchst Du auch noch ein Programm welches den Empfänger ausliest.


    Edit: ich sehe gerade: In Deinem Link ist ja beschrieben wie es weitergeht (ntp - konfigurieren).


    Edit:Edit: Ich habe mal "rootwait" in cmdline.txt weggelassen, bootet bei mir trotzdem.
    Versuch doch mal mit raspi-config den seriellen port einzustellen.


    Das Display funktioniert ausnahmslos an jedem RaspberryPI Modell.


    Was aber Probleme verursachen kann ist die Stromversorgung. Das Display benötigt mind. 430mA. Alle PI Modelle vor B+ haben eine Polyfuse welche den Strom auf max. 1A begrenzt. Der PI benötigt aber mind. 700mA für sich selbst. Wer also mit älteren PI's vor hat das Display über den PI mit Strom zu versorgen wird hier Probleme kriegen.
    Ihr müsst dann also euer Netzteil ans Display anschließen und von dort geht ihr, wahlweise über GPIO oder dem PWR-Out USB, erst zum PI. Dann funktioniert auch das problemlos (sofern das Netzteil genug Ampere liefern kann).


    Hallo meigrafd,
    stimmt leider nicht.
    Gordon (von der Foundation) schrieb dazu in seinem Blog


    Quote


    Unfortunately the B didn’t have the right I2C connections down the DSI connector. That’s one of the reasons for the extra pins on the display conversion board.
    Will investigate what changes (software and jumper wires) would be required, but I would suggest a B+ / 2B / A+ would be the easiest addition
    Gordon


    siehe dazu auch diesen thread:
    Official display and RPi "B"


    Es wurde schon im Vorstellungblog des Displays (Blog) moniert.
    Beim dem RPI ist die I2C Verbindung nicht an dem dem Steckverbinder (S2) für das Display angeschlossen.
    Bei dem B+ und dem RPI 2 B ist der I2C Bus angeschlossen. Über dem I2C Bus werden einige Parameter (Helligkeit, Power) gesteuert. Wie oben zitiert will Gordon eine Lösung finden, es funktioniert bei mir aber auch mit der allerneusten Software
    (rpi-update) von gestern noch nicht.
    Darum bin ich jetzt etwas erstaunt das es bei Beetlevirus jetzt läuft.



    Ich habe 2 alte Raspis, bei dem einen habe ich den I2C Bus an den Displayanschluß angeschlossen (siehe auch den obeb erwähnten Thread), damits funktioniert es dann.




    Ach ja, der Raspi ist so angeschlossen wie Du es oben vorgeschlagen hast.


    Ait