Posts by moppi

    ich werfe mal Codiac ins rennen ...


    nach dem mich bluefish und Eclipse verlassen haben.
    der läuft auf jedem PHP server und kann dann eigentlich von jeden punkt aus programmiern :3


    edit:
    das einzigste was richtig nervt ist die STRG+D funktion
    warum sie das aus VIM und co übernommen haben ist mir ein rätsel

    ich hab nun den DT deaktivert
    und meine LED´s haben wir standart funktion
    was aber weiterhin keine funktion hat ist das auslesen von dem Sensor ::(
    ich denke es ist weiterhin ein rechte problem. aber ich weiss einfach nicht wo :\

    config.txt


    und hier mein Gipo richtungs belegung beim boot


    Code
    echo "23" > /sys/class/gpio/export
    echo "24" > /sys/class/gpio/export
    echo "25" > /sys/class/gpio/export
    echo "out" > /sys/class/gpio/gpio23/direction
    echo "out" > /sys/class/gpio/gpio24/direction
    echo "out" > /sys/class/gpio/gpio25/direction


    bisher lief es ohne problme, und nun geht garnichts mehr :(

    DT ist an.


    ich hab vorhin noch das komplette system geupdatet



    root@raspi2:~# uname -a
    Linux raspi2 4.1.7-v7+ #815 SMP PREEMPT Thu Sep 17 18:34:33 BST 2015 armv7l GNU/Linux


    nun kommt noch hinzu das meine php scripte die per exec echo "1" > /sys/class/gpio/gpio25/value (als bsp.)
    abrufen nun auch nicht mehr laufen



    [Wed Sep 23 13:06:02 2015] [error] [client 192.168.1.27] cannot create /sys/class/gpio/gpio23/value: Permission denied
    [Wed Sep 23 13:06:02 2015] [error] [client 192.168.1.27] sh: 1: cannot create /sys/class/gpio/gpio23/value: Permission denied
    [Wed Sep 23 13:06:06 2015] [error] [client 192.168.1.27] sh: 1: cannot create /sys/class/gpio/gpio24/value: Permission denied



    der apache/php laufen mit www-data sind auch in der gruppe pi

    hi


    ich bekomm es schon als root, da brauch ich dann kein sudo mehr.



    root@raspi2:~# uname -a
    Linux raspi2 4.1.6-v7+ #810 SMP PREEMPT Tue Aug 18 15:32:12 BST 2015 armv7l GNU/Linux



    , ich fühl mich einfach unwohl wenn ich kein root bin.

    ich hab ein problem mit meinem Raspi 2 , kann über Gipo meinen AM2302 nicht auslesen



    ./Adafruit_DHT 2302 4
    Using pin #4
    Data (0): 0x0 0x0 0x0 0x0 0x0


    nun ich dachte zu erst das der sensor defekt ist und hatte mir einen zweiten bestellt, da bekam ich das gleich problem


    da konnte ich mir nicht mehr vorstellen das es an den sensoren liegt


    und siehe da auf meinem alten Raspi 1 lief es dann



    ./Adafruit_DHT 2302 4
    Using pin #4
    Data (40): 0x2 0x56 0x0 0xd0 0x28
    Temp = 20.8 *C, Hum = 59.8 %


    ich hab es dann noch mit AM2302 probiert es auzs zu lesen wo ich dann ein "permission denied" bekomme
    ich weiss nun nicht wo ich suchen muss, bzw. wo ich welche rechte schalten muss.
    da ich auf den gipo´s einige LED´s betreibe die ohne problme funktioniern. bin ich nun echt ratlos