Posts by C4mp1n0

    So sieht mein aktueller Anschluss aus, welcher auch funktioniert.

    Die Stromversorgung erfolgt über den Raspi selber an 3.3V


    Mein Wunsch ist es, einen weiteren Fühler, am liebsten an Verteilung 2, notfalls aber auch an Verteilung 1 anzuschließen.


    Grund dieser Verkabelung ist, dass Raspi und Verteilung 1 sich im Serverschrank befinden, von dort aus geht einmal ein Kabel ins Wohnzimmer, an diesem ist nur der eine Fühler angeschlossen, ein weiterer Fühler ist direkt im Serverschrank verbaut.

    An das Kabel zu Verteilung ist auch wieder ein Fühler direkt angeschlossen im Arbeitszimmer, und von dort aus geht es noch weiter ins Schlafzimmer und auf den Balkon.


    Daher der "verwüstete" Aufbau, welcher aber bis jetzt funktioniert, nur halt nicht, wenn ich einen weiteren anklemme.

    Guten Abend,

    Ich versuche seit Tagen einen weiteren DS18B20 Temperatur Fühler an meinen Raspberry Pi anzuschließen, leider ohne Erfolg ;(

    Folgende Situation:
    Im Moment habe ich an meinem Raspi 5 Fühler über One Wire angeschlossen, welche seid Jahren ohne Probleme laufen.

    Nun hatte ich den Plan, einen weiteren anzuschließen, und da geht die Problematik los.


    Schließe ich den neuen Fühler einzeln an den Raspi an, funktioniert auch alles wie es soll, er wird erkannt und gibt die richtigen Werte aus.

    Wenn ich ihn nun an seinem Bestimmungsort mit den anderen zusammen anschließe, zeigen auf einmal alle den Wert "0" an. :rolleyes:


    klemme ich dann einen der anderen ab, funktionieren die restlichen und der neue ohne Probleme.


    ist es möglich, dass der Raspi mit 6 Fühlern überfordert ist?

    kann es auch daran liegen, dass mein funktionierender Aufbau keine richtige Ring- oder Sternverdrahtung ist? :/

    ich würde eigentlich gerne vermeiden, unzählige weitere Kabel zu ziehen...


    Im Moment, so wie es funktioniert gehen vom Raspi im Stern Prinzip 3 Kabel Weg, von einem dieser 3 Kabel habe ich dann 3 Fühler angeschlossen, an den anderen beiden hängt jeweils ein Fühler.


    Ich hoffe es ist so verständlich, ansonsten müsste ich mal eine Skizze anfertigen :D


    Danke im Voraus :danke_ATDE:


    grüß, C4

    Freut mich, dass du ein eigenes Script entwickelt hast, welches funktioniert.
    Mich stört die Variante mit der Log Datei nicht, im Gegenteil, ich binde sie Zeitgleich noch auf einer Webseite ein, Weswegen dies für mich die schnellste einfachste Lösung war.
    Aber es wäre cool, wenn du mir mal ein bisschen zu eurer Handy Alarmierung erzählen kannst, da bei uns die SMS Alarmierung noch immer auf sich warten lässt. .. ;(
    Hast du evtl ein paar Erfahrungsberichte für mich?
    Gruß, C4

    Hier mal der ausschnitt, meines Bash Skriptes, nicht wundern, ich verwende es noch für weitere Schalter auszulesen und Relais zu steuern, den Teil habe ich jetzt aber aus Bequemlichkeit nicht mit kopiert.


    Vom Prinzip erstellt das eine log.txt dabei, in welche "Einsatz" geschrieben wird, sobald das Relais anzieht.
    Wird der Alarm Quitiert, wird in die log.txt "Kein Einsatz" geschrieben.


    Zieht das Relais an, und in der Log Datei steht "kein Einsatz" werden die Befehle ausgeführt und in die Log date "Einsatz"geschrieben.
    solange dann in der Log Datei "Einsatz" steht, wird nichts ausgeführt.


    Hoffe, das ganze ist verständlich, bei mir funktioniert diese (wenn auch sehr unsaubere) Methode jetzt schon länger ohne Probleme.


    ich habe das Test Script jetzt mal probiert, leider erhalte ich immer beim ausführen folgende Meldung:

    Python
    pi@raspberrypi ~/MFRC522-python $ sudo python test.py
    Traceback (most recent call last):
     File "test.py", line 5, in <module>
       from pirc522 import RFID
    ImportError: No module named pirc522


    Irgendwie blicke ich da nicht mehr durch...

    Guten Abend,


    Heute kam endlich mein lang ersehnter RFID Reader (RC522).
    als ich ihn angeschlossen und MFRC522 installiert habe funktionierte auch alles. :bravo2:
    Nun zu meinem Problem:


    Ich würde gerne, wie es die Überschrift schon sagt, ein Relais Board schalten.
    (dieses lässt sich auch einzeln ansteuern funktioniert) :bravo2:


    Leider verstehe ich nach stunden langem googeln nicht, wie ich das fertig bringe, dass bei einem bestimmten Tag ein bestimmtes Relais geschaltet wird.


    python Read.py gibt folgendes aus:


    Code
    pi@raspberrypi ~/MFRC522-python $ sudo python Read.py
    Welcome to the MFRC522 data read example
    Press Ctrl-C to stop.
    Card detected
    Card read UID: 213,145,204,229
    Size: 8
    Sector 8 [0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0]
    ^CCtrl+C captured, ending read.


    wie kann ich nun auf diese UID reagieren?


    außerdem lässt sich mit der Read.py nichts auf die Karte schreiben.
    hier erhalte ich immer folgendes :



    er schreibt es kurz, und überschreibt es dann wieder? :helpnew:


    so sieht meine Write.py aus:


    ich habe auch schon nach diesem Thema hier die conf dabei bearbeitet und meine UID eingetragen, leider ohne Erfolg.



    kann mir jemand sagen, was ich falsch mache?


    Danke im Voraus,
    Gruß C4


    Jan spielt normalerweise die Scripte schon auf. Zumindest tut er das bei den Relais, die wir anbieten. Auf seiner Seite bietet er das nicht explizit nicht an, macht es aber zum Testen. Letztendlich wäre die Lösung tatsächlich mal zu schauen, welche Scripte drauf sind.


    es geht mir darum, zu gucken, welche Dateien schon enthalten sind und ggf fehlende zu ergänzen.


    Problem ist ja immer noch, dass er das eingegebene WLAN nicht speichert und sich verbindet.


    Ich habe jetzt mal minicom geladen und gestartet, leider komme ich hiermit nicht wirklich weiter...



    Ab hier tut sich gar nichts mehr.... :s

    hey Ho,


    Nach langem habe ich nun endlich wieder Zeit, mich mit meinen "Spielereine" zu befassen..
    (Doch bisschen viel, Gesellenprüfung, Führerschein UND Raspberry :D )


    Wie genau muss ich denn da vorgehen, um das Relais Board über den Raspberry zu programmieren?
    Verbinde ich einfach


    Board "RX" -> Raspberry "TX"
    Board "TX" -> Raspberry "RX"
    Board "GND" -> Raspberry "GND"


    oder muss ich noch was beachten?
    Und wie geht es dann weiter, wenn ich es so angeschlossen habe?


    Sorry, bin echt zu unerfahren und immer froh, wenn meine "Copy & Paste" Scripts Funktionieren :D


    Benötige ich auf dem Raspberry irgendwelche Software?


    Danke und Gruß,


    C4

    Dann werde ich mir wohl noch einen USB -TTL Adapter kaufen müssen.
    Hat jemand da Infos, ob das auch mit einem Mac funktioniert?
    Sonst stehe ich vor dem nächsten Problem :/
    Bis jetzt habe ich nichts gemacht, außer das Netzteil aufgelötet und mich mit dem Hotspot verbunden, meine WLAN Daten eingegeben und das war es.

    Das habe ich mal durchgelesen, aber so wie es mir scheint, finde ich dort auch keine Lösung für mien Problem.
    Oder habe ich in der Anleitung grundlegend was falsch verstanden, dass das ganze gar nicht "Plug & Play" ist, sondern ich vorher das ganze über RX/TX anschließen und einrichten muss?
    Ich dachte eigentlich, durch die Hotspot Funktion erspare ich mir das.

    Hey Ho,


    Vor Kurzem habe ich mir dieses Wifi Relais gekauft: Relais


    Ich habe es nach der beigefügten Anleitung zusammengelötet und nun den Plan, es hinter den Lichtschalter einzubauen und in meine auf dem Raspberry laufende Steuerung einzubinden.


    Jedoch komme ich immer nur bis zu dem Punkt, wo sich das Relais als Hotspot bereit stellt und ich meine WLAN Daten eingeben soll.
    Wenn ich das mache, startet es neu und stellt sich wieder als Hotspot da.


    ich habe auch schon alles probiert, WLAN Namen und PW geändert, anderer Router, usw...


    Jemand eine Idee, was ich falsch mache?


    Danke und Gruß,
    C4

    Ich habe es noch einfacher gemacht.
    Bei mir hängt einfach ein 230V Relais an der Steckdose, welches Stromlos geöffnet ist. Über das Relais habe ich dann einen "Schalter", welcher vom Raspberry ausgelesen werden kann.
    Mein Raspberry wird so, genau so wie meine Netzwerkkomponenten (Router, Switch usw) über eine 12V autobatterie versorgt, welche gleichzeitig geladen wird.


    Hoffe das hilft dir ein wenig weiter,
    Gruß C4

    Nach etwas lesen im Netz sind mir inzwischen ganz oft die Begriffe routing aufgefallen...
    Muss ich da auch etwas beachten?
    Und wie sieht das mit der Subnetzmaske aus? Mache ich dann überall 255.255.0.0 oder 255.255.255.0?
    Danke schon mal für die Tipps.

    [font="Droid Sans, Arial, Helvetica, sans-serif"]Guten Morgen,[/font]
    [font="Droid Sans, Arial, Helvetica, sans-serif"]Ich habe vor, bei uns im Haus das Netzwerk neu zu gestalten.[/font]
    [font="Droid Sans, Arial, Helvetica, sans-serif"]Aktuelle Situation:[/font]
    [font="Droid Sans, Arial, Helvetica, sans-serif"]Im DG ist ein Internet Anschluss vorhanden, welcher von einer Fritz.Box Fon bereit gestellt wird.[/font]
    [font="Droid Sans, Arial, Helvetica, sans-serif"]Von da aus geht es in einen Switch, welcher im DG Drucker, PC und TV versorgt.[/font]
    [font="Droid Sans, Arial, Helvetica, sans-serif"]Außerdem geht es von dem Switch über PowerLan in meine Wohnung im EG, von wo das Netzwerk über Diverse Switches und Router im Switch Modus an PC, TV, Handys, Tablet, Laptop, und Heimautomatisierung Verteilt werden. Das ist im Moment aber nur ein auf gut Glück zusammen gebasteltes Chaos... Einer der Router stellt im Moment Provisorisch einen DHCP Server bereit, damit ich Gastgeräten nicht immer manuell eine IP geben muss. Alle anderen Geräte haben aber sowieso eine feste IP.[/font]


    [font="Droid Sans, Arial, Helvetica, sans-serif"]Nun habe ich den Plan, im EG nur noch einen 24Port Switch und die Fritz.Box 7270 zu verwenden, welche als VoIP Gateway dient.[/font]
    [font="Droid Sans, Arial, Helvetica, sans-serif"]Mein Plan ist nun, dass alle Geräte im DG eine eine IP im Bereich 192.168.2.xxx bekommen, alle Geräte im EG im Bereich 192.168.1.xxx.[/font]
    [font="Droid Sans, Arial, Helvetica, sans-serif"]Dann Soll die Fritz.Box Fon im DG einen DHCP Server für den Bereich 192.168.2.xxx bereitstellen, im EG soll die Fritz.Box 7270 den Bereich 192.168.1.xxx mit DHCP versorgen.[/font]
    [font="Droid Sans, Arial, Helvetica, sans-serif"]Trotzdem sollen aber alle Geräte im EG auch über die Fritz.Box Fon im DG mit 192.168.2.1 ins Internet können, und alle Geräte, egal ob im 192.168.1.xxx oder 192.168.2.xxx Bereich auf NAS und Server mit 192.168.1.116 für NAS und 192.168.1.117 für Server zugreifen können.[/font]
    [font="Droid Sans, Arial, Helvetica, sans-serif"]Außerdem sollen aber auch alle Geräte im EG auf den Drucker im DG mit 191.168.2.40 zugreifen können.[/font]
    [font="Droid Sans, Arial, Helvetica, sans-serif"]Geplant ist, dass Neue Geräte, welche sich egal ob per WLAN im EG oder An dem 24Port Switch verbinden, per DHCP eine IP aus dem 192.168.1.xxx er Bereich bekommen, verbindet sich ein Gerät im DG per WLAN oder Kabel, soll eine IP aus dem 192.168.2.xxx er Bereich vergeben werden.[/font]


    [font="Droid Sans, Arial, Helvetica, sans-serif"]Der Sinn dahinter soll sein, dass sollten meine Eltern Besuchern ihren Internet Anschluss zur Verfügung stellen, diese nicht auf mein Netzwerk im 192.168.1.xxx er Bereich und meine Heimautomatisierung kommen.[/font]
    [font="Droid Sans, Arial, Helvetica, sans-serif"]Außerdem finde ich es bisschen überflüssig, dass ich derzeit im Serverschrank im EG 4 Router stehen habe, welche bis auf die Fritz.Box alle nur als Switch arbeiten.[/font]


    [font="Droid Sans, Arial, Helvetica, sans-serif"]Nun meine Frage, ist das so alles machbar, wie ich mir das gedacht habe?[/font]
    [font="Droid Sans, Arial, Helvetica, sans-serif"]Gibt es irgendwelche Haken an der ganzen Sache, oder muss ich noch irgendetwas beachten?[/font]


    [font="Droid Sans, Arial, Helvetica, sans-serif"]Als 24 Port Switch habe ich mir den Netgear FS726T ausgesucht.[/font]
    [font="Droid Sans, Arial, Helvetica, sans-serif"]http://support.netgear.de/product/FS726T[/font]


    [font="Droid Sans, Arial, Helvetica, sans-serif"]Danke im Voraus für Ratschläge, und evtl paar Tipps zur reibungsfreien Umsetzung[/font]