Posts by Korikatzo

    Hallo zusammen,


    Da ich leider nichts passendes finde hoffe ich ihr könnt mir weiterhelfen:


    Ich benötige ein 0 bis 10V Analog Signal, einstellbar mittels des Pi. Habe bisher nur den mcp4725 von adafruit und ähnliche gefunden, der geht jedoch leider nur bis 3.3V am Pi wenn ich das richtig verstanden habe.

    Kann notfalls auch etwas teurer sein, wichtig ist ein fertiges, zuverlässiges Modul.

    btw: Ich gehe jede Wette ein, dass Du dadurch Deine Gewährleistungs-Ansprüche verlierst ...

    Da hast du natürlich Recht ;) Aber das sollte wohl jedem klar sein, dass sobald man seinen Pi mit dem Lötkolben bearbeitet die Gewährleistung vermutlich Geschichte ist.


    Spricht denn konkret etwas dagegen die Messpunkte als Stromversorgungspunkte zu missbrauchen (außer der bereits genannten Gefahr durch mechanische Belastung und Unfälle beim löten)? War in meinen Augen die einfachste Lösung für das Platzproblem unter Beibehaltung der Absicherung durch die Polyfuse. Lasse mich aber gerne eines besseren belehren :geek:

    Hallo,


    Klar sollte man beim löten vorsichtig sein.

    Bei mir ist das ganze über die lötpunkte umgesetzt bei einem Pi der in ein relativ kleines Gehäuse verbaut wurde mit 12V Versorgung die über einen Festspannungsregler den Pi mit 5V versorgt. Der Pi ist fest verschraubt, so wie die Platine des Reglers und genügend Leitung dazwischen, daher kein Problem mit der mechanischen Belastung. Und ich hab nicht seitlich vom Pi die Platzverschwendung für den Micro USB Stecker.


    Ob man das benötigt muss jeder selbst wissen. Bei einem Raspberry mit direkter 5v Versorgung und im normalen Gehäuse würde ich das auch nicht so lösen sondern einfach über mikro USB. (oder USV mit Schraubklemmen).


    Gruß

    Hallo,


    Es gibt auf der Rückseite des Pi Messpunkte, auch einen für Masse und +5V, da kannst die dir Stromversorgung direkt anlöten und hast dabei trotzdem die Sicherung usw.


    Hinweis: Die Verbindungen der Messpunkte sind nicht auf hohe Ströme ausgelegt, daher ist diese Lösung nicht empfehlenswert.

    Besser ist die Verbindung über die GND/5V der Stiftleiste + eigene Absicherung wie bereits vorgeschlagen


    P.s: Hier hast du die Pläne für die Pi, bspw im Plan des 3B siehst du oben links den Anschluss des Micro USB mit Messpunkte PP1/2 für 5V und PP3/4/5/6 für Masse.


    Gruß

    Hi,


    Naja, war halt eigentlich Gedanke weil ich die Erfahrung gemacht habe dass die Micro USB Verbindung anfällig ist und das Problem des nötigen Querschnitts.. Daher bin ich auf die Versorgung über die Messpunkte gekommen. Falls jemand das gleiche Problem hat könnte das eine gute Lösung sein.


    Gruß

    Hallo,


    Spricht etwas dagegen den Pi über die Messpunkte auf der Unterseite zu versorgen?

    Hab grad die Nummer der richtigen Punkte nicht im Kopf, aber an die direkt an der Micro USB Buchse könnte man einen gewissen Querschnitt anlöten, umgeht dabei nicht Absicherung und hat auch nicht die wackelige Micro USB Verbindung.


    P.s: Hoppla der Thread stand ja bereits mit einem Fuß im Grab


    Gruß

    Hallo reaper,


    Auch erstmal willkommen😋.

    Die anfängliche Begeisterung sich direkt in etwas großes zu stürzen kennen hier vermutlich die meisten. Jedoch (das folgende ist lediglich meine Meinung, musst du natürlich nicht befolgen) ist ein Mediacenter je nach gewünschtem Umfang schon eine recht komplizierte Sache mit der ein oder anderen versteckten Hürde. Das kann dazu führen, dass einem die Motivation recht schnell verloren gehen kann wenn es nicht so voran geht wie man sich s vorstellt.


    Meine Empfehlung wäre, eventuell erstmal die Licht Automatik zu realisieren (je nach anzusteuernder Hardware wohl etwas einfacher für s erste) oder dein Mediacenter erstmal in "Teilprojekte" aufzuteilen. Heißt zb erstmal die Funktion für das Radio zu erstellen und testen. (Zwischendurch Erfolgserlebnisse motivieren dran zu bleiben 😁)


    Wenn dann deine ganzen teilfunktionen passen kannst du das ganze mit einem Hauptmenü zusammenfassen.


    Mfg

    Edit: Und plötzlich scheint es zu funktionieren (mit vorsichtigem Optimismus)....

    Hab den Router nochmals neugestartet (eig gestern und vorgestern Abend auch schon)

    und bin auf etwas mit ARP Cache leeren gestoßen, das hab ich mal gemacht und nun funzt es wohl wieder... Wobei ich nicht genau verstehe weshalb...^^


    Hallo zusammen,


    mein Raspberry Pi 2 lief seit mehreren Wochen ohne Probleme 24/7, erreichbar durch einen Edimax WLAN USB Stick nur im eigenen Netzwerk.

    Vor 2 Tagen war er dann auf einmal nicht mehr über Putty erreichbar und auch die Website die er hostet auch nicht(Flask), war jedoch weiterhin im WLAN Netz.


    Zuerst Neustart etc versucht, dann alles abgesteckt bis auf den WLAN Stick

    und neues Image auf einer anderen Micro SD installiert, eingerichtet wie immer.

    (Energiesparmodus vom Edimax ist über die 8192cu.conf Datei deaktiviert)


    Er ist wieder ganz normal im WLAN, aber nicht direkt erreichbar durch Putty am PC.

    Mir ist aber zufällig aufgefallen, dass ich mich über Putty anmelden kann sobald ich vom Pi einen Ping Versuch zu meinem PC starte.

    Manchmal schlägt der erste fehl, die weiteren gehen dann durch.


    WLAN Konfiguration am Pi ist minimalistisch gehalten, lediglich SSID/PSK.

    Habe es über die alte Weise durch /etc/network/interfaces versucht, aber auch über wpa_supplicant oder direkt in der dhcpcd.conf Datei.

    Immer das selbe Ergebnis:

    - Pi ist im Netzwerk

    - nicht erreichbar, außer nach anpingen des PCs


    Was könnte ich noch versuchen?

    Hallo zusammen,


    ich habe ein Script, welches durch Interrupts abwartet ob ein Button gedrückt wird und dann je nachdem eine Aktion ausführt.
    Problem daran ist, dass ich ja keine permanente Aufgabe in einem Loop habe der dafür sorgt dass das Script nicht nur einmal durchläuft und dann beendet wird.


    Gibt es eine elegantere Lösung als Pass/time.sleep?:


    Code
    While True:
    
    
      pass


    Code
    While True:
    
    
      time.sleep(1000)


    Pass scheint den CPU stark zu belasten obwohl eig nichts zu bearbeiten ist.


    Hätte Time.sleep mit einem großen Wert irgendeinen Nachteil im Bezug auf Funktionen die durch einen Interrupt aufgerufen werden?

    Hallo zusammen,


    erstmal großen Respekt, schön durchdachtes Projekt.


    Bin selber auch ein bisschen am basteln mit einem AquaPi wenn man mal die Zeit dazu hat (daher auch erst Temperaturmessung bisher... :D ).
    Habe mich auch eine Zeit lang über PH-Messung mit dem Pi erkundigt und die einzig zufriedenstellende Lösung die ich gefunden habe ist die von Atlas-Scientific.
    175 Dollar für das Hobby ist mir dann für einen Messwert den ich sowieso nicht großartig beeinflussen werde doch zu teuer (Leitungswasser Werte sind vollkommen ok für meine Tiere).


    Aber Atlas-Scientific bietet auch direkt Beispielcode für den Pi und Arduino an.


    MfG

    Hallo,


    also ich hab echt einen riesigen Respekt vor dem großen Wissen von gewissen Leuten hier im Forum.
    Aber ein paar eben jener Leute haben hier einen Umgang, man könnte meinen jeder will den anderen nur angreifen und nicht helfen.


    Aber das nur so nebenbei ;)


    jar


    Sorry, ich dachte einfach, man kann sich zusammenreimen, wenn ich schreibe:


    Quote

    [font="Source Sans Pro, Tahoma, Helvetica Neue, Arial, sans-serif"]könnte man das Relais nun sicher anschließen,....[/font]


    dass ich das Relais-Board meine, dass auch der Threadersteller hat. Also jenes, um das es die ganze Zeit ging :) .
    Wenn man dem Link des TEs folgt erhält man zwar keinen Schaltplan,
    aber ich behaupte mal auch ohne Schaltplan erkennt man anhand der vielen Bilder,
    dass das Relais nur einen Jumper zwischen VCC und JD-VCC besitzt.


    Aber ist ja auch egal, sorry dass ich zuwenig Infos gegeben habe :)


    Mein Relaisboard ist das gleiche wie das des TEs.
    In diesem Ebay-Angebot wo ich meines gekauft habe, ist auch ein Schaltplan enthalten.
    Ich möchte das Relais-Boards direkt über das gleiche Netzteil wie den Pi mit Strom versorgen.


    Könnte mir bitte jemand sagen,
    wo ich dafür am Board GND und VCC anstecken muss
    und ob der Jumper zwischen VCC und JD-VCC eingesteckt sein muss oder nicht?


    MfG

    Quote

    [font="Source Sans Pro, Tahoma, Helvetica Neue, Arial, sans-serif"]klares JA für ein Relais, sehr umständlich für 8 Relais wo ein ULN 2803a genügt + von mir aus beide Rs zur Sicherheit je Zweig.[/font]


    Hab nur ein paar BC337 da, diese also zum testen :)


    Quote

    [font="Source Sans Pro, Tahoma, Helvetica Neue, Arial, sans-serif"]klasse Frage, welcher Jumper auf welche Schaltung beziehst du dich, es gibt ja etliche.[/font]
    [font="Source Sans Pro, Tahoma, Helvetica Neue, Arial, sans-serif"]Es gibt nicht DIE Schaltung es gibt nicht DEN Jumper.[/font]


    Korrigiere mich falls ich mich täusche, aber auf dem 8 Kanal Relaisboard um das es in diesem Thread geht, sehe ich nur einen Jumper auf VCC und JD-VCC :)

    Hallo,


    könnte man das Relais nun sicher anschließen, wenn man die INs an jeweils den Kollektor eines Transistors anschließt, die Basis über einen 1kOhm Widerstand an den GPIO des Pi (mit 10kOhm gegen Ground als PullDown) und den Emitter des Transistors auch gegen Ground?


    Wenn ja, was muss man mit dem Jumper machen bzw wo noch was ans Relais anschließen :P?