Posts by Janomine


    Na da werden wir wohl doch noch die 100er Beitragsmarke, für das Schalten von Relais knacken.


    Aber zurück zum Thema, der durch dich festgestellte "merkwürdig Effekt, das das Relais bei GPIO High also 1 und nicht wie bei allen anderen LOW also 0 durch schalten" ist normal und auch logisch. Wenn Du nicht glaubst, das der ULN nicht mit viel, viel, weniger, als 20mA Schaltstrom die Relais schaltet, dann miss dies doch einfach mit einem Messgerät nach.


    Warum ist das logisch, sorry wenn ich das nicht verstehe. Kehrt der ULN das irgendwie um?

    Guten Morgen Jungs,


    Also mittlerweile läuft das Relais mit dem ULN, nur ist bei mir der merkwürdig Effekt, dass das Relais bei GPIO High also 1 und nicht wie bei allen an
    deren LOW also 0 durch schaltet. Das ist zwar sehr positiv und ich bin damit höchst zufrieden, nur wundert es mich. Habe hier diverses gelesen, dass dies am ULN liegt, wollte jetzt aber nochmal nachfragen.


    Das habe ich oben extra geschrieben, der service Befehl im Zusammenhang mit dem Networking ist verbuggt (Debian), und führt meistens dazu, dass das networking abschmiert. Der ist auch im Bug-Tracker usw bekannt. Außerdem funktioniert zum jetzigen Zeitpunkt noch so ziemlich alles auch über init.
    In Debian 8 soll dieser aber angeblich schon behoben sein.

    Die einfachsten Möglichkeiten nochmal aufgezählt:


    - networking wlan0 nachts abschalten
    - Mit Edding oder Tape das Licht abkleben
    - Die LED zerstören/ablöten
    - Einen anderen Wlan-Stick kaufen
    - Die Position des PI's verändern, oder mit einem USB-Verlängerungskabel den Stick unter einem Schrank o.ä verstecken


    raspiprojekt Es kann auch gut sein, dass die LED nicht über die Firmware zu steuern ist, und diese generell bei einem Signal blinkt.


    Es gibt Möglichkeiten bei nem Linux-Router die LEDS zu steuern, aber bei einem per USB angeschlossenen Wlan Stick an einen PI, fällt mir nichts ein. (Womit es immer noch sein kann, dass es über die Firmware usw überhaupt nicht geht, kommt ja wiederrum auf den Stick an.)


    pi nochmal geflasht. Auch ohne eine von mir vorgenommene IP Konfiguration bekommt er die: [font="Source Sans Pro, Tahoma, Helvetica Neue, Arial, sans-serif"]169.254.25.251 Ip Adresse zugewiesen, jetzt ist die Frage, was hat es damit auf sich, ist die nur für heute (11.06) gültig oder bleibt die so? Die Konfiguration im Pi sagt bei dieser IP aus, dass sie manuell ist, dmnach dürfte sie sich nicht ändern oder?[/font]


    Standardmäßig ist DHCP eingestellt, sprich ein DHCP-Server weist deinem PI eine IP-Addresse zu, die eine Lease-Dauer hat wann sie ab läuft.


    Tipp: Schalt dir nen Router ins Netzwerk (Sollte eig Grundbasis sein), und konfigurier wie oben beschrieben den PI auf deine statische IP-Addresse.


    Das einrücken ist kein muss, aber ich fahre damit seit Jahren alle meine Configs so, weil die interfaces Datei bei Tabs usw gerne mal pingelig ist.
    So sollte es eigentlich funktionieren, wobei dann noch die Frage bleibt ob es mit deinem Aufbau (PI -> PI) überhaupt geht, denn du hast keinen richtigen Gateway dazwischen.
    Was spricht dagegen einen Router dazwischen zu hängen, dann bist du auf der sicheren Seite.


    address = Die statische IP des PI's
    netmask = Subnetzmaske
    gateway = die ip des routers/gateways



    Hallo erstmal :)


    Normalerweise muss man noch netmask mit angeben, ich empfehle dir außerdem das networking immer mit folgendem Befehl neuzustarten:
    "/etc/init.d/networking stop && /etc/init.d/networking start", da der Befehl "service networking restart" verbuggt ist. (Dieser wurde schon zahlreich gemeldet und ist unter Debian 8 behoben)


    Deine Config sollte also Beispielsweise so aussehen:



    auto lo
    iface lo inet loopback


    iface eth0 inet static
    address 192.168.0.10
    netmask 255.255.255.0
    gateway 192.168.0.1


    Du hast nun also Raspbian Wheezy installiert? Am einfachsten wäre es immer noch dich per SSH aufzuschalten, dann hast du diese ganzen Tastatur & Monitor Probleme nicht. Gut die Netzabhängigkeit, ist hier vielleicht wieder ein gegen Argument. Um den Raspberry zu konfigurieren, gibst du einfach "sudo raspi-config" in die Konsole ein (Terminal, ich weiß ja nicht ob du eine Grafische Oberfläche am laufen hast, da du aber von einer Taskleiste sprichst gehe ich davon aus). Ein paar mehr Infos wären hilfreich.
    Automatisch zusammengefügt:
    [hr]

    Danke Andreas, für deine nette Rückmeldung. Warum nicht alle so Antworten, mag wohl an der Persönlichkeit der einzelnen Leute liegen.


    Ich bin normal der letzte der einen Thread mit einer Frage startet, oder sich dafür in einem Forum registriert, das ist das erste mal. Meine Fragen waren soweit geklärt, und die Bauteile sind bestellt.
    Doch dann kommt z.b jar an und schreibt eine Aussage in seine Antwort, ich stelle dazu eine normale Frage & werde danach mit einem frechen YouTube-Link zum "Denkanstoß" abgestempelt. Das man heutzutage so mit Foren-Usern umgeht, echt schlimm.


    Nur wenn ich den ULN nicht komplett verstehe, auch nachdem ich mir zahlreiche Datenblätter & Schaltpläne angeschaut habe, und mir zum Thema PI-Relais mehrere Stunden die Finger wund getippt habe, kann man doch wenigstens eine kurze und nette Antwort anstatt diesem YouTube-Link & Grundlagen Gestachele zurückgeben oder?


    Achja und an jar:


    Meine Fragen hatten sich nach deiner Antwort erledigt, nur damit hast du mich dann wieder verwirrt.


    "[font="Source Sans Pro, Tahoma, Helvetica Neue, Arial, sans-serif"]aber die 5V vom externen Netzteil an COM schaden auch nicht, bei direkter Relaisansteuerung sind sie Pflicht."[/font]


    [font="Source Sans Pro, Tahoma, Helvetica Neue, Arial, sans-serif"]Darauf wolltest du anscheinend aber nicht mehr antworten, daher ignoriere ich das einfach mal. "[font="Source Sans Pro, Tahoma, Helvetica Neue, Arial, sans-serif"]bei direkter Relaisansteuerung sind sie Pflicht."[/font][/font]


    [font="Source Sans Pro, Tahoma, Helvetica Neue, Arial, sans-serif"][font="Source Sans Pro, Tahoma, Helvetica Neue, Arial, sans-serif"]Grüße an Andreas, und an alle die mir geholfen haben meine Fragen zielgerecht zu beantworten :thumbs1:.[/font][/font]

    du bist dem Link nicht gefolgt, kannst den noch nicht mal bis zu Ende gelauscht haben......


    nun liegt es an dir rauszufinden warum jeder ULN das weiss


    Auf meine andere Frage bezüglich deiner Aussage "Bei direkter Relaisansteuerung" bist du allerdings nicht eingegangen...
    Ich habe manchmal das Gefühl, du liest oder antwortest nur auf einen Bruchteil von dem was ich schreibe, was dazu führt, dass ich weiter nachfragen muss... :daumendreh2:

    ja,
    aber die 5V vom externen Netzteil an COM schaden auch nicht, bei direkter Relaisansteuerung sind sie Pflicht.


    jeder ULN weiss das!

    External Content www.youtube.com
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.


    Danke für deine hilfreiche Antwort, damit haben sich meine hauptsächlichen Fragen geklärt. Nur was meinst du jetzt mit "bei direkter Relaisansteuerung sind sie Pflicht"? Und woher soll ein ULN das denn wissen, die können bis zu 60V am Output raushauen?


    Ich kann mir sehr wohl einige Fragen in dem Bereich selbst beantworten, aber bei so vielen Schaltplänen & Bildern, und Versionen des ULN2803 blick ich einfach nicht mehr durch. Ich möchte doch einfach nur ganz simpel das ULN2803 anschließen, und habe dazu gefragt ob ich alle GND's zusammen schalten soll, (gemeinsame Masse oder nicht).


    Außerdem gibt es da die ULN2803 A & D usw. Modelle, wo liegt der Unterschied? Den Datenblättern konnte ich keine wirklichen Unterschiede entnehmen. Ich möchte die 5V vom Relaisboard ja über ein externes Netzteil fahren, auf den ganzen Bildern ist also die zusätzliche VCC Verbindung vom Netzteil zum ULN völlig überflüssig?


    Also so wie ichs jetzt verstanden habe, alle GND's zusammen? PI, ULN, RelaisBoard, Externes-Netzteil? VCC vom Netzteil an RelaisBoard, GPIO an den Eingang vom ULN und die IN vom Relaisboard an die Outputs from ULN? Und wo liegt die Schaltgrenze vom ULN? Eingang vom PI 3.3V & Output 5V, konnte das in keinem Datenblatt finden.


    Hier mal zwei Beispiel-Bilder von einem anderen Foren-User.


    Bild1
    Bild2



    Habe jetzt noch ein anderes Schalt-Bild gefunden http://www.forum-raspberrypi.de/attachment.php?aid=7049, hier wurde das ganze nochmal völlig anderst angeschlossen.


    Die Frage ist jetzt auch, ein [font="Helvetica Neue, Helvetica, Arial, sans-serif"]ULN2083 A, D, welche Art?[/font]


    [font="Helvetica Neue, Helvetica, Arial, sans-serif"]Außer einem Datenblatt von Conrad, habe ich nicht wirkliche Infos gefunden.[/font]


    [font="Helvetica Neue, Helvetica, Arial, sans-serif"]Datenblatt[/font]


    Wie garantiert man denn bei einem 3.3V Steuerstrom, einen Output am Treiber von 5V, der kann ja anscheinend bis 60V.


    PS du wurdest auch schon mal aufgefordert fullquote nicht zu machen, aber ........



    Kann mich nicht erinnern darauf hingewiesen worden zu sein (außer jetzt von dir), dann mache ich das nun ab sofort.



    Habe dann aber noch ne Frage zum ULN2803, wie ist da die gemeinsame Masse (GND) am besten anzuschließen?


    Habe jetzt mehrere Schaltpläne und Beispielbilder angesehen, nur werde ich bezüglich der gemeinsamen Masse noch nicht wirklich schlau.
    Das handeln nämlich wieder viele unterschiedlich.


    Betrieben wird der ULN2803 ja mit einem externen 5V Netzteil, und speist somit das Relais auch mit 5V, angesprochen wird er mit den 3.3V aus den GPIO-Pins des PI's.


    VCC & GND vom Relais-Board kommen an das externe Netzteil, vom externen Netzteil noch VCC an den Treiber, und die Treiber-Pins werden mit dem IN an der Relais-Karte verbunden. Die andere Seite der Treiber-Pins kommen an die GPIO-Ports.


    Stimmt das so, wenn ja wie wird dann GND angeschlossen?


    Alle GND's zusammen, oder GND vom PI zum Treiber, und GND von der Relais-Karte zum externen Netzteil?


    Hier mal zwei Beispiel-Bilder von einem anderen Foren-User.


    Bild1
    Bild2

    und die Kopplung zwischen PI 3,3V und Arduino üblicherweise 5V betrachtest du wieder nicht? da wären wir doch wieder beim Thema!


    PS du wurdest auch schon mal aufgefordert fullquote nicht zu machen, aber ........


    Ich habe doch extra vom Ethernet-Shield gesprochen?


    PI -> lokales Netz -> Arduino-Ethernet-Shield -> Arduino -> Relais-Karte.


    Genau deswegen habe ich nach einer Kaufmöglichkeit des originalen Ethernet-Shields gefragt....


    Außerdem so wie ich das verstehe, hast du den PI direkt an den Arduino angestöpselt, es gibt auch den Arduino Zero mit 3.3 Volt Betriebsspannung, der kann dann aber wiederrum keine Relais-Karten mit 5V ansteuern.




    Die Kommunikation zwischen PI & Arduino wäre kein Problem, meine Frage betraf eher das Ethernet-Shield, aber auf meine Hauptsächliche Frage bist du natürlich überhaupt nicht eingegangen.
    Wenn ein Neuling auf dieses Thema stößt, findet er nur wirre Antworten und keine richtige Lösung, daher machen die meisten nochmals einen Thread auf wie du sicher bereits bemerkt hast.
    Da eben jeder eine andere Meinung & andere Vorschläge hat, ist das eben nicht ganz so einfach. Es wurden mir hier auch noch andere Treiber empfohlen, darum habe ich speziell jetzt diesen oben in meinem Beitrag angesprochen. Ich habe leider keinerlei Ahnung von solchen Treibern, daher frage ich lieber nochmal nach. Wenn das ein Problem für dich ist, (ja nein vielleicht) dann antworte mir eben nicht.


    Warum sollte ich etwas vergessen, was bei mir perfekt läuft, nur ich noch eben die Relais ergänzen möchte?


    PS: Entscheidungen sind nicht einfach... :angel:



    Aber danke für deinen "demotivierenden" Beitrag, werde mir nun mal nen Set ULN2803 bestellen & sie nach Schaltplan verlöten.


    Wenn einfach mal ein Thema aufgemacht werden würde mit genau dieser kurzen & knappen Erklärung und dem entsprechenden Direkt-Link zum Treiber, könnten sich viele Einsteiger ein langes suchen & das neue Themen erstellen sparen.