Posts by MacKnilch

    Löse doch mal Deine Domain auf, z.B. mit:
    host domain.tld


    Geht nur auf einem Unix-System, auf Windows notfalls ping statt host.


    Ich könnte mir gut vorstellen, dass das die gleiche IP-Adresse liefert wie für http://www.domain.tld. Bäh, der Editor klatscht automatisch ein http:// davor.
    Bei vielen DNS-Dienstleistern wird das standardmäßig so gemacht, entweder ist www gleich dem root Eintrag, oder umgekehrt.


    Gruß M.

    Ich werfe als Stichwort mal Node.js in die Runde. Damit, und natürlich Programmierwissen in JavaScript auf Client- und Serverseite, kann man so etwas umsetzen. Mit Node.js kann man sogar Push-Nachrichten senden, spricht wenn der Zustand sich ändert, kann die Ausgabe im Browser aktualisiert werden, ohne dass die Seite regelmäßig neugeladen werden muss.

    Was für einen Ausgangsstrom kann das Netzteil liefern? Klingt für mich nach einer Überlastung, deshalb schaltet das NT ab o. die Spannung bricht zusammen, womit der Schütz dann nicht anspricht. Wenn kein Strom aufgedruckt ist, dann mess mal den Innenwiderstand.


    Edit: 2A sollten aber schon reichen.

    Moin,


    da stimmt die umask nicht. Schau Dir mal im Manual von Samba den Bereich File and Directory Permissions an. Mit den Einstellungen für create mask usw. kannst Du dass einstellen.


    Ich habe im Internet viele Anleitungen für einen LAN -> WLAN Hotspot gefunden (z.B. das hier: Youtube Link), jedoch konnte ich nichts/wenig bezüglich WLAN -> WLAN bzw. VPN -> WLAN finden.


    Das ist auch kein Wunder, da es sich nicht unterscheidet. Du musst eben nur Dein WLAN-Interface an den Start bringen und in den Tuts statt des LAN- das WLAN-Interface benutzen.
    radioshack Es ist etwas umständlich, aber einen Vorteil hat sein Vorgehen. Er kann mehr Clients damit absichern, vielleicht auch die seiner Klassenkameraden, ohne denen selber Zugang zum VPN geben zu müssen.

    Das Verzeichnis .pyload ist schon richtig. Unter welchem Useraccount läuft denn pyload? Hoffentlich nicht root, weil das ist ein ganz schlechte Idee!
    In dem home-Verzeichnis des Users gibt es dann .pyload und da das Download Verzeichnis.

    cron würde ich nicht dafür nehmen, viel zu aufwändig. at sollte gehen.


    Code
    at 0:00
    /pfad/zu/youtube-upload --email=email --password=sicherespasswort --title="Titel" --description="Beschreibung" --category=Games --keywords="tags" --private /media/test.mp4
    [CTRL] + [D]


    und mit


    Code
    atq


    prüfen.

    cec-client liegt im Suchpfad des Users, der den cronjob ausführt? Zum Testen kannst Du mal den absoluten Pfad von cec-client im Script setzen. Sollte das nicht gehen, würde ich mal schauen, ob das Script überhaupt aufgerufen wird, eventuell eine Zeile einfügen, die bei jedem Aufruf ein echo in eine Datei schreibt.

    Du könntest noch ein anderes FS als NTFS für die HDD benutzen, z.B. ext3 oder ext4. NTFS wird sicher über fuse angesprochen und das ist langsam und CPU intensiv. Wunder darfst Du aber nicht erwarten. Mit Ethernet, einer USB-Platte mit ext4 und AFP (netatalk) bin ich mal auf ca. 5MByte/s gekommen. Angefangen hatte ich mit HFS+ auf der HDD, da waren nur max. 3-4MByte/s drin.
    Das war mir für den angedachten Fall zulangsam und ich habe dafür einen Cubietruck im Einsatz, der gut das 5-fache schafft.

    EDIT:
    Hab eine Schaltung gefunden, die so funktionieren sollte, wie ich will. Nur brauch ich 3,3V statt 5V und der Schalter muss raus. Wie model ich das um? http://www.ledhilfe.de/download/file.php?id=15086


    Du hast am RasPi doch sowie 5V, insofern musst Du nichts ummodeln, nur den Schalter überbrücken.


    Eine andere Möglichkeit wäre der PWM Ausgang des RasPis zu nutzen. Du brauchst eine PWM Wandler Schaltung, die aus dem PWM Signal eine analoge Spannung macht und über die PWM Frequenz wird die Helligkeit der LED gesteuert. Für das Pulsieren benötigst Du eine PWM Frequenz, die mit einer zweiten Frequenz moduliert wird, im Prinzip ein Wobbelgenerator, aber das geht auch per Software und Du hast alle Freiheiten, die LED zusteuern.


    Jetzt muß ich nur noch eine Möglichkeit
    für ein Cofig-Datei zum eintragen finden, damit ich nicht jedesmal
    neu eintippen muß


    Notfalls einen alias in der Shell einrichten, wenn Du die Aufnahme händisch startest, oder ein kleines Shellscript mit gleichem Namen wie das binary schreiben, das das binary mit den zusätzlichen Parametern aufruft.


    M.


    Gib den Befehl von unten ein. Bei dem fährt er sofort herunter und der Befehl ist kürzer ;)


    Code
    sudo halt


    shutdown -h now ist aber sauberer, sprich laufende Dienste werden ordentlich beendet und nicht einfach gekillt. Macht sich z.B. bei Datenbanken besser. :sleepy:
    In diesem Fall vielleicht nicht wichtig und ist mehr als allgemeiner Hinweis gedacht.

    So das Problem hat sich erledigt, oder auch nicht. Wie man es nimmt.


    Ich habe nochmal die Suchmaschine meines Vertrauens angeworfen und dabei festgestellt, das auch andere User, z.T. unter Windows ähnliche Probleme hatten, sobald sie den PS-Treiber von Kyocera verwendet haben und stattdessen den Drucker mit PCL angesprochen haben. Also habe ich meinen Drucker auf automatische Emulationserkennung umgestellt und den Drucker als HP LaserJet 4/5 in CUPS eingerichtet und dann klappte es auch mit der Testseite. AirPrint war dann auch kein Problem mehr. Der Drucker lässt sich nun von unseren iDevices ansprechen. Warum es nicht mit PS klappt, vom Mac und FreeBSD aus schon, entzieht sich meiner Kenntnis. Ich kann damit leben und werde es nicht weiterverfolgen, da das nächste Projekt schon wartet.


    Gruß M.

    Hallo Forenmitglieder und die, die es noch werden wollen,


    ich habe mir vor gut 1 Woche meinen ersten Raspberry Pi zugelegt und möchte zum Aufwärmen gerne meinen ollen 13 Jahre alten Kyocera FS-1200 Laserdrucker mit Airprint ausstatten. Weitere Projekte sind schon angedacht.


    Ich habe aktuell einen RasPi Model B Rev. 2. Eigentlich bin ich FreeBSD User und leider ist der Versuch der Installation von FreeBSD kläglich gescheitert, das System selber lief wie der Teufel, aber 3-party Software macht noch Probleme. So nutze ich nun raspbian. Das X-Gedöns habe ich von der Karte geputzt und dann cups und avahi-daemon installiert. Die GK muss sich mit 16MB begnügen. Zugreifen tue ich nur per SSH.


    Die Installation von cups lief problemlos, es 'läuft' und kann per Webinterface konfiguriert werden. Ich habe den Drucker hinzugefügt, sowohl mit lpd:// als auch mit socket:// und wollte die Cups Testseite drucken, was mit einer Postscript error Seite endete.

    Code
    ERROR:
    limitcheck
    OFFENDING COMMAND:
    image
    STACK:
    -mark-
    -mark-
    -mark-


    Dann viel mir auf, das cups ja von Apple ist und der Drucker an unseren Macs tadellos läuft. Also habe ich die /etc/cups/printers.conf und das ppd-File aus /etc/cups/ppd von meinem Mac auf den rasPi kopiert und den cupsd neu gestartet. Die Ernüchterung kam sehr schnell, immer noch der obige Postscript Fehler bei der cups Testseite. Also habe ich cups nochmal auf meinem FreeBSD Server installiert und dort läuft es auch mit der gleichen printers.conf und dem ppd-File vom Mac.


    Dann ging es ans debuggen auf dem RasPi. Zuerst viel mir auf, das gs sehr lange und mit hoher CPU Last läuft, ca. 5 Minuten. Ich habe dann mal ps- und pdf-Files direkt auf den RasPi kopiert und mit lp -o media=A4 /path/to/pdf gedruckt und das klappte wie am Schnürchen mit beiden Filetypen. Danach habe ich eine Textdatei mit lp gedruckt, was wieder mit einem Postscript error endete.

    Code
    ERROR:
    undefined
    OFFENDING COMMAND:
    ....Undefined
    STACK:
    60
    -mark-
    -mark-
    -mark-
    -mark-


    Mit texttopdf habe ich danach aus dem Textfile ein PDF gemacht und dieses dann wieder mit lp dem Drucker vorgeworfen, was zügig funktionierte.


    Das sieht für mich so aus, als ob etwas mit cups/gs auf dem RasPi krumm ist und gerade gezogen werden muss, oder aber, dass der RasPi zu schwach auf der Brust ist. Mein Gefühl sagt mir, dass die Postscript Fehler nicht ursächlich von meinem Drucker kommen, sondern von gs. Die Fehler des Druckers sehen anders aus. Der Drucker ist auch so eingestellt, dass er PS-Fehler nur anzeigt, aber nicht ausdruckt. Deshalb vermute ich, dass der Fehler im PS-File ist, was an den Drucker gesendet wird und der druckt aus und meldet sich dann auch mit einem KPDL-Fehler (Kyoceras Name für PostScript).


    Hat jemand noch eine Idee, was ich noch machen kann, um dem Problem auf die Spur zukommen?
    Ich bin für jeden Tipp sehr dankbar.


    Wenn Ihr zusätzliche Infos braucht, lasst es mich wissen.


    Gruß MacKnilch