Posts by Burny

    MrToddsFriends

    Quote

    "No dialect specified on mount. Default has changed to a more secure dialect, SMB2.1 or later"

    Diese Meldung konnte ich mit Anpassung von Windows 2008 64Bit R2 durch Umstellungen unter Windows auf nur mehr SMB2.1 und dem Raspberrry Client auf

    Code
    1. [Mount]
    2. What=//DOMAIN/FHEM$
    3. Where=/media/hdd
    4. Type=cifs
    5. Options=vers=2.1,iocharset=utf8,domain=DOMAIN,username=user,password=blabla,rw,dir_mode=0777,file_mode=0666

    abstellen.


    Dennoch blieb die Fehler Meldung CIFS VFS: ioctl error in smb2_get_dfs_refer rc=-2 in der syslog übrig.

    Ich habe nochmal ein Testsystem mit dem aktuellen Jessie Stretch Lite inklusive aller Updates erstellt.

    Die Fehlermeldung ist nach wie vor vorhanden.

    Die Zugriffe, Lesen, Schreiben, Ordner erstellen usw. funkionieren ohne Probleme auf die Freigabe des Windows 2008 R2 Servers.

    Ich möchte aber diese Fehlermeldung beseitigen, aber bisher habe ich dazu keine Lösung im Internet gefunden die mir weiterhelfen konnte.

    Hat jemand noch eine Idee um diese Fehlermeldung

    CIFS VFS: ioctl error in smb2_get_dfs_refer rc=-2

    zu beseitigen?


    Ich habe jetzt SMB1 auf dem Windows Server 2008R2 64Bit deaktiviert.

    Eigenartig ist das der Raspberry sich dennoch mit vers=1.0 ohne Fehler im Syslog anmeldet aber keinen Zugriff mehr auf den Fileserver hat.

    Mit vers=2.1 ist der error CIFS VFS: ioctl error in smb2_get_dfs_refer rc=-2 zwar im Syslog aber der Zugriff auf den Fileserver funktioniert.

    Für heute reichts mir mit dem Schmarn.

    Bei der manuellen Eingabe von

    mount -t cifs -o vers=2.1,username=<user>,password=<name> //Server/Dir /mount/point

    habe ich ja schon den Eintrag CIFS VFS: ioctl error in smb2_get_dfs_refer rc=-2 in der syslog.

    Weniger kann ich nicht mehr eingeben.


    Ich habe auch Windows damit gemeint und nicht Linux.

    Unter Linux findet man zumindest Hilfen wo unter Windows eine Ewigkeit nichts zu finden ist.

    Ich habe nach der Änderung immer einen kompletten Neustart des Systems gemacht.

    In der fstab steht nur das darin was die Installation automatsich einträgt.

    Code
    1. proc /proc proc defaults 0 0
    2. PARTUUID=1038f195-01 /boot vfat defaults 0 2
    3. PARTUUID=1038f195-02 / ext4 defaults,noatime 0 1

    Ein manueler mount liefert den gleichen Fehler in der syslog.

    sudo mount -t cifs //<Fileserver IP>/<Datei Verzeichnis> /media/hdd -o domain=<domain>,vers=2.1,user=<user>,password=<name>

    Code
    1. CIFS VFS: ioctl error in smb2_get_dfs_refer rc=-2

    Der Zugriff auf das Verzeichnis funktioniert.

    Ich kann es drehen wie ich will.

    Ich bekomme den error Eintrag

    CIFS VFS: ioctl error in smb2_get_dfs_refer rc=-2

    in der syslog nicht weg auch wenn ich die Reihungen ändere.

    Code
    1. [Mount]
    2. What=//<Fileserver IP>/<Datei Verzeichnis>
    3. Where=/media/hdd
    4. Type=cifs
    5. Options=vers=2.1,username=<user>,password=<name>,rw,domain=<domain>,iocharset=utf8,dir_mode=0777,file_mode=0666


    Quote

    Options=username=<user>,password=<name>,

    rw,domain=domain>,iocharset=utf8,dir_mode=0777,file_mode=0666,vers=2.1

    Bei mir wurden Scripts erstellt um sicher zu stellen das beim mount das Netzwerk schon zur Verfügung steht.

    Dadurch wurde keine zusätzlichen Definitionen in der fstab vorgenommen.

    Ich hatte immer das Problem das die Funktion auf Netzwerk warten unter raspi-config nicht einwandfrei funktionierte, was anschließend den mount verhinderte.

    Dafür wurden neue Datein mit Script erstellt.

    sudo nano /usr/local/bin/network_wait_online

    sudo nano /etc/systemd/system/network_wait_online.service

    sudo nano /etc/systemd/system/media-hdd.mount

    Bei dieser Ausführung hatte ich Unterstützung aus einem Forum.

    Vielleicht hilft diese Ausführung auch anderen Usern weiter.


    Leider hat die Änderung mit dem Parameter vers=2.1 noch nicht vollständig den error im syslog behoben.

    Code
    1. FS-Cache: Netfs 'cifs' registered for caching
    2. Key type cifs.spnego registered
    3. Key type cifs.idmap registered
    4. CIFS VFS: ioctl error in smb2_get_dfs_refer rc=-2
    5. crng init done

    Hier bedarf es leider noch einer Anpassung um den Eintrag

    CIFS VFS: ioctl error in smb2_get_dfs_refer rc=-2

    zu entfernen.

    Unter [Mount] ist noch eine Anpassung notwendig. Der EIntrag

    Code
    1. [Mount]
    2. What=//<Fileserver IP>/<Datei Verzeichnis>
    3. Where=/media/hdd
    4. Options=username=<user>,password=<name>,rw,domain=<domain>,iocharset=utf8,dir_mode=0777,file_mode=0666,vers=2.1
    5. Type=cifs

    ist auf

    Code
    1. [Mount]
    2. What=//<Fileserver IP>/<Datei Verzeichnis>
    3. Where=/media/hdd
    4. Options=username=<user>,password=<name>,rw,domain=<domain>,iocharset=utf8,dir_mode=0777,file_mode=0666,vers=2.1,Type=cifs

    zu ändern.

    Es ist zwar kein error Eintrag in der Syslog vorhanden dafür funktioniert aber der mount nicht mehr.

    Ist hier eine andere Schreibweise notwendig damit der mount wieder funktioniert?


    Ich habe dazu einen Hinweis gefunden und eine Eintrag unter [Mount] ergänzt der die error Meldung beheben sollte.


    Windows verwendet die folgenden Versionen:

    SMB 1.0 ..: Windows 2000

    SMB 2.0 ..: Windows Server 2008 und Windows Vista SP1

    SMB 2.1 ..: Windows Server 2008 R2 und Windows 7

    SMB 3.0 ..: Windows Server 2012 und Windows 8

    SMB 3.0.2 : Windows Server 2012 R2 und Windows 8.1 (NICHT nutzbar!)

    SMB 3.1.1 : Windows Server 2016 und Windows 10 (NICHT nutzbar!)

    Zu beachten sind die fett gedruckten Versionen (ab cifs-utils Version 4.5) die zulässig sind. Unter Mount ist zusätzlich der Parameter vers=2.1 einzutragen.


    Um die Versionsnummer abfragen zu können ist ain der Console smbd –version einzugeben .

    In meinem Fall bekomme ich die

    Version 4.5.12-Debian

    angezeigt.

    Code
    1. [Mount]
    2. What=//NAS/FHEM
    3. Where=/media/hdd
    4. Options=username=<user>,password=<name>,rw,domain=<domain>,iocharset=utf8,dir_mode=0777,file_mode=0666
    5. Type=cifs
    6. vers=2.1

    Leider behebt die Ergänzung vers=2.1 ncht die error Meldung.

    Bei der routinemässigen Überprüfung des syslog habe ich nach den letzteren Installationen folgende Einträge die ich früher nicht hatte.

    Hier dürfte es doch bei den letzteren Jessie Stretch Lite Änderungen gegeben haben.

    Code
    1. No dialect specified on mount. Default has changed to a more secure dialect, SMB2.1 or later (e.g. SMB3), from CIFS (SMB1). To use the less secure SMB1 dialect to access old servers which do not support SMB3 (or SMB2.1) specify vers=1.0 on mount.
    2. CIFS VFS: ioctl error in smb2_get_dfs_refer rc=-2

    Wo muss ich diese Sicherheits Änderungen durchführen?

    Im Netzwerk befinden sich nur Windows 2008 R2 64Bit Server.

    Ich hätte heute einen Raspberry Pi 3+ versucht zu installieren.

    Nun bin ich auf einige Dienste gestoßen die ich benötige, sich aber nicht herunterladen lassen.


    Der Raspberry Pi 3+ soll den Raspberry Pi 3 ersetzen.


    Folgende Dienste sind mir derzeit aufgefallen die sich nicht mehr installieren lassen.

    sudo apt-get install libcrypt-rijndael-perl

    sudo apt-get install -y python-smbus

    Liegt das an dem Raspberry Model oder hat sich betreffend der Dienste etwas geändert?