Posts by froschn

    Oh, sorry, ja, der which hat es gebracht. Vielen Dank an alle.


    Falls es jemand interessiert, ich habe mir ein Experimentierauto (40cm) aus alten Metallbaukästen zusammengebastelt und im kompletten Eigenbau Elektronik etc. aufgebaut. Alles steuere ich über eine Website im WLAN. Völlig sinnfrei, macht aber viel Spaß. Da das Fahrzeug auch akustische Meldungen (z.B. beim Hindernis) abgeben sollte, hatte ich obiges Problem.

    Steckbrief "Pilatron 42"

    Website

    IP http://192.168.178.20/car05.html (nur intern)


    css: für das Layout


    jQuery: JavaScript-Bibliothek


    AJAX: Asynchrones JavaScript and XML (Request an den Webserver zu einzelnen Inhalten, ohne dass die ganze Webseite neu geladen werden muss)

    Server

    Hardware: Pi 3b, WLAN, Bluetooth, 32 GB microSD, HDMI, Audio


    Webserver: lighttpd


    Datenbank: mySQL


    PHP: car05.php (Programm zur Ansteuerung der car-Elektronik. mit LEDs, Schieberegister, Optokoppler zur Potentialtrennung, Relais,

    Geschwindigkeit stufig, Lenkung stufig mit Endschaltern, etc.)


    Python: Programme im Autostart und Hintergrund

    • endpoints.py (Entfernungsmessung mittels Ultraschall, Audio-Warnung < 20 cm)
    • nunlos.py (Audio Startmeldung)
    • backsteuer.py (Audio Meldungen Links, Rechts)
    • stop.py (shutdown Pi)

    Hi,

    ein Python-Programm nunlos.py spielt eine Audiodatei, z.B.

    .....

    from subprocess import call

    call(["omxplayer", "esgehtlos.m4a"])

    ...

    ab.

    Wenn ich das Programm in Autostart und Hintergrund lege

    /etc/rc.local

    ...

    python /var/www/html/nunlos.py &

    ...

    wird die Audiodatei nicht abgespielt.


    Bitte, hat jemand eine Idee?

    Grüße vom Froschn:helpnew:

    Guten Morgen,
    ich habe von Makibes ein Touch-Screen 5-Zoll-LCD-HDMI 800 × 480 High Resolution für Raspberry Pi 2 Modell B / Raspberry Pi Modell B / B + / A +
    Die virtuelle Tastatur funktioniert - nur kann ich keine Zahlen und Sonderzeichen eingeben - die fehlen einfach. Auch in den Einstellungen habe ich keine Möglichkeit gefunden.
    Hat jemand eine Idee oder ist das einfach nur Murks?
    Viele Grüße, Froschn

    Hallo Andreas,
    ich hoffe, ich nerve dich nicht. Aber es läuft nicht. Ich habe jetzt eine Stunde gewartet aber die grafische Oberfläche zeigt sich nicht. Das fehlende Modul g2d_23 soll ja unwichtig sein. Wartet der X server nun vielleicht auf eine bestimmte Eingabe?
    Viele Grüße vom
    Froschn

    Hallo Andreas,


    vielen Dank für deine Antwort.
    Ich habe das System komplett neu aufgespielt und dann deine Empfehlungen angewendet.
    Leider geht es noch nicht (Neustart, etc. alles gemacht):


    Last login: Mon Nov 23 08:32:38 on ttys000
    MacBook-Pro:~ guntersteinmann$ ssh pi@192.168.178.20
    pi@192.168.178.20's password:


    The programs included with the Debian GNU/Linux system are free software;
    the exact distribution terms for each program are described in the
    individual files in /usr/share/doc/*/copyright.


    Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
    permitted by applicable law.
    Last login: Mon Nov 23 07:38:54 2015
    pi@raspberrypi ~ $ sudo startx



    X.Org X Server 1.16.4
    Release Date: 2014-12-20
    X Protocol Version 11, Revision 0
    Build Operating System: Linux 3.17-1-armmp armv7l Raspbian
    Current Operating System: Linux raspberrypi 4.1.7-v7+ #817 SMP PREEMPT Sat Sep 19 15:32:00 BST 2015 armv7l
    Kernel command line: dma.dmachans=0x7f35 bcm2708_fb.fbwidth=656 bcm2708_fb.fbheight=416 bcm2709.boardrev=0xa01041 bcm2709.serial=0xa6114003 smsc95xx.macaddr=B8:27:EB:11:40:03 bcm2708_fb.fbswap=1 bcm2709.disk_led_gpio=47 bcm2709.disk_led_active_low=0 sdhci-bcm2708.emmc_clock_freq=250000000 vc_mem.mem_base=0x3dc00000 vc_mem.mem_size=0x3f000000 dwc_otg.lpm_enable=0 console=ttyAMA0,115200 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait
    Build Date: 18 February 2015 05:34:25PM
    xorg-server 2:1.16.4-1 (http://www.debian.org/support)
    Current version of pixman: 0.33.3
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
    Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (==) Log file: "/var/log/Xorg.1.log", Time: Mon Nov 23 07:53:06 2015
    (==) Using system config directory "/usr/share/X11/xorg.conf.d"
    modprobe: FATAL: Module g2d_23 not found.


    Hier muss ich mit ctrl c abbrechen


    letzte Meldung dann


    xinit: connection to X server lost
    waiting for X server to shut down (EE) Server terminated successfully (0). Closing log file.
    xinit: unexpected signal 2


    Hast du bitte noch eine Idee?


    Viele Grüße, Froschn

    Hallo dunklesToast, vielen Dank für die schnelle Antwort. Ich habe update und upgrade durchlaufen lassen. Läuft aber leider noch nicht:


    pi@raspberrypi ~ $ sudo startx
    xauth: file /root/.Xauthority does not exist



    X.Org X Server 1.16.4
    Release Date: 2014-12-20
    X Protocol Version 11, Revision 0
    Build Operating System: Linux 3.17-1-armmp armv7l Raspbian
    Current Operating System: Linux raspberrypi 4.1.13-v7+ #826 SMP PREEMPT Fri Nov 13 20:19:03 GMT 2015 armv7l
    Kernel command line: dma.dmachans=0x7f35 bcm2708_fb.fbwidth=656 bcm2708_fb.fbheight=416 bcm2709.boardrev=0xa01041 bcm2709.serial=0xa6114003 smsc95xx.macaddr=B8:27:EB:11:40:03 bcm2708_fb.fbswap=1 bcm2709.disk_led_gpio=47 bcm2709.disk_led_active_low=0 sdhci-bcm2708.emmc_clock_freq=250000000 vc_mem.mem_base=0x3dc00000 vc_mem.mem_size=0x3f000000 dwc_otg.lpm_enable=0 console=ttyAMA0,115200 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait
    Build Date: 18 February 2015 05:34:25PM
    xorg-server 2:1.16.4-1 (http://www.debian.org/support)
    Current version of pixman: 0.33.3
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
    Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (==) Log file: "/var/log/Xorg.1.log", Time: Sun Nov 22 17:26:38 2015
    (==) Using system config directory "/usr/share/X11/xorg.conf.d"
    modprobe: FATAL: Module g2d_23 not found.

    Hallo zusammen,
    ich bin neu im Raspberrry. Ich habe den PI 2 gekauft, raspian installiert und kann mich auch einloggen.
    Ich arbeite auf dem MAC und möchte vorerst die grafische Oberfläche nutzen.
    Das ist mir noch nicht gelungen. Ich habe vom meigrafd die folgende Anleitung gefunden und genutzt.
    Leider ohne Erfolg:


    Zieh dir Raspbian von hier: http://www.raspberrypi.org/downloads
    Flash es auf deine SD
    Starte den RPI mit der geflashten SD
    Logg dich als pi ein
    Führ den Befehl sudo raspi-config aus
    Wähle den 1. Punkt aus
    Danach die Punkte unter 4.
    Danach ggf noch den 8. Punkt
    Dann gehst du unten auf Finish und bestätigst den reboot (alternativ gibst du den Befehl sudo reboot ein)
    Nach erneutem hochfahren führst du dann zunächst den Befehl sudo rpi-update aus und startest nochmals neu (achtung: nicht abkürzen und den vorherigen reboot überspringen!!)
    Anschliesend meldest du dich erneut an und führst dann den Befehl startx aus


    Soweit durchgeführt und neu eingeloggt.


    pi@raspberrypi ~ $ startx



    X.Org X Server 1.16.4
    Release Date: 2014-12-20
    X Protocol Version 11, Revision 0
    Build Operating System: Linux 3.17-1-armmp armv7l Raspbian
    Current Operating System: Linux raspberrypi 4.1.13-v7+ #826 SMP PREEMPT Fri Nov 13 20:19:03 GMT 2015 armv7l
    Kernel command line: dma.dmachans=0x7f35 bcm2708_fb.fbwidth=656 bcm2708_fb.fbheight=416 bcm2709.boardrev=0xa01041 bcm2709.serial=0xa6114003 smsc95xx.macaddr=B8:27:EB:11:40:03 bcm2708_fb.fbswap=1 bcm2709.disk_led_gpio=47 bcm2709.disk_led_active_low=0 sdhci-bcm2708.emmc_clock_freq=250000000 vc_mem.mem_base=0x3dc00000 vc_mem.mem_size=0x3f000000 dwc_otg.lpm_enable=0 console=ttyAMA0,115200 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait
    Build Date: 18 February 2015 05:34:25PM
    xorg-server 2:1.16.4-1 (http://www.debian.org/support)
    Current version of pixman: 0.33.1
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
    Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (==) Log file: "/var/log/Xorg.1.log", Time: Sun Nov 22 16:39:38 2015
    (==) Using system config directory "/usr/share/X11/xorg.conf.d"
    modprobe: FATAL: Module g2d_23 not found.
    xinit: connection to X server lost


    waiting for X server to shut down ^C(EE) Server terminated successfully (0). Closing log file.


    xinit: unexpected signal 2
    Konnte keinen Dateideskriptor finden, der auf die Konsole verweist.
    pi@raspberrypi ~ $


    Bitte, was kann ich tun? :s