Posts by dast

    Hast du mal geprüft, ob irgendwas im Journal ist - oder ist das komplett leer?

    Ist nicht leer, steht einiges drinnen. Aber nix bzgl. derm mjpg_streamer.service.

    Hab nach video, mjpg, usw. gesucht ... aber nix :(


    Nachtrag: was bekommst du, wenn du `journalctl`mit `sudo` aufruftst?

    Direkt nach dem Reboot:

    Code
    pi@raspberrypi:~ $ sudo systemctl status mjpg_streamer.service
    ● mjpg_streamer.service - MJPG Streamer
       Loaded: loaded (/lib/systemd/system/mjpg_streamer.service; disabled; vendor preset: enabled)
       Active: inactive (dead)
    
    pi@raspberrypi:~ $ journalctl -u mjpg_streamer.service 
    -- No entries --
    
    pi@raspberrypi:~ $ sudo journalctl -u mjpg_streamer.service 
    -- No entries --

    So, Logging per Storage=persistant in /etc/systemd/journald.conf aktiviert und neu gestartet.

    Leider das selbe Ergebnis:

    Code
    pi@raspberrypi:~ $ journalctl -u mjpg_streamer.service
    -- No entries --

    Vermutlich wirklich, wie meigrafd angemerkt, der falsche Zeitpunkt wo der Service versucht wird zu starten.

    Wie kann ich denn jetzt den Zeitpunkt verändern?


    Danke schon mal!


    LG Daniel.

    Danke meigrafd,


    danke für deine Antwort und sorry für die Wiederholung im Post.


    WIe aktiviere ich denn das Logging für der Service beim Booten?


    Und wie ändere ich den Zeitpunkt wann die Unit ausgeführt wird? Dachte das wird über die "Requires" und "After" Keywords getriggert.

    Oder meinst du eben ein anderes "After"? Falls ja, was wäre denn da ein geeigneter Kandidat?


    Danke nochmal und Grüße,

    Daniel.

    Hallo,


    danke schon mal für das rasche Feedback.


    Folgendes erhalte ich direkt nach dem Reboot:

    Code
    pi@raspberrypi:~ $ journalctl -u mjpg_streamer.service
    -- No entries --


    Wenn ich den Service händisch per sudo systemctl start mjpg_streamer.service starte, erhalte ich folgendes:

    Code
    pi@raspberrypi:~ $ journalctl -u mjpg_streamer.service
    -- Logs begin at Thu 2016-11-03 18:16:42 CET, end at Mon 2018-02-05 21:52:20 CET. --
    Feb 05 21:52:20 raspberrypi systemd[1]: Started MJPG Streamer.
    Feb 05 21:52:20 raspberrypi mjpg_streamer[1005]: MJPG-streamer [1005]: starting application
    Feb 05 21:52:20 raspberrypi mjpg_streamer[1005]: MJPG Streamer Version.: 2.0
    Feb 05 21:52:20 raspberrypi mjpg_streamer[1005]: MJPG-streamer [1005]: MJPG Streamer Version.: 2.0
    Feb 05 21:52:20 raspberrypi mjpg_streamer[1005]: MJPG-streamer [1005]: Using V4L2 device.: /dev/video0
    Feb 05 21:52:20 raspberrypi mjpg_streamer[1005]:  i: Using V4L2 device.: /dev/video0
    Feb 05 21:52:20 raspberrypi mjpg_streamer[1005]:  i: Desired Resolution: 720 x 480


    Scheint nur beim Reboot nicht zu funktionieren ...


    Danke und Grüße,

    Daniel.

    Habe mir für den MJPG Streamer auf meinem RPi2 folgenden serviced Dienst angelegt:

    Wenn ich diesen nun in der Shell per

    sudo systemctl start mjpg_streamer.service

    oder

    sudo systemctl restart mjpg_streamer.service

    aktiviere, funktioniert das ganze einwandfrei.


    Wenn ich nun aber einen Reboot ausführe scheint es ein Problem zu geben und MJPG Streamer startet nicht ganz ordnungsgemäß:

    Code
    pi@raspberrypi:~ $ sudo systemctl status mjpg_streamer.service
    ● mjpg_streamer.service - MJPG Streamer
       Loaded: loaded (/lib/systemd/system/mjpg_streamer.service; disabled; vendor preset: enabled)
       Active: inactive (dead)

    Vielleicht wird auch versucht das ganze "zu früh" zu Starten und eventuell einer der benötigten Ressourcen noch nicht bereit ist.


    Sehe ich das irgendwo in einem Log? Oder weiß jemand vielleicht wo das Problem liegt?


    Danke und Grüße,

    Daniel.

    Das "Instrument" der Python minimalmodbus erwartet folgendes:


    Attributes:
    - port (str): Serial port name.
    - Most often set by the constructor (see the class documentation).
    - baudrate (int): Baudrate in Baud.
    - Defaults to :data:`BAUDRATE`.
    - parity (probably int): Parity. See the pySerial module for documentation.
    - Defaults to :data:`PARITY`.
    - bytesize (int): Bytesize in bits.
    - Defaults to :data:`BYTESIZE`.
    - stopbits (int): The number of stopbits.
    - Defaults to :data:`STOPBITS`.
    - timeout (float): Timeout value in seconds.
    - Defaults to :data:`TIMEOUT`.


    Nein, cuteCom hab ich noch nicht probiert.


    Ich hab nur am /dev/ttyUSB0 einen RS232-USB Adapter hängen über den ein Python Skript (mit pyserial) alle Minute ein paar Werte der Wärmepumpe abfragt.
    Das läuft wunderbar ... ohne irgendwelche Änderungen.

    Ja, das Gerär ist unter /dev/ttyUSB1 zu erreichen. Am /dev/ttyUSB0 hängt ein RS232-USB Adapter.


    Sieht man auch im dmesg:


    [ 1164.399701] usbcore: registered new interface driver ch341
    [ 1164.399869] usbserial: USB Serial support registered for ch341-uart
    [ 1164.399973] ch341 1-1.5:1.0: ch341-uart converter detected
    [ 1164.411255] usb 1-1.5: ch341-uart converter now attached to ttyUSB1


    Der obere Auszug vom "stty -F /dev/ttyUSB1 -a" war VOR dem
    stty -F /dev/ttyUSB1 start undef und
    stty -F /dev/ttyUSB1 stop undef.


    Hier nochmal alles:


    pi@raspberrypi ~/sdm $ stty -F /dev/ttyUSB1 -a
    speed 19200 baud; rows 0; columns 0; line = 0;
    intr = ^C; quit = ^\; erase = ^?; kill = ^U; eof = ^D; eol = <undef>; eol2 = <undef>; swtch = <undef>; start = <undef>; stop = <undef>; susp = ^Z; rprnt = ^R; werase = ^W;
    lnext = ^V; flush = ^O; min = 0; time = 0;
    -parenb -parodd -cmspar cs8 hupcl cstopb cread clocal -crtscts
    -ignbrk -brkint -ignpar -parmrk -inpck -istrip -inlcr -igncr -icrnl -ixon -ixoff -iuclc -ixany -imaxbel -iutf8
    -opost -olcuc -ocrnl onlcr -onocr -onlret -ofill -ofdel nl0 cr0 tab0 bs0 vt0 ff0
    -isig -icanon -iexten -echo -echoe -echok -echonl -noflsh -xcase -tostop -echoprt -echoctl -echoke


    pi@raspberrypi ~/sdm $ python modbus.py


    MinimalModbus debug mode. Writing to instrument (expecting 7 bytes back): '\x01\x04\x00\x00\x00\x011\xca' (01 04 00 00 00 01 31 CA)
    MinimalModbus debug mode. No sleep required before write. Time since previous read: 1450886784634.4 ms, minimum silent period: 2.01 ms.
    MinimalModbus debug mode. Response from instrument: '' () (0 bytes), roundtrip time: 1001.4 ms. Timeout setting: 1000.0 ms.


    Traceback (most recent call last):
    File "modbus.py", line 15, in <module>
    data = instrument.read_register(0x0000, 2, functioncode=4) # Registernumber, number of decimals
    File "/usr/local/lib/python2.7/dist-packages/minimalmodbus.py", line 258, in read_register
    return self._genericCommand(functioncode, registeraddress, numberOfDecimals=numberOfDecimals, signed=signed)
    File "/usr/local/lib/python2.7/dist-packages/minimalmodbus.py", line 697, in _genericCommand
    payloadFromSlave = self._performCommand(functioncode, payloadToSlave)
    File "/usr/local/lib/python2.7/dist-packages/minimalmodbus.py", line 795, in _performCommand
    response = self._communicate(request, number_of_bytes_to_read)
    File "/usr/local/lib/python2.7/dist-packages/minimalmodbus.py", line 930, in _communicate
    raise IOError('No communication with the instrument (no answer)')
    IOError: No communication with the instrument (no answer)
    Automatisch zusammengefügt:[hr]
    Was mir gerade aufgefallen ist:


    Am /dev/ttyUSB0 hängt ja ein RS232-USB Adapter, der einwandfrei funktioniert.
    Bei diesem ist start und stop auch auf start = ^Q; stop = ^S; gesetzt.

    Code
    pi@raspberrypi ~/sdm $ stty -F /dev/ttyUSB1 -a
    speed 19200 baud; rows 0; columns 0; line = 0;
    intr = ^C; quit = ^\; erase = ^?; kill = ^U; eof = ^D; eol = <undef>; eol2 = <undef>; swtch = <undef>; start = ^Q; stop = ^S; susp = ^Z; rprnt = ^R; werase = ^W; lnext = ^V;
    flush = ^O; min = 0; time = 0;
    -parenb -parodd -cmspar cs8 hupcl cstopb cread clocal -crtscts
    -ignbrk -brkint -ignpar -parmrk -inpck -istrip -inlcr -igncr -icrnl -ixon -ixoff -iuclc -ixany -imaxbel -iutf8
    -opost -olcuc -ocrnl onlcr -onocr -onlret -ofill -ofdel nl0 cr0 tab0 bs0 vt0 ff0
    -isig -icanon -iexten -echo -echoe -echok -echonl -noflsh -xcase -tostop -echoprt -echoctl -echoke


    Hab start und stop mal auf <undef> gesetzt, leider ohne Erfolg!


    Sorry, aber was meinst du mit Start- und Stop-Zeichen auf [font="Courier New"]undef[/font] setzen?

    dreamshader: Nein, das von dir genannte Monitor-Programm hab ich noch nicht probiert. Muss ich erst mal zum Laufen bringen ...
    Und ja, hab auf beiden Seiten (Adapter und Modbus-Gerät) nen 120 Ohm Widerstand zwischen den Signalleitungen.


    olli112: Ich möchte eben auch den SDM630 Modbuszähler von B+G auslesen. Funktioniert aber leider nicht ... :(


    Zuerst mal danke für die Antworten!


    Unter Windows 10 hab ichs mit dem QModMaster Programm (http://sourceforge.net/projects/qmodmaster/) probiert.
    Und ja, ich versuche am Raspberry Pi die Daten eines Energiemessgerätes auszulesen; läuft über Modbus.
    Ich hab das ganze unter Python mittels zwei verschiedener Libs probiert ... beides mal das selbe Problem:
    -> Bekomme einfach keine Antwort!
    Probiert hab ichs mit der pymodbus-lib (https://github.com/bashwork/pymodbus) und MinimalModbus (https://github.com/pyhys/minimalmodbus).

    Hallo liebe Forumsgemeinde,


    habe mir grad folgenden RS485-USB-Adapter bestellt: http://www.ebay.de/itm/USB-RS4…aspberry-Pi-/181923686340


    Leider läuft das Ding nur unter Windows (mit Modbus Master getestet).


    Unter dem Raspberry Pi wird der Adapter zwar korrekt erkannt und unter /dev/ttyUSB1 angemeldet.


    Wenn ich allerdings mein Python Skript starte


    erhalte ich nur:


    Kennt jemand das Problem und kann mir weiterhelfen?