Posts by MrMoods

    Ich habe das gleiche Problem...

    KlappMint # date ; dd if=/dev/sdb of=/mnt/pladde/rpi.img bs=1M ; date
    Do 31. Dez 15:07:13 CET 2015
    7420+0 Datensätze ein
    7420+0 Datensätze aus
    7780433920 Bytes (7,8 GB) kopiert, 869,729 s, 8,9 MB/s
    Do 31. Dez 15:21:43 CET 2015
    KlappMint # ls -l
    insgesamt 7598084
    -rw-r--r-- 1 root root 7780433920 Dez 31 15:21 rpi.img
    KlappMint # file -s rpi.img
    rpi.img: x86 boot sector

    Beim Mounten bekomme ich dann:

    KlappMint pladde # mount rpi.img /mnt/image -o offset=$((122880*512))
    mount: Sie müssen den Dateisystemtyp angeben

    Hab mal mit -t ext4 versucht, ging aber auch nicht.


    Ach ja, ich betreibe die Karte in einem Raspberry Pi 2 Mod. B und das Backup der Karte habe ich in einem Kartenleser am Laptop unter Linux Mint 17.3 durchgeführt.
    Automatisch zusammengefügt:
    So, habe das Image jetzt einfach mal mittels cp auf eine andere SD-Karte zurückkopiert und es funktioniert scheinbar. Kann es aber nicht mounten.
    Automatisch zusammengefügt:
    Gnaaa.

    Wenn ich in der Desktopumgebung mit rechts auf das Image klicke, bietet er mir das Einhängen an und das funktioniert auch. Wieso bekomme ich es dann mit einem normalen mount nicht hin?

    Na klasse.

    Ich hab gestern ohne zu recherchieren zwei WLAN-Sticks gekauft. Ergebnis: Ich habe natürlich genau diese Variante erwischt.

    Jetzt weiß ich auch, warum ich hier gestern Abend/Nacht fast verzweifelt bin.

    Das Komische ist, dass der Stick am Raspberry Pi 2 im grafischen Desktop funktioniert (Scannen möglich, Netze werden angezeigt), aber so richtig komme ich damit nicht klar.

    Als ich fertig war, lief gar nichts mehr und ich habe den Pi heute neu aufgesetzt.

    Okay. Ich hab jetzt kurzzeitig nur Bahnhof verstanden. Das muss ich mir nochmal in Ruhe zu Gemüte führen. Bin heute etwas übermüdet.

    Problem mit dem manuellen Starten ist, dass die Kiste ja unbeaufsichtigt laufen soll. Ich möchte so immer auf dem Handy nach dem Boot eine Nachricht bekommen, damit ich weiß, dass der Rechner neu gestartet wurde.

    Ich habe gestern noch ein wenig rumgesucht und bin dabei auf Telegram-Bots gestoßen, so dass ich mich einfach durch das Aufrufen einer URL benachrichtigen kann. Klappt auch wieder alles super (URL-Aufruf durch wget), aber eben wieder nicht beim Booten.

    Ich denke echt, es liegt an der (noch) fehlenden Internetverbindung. Und das, obwohl ich Requires=network.target in der Startdatei angegeben habe. Versteh ich nicht.

    Wie gesagt, das mit dem Daemon muss ich mir nochmal genauer anschauen. Das werde ich ja eh brauchen, da ich ja später auch Befehle an den Pi schicken will.

    Hallo.

    Ich möchte mich von meinem Pi nach abgeschlossenem Bootvorgang benachrichtigen lassen.

    Zuerst wollte ich dazu eine WhatsApp-Nachricht über Yowsup schicken. Da mir Yowsup aber nicht gefällt und auch nicht so gut läuft, habe ich das verworfen.

    Jetzt habe ich mir Telegram installiert. Das Problem bei Telegram ist, dass es eigentlich keine Nachrichten per Kommandozeile verschickt. Nach langem Googeln habe ich dazu eine Lösung gefunden und mir folgendes Skript zusammengebaut:


    Wenn ich das Skript von Hand ausführe, funktioniert alles einwandfrei.

    Also habe ich jetzt noch die Datei /etc/systemd/system/nachricht_nach_booten.service mit folgendem Inhalt angelegt:

    Diese Datei habe ich dann mit systemctl enable nachricht_nach_booten.service aktiviert. Scheinbar funktioniert das auch soweit, da ich nach jedem Reboot ein aktuelles Datum mit Uhrzeit in meiner TELEGRAM_BOOT vorfinde. Allerdings bekomme ich in Telegram keine Nachricht aufs Handy.

    Liegt es vielleicht daran, dass Telegram keine Console hat? Immer, wenn ich das Skript von Hand ausführe, öffnet sich der Telegram-Client und führt alle Befehle aus und schließt sich danach wieder. Das wird vermutlich als Service ohne Console nicht funktionieren, oder?

    Gibt es eine Möglichkeit, das zu umgehen?

    Erledigt.

    Man muss unter /etc/systemd/system eine Datei mit einer Service-Beschreibung anlegen und diese dann mittels systemctl enable blabla.service aktivieren. Allerdings funktioniert das nicht so, wie ich wollte, aber dazu mache ich einen neuen Thread auf, weil sich das Problem auf Telegram bezieht.

    Ich glaube, ich habe es eben selbst rausgefunden. Kann es sein, dass die /etc/rc.local gar nicht ausgeführt wird, weil agetty installiert ist und die Skripten in /etc/systemd/system liegen? Zumindest scheint raspi-config dort in der autologin@.config den Auto-Login abzulegen.

    Hallo.

    Hab den Pi erst seit gestern und schlage mich so durch. Habe erfolgreich Raspbian installiert und nach einigem Rumspielen dann auch Yowsup.

    Yowsup funktioniert (trotz diverser Fehlermeldungen beim Installieren) einwandfrei. Ich muss mir nur noch anschauen, wie man den Listener ans Laufen bekommt.

    Idee war eigentlich, dass der Pi mir nach dem Hochfahren, wenn der Bootvorgang abgeschlossen ist, über WhatsApp eine Nachricht schickt.

    Dazu habe ich folgende Zeile in die /etc/rc.local eingefügt:

    Code
    yowsup-cli demos -s 49MeineNummer "RaspberryPi hochgefahren!" -c /home/pi/yowsup/config

    Leider passiert nach dem Booten aber nichts. Vielleicht, weil das Netzwerk noch nicht erreichbar ist? Ich habe auch schon in der Pi-Konfiguration eigeschaltet, dass er beim Booten auf das Netzwerk warten soll, hat aber nichts gebracht.

    Hat jemand eine Idee, was ich falsch mache?