Posts by noxx

    pi@raspberrypi ~/pimatic-app $ sudo netstat -tulpen | grep -i :8081
    tcp 0 0 0.0.0.0:8081 0.0.0.0:* LISTEN 0 7623 2377/motion


    Versuche gerade die von Motion erzeugten Dateien (*.jpg und *.swf) auf einen
    Webserver zu speichern. Klappt auch. Da das mit dyndns bisher nicht klappt,
    dachte ich, ich könnte die Bilder evtl als Webcam-Stream nutzen.


    Motion erzeugt leider nicht eine Datein, sondern pro Sekunde 2 Bilder mit
    fortlaufender Nummer. Gibt es möglichkeiten per PHP diese Daten zu verwerten?

    Motion bringt doch einen eigenen Server mit.


    Ich steuerte nicht die lokale IP an, sondern die
    Zugewiesene vom Provider, gebe dann zB
    30.31.32.33:8081 an, werde dann auf
    192.168.1.10:8081 vom Router weitergereicht.
    Das geht, andere Ports funktionieren bei anderen
    Tools. Nur motion nicht.Entweder liegt es an Einstellungen von motion oder ich brauche was anderes.


    Grus

    Hallo zusammen,


    bisher habe ich hier nichts passendes gefunden....


    Ich habe an meinem Pi eine Creative 720p Webcam angeschlossen.


    Nun würde ich gerne auf den Stream auch ausserhalb meines Netzwerkes
    zugreifen, finde dafür aber kein brauchbares Tutorial.


    Habe zz Motion am laufen, geht, aber nur lokal.


    wenn ich per dyndns auf denn PI zugreifen
    http://ipmeinesrouters:8081 (port weiterleitung von 8081 auf 8081)
    bekomme ich kein Bild.

    Hallo,


    brauche mal Hilfe.


    Habe Pilight installiert
    Sender ist angeklemmt
    Beim Start gibt es allerdings einen Fehler


    Code
    pi@raspberrypi ~ $ sudo service pilight start
    [FAIL] Starting : pilight failed!


    Wie bekomme ich dem auf die Spur?


    Sender am PI2
    http://www.amazon.de/gp/product/B00OLI93IC?psc=1&redirect=true&ref_=oh_aui_detailpage_o02_s00 (Affiliate-Link)


    Empfänger
    http://www.amazon.de/gp/product/B00544QEHA?psc=1&redirect=true&ref_=oh_aui_detailpage_o03_s00 (Affiliate-Link)



    Gruß


    Edit: Die /var/log/pilight.err zeigt folgendes:

    Code
    [Jun 18 15:49:58:405613] pilight-daemon: ERROR: config setting "webserver-https-port" is invalid



    Edit 2:
    So, läuft. Habe die Zeile webserver-https gelöscht, dann läuft es.


    Nun aber was anderes. Habe leider nur den Empfänger.
    Ist der Sender zwingend nötig, oder komme ich sonst irgendwie
    an die Device Einstellung?


    Gruß


    Edit 3:
    Der Dimmer scheint irgendwas zu senden, kann ich damit was anfangen?


    So, mal ne schlechte Nachricht. Mephisto 3 kann keine lokalen (SD Karte, USB Stick, NAS,...) abspielen,
    zumindest nicht über die GUI/Display.


    syd711 baut das in die nächste Version ein. Er findet aber erst Zeit nach dem Sommer. Mir fehlt leider
    das Know-How. Werde dann wohl warten müssen.


    Gruß

    Hallo


    um mein NAS Laufwerk nach dem start zu mounten habe ich in die /etc/fstab
    folgenen Eintrag eingfügt:


    //192.168.1.18/Musik/MP3 /media/mp3 cifs guest 0 0


    Gebe ich
    sudo mount -a


    in die Konsole ein, wird das Laufwerk unter /media/mp3
    eingebunden.
    Aber nach einem Neutstart ist /media/mp3 leer.
    Ich muss erst manuell wieder mit
    sudo mount -a
    mounten.


    Warum gehts nicht automatisch?

    Ok, steht ja da.


    Quote


    The hardware architecture of the radio is pretty simple. The Raspberry Pi with USB WLAN and USB sound has another USB cable attached that will power a relay. This relay enables the power supply for the Logitech amplifier and another relay that enables the display. I used the switch of the poti of the Logitech amplifier to control the power to the Raspberry Pi.


    Er schaltet mit den Relais das Netzteil vom Lautsprecher Verstärker und und das Display.
    Denke er macht das, um mit einem Schalter, den vom Verstärker


    - den PI einschalten zu können
    - das Display einschalten zu können
    - den Verstärker selbst einschalten zu können


    5V sind dann wohl um die Relais zu schalten.
    An den Schaltkontakten dann 5V oder 12V, je nachdem
    was das Display oder der Verstärker an Versorgung brauchen.


    Für mich erstmal unwichtung, da mein Poti am Verstärker keinen Schalter hat.

    was ist den mit den Relais?


    Ich kämpfe gerade mit dem Encoder :(
    Anscheinend liegt es an PI4J. syd711
    hat PI4J v0.5.5 integriert, die läuft wohl
    nicht mit dem PI2, sondern erst ab v 1.0


    Habe zwar den pi4j-core.jar getauscht, aber
    100% läuft er noch nicht. Zumindest dreht er
    schonmal zu einer Seite.


    ...
    Und wie hattest du das mit der Zugangsberechtigung der Hühner resp. Fuchs und Wiesel vorgesehen?
    Automatik bedeutet, dass das Legepersonal evtl. wegen Arbeitsbedingungen streikt oder mit dem Tod bestraft wird weil nachts ausgesperrt.


    In erster Linie gehts darum, eine Möglichkeit zu schaffen Kontrolle über
    den Stall zu bekommen, wenn ich mal nicht zuhause bin.


    Bisher laufen die Tiere, sobald es dämmert, alle alleine in den Stall.



    Werde mir mal die Möglichkeiten der Hausautomatisierung (zb FHEM)
    anschauen. Möchte natürlich die versuchen unter 100€ zu bleiben,
    sofern es geht. PI B, WLAN-Stick und Kamera sind noch vorhanden, die zähle
    ich nicht mit.

    Habe auch den Panasonic Encoder, bei mir spielt der verrückt.
    Läuft das ganze am PI 1 oder PI 2?
    Habe einen neuen von Alps oder so bestellt, hoffe der läuft besser.


    Google geht glaub ich, muss aber in der CONF aktiviert werden.
    Bin aber nicht sicher, ob syd711 den Fehler in der Api behoben hat.

    Vorher war ne Api zu Goole-Musik fest verbaut. Das hatte immer einen Fehler ausgeworfen,
    weil Google am Code was geändert hat.
    syd711 hats dann für mich (oder....) rausgenommen.

    Hallo,


    leider gibt es nichts fertiges für den PI, oder ich habe es nicht gefunden.


    Ich möchte für einen Hühnerstall eine Stallsteuerung, welche folgende
    Aufgaben erledigt:


    1) Überwachung
    Hierfür soll der PI in Verbindung mit der PI-Kamera ein Live-Bild erzeugen,
    damit ich per Browser auf den Stream zugreifen kann


    2) Lichtsteuerung
    Hier soll der PI einen LED-Lichtleiste ansteuern und einen Sonnenaufgang
    und Sonnenuntergang simulieren, zb
    5.00 Uhr- 5.30Uhr von 0% auf 100%
    22.00Uhr-22.30Uhr von 100% auf 0%


    Zwischen lokalem Sonnenaufgang und Sonnenuntergang soll auf 30%
    eingestellt weren. Heisst, wenn um 8.00Uhr die Sonne aufgeht und um 21.00 Uhr
    unter, soll das ganze für den Tag so aussehen:
    5.00 Uhr- 5.30 Uhr von 0% auf 100%
    7.30 Uhr - 8.00 Uhr 100% auf 30%
    8.00 Uhr - 21.00 Uhr 30%
    21.00 Uhr - 22.00 Uhr 30% auf 100%
    22.00 Uhr - 22.30 Uhr von 100% auf 0%


    3.) Klappenöffnung
    Tür/Klappe in Abhängigkeit des lokalen Sonnenaurfgangs und Untergang steuern
    Heisst, wenn um 8.00Uhr die Sonne aufgeht und um 21.00 Uhr
    unter, soll das ganze für den Tag so aussehen:
    8.15 Uhr (15 Minuten nach Aufgang) Klappe öffen (zb Motor Rechts)
    22.30 Uhr (30 Minuten nach Untergang) Klappe schließen (zb Motor Links)


    ------------------------------------------------------------------------------------------------


    Da mir bisher die Erfahrungen an Zusatzplatinen, sofern ich welche brauche, habe
    und mit auch die Programmiererfahrungen fehlen, werfe ich die Frage in den Raum,
    wie man das ganze und womit am einfachsten realisieren würde. Benötigte Kenntnisse
    würde ich mir dann ggf aneignen.


    Danke.


    Gruß

    Du musst es ja nicht selbst kompilieren, es sei den du willst am Programm
    was ändern. Ich habs auch nicht hinbekommen, deshalb hat mit syd711 eine
    kompilierte Version gegeben.


    - Raspian installieren


    - MPD installieren
    sudo apt-get install mpd mpc alsa-utils
    (siehe auch: http://www.forum-raspberrypi.d…-mpc-auf-dem-raspberry-pi)


    -Mephisto 3 downloaden und nach /home/pi kopieren
    https://drive.google.com/file/…xbThNWjg/view?usp=sharing


    - per SSH auf den Pi einloggen und entpacken mit
    unzip m3-without-google.zip


    - ins Verzeichnis wechseln
    cd callete-deployment


    - und run.sh ausführbar machen
    sudo chmod +x run.sh


    - run.sh bearbeiten
    sudo nano run.sh


    - und den Pfad vor Java anpassen oder enfernen
    sudo java -Dfile.encoding=utf8.......


    - Ins Verzeichnis ./callete-deployment/conf/ wechseln und callete.properties bearbeiten
    3x IPs (aktuell 192.168.1.23) anpassen, habe für local auf 127.0.0.1 geändert


    Dann sollte die run.sh laufen


    Bastelt gerade selber noch. Lautsprecher, Verstärker und Rotary Encoder sind bestellt.
    Gehäuse ist fertig.
    Habe noch einen alten Rotary Encoder, aber irgendwas stimmt da nicht.
    Habe das Mephisto mit dem PI B und PI 2 probiert, aber trotz identischer Einstellungen
    reagiert der Encoder total unterschiedlich.


    PI B:
    Beim berühren des Encoders scrollt der schon durch das Menü.
    Button scheint ok zu sein. Kurz drücken = OK, Lang drücken = Hauptmenü


    PI 2:
    Beim Druck auf den Button scrollt er, beim langdrücken geht er ins Hauptmenü. Beim drehen passiert nichts.


    Was ich aber nicht wegbekomme, ist ein kleiner schwarzer Rand (ca 5mm) unter der GUI. Habe schon zu syd711
    Kontakt gehabt, aber das gleiche Problem hat auch er.



    Wenn das Tool automatisch nach dem booten starten soll, dann kann man auch die run.sh in den Ordner
    /etc/init.d/ kopieren
    Habe die Datei noch angepasst:

    Bash
    #!/bin/bash
    clear
    cd /home/pi/callete-deployment
    sudo java -Dfile.encoding=utf8 -Dlogb.............


    Muss ebenfalls mit chmod +x ausführbar gemacht werden

    Ja, diesen Fehler hatte ich auch schon, als ich es selber kompiliert hatte. Mit dem Paket läuft es.


    Paktet entpacken mit

    Code
    unzip m3-without-google.zip


    ins Verzeichnis wechseln

    Code
    cd callete-deployment


    run.sh ausführbar machen

    Code
    sudo chmod +x run.sh


    run.sh bearbeiten (Pfad für Java anpassen)

    Code
    sudo nano run.sh


    Code
    sudo java -Dfile.encoding=utf8.......


    dann die run.sh starten.
    Läuft so eigentlich bei mir