Posts by Dynalon

    Vielen Dank auch an Urs-19 und RTFM.


    Zwar ging meine Fragestellung eher in die Richtung "Wie deaktiviert man in Raspbian den HDMI Port dauerhaft?", alles was ich zu Octoprint und Co geschrieben habe sollte eher ergänzendes Informationsbeiwerk sein. Da man als Newbie in Foren gescholten wird, wichtige Hintergrundinformationen zu vergessen, wollte ich vorbildlich alles erwähnen, was relevant sein könnte. Aber nun weiß ich, dass ich mich der Installation vielleicht mal von der anderen Seite nähern sollte: Erst ein nacktes Raspbian installieren, dann Display Treiber und wenn das läuft Octoprint dazu...


    Ich wünsche Euch einen angenehmen Start in die Woche!

    Hallo alle zusammen,


    ich bin ehrlich gesagt ein Neuling, was den Raspi angeht. Zwar habe ich mittlerweile seit mehreren Jahren mittlerweile 4 (1x 2B, 2x 3B und 1x Zero W) in Betrieb, doch bin ich offensichtlich kein Kind des Terminals. Alles was ich damit anstelle, erfordert viel Googeln, mehrere Versuche und leider werde ich gefühlt auch einfach nicht schlauer.


    Nun stehe ich vor einem Problem, welches von Euch (hoffentlich) mit einem Fingerschnippen gelöst werden kann:


    Mein Raspi 3B (aktuelles Octopi 0.17.0) soll per 3,5" Head Display betrieben werden und das Touch UI (Wer Octoprint kenn, kennt dieses bestimmt auch) anzeigen.

    Mit viel Mühe läuft alles theoretisch, AUSSER dass auf dem Head Display nur Text ausgegeben wird und der sich nach dem Booten nicht mehr ändert. Einfach gesagt, handelt es sich um die Meldungen, die durchlaufen wenn er bootet. Die letzte Zeile lautet "Octopi-Printer login:" (siehe unten).

    Anders als bei Putty passiert hier aber NICHTS. Wenn ich per angeschlossenes Keyboard Nutzernamen und/oder Passwort eingebe, benimmt er sich, als ob ich vergessen hätte, die Tastatur anzuschließen. Über Putty verhält er sich hingegen so, wie man es von ihm kennt und erwartet (so habe ich alles ja eingerichtet). Gebe ich etwas via Putty ein, ändert sich zwar dort die Eingabe ganz normal, das Head Display verändert sich in keinster Weise (Zeigt also keinen neuen Text oder meine Eingabe o.ä. an). Schließe ich nachträglich einen Monitor per HDMI an, sehe ich mein Octorpint Touch UI, was eigentlich auf dem Head Display laufen sollte.

    Zusammengefasst: Ich glaube, aus einem mir vollkommen unerklärlichen Grund bootet er (egal ob ein Kabel/Monitor angeschlossen ist oder nicht) immer mit HDMI. :wallbash:

    Ich habe schon mehrere Stunden gesucht, doch alles was ich finde, sind Befehle um den Monitor kurzzeitig (= bis zum nächsten Boot) auszuschalten oder Problemdiskussionen von Menschen, deren HDMI eben nicht funktioniert.


    Ich möchte aber den HDMI Ausgang permanent ausschalten, so dass er hoffentlich dann nur noch das Head Display nutzt.


    Alles was ich sonst mit dem Kerl angestellt habe, war das Display (Hersteller Quimat, 3,5" - mehr steht nicht auf der Packung) einzurichten nach dieser Anleitung: https://medium.com/@brune/rasp…installieren-f567d751fee6

    Zur Installation von Octopi bin ich diesem Tutorial gefolgt: https://www.youtube.com/watch?v=OJ59hXSyBoI&t=781s

    Ansonsten habe ich meines Wissens nach nur noch 1Wire aktiviert, um einen Filamentsensor anzuschließen.


    Abgesehen von der falschen Anzeige funktioniert alles absolut normal.


    Ich freue mich riesig über etwas Hilfe. Bitte wenn es nicht zu viele Umstände macht, freue ich mich über eine idiotensichere Antwort, bei der Ihr keine Kenntnisse voraussetzt. :daumendreh2:


    Vielen Dank für Eure Hilfe!


    Gruß, Dynalon


    Hallo alle zusammen,


    ich habe leider kürzlich am eigenen Leib erfahren, daß die Gegend in der ich wohne nicht ganz so sicher ist wie ich dachte.


    Kurzum, mein Ziel ist es, außen an meinem Haus 3 Überwachungskameras anzubringen, die über Wifi mit dem Pi verbunden sind (siehe Attachment). Im Idealfall soll bei jeder Bewegung 1 Bild pro Sekunde (von mir aus auch ein kurzes 5min-Video) aufgenommen werden, daß von der jeweiligen Kamera per Wifi zum Pi übertragen und dort auf einem USB Stick gespeichert wird. Wenn ich es nicht anders entscheide soll sich wiederum das Bild/Video nach 1 Woche automatisch löschen. Wenn es mit der Bewegungserkennung nicht klappt, reicht es mir auch, wenn durchgehend gefilmt wird.



    Nun zum Problem: Ich will nicht 3 Raspberries mit Kamera draußen bei jedem Wetter (eben auch im Winter) an der Hauswand hängen haben, sondern hätte lieber IP66 zertifizierte Kameras für den Außeneinsatz.


    Ich habe bereits eine Kamera (nur für Innenbereich) zum testen hier, komme aber als absoluter Raspberry Noob nicht weiter. Windows und Android geben ein Bild, aber wie/ob man das dem Raspberry beibringen kann, hab ich keine Ahnung. Betriebssystem bin ich flexibel (derzeit versuche ich es mit dem aktuellen NOOBS auf einem Raspberry Pi2 B), bin aber auch bereit, alles andere zu installieren.
    Meine Testkamera ist diese:


    http://www.szneo.com/en/products/show.php?id=147


    Später soll so etwas in der Art verwendet werden:


    http://www.amazon.de/Wasserdichte-%C3%9Cberwachungskamera-Bewegungsmelder-Alarmfunktion-Fernbedienung/dp/B015Z1SBMC/ref=sr_1_95?ie=UTF8&qid=1455712645&sr=8-95&keywords=ip+kamera (Affiliate-Link)


    oder so etwas:


    http://www.amazon.de/NetBoat-Wasserdicht-%C3%9Cberwachung-WLAN-Nachtsicht-Benachrichtigung/dp/B01A5GFSR8/ref=sr_1_92?ie=UTF8&qid=1455712645&sr=8-92&keywords=ip+kamera (Affiliate-Link)



    Würde mich riesig freuen, wenn Ihr mir mit ein paar (idiotensicheren) Tipps weiterhelfen könnt!


    Viele Grüße,


    Dynalon