Posts by bumtheduke

    Ich hab das Problem jetzt so gelöst:


    Hab ein Skript startup.sh mit folgendem Inhalt geschrieben:


    sudo service pilight stop
    sudo iptables -A INPUT -s 127.0.0.1 -j ACCEPT
    sudo service pilight start



    Ich rufe dieses Skript beim Booten auf, uns schon funktionierts.
    Achtung: Aufruf beim Booten über rc.local funktioniert nicht.
    Ich mache den Aufruf über einen Eintrag im crontab:
    @reboot sudo /home/pi/startup.sh

    Habe einen MSP3008 am SPI-Bus (Pi 3; Rasbian Jessie).
    Das Auslesen des Spannungswertes am Kanal 0 funktioniert genau 1x nach dem Rebbot ( und da auch nicht immer), danach werden immer 0V ausgegeben.
    Hat jemand eine Idee? Danke imVoraus


    #include <stdio.h>

    #include <wiringPi.h>
    #include <mcp3004.h>


    #define BASE 100
    #define SPI_CHAN 0


    int wert;


    int main (void){



    wiringPiSetup();
    mcp3004Setup(BASE, SPI_CHAN);
    wert = analogRead(100);
    printf("%f V\n",0.00322265625*wert);


    }

    Meine Konfiguration:
    Raspberry Pi B, Rasbian Jessie, pilight V7.0, WLAN


    Nach der Installation hat pilight-receive kurz funktioniert, jetzt kommt sowohl bei send als auch bei receive die Meldung NOTICE: no pilight ssdp connection found.


    Folgendes habe ich bereits probiert:


    - in config.json steht der EIntrag: "standalone": 1 (und das steht auch nach dem reboot noch da).
    - iptables -A INPUT -s 127.0.0.1 -j ACCEPT erledigt
    - der daemon läuft
    - "[font="Courier"]iface lo inet loopback[/font]" in [font="Courier"]/etc/network/Interfaces[/font]



    Ich möchte pilight auf einem Standalone-Pi betreiben und eigentlich nur die API benutzen (kein Web-Interface).


    Hat jemand Ideen, was helfen könnte?
    Danke