Posts by Bauer1

    Nein, leider kann der RPi auf kein Netzwerk zugreifen.
    Das Ganze wird im Garten stehen und dient zur Zeitsteuerung einer Bewässerung, die von Ebbe und Flut abhängt.
    der RPi wird ein Accesspoint erstellen, und ich werde die Zeiten etc dann per Web-Ui mit dem Handy einstellen und ändern können.


    Ich hatte mir gedacht, dass ich die Zeit so recht einfach setzen könnte. Über putty ist das ja auch gar kein Problem. Da ich jedoch nicht immer mit dem Notebook zum RPi laufen möchte, wenn ich ihn kurz vom Strom hatte fand ich dies die einfachste Methode, ohne zusätzliche Hardware verbauen zu müssen (z.B.. RT Clock etc).


    Ich hab es leider noch nicht verstanden, wie ich das jetzt genau einstelle. Ich kann zwar ein Script als sudo ausführen lassen, aber da ich dann bei einer neuen Uhrzeit immer das Script mit ändern müsste (mit der richtigen Zeit drin), hab ich ein Problem.


    Kann ich nur den Befehl "date --set=..." für www-data freischalten
    Oder könnte sich der RPi die Uhrzeit irgendwie vom iPhone holen?

    Danke!
    Nein das Problem kann ich so nicht lösen, da der Pi später keine Internet Verbindung haben wird, ich aber trotzdem die Uhrzeit einstellen möchte.


    Ich blicke durch die Anleitung leider nicht ganz durch. Ist es möglich NUR das Recht zum Einstellen der Uhrzeit zu vergeben?

    Moin!
    Ich möchte mittels php-script die Uhrzeit meines RPis einstellen.


    Der Konsolenbefehl lautet also zb

    Code
    sudo date --set='@1497712620'


    wobei die Zahl dabei das Datum und die zu setzende Uhrzeit als Zeitstempel ist.



    Über php möchte ich das ganze ausführen also:
    [code=php]echo shell_exec("sudo date --set='@" .$timestamp . "'");[/php]


    "$timestamp" ist hierbei wieder Datum und Uhrzeit als Zeitstempel.


    Jetzt haperts wahrscheinlich daran, dass www-data nicht die nötigen Rechte hat, um diesen Befehl auszuführen.


    Wie kann ich dieses Problem ändern?

    Nein, natürlich nicht. Aber ich suche seit Stunden nach dem Fehler und ich weiß, dass es zu Beginn mal ging. Also habe ich mir wohl aus Versehen irgendwas zerschossen. Und in der Zeit, in der ich weiter nach dem Fehler suche, ist es für mich einfacher, es neu aufzusetzen.

    Ich denke ich werde den Rpi ganz neu aufsetzen. Ist zwar viel Arbeit alles wieder so zum laufen zu kriegen, aber vielleicht funktioniert es ja.


    Trotzdem erstmal danke für eure Bemühungen! :thumbs1:

    So. Hier sind die Ausgaben der Befehle:


    Danke für deine Hilfe, alleine komme ich echt nicht weiter!

    Ich meine natürlich /var/www/html/. Der Unterschied zu /html/ ist mir bewusst.


    Wenn ich das jetzt richtig sehe, gehört die Datei test.php dem Benutzer www-data (x=lesen, w=schreiben, x=ausführen), die Gruppe, zu der ich Pi hinzugefügt habe kann lesen und ausführen und andere auch lesen und ausführen. Ist das so richtig?


    Wenn www-data also alle Rechte hat, und der Server als www-data ausgeführt wird, wieso bekomme ich trotzdem 403-forbidden?

    Hab die Datei jetzt im /html liegen. Gleicher Fehler wie vorher.


    Nochmal die Ausgabe mit der Datei:

    Code
    pi@raspberrypi:~ $ ls -la /var/www/html/
    insgesamt 28
    drwxr-sr-x 2 www-data www-data  4096 Mai 19 23:18 .
    drwxr-sr-x 3 pi       www-data  4096 Apr 13 22:49 ..
    -rwxr-xr-x 1 www-data www-data 11104 Apr 13 22:50 index.html
    -rwxr-xr-x 1 www-data www-data  3373 Apr 15 13:26 index.lighttpd.html
    -rw-r--r-- 1 www-data www-data    79 Mai 19 23:18 test.php



    Filezilla kann auch sftp. Ist da noch ein Unterschied weshalb ich lieber WinSCP verwenden sollte?

    Danke für eure schnellen Antworten!


    Ja, das php-Modul ist installiert. Habs zur Sicherheit nochmal überprüft.


    die Ausgabe von ls -la /var/www/html/ ergibt:


    Code
    pi@raspberrypi:~ $  ls -la /var/www/html/
    insgesamt 24
    drwxr-sr-x 2 www-data www-data  4096 Mai 19 19:43 .
    drwxr-sr-x 3 pi       www-data  4096 Apr 13 22:49 ..
    -rwxr-xr-x 1 www-data www-data 11104 Apr 13 22:50 index.html
    -rwxr-xr-x 1 www-data www-data  3373 Apr 15 13:26 index.lighttpd.html


    Ich habe die Rechte jetzt wie du gesagt hast wieder vergeben wie vorher.
    Jetzt kann ich allerdings auch nicht mehr mit Filezilla Datein in das Verzeichnis /var/www/ kopieren... (permission denied)

    Hallo!


    Ich habe mit Apache2 einen Webserver aufgesetzt. Die Testwebsite "Apache2 Debian Default Page" kann ich problemlos aufrufen.
    Jetzt kommt das Problem: Ich möchte eine php-Seite aufrufen. Doch das geht nicht. Im webbrowser erscheint immer die Fehlermeldung "403 - Forbidden".


    Ich hatte es eigentlich vor drei Monaten schon genauso gemacht, aber komischerweise hat es damals funktioniert.


    Woran könnte der Fehler liegen?
    Ich habe pi schon der Gruppe www-data zugewiesen und mittels " sudo chown pi:www-data -R /var/www" die Rechte neu vergeben.


    Habt ihr ne Lösung? Mich wundert, dass eine html aufrufbar ist, eine php-Seite allerdings nicht...



    Freue mich über eure Antworten!

    Danke für eure Antworten.


    Da hast du natürlich Recht schnasseldag,


    Der Sensor soll die Geschwindigkeit eines Sprühgerätes messen (aus diesem Projekt: hier)


    Die Drehzahl des Rades wird bei maximal 5 Umdrehungen pro Sekunde liegen. Während des eigentlichen Betriebs eher eine Umdrehung pro Sekunde.
    Die eigentliche Idee war an der Felge des Sprühgerätes einen Magnet zu befestigen und den Sensor an der Achse (Siehe Anhang).


    Der Sensor liegt etwa 5m vom RPi entfernt. Den Abstand zwischen Sensor und Magnet/Felge könnte ich je nach Einbau variieren.
    Ich werd mal gleich versuchen was aus dem Datenblatt herauszulesen.

    Nein, ich will ihn nicht mit Strom versorgen, ich hatte das Prinzip nur noch nicht verstanden, warum drei Kabel vorhanden sind.


    Um das Problem mit der Mechanik bzw. dem Reed-Kontakt zu vermeiden habe ich nochmal nach Hallsensoren gesucht.
    Ich habe jetzt so einen ins Auge gefasst: >>so einen<< (Affiliate-Link)


    Funktioniert dieser vom Prinzip ähnlich, sodass ich also nur zwei Kontake an den RPi klemmen muss? Reicht dann auch die Stromversorgung des RPi oder ist das Funktionsprinzip anders?


    Gruß
    Henning

    Danke für deine schnelle Antwort!
    Heißt ein sich änderndes Magnetfeld, dass ich einen einfachen Magnet am Rad befestigen kann oder muss ich mehrere verschiedenpolige Magnete an der Felge befestigen?


    Und wie schließe ich dann die drei Kabel an, wenn ich direkt an die GPIOs gehen kann?


    Das wär ja an sich noch einfacher

    Moin!


    Noch eine andere Frage. Ich möchte auch einen Näherungsschalter verbauen um die Geschwindigkeit am Rad zu erfassen. Beispielsweise >diesen<, da er mir recht robust gegenüber Wasser und Dreck vorkommt.



    Diesen würde ich mit 12 V versorgen. Dann muss ich natürlich einen Spannungsteiler oder ähnliches einsetzen um die Spannung von 12V auf 3,3V runterzuwandeln.


    Mit welcher Stromstärke errechne ich jetzt die Widerstände? Mit den angegebenen 200mA (maximale Stromstärke)?
    Oder gibt es eine einfachere Variante, als einen Spannungsteiler zusammen zu löten?


    Möchte nur ungern nen gegrillten RPi haben ;)


    MfG


    Wenn Du auf das Rad, dass durch den Durchfluss der Flüssigkeit gedreht wird, Magneten aufkleben willst, um diese dann mit einem Hallsensor auszulesen, wäre ein TLE4945L vielleicht eine gute Wahl. Die Erläuterung dazu habe ich vor einiger Zeit mal hier geschrieben: http://www.forum-raspberrypi.d…ahlregelung-licht-und-lcd


    Sollte es möglich sein, das Rad im Dunkeln (kein störendes Fremdlicht) zu betreiben, könnte man es evtl. auch mit einem Optokoppler auslesen.


    edit:
    PiPilot: Da müsste das Zigarettenanzündersteckerteil aber schon eine gute Qualität haben, damit es sowohl mit schwankender Eingangsspannung als auch mit (schnell) schwankendem Ausgangsstrom zurecht kommt und trotzdem eine stabile Ausgangsspannung liefert.


    Nein ich meine nicht zum Messen der Flüssigkeit.
    Ich meine einen Sensor um die Drehgeschwindigkeit des Reifens, also der Fahrgeschwindigkeit zu benutzen.



    Ich dachte an >so einen<weil dieser relativ einfach zu montieren wäre.
    Gibt es da unterschiede? Habe gelesen welchen müssen mit zweipoligen Magneten genutzt werden? Woran erkenne ich solche Sensoren?
    Ich würde der Einfachheit halber sonst "normale" Magneten an der Felge befestigen.


    EDIT: Es gibt anscheinend "Öffner", "Schließer" und "Wechsler". Wo liegt der Unterschied und welcher wäre für meinen Einsatzzweck am besten geeignet?


    Wie hoch darf der Schaltstrom eines Sensors sein?
    Würde gerne einen Näherungssensor >dieser Art< (Affiliate-Link)am RPi zum Erfassen der Geschwindigkeit nutzen.
    Dort ist ein maximaler Schaltstrom von 300mA angegeben? soviel kann der RPi doch gar nicht leifern oder?


    Soll der RasPi sonst noch irgend etwas machen? Falls nicht, fände ich einen Arduino (oder auch einfach nur einen µC) wesentlich geeigneter für diese Aufgabe. Den RasPi abzuschalten, indem man den Strom abstellt, ist keine gute Idee. Das wird auf Dauer das Dateisystem auf der SD-Karte zerlegen. Für solche Fälle könnte man eine USV einsetzen. Um den RasPi mit Strom zu versorgen könntest Du beispielsweise einen Step-Down mit einem KIS Modul nehmen. Beispiel: ebay 201048547297. Zur Sicherheit vielleicht noch einen etwas dickeren Elko an den Ausgang, damit die Spannung halbwegs stabil bleibt.


    Den Arduino (Clone) könntest Du übrigens direkt mit 12V versorgen. Auch ein einfaches Abschalten wird er Dir nicht übel nehmen.


    Danke für deine Antwort.
    Erstmal soll der RasPi nichts anderes machen. Da ich mich in den letzten Wochen viel mit dem Raspi, Python etc beschäftigt habe würde ich es gern damit erstmal versuchen.


    Das Ausschalten wär an sich auch kein Problem, die Stromversorgung bleibt auch bei ausgeschalteter Zündung bestehen. Ich könnte ihn ganz normal über einen Schalter abschalten.


    Der Step-Down sieht für meine Zwecke schonmal ganz gut aus.

    Moin Leute!



    Ich komme aus der Landwirtschaft, genauer gesagt aus dem Obstbau. Führe mit meinem Vater einen Obstbaubetrieb.
    Eine der vielen Aufgaben ist der Pflanzenschutz.
    Die ausgebrachte Menge an Dünger/Pflanzenschutzmittel/Wasser wird über den Spritzdruck reguliert.
    Um die Menge genauer auszubringen kann man sogenannte Spritzcomputer verwenden, die den Druck über einen Wasserdurchflusssensor und einen Geschwindigkeitssensor am Rad regeln.


    Das kann ich doch auch selbst bauen hab ich mir gedacht.


    Also habe ich mir einen Durchflusssensor bestellt (Link (Affiliate-Link)) in an den RPi angeschlossen und erstmal am Wasserhahn probiert wie genau das Ding so arbeitet. Ich war positiv überrascht.



    An der Spritze ist ein Elektromotor vorhanden (12V), über den der Druck eingestellt wird. Geöffnet und geschlossen werden die Düsen über Magnetventile (auch 12V).
    Es läuft dann also wie folgt: Ich gebe eine Ausbringungsmenge ein, der Spritzcomputer (dann der RPi) errechnet anhand der Geschwindigkeit (gemessen durch einen Hallsensor am Rad), ob die akutelle Ausbringmenge stimmt und regelt bei Bedarf nach.


    Jetzt fehlt mir noch die Stromversorgung. Die Betriebsspannung des Treckers beträgt 12 V. Ich brauche natürlich 5 V für den RPi und 12 Volt für die Magnetventile und den Elektromotor (justieren des Drucks). Was eignet sich dafür? Einfach ein Spannungsregler wie dieser??


    Wie hart trifft es den RPi wenn ich ihm einfach den Strom entziehe? Muss ich noch etwas einbauen, damit er sich sicher runterfährt, quasi über einen Kondensator Strom zwischenspeichern oder so?


    Ich benötige also:
    - RPi (vorhanden RPi 2, Model B)
    - Durchflusssensor (Affiliate-Link) (vorhanden)
    - Display (Affiliate-Link) (auf dem Postweg)
    - ein paar Kippschalter (zum Schalten der Magnetventile)
    - Spannungsquelle 5V
    - ein Gehäuse



    Ich werde diesen Thread nach und nach ergänzen mit den Fortschritten und allem was mir so in den Sinn kommt.


    Über Anregungen und Ideen freu ich mich! :)


    Stand 20.04.16


    Mein Display kam heute an und musste natürlich ausprobiert werden! :thumbs1:
    Es ist etwas blass, das könnte aber auch daran liegen, dass es nur mit 3,3V versorgt wird.

    Moin!
    Ich schließe mich einfach mal an, da ich kein neues Thema dafür erstellen will.


    Ich habe auf meinem RPi einen AP laufen. Ich möchte per Filezilla auf den Rpi zugreifen können, da ich im Outdoorbereich für mein Projekt keinen Router habe.
    So. AP an sich funktioniert, Verbindung wird hergestellt.
    Ich kann mich auch mit Putty mit dem RPi verbinden.


    Leider funktioniert es mit Filezilla nicht. Woran könnte das liegen, verwenden die nicht beide die gleiche Verbindungsart sftp?
    Hat jemand eine Idee wo der Fehler liegen könnte?


    Gruß
    Henning