Posts by [TOM]


    hostname: Diesen Hostname erhällt euer RaspberryPI, über die er im LAN ansprechbar wäre (DNS)
    autoconf: ...entzieht sich momentan auch meiner Kentniss, aber auf off stellen funktioniert :)



    Hallo Meigrafd,


    zwei Fragen dazu:


    1. Hast Du schon was zu autoconf rausbekommen?
    2. Wie soll das mit dem hostname funktionieren, so dass der Name im Netz bekannt ist? Es müsste ja ein Nameserver auf dem Raspberry laufen, den ich damit konfiguriere.



    Gruß


    [TOM]
    Automatisch zusammengefügt:[hr]
    Weil es zum Thema passt eine Ergänzung zu dem Post von Meigrafd:


    Man kann in der /boot/cmdline.txt auch eine MAC-Adresse vergeben. Klappt nicht immer, aber meistens. Dazu einfach folgenden Eintrag anhängen:

    Code
    smsc95xx.macaddr=XX:XX:XX:XX:XX:XX


    Prinzipiell kann man jede beliebige MAC-Adresse verwenden. Man sollte aber eine "private" bevorzugen. Diese hat den Aufbau

    Code
    x2:xx:xx:xx:xx:xx
    x6:xx:xx:xx:xx:xx
    xA:xx:xx:xx:xx:xx
    xE:xx:xx:xx:xx:xx


    Die Xe könnt ihr beliebig mit den HEX-Ziffern 0-F ersetzen.



    [TOM]

    Ich habe etwas gefunden. Wenn ich das Passwort nochmal mit passwd ändere, dann geht es. :s Hatte erst gedacht, es sei eventuell zu kurz, aber das war es nicht. Hat jemand eine Idee, warum das erste passwd nicht ausreicht? Ich bin doch nicht unter Windows, wo man nach einem useradd sicherheitshalber rebooten sollte. :cool:


    [TOM]




    Nachtrag:


    Man muss das Passwort für alle bereits existierenden User mit passwd neu setzen. Bei allen Usern, die dann nachträglich hinzugefügt werden, funktioniert es aber einwandfrei wie erwartet.


    Ich werde bei Gelegenheit mal versuchen das nochmals zu reproduzieren und mir dann die /etc/shadow genauer anschauen.

    Hab nochmal eine Neuinstallation durchgeführt und wieder das gleiche Problem. Ich bekomme ein "authentication failure". Folgendes habe ich gemacht:


    Code
    $ useradd -m tom
    $ passwd tom


    Als Passwort habe ich tom genommen. Wenn ich jetzt (von User pi aus) den User switchen will passiert folgendes:

    Code
    $ su - tom
    Password:
    su: Authentication failure


    In /var/log/auth.log ist folgendes zu finden:

    Code
    Sep 15 23:09:27 tomo su[1640]: pam_unix(su:session): session opened for user tom by pi(uid=0)
    Sep 15 23:13:32 tomo su[1665]: pam_unix(su:auth): authentication failure; logname=pi uid=1000 euid=0 tty=/dev/pts/0 ruser=pi rhost=  user=tom
    Sep 15 23:13:33 tomo su[1665]: pam_authenticate: Authentication failure
    Sep 15 23:13:33 tomo su[1665]: FAILED su for tom by pi


    Merkwürdig finde ich uid=0. Die /etc/ssh/sshd_config ist unverändert



    Und hier auch noch ein Ausug aus der /etc/passwd:

    Code
    root:x:0:0:root:/root:/bin/bash
    pi:x:1000:1000:,,,:/home/pi:/bin/bash
    tom:x:1002:1002::/home/tom:/bin/bash


    Ich habe noch nie Default-Einstellungen ändern oder mich mit PAM beschäftigen müssen, um neue User anzulegen, die sich per SSH anmelden können. Was ist denn bei Raspbian anders?


    [TOM]


    Hallo Tom,
    hast du mal nach einem fehlgeschlagenen Login-Versuch in die Log-Datei `reingeschaut?


    Gruß
    Chris



    Jepp. Da stand was von Auth-Fehler. Allerdings war das Passwort zu kurz zum mehrmaligen vertippen. ;)


    Merkwürdigerweise funktioniert es jetzt, so dass ich es nicht mehr reproduzieren kann. Werd das mal beobachten und ggf. neu aufsetzen und die Schritte wiederholen.


    [TOM]
    Automatisch zusammengefügt:[hr]


    Evtl. steht in der [font="Courier New, Courier, mono"]/etc/ssh/sshd_config ?![/font]

    Code
    AllowUsers pi


    Dann hätte nur der user pi SSH-Zugriff.



    Nein, das hatte ich zuerst geprüft. Da es jetzt funktioniert, kann ich den Fehler auch nicht mehr reproduzieren.


    [TOM]

    Hallo zusammen,


    ich habe das Raspbian Lite vom 27.05.2016 und dort per adduser ein paar neue User angelegt. Standard-Shell ist die /bn/bash. Wenn ich mich jetzt mit einem der neuen User per SSH anmelden will, funktioniert das nicht - für den Standard-User pi aber schon.


    Wenn ich in der /etc/ssh/sshd_conf

    Code
    ChallengeResponseAuthentication yes


    setze kann ich mich zwar per SSH (Putty/Kitty) anmelden, aber nicht per SFTP.


    Ich frage mich, wo das für den User pi unter Raspbian konfiguriert wird. Hab schon das halbe System durchsucht, aber offensichtlich die falsche Hälfte.


    Mein Ziel ist es, weiteren Usern SSH und SFTP zu erlauben und die Konfiguratin dazu an der gleichen Stelle vorzunehmen wie für den User pi.



    [TOM]

    Ich meine den Pfad /var/www/html/unifi. Liegt in einem dieser 4 Verzeichnisse eine .htaccess. Die ist versteckt, Du musst ls -la zum Anzeigen nutzen.


    Gesendet von meinem HUAWEI RIO-L01 mit Tapatalk

    Ich habe verschiedene bestellt - funktionieren erwartungsgemäß alle. Du musst nur drauf achten, ob du links oder rechts gewinkelt brauchst.


    Gesendet von meinem HUAWEI RIO-L01 mit Tapatalk

    Wieviel Stellen kann denn die Dezimalzahl haben (von - bis)? Gibt es Beschränkungen bei den Stellen der Hexadezimalzahl? Wie groß sollen die Chunks sein? Immer 2 Stellen?


    [TOM]


    Gesendet von meinem HUAWEI RIO-L01 mit Tapatalk

    Was heißt denn “geht nicht“? Kommt eine Fehlermeldung und wenn ja welche? Kommt gar nichts? Funktionieren andere Befehle, wie z. B. “ls -l“?


    [TOM]


    Gesendet von meinem HUAWEI RIO-L01 mit Tapatalk

    Denkst Du, die Bandbreite von USB 2.0 reicht Dir dafür? Wenn ich mich richtig erinnere, haben hier schon einige geschrieben, dass die Performance dafür nicht reicht.



    [TOM]


    Gesendet von meinem HUAWEI RIO-L01 mit Tapatalk

    Was die Browser so können, kann ich nicht sagen, da ich keine grafische Benutzeroberfläche installiert habe. Aber das FTP Protokoll und das Anzeigen von Bildern gehört mittlerweile zum Standard von Browsern. Ich vermute eher, dass es an der Namensauflösung liegt. Nimm mal die IP-Adresse der FritzBox, also üblicherweise die 192.168.178.1. Und falls Du Dich noch mit Username und Passwort anmelden musst, musst Du die URL noch entsprechend erweitern:



    Code
    ftp://USER:PASS@192.168.178.1/USB_DEVICE_NAME/BILD.jpg


    Und achte auch auf die Groß-/Kleinschreibung.


    [TOM]

    Interner Serverfehler klingt nach einem 500er HTTP Status-Code. Und das ist häufig ein Zeichen für einen Schreibfehler in der .htaccess. Schau Dir die nochmal genau an. In den Logs erhält man auch gute Hinweise (/var/log/apache2).


    Ich habe mir auch mal das Video angescaut. Ein paar sprachliche Unschärfen. Nimm die Anpassungen in der php.ini direkt vor.


    [TOM]

    Ich weiß ja nicht, was Du genau vor hast, aber vielleicht lohnt es sich, wenn Du Dir mal dnsmasq anschaust. Das ist sowohl Nameserver als auch DHCP Server. Ich habe sonst auch immer mit den “großen Jungs“ gespielt. Aber für den RPi wird mir dnsmasq immer sympathischer.


    [TOM]

    Irgendwie haben wir noch nicht genau verstanden, was Du vor hast. Sind die Pi's im gleichen Subnet? Soll das (halb-)automatisch oder manuell möglich sein?


    Wenn Du das manuell machen willst (weil die Pi's zum Beispiel nicht im gleichen Netz hängen), dann schau mal hier. Das gibt Dir eine Idee, wie man Konfigurationsdateien auslagert. Eventuell hilft Dir das bei Deinem Problem. Damit kannst Du ein Image auf SD-Karte schreiben, customizen und verteilen.



    vorab ... bitte keine Antworten wie "mach's auf dem Router" ... static macht man nicht etc. Danke!


    Interessante Einleitung. Klingt irgendwie vorbelastet oder gereizt. :s


    [TOM]