Posts by moby dick

    Hallo zusammen

    Ich war bzw. bin immer noch Krank!!! Darum hatte ich leider keine Zeit für mein Rassberry!!!

    Auf deine Frage Schallschraubenzieher

    Mein DHT Problem und Router einen update/upgrade bekommen habe nix mit einander zu tun.

    Aber: Mein Telefon Anbieter hat mit eine neue Software für meine Router gegeben, mit anderen Worten ich konnte nicht mehr auf den Rasberry zugreifen per putty wegen IP stimmt nicht mehr!!!

    Nach neuem Start von Rasberry hatte ich eine neue IP für putty und alles war wieder gut!!!


    Auf deine frage holgerble

    Du hast glaub recht!!!

    Adafruit_DHT habe ich glaub vor langer Zeit wo andere hin kopiert

    Gibt es eine Möglichkeit nachzusehen wo der Ordner Adafruit_DHT war?

    Ich kenne mich mit Rasberry noch nicht so gut an!!!


    Danke für die Antwort!!!

    Nein am Rasberry habe ich vor den abschalten nix geändert.

    Ich habe auf meinen Router einen update/upgrade bekommen, danach habe ich den Rasberry neu gestartet, damit der Rasberry seine neu IP von Router bekommt.

    Jetzt wird wieder Der Rasberry mit IP im Router angezeigt, vor her nicht!!


    Nach den neu Start von Rasberry bekomme ich die Fehlermeldung s.o.!!!

    Hallo zusammen

    Habe den Sensor DHT 22 am Rasberry angeschlossen und zum laufen bekommen.


    Temperatur und Feuchtesensor worden richtig angezeigt!!

    Nach dem ich den Rasberry neu gestartet habe und sonst nix verändert habe, bekomme ich jetzt folgenden Fehler angezeigt:


    Traceback (most recent call last):

    File "sensor12.py", line 65, in <module>

    humidity, temperature = Adafruit_DHT.read_retry(sensor, gpio)

    File "build/bdist.linux-armv7l/egg/Adafruit_DHT/common.py", line 94, in read_retry

    File "build/bdist.linux-armv7l/egg/Adafruit_DHT/common.py", line 81, in read

    File "build/bdist.linux-armv7l/egg/Adafruit_DHT/Raspberry_Pi_2.py", line 34, in read

    RuntimeError: Error accessing GPIO.


    Meine Frage ist:

    Was muss ich machen damit das Programm wieder lauft?:danke_ATDE:

    Hallo zusammen

    Habe den Sensor DHT22 an mein Raspberry Pi nach der Anleitung

    https://tutorials-raspberrypi.…ratur-messen-dht11-dht22/

    angeschlossen mit ein Pull-Up Widerstand von 4.7 k.


    Ich konnte Temperatur und Luftfeuchtigkeit auslesen.


    Danach habe ich mit einem ca.7 Meter langen Kabel den Sensor verlängert.

    Der Pull-Up Widerstand wider stand ist beim Raspberry Pi.


    Jetzt bekomme ich eine Luftfeuchtigkeit von 3306,6%


    Meine Frage ist:

    Warum ist die Luftfeuchtigkeit jetzt soooo hoch?

    Wo muss der Widerstand sitzen am Raspberry Pi oder besser am Sensor DHT22 oder ist das unwichtig?


    Danke für die Antwort!!!

    Hallo zusammen,
    mein Raspberry Pi hat ein WLAN-USB-Sticks und alles ist richtig eingerichtet und Ich könnte über den WLAN-USB-Sticks auf den Raspberry Pi zugreifen!!!
    Jetzt das Problem:
    Zuhause hatte ich ein Stromausfall und Raspberry Pi und Router hatten kein Strom mehr bekommen. Nach dem der Strom wieder da war, hatte ich kein WLAN-USB-Sticks Verbindung mehr.
    Die Fehler Meldung ist: dhcpcd not runnig
    Wenn ich den Raspberry Pi über Lan-Kabel verbinde habe ich wieder Internet.

    Meine Frage ist: Was muss ich machen, damit ich wieder WLAN-USB-Sticks habe?

    Danke für die Antwort

    Hallo zusammen
    Was mochte Ich erreichen?
    Ich mochte mit Socket und Threading LET An, Aus oder Blinken lassen Anzahl 2 LED!

    Das Programm in Python ist noch nicht Fertig (LED Blinken lassen)!!!

    Mein Gedanken:
    Über Socket bekomme ich die Info LED An, Aus oder Blinken lassen.
    Die Info wird nach Infook weiter gegeben (Funktioniert)
    Mit def anzeige (Threading) mochte ich gerne die LED An, Aus oder Blinken lassen (Blinken ist noch nicht Programmiert)

    Mein Problem ist jetzt:
    def anzeige wird nicht ausgeführt bzw. print('Anzeige ... wird nicht Angezeigt!!!

    Meine Frage ist warum wird Threading (def anzeige) nicht ausgeführt? :helpnew:

    Danke für die Antwort


    [font="Times New Roman"]ich habe jetzt[/font]
    [font="Times New Roman"]$file = '/var/www/daten_temperatur';[/font]
    [font="Times New Roman"] [/font]
    [font="Times New Roman"]mit Browser[/font]
    [font="Times New Roman"]http://192.168.1.7/abc.php[/font]
    [font="Times New Roman"] [/font]
    [font="Times New Roman"]alles OK![/font]
    [font="Times New Roman"] [/font]
    [font="Times New Roman"]mit Cron-Job[/font]
    [font="Times New Roman"]pi@raspberrypi /etc $ sudo nano crontab[/font]
    [font="Times New Roman"] [/font]
    [font="Times New Roman"]und in crontab selber[/font]
    [font="Times New Roman"]/1 * * * * pi /var/www/abc.php[/font]
    [font="Times New Roman"] [/font]
    [font="Times New Roman"]wird nicht ausgeführt!!! :helpnew: [/font]
    [font="Times New Roman"] [/font]
    [font="Times New Roman"] [/font]
    [font="Times New Roman"]-rwxr-xr-x 1 root www-data  789 Mai 27 10:43 abc.php[/font]
    [font="Times New Roman"]-rwxr-xr-x 1 www-data www-data 41 Mai 27 10:51 daten_temperatur[/font]
    [font="Times New Roman"]-rw-r--r-- 1 www-data www-data 177 Mär 17 07:53 index.html[/font]
    [font="Times New Roman"]-rw-r--r-- 1 www-data www-data 21 Mär 17 08:02 phpinfo.php[/font]
    [font="Times New Roman"]drwxr-sr-x 8 pi www-data 4096 Mai 12 07:25 pilight[/font]
    [font="Times New Roman"]drwxr-sr-x 3 pi www-data 4096 Apr  9 13:35 ws[/font]



    [font="Times New Roman"][font="Times New Roman"]Frage:[/font]
    [/font]
    [font="Times New Roman"]abc.php hat root[/font]


    [font="Times New Roman"]und[/font]


    [font="Times New Roman"]daten_temperatur hat www-data[/font]


    [font="Times New Roman"] [/font]
    [font="Times New Roman"][font="Times New Roman"]???? kann das Richtig sein - warum das so jetzt ist frage mich nicht LOL[/font]
    [/font]

    [font="Times New Roman"]Wenn ich die PHP Code per Browser aufrufe ist alles in Ordnung![/font]
    [font="Times New Roman"]Darum meine Frage: Wie rufe ich per Cron eine Browser Seite auf?[/font]
    [font="Times New Roman"] [/font]
    [font="Times New Roman"]http://192.168.1.7/abc.php[/font]

    [font="Times New Roman"]Ich versuche mit den PHP Code die Temperatur (3 mal) auszulesen und dann in die Text Datei zuschreiben. Die drei Echo $temp sind nur zum Testen ob die Temperatur aus gelesen wurde.[/font]
    [font="Times New Roman"]Das auslesen der Temperatur, das Anzeigen bei Echo und schreiben in die Text zuschreiben lauft per Browser richtig! Das Programm selber ist in Ordnung!![/font]
    [font="Times New Roman"] [/font]
    [font="Times New Roman"]Aber mein Problem ist jetzt - nicht mit CROJOB!!![/font]
    [font="Times New Roman"]Das auslesen der Temperatur ist noch richtig[/font]
    [font="Times New Roman"]Das abspeichern der Text Datei nicht mehr[/font]
    [font="Times New Roman"]Die Fehlermeldung ist:[/font]
    [font="Times New Roman"]file_put_contents(daten_temperatur): failed to open stream: Permission denied in /var/www/abc.php[/font]
    [font="Times New Roman"] [/font]
    [font="Times New Roman"]Was ist der Grund da für? Im Browser alles OK! Aber mit CROJOB nicht![/font]

    [font="Times New Roman"]Hallo zusammen,[/font]


    [font="Times New Roman"]versuche alle 5 min ein PHP Programm mit CRONJOB aufzurufen.[/font]
    [code=php]
    ?php
    $temp = exec('cat /sys/bus/w1/devices/10-0008009e3229/w1_slave |grep t=');
    $temp = explode('t=',$temp);
    $temp = $temp[1] / 1000;
    $temp1 = round($temp,2);
    echo $temp1 . " &#x00B0;C <br><br>";


    $temp = exec('cat /sys/bus/w1/devices/10-0008022ddcb1/w1_slave |grep t=');
    $temp = explode('t=',$temp);
    $temp = $temp[1] / 1000;
    $temp2 = round($temp,2);
    echo $temp2 . " &#x00B0;C <br><br>";


    $temp = exec('cat /sys/bus/w1/devices/10-000802715171/w1_slave |grep t=');
    $temp = explode('t=',$temp);
    $temp = $temp[1] / 1000;
    $temp3 = round($temp,2);
    echo $temp3 . " &#x00B0;C <br><br>";
    $file = 'daten_temperatur';
    $current = file_get_contents($file);
    $current .= date('Y.m.d H:i') ." | ". $temp1 ." | ". $temp2 ." | ". $temp3 ." $
    file_put_contents($file, $current);
    ?>



    [/php]



    [font="Times New Roman"]file_put_contents(daten_temperatur): failed to open stream: Permission denied in /var/www/abc.php[/font]


    [font="Times New Roman"]Ist die Fehlermeldung[/font]
    [font="Times New Roman"]Was muss ich machen damit das Programm ausgeführt wird?[/font]


    [font="Times New Roman"][font="Times New Roman"]Das PHP Programm lauft beim IE!![/font][/font]
    [font="Times New Roman"] [/font]
    [font="Times New Roman"]Danke für die Hilfe[/font]

    [font="Times New Roman"]Hallo zusammen,[/font]
    [font="Times New Roman"]habe die Funksteckdosen Set 4 mit Wandschalter[/font]
    [font="Times New Roman"]1.)[/font]
    [font="Times New Roman"]http://i.ebayimg.com/00/s/NzY4WDYzNg==/z/YvkAAOSwT6pVq~sE/$_1.JPG[/font]
    [font="Times New Roman"] [/font]
    [font="Times New Roman"]und[/font]
    [font="Times New Roman"]2.)[/font]
    [font="Times New Roman"]https://www.snap-hunter.de/de/…ckdosen-fernbedienung-set[/font]
    [font="Times New Roman"] [/font]
    [font="Times New Roman"]beide laufen auf 433 MHz.[/font]
    [font="Times New Roman"] [/font]
    [font="Times New Roman"]und Pilight[/font]
    [font="Times New Roman"]https://raspberry.tips/hausaut…-zur-hausautomatisierung/[/font]
    [font="Times New Roman"] [/font]
    [font="Times New Roman"]Meine Frage:[/font]
    [font="Times New Roman"]Warum wird Funksteckdosen 1.) NICHT angezeigt und Funksteckdosen 2.) wird ohne Probleme angezeigt?[/font]
    [font="Times New Roman"]Wo ist das Problem?[/font]
    [font="Times New Roman"] [/font]
    [font="Times New Roman"]Danke für die Antwort[/font]

    [font="Times New Roman"]Danke für die Antwort!![/font]
    [font="Times New Roman"]Ein Raspberry Pi, ein 433Mhz Empfänger und die Wetterstation WS1173 habe ich schön.[/font]
    [font="Times New Roman"]Was ich jetzt benötige ist das Python Programm für den Raspberry Pi?[/font]

    [font="Times New Roman"]Hallo zusammen,[/font]
    [font="Times New Roman"]ich habe die Wetterstation WS1173 und lauft auf 433 MHz.[/font]
    [font="Times New Roman"] [/font]
    [font="Times New Roman"]Meine Frage ist:[/font]
    [font="Times New Roman"]Wie kann ich die Wetter Daten über 433Mhz und den Raspberry Pi auslesen? :s [/font]
    [font="Times New Roman"] [/font]
    [font="Times New Roman"]Danke für die Antwort[/font]

    Hallo zusammen,
    bin neu im Forum und kenne mich mit dem Raspberry auch noch nicht gut aus.


    Raspberry:


    und HTML


    Mit
    http://192.168.1.7:8080/


    bekomme ich die Antwort:
    Hello Word
    mit andere Worten der WebSocket lauft? - oder nicht?


    Wenn ich habe jetzt das html Start auf dem Raspbery bekomme ich als Antwort
    Connection was close ...
    Warum ist das so? Muss ich nicht die Antwort bekommen:
    Hello Word
    Frage: Was macht ich in HTML nicht Richtig?


    Danke für die Antwort!!!