Posts by Obstsalat

    pi@raspberrypi ~ $ python3 -c "from pprint import pprint; import pip; pprint( pip.get_installed_distributions() )"
    Traceback (most recent call last):
    File "<string>", line 1, in <module>
    ImportError: No module named pip


    pi@raspberrypi ~ $ python -c "from pprint import pprint; import pip; pprint( pip.get_installed_distributions() )"
    [wsgiref 0.1.2 (/usr/lib/python2.7),
    argparse 1.2.1 (/usr/lib/python2.7),
    picamera 1.10 (/usr/local/lib/python2.7/dist-packages),
    pygame 1.9.1release (/usr/lib/python2.7/dist-packages),
    distribute 0.6.24dev-r0 (/usr/lib/python2.7/dist-packages),
    numpy 1.6.2 (/usr/lib/pymodules/python2.7)]


    Ich hab python2, habe gestern (und heute) auch deinen Code für Python 2 ausgeführt.
    Automatisch zusammengefügt:[hr]
    Ja ich glaube die Karte ist hinüber. Mein Script ist schon wieder weg, dafür sind Dateien da die ich vorher bereits gelöscht habe.

    Bei Videoaufnahme müsste ich angeben können dass nur alle 5 Sekunden ein Bild gemacht werden soll. Wäre natürlich das einfachste aber die Optionen für die Programme erschlagen einen :) Da kämpfe ich mich gerade durch aber bisher ohne Erfolg.


    Gestern habe ich es geschafft picamera zu installieren. Heute ist davon nichts mehr übrig, wie gibts denn sowas? picamera ist nicht mehr installiert. Auch mein Beispiel Pythonscript ist weg. Spinn ich??

    So ich hätte jetzt ein Script das mir Bilder in einem bestimmten zeitlichen Abstand aufnimmt.
    Jetzt suche ich nach einer Möglichkeit um diese Bilder "on the fly" in ein Video umzuwandeln. Alles was ich bisher finde nimmt die Bilder auf einmal und wandelt sie um.
    Ich bräuchte aber etwas das nach und nach ein soeben aufgenommenes Einzelbild an den Film anhängt. Von mir aus auch eine Gruppe von x Bildern. Aber ich kann aus Platzgründen niemals alle Einzelbilder zuerst speichern.
    Die Programme die ich finde (ffmpeg und so) erzeugen übrigens viele Ergebnisse die ich nirgends abspielen kann. Was ist da für ein Format zu empfehlen?

    Ich versuche jetzt seit 5 Minuten nach deiner Antwort picam zu installieren, ohne irgendwelche Meldungen der Art "ImportError: no module named irgendwas".
    Das ist das was mich an Linux so nervt, man kann nicht einfach mal eben was installieren ohne dass wer weiß was alles fehlt.
    Gibt es ein fertiges Image für den Raspi wo das alles schon funktionsfähig drauf ist?

    Hallo Forum
    Auf meinem Raspi ist raspistill und raspivid lauffähig. Juhuu :)
    Damit möchte ich Langzeitaufnahmen realisieren. Es soll pro Tag ein Zeitrafferfilm erstellt werden, alle 5 Sekunden eine Aufnahme. Etwa für 10 Stunden pro Tag, gibt etwa 5 Minuten Film.


    Starten würde ich das ganze per cronjob morgens. Trotzdem stellen sich mir noch mehrere Fragen.


    1. Wie mache ich die Aufnahmen am besten? Einzeln per Script und sleep? Oder per einzigem raspistill Befehl mit -tl Parameter der die ganzen 10 Stunden läuft? Oder eine Kombination die sagen wir 5 Minuten eine Aufnahme macht und dann wird das wieder per cron gestartet, damit bei einem Ausfall wenigstens 5 Min. später trotzdem wieder alles läuft?


    2. Wie komprimiere ich die Bilder in einen Stream? Die Bilder sind 1536x2048 groß und es gibt pro Tag 7200 davon. Die sollten schon kontinuierlich verarbeitet werden, sonst explodiert ja die Speicherkarte.



    3. Jede Minute soll ein aktuelles Bild für eine Webcam an einen separaten Ort kopiert werden. Wäre mit Script natürlich möglich. Ich habe schon gesucht ob es ein passenderes Programm gibt das meine Anforderungen erfüllt. Aber es ist ja ein grusliger Aufwand in Linux was zu installieren, wäre mir schon recht wenn das mit raspistill oder raspivid geht :)


    Wer Tips hat, bitte lassts mich wissen.


    Übrigens der Parameter -dt der einen Zeitstempel in den Dateinamen einfügt erzeugt bei mir das: img313181612.jpg
    Es ist März 13. 18:16:12 Uhr soweit stimmts ja. Aber wo ist die 16 fürs Jahr und warum ist der März einstellig? Damit lässt sich nur bedingt was anfangen.

    Aber nicht auf etwas zu reagieren ist relativ einfach... ich vermute da sind nicht soo viele Fehler drin.


    Diese Vermutung hat bisher für sehr viele Sicherheitslöcher und Probleme gesorgt ;) Es ist nicht das nicht reagieren was so kritisch ist, sondern gezielt falsch aufgebaute Nachrichten die etwas zum Überlauf bringen könnten oder einen Fehler bei der Verarbeitung bewirken können. Bis die Nachricht im Programm ankommt und ignoriert wird gibt es einige Verarbeitungsschritte im Betriebssystem, auch da können Fehler sein.

    Außerdem weiß man nie was auf einem Port alles hört. Wenn man Ports in der Firewall offen lässt auf denen sowieso keiner hört, kann sich da ein Schadprogramm unbemerkt einnisten und eben doch hören - und vielleicht doch von irgendetwas angesprochen werden.

    Die Finder sehen spitze aus!
    Dein Hubo auch :) ich bin nur gerade selbst am entwerfen einer Schaltung. Dazu werde ich bei Gelegenheit einen eigenen Thread starten um eure Meinungen einzuholen. Ich bin auf einen i2c Baustein gestoßen der Eingänge und Ausgänge zur Verfügung stellt.


    Zum Thema. Dass wenige mA wirklich so wenig sind um tatsächlich Antenneneffekte spüren zu lassen hätte ich nicht gedacht. Es ist schon einfacher ein paar Kabel zu ziehen als mehrere eigene Raspis jeweils in unmittelbare Nähe von im Haus verteilten Relais zu setzen.Ich habe die Meinung gelesen ein verdrilltes Kabel würde dazu reichen. Wie sieht es mit CAT aus?

    Ich suche zur Zeit auch eine bezahlbare Lösung um Relais zu steuern. Eine Karte mit 8 Relais zu 45 Euro ist bisher preislich gesehen das traumhafteste was ich mir vorstellen kann :)
    Kann eine Länge von 10 m bei einem Relais tatsächlich schon Antenneneffekte haben? Bei einer Signalleitung könnte ich mir das vorstellen aber eine Relaisspule wirklich auch?


    Dazu hätte ich eine Frage, wie sind solche Relais von der Sicherheit her zu sehen? Ist so eine Karte wirklich problemlos zum schalten von Beleuchtungen in einer Hausinstallation denkbar? Wie sollte sie verbaut werden, was sagen die Profis dazu?
    Sie ist bzgl. Preis selbstverständlich viel günstiger als einzelne Relais von Eltako zum Beispiel, aber genau das lässt mich zweifeln ob man sie wirklich dauerhaft in einem Haus einsetzen kann um 230 V Verbraucher zu schalten.
    Die erwähnten Relais hätten für mich den Vorteil dass sie auf eine Hutschiene passen, dass der Elektriker sie mir 230-seitig anschließen kann wie normale andere Relais und ich die Ansteuerung selbst machen kann. Sie sind für größere Lasten ausgelegt und haben eine geringe oder gar keine Dauerlast im Schaltkreis. Aber sie kosten eben 20 € und aufwärts.

    Stromstoßrelais wären mir sympathisch weil die keinen Strom ziehen während sie eingeschaltet sind. Doof ist dabei dass man nicht in der Steuerung weiß ob sie an oder aus sind. Hierzu habe ich etwas über Rückmeldekontakte gefunden. Das würde bedeuten ich darf doppelt so viele Eingänge einplanen. Das wird dann aber auch zu krass.

    hi ihr den MCP hab ich schon entdeckt. Der kann tatsächlich als Eingang oder Ausgang geschaltet werden. dreamsheader wo siehst du damit ein Problem?


    Ich brauch beides, Ausgänge und Eingänge. Beide ca. 80. Also schon mehr als 128 Ports insgesamt. Inzwischen hab ich PCF Bausteine gefunden von denen es zwei verschiedene Ausgaben mit verschiedenen i2c Adressen gibt. Da könnt man jeweils 8x16 Pins adressieren. Packt der Raspi so viele Bausteine an seinem Bus? (Strombelastung)


    Was findet ihr besser? Meine Schieberegisterlösung oder einen solchen Baustein? Schieberegister hätten den Vorteil man kann sie beliebig erweitern.


    Is sowas wirklich so spezifisch? Bei meiner Suche fand ich einige Fragen wie diese. Seltsam dass es da nichts fertiges gibt.
    Falls jemand eine gute Idee hat oder selbst Erfahrungen mit einer Lötarbeit hat, dann bitte melden. Selber löten würde das bringen was ich suche. Ist aber aus die größte Ausfallwahrscheinlichkeit :lol:


    Mit den Ausgängen soll Licht und Rolläden geschaltet werden. Könnte ich da mit so einer Platine mit blauen Relais hinkommen ohne ein weiteres Relais? Hätte nix dagegen wenns so funktioniert! Kürzlich las ich irgendwo dass LED Lampen und Energiesparlampen einen höheren Einschaltstrom haben. Ich will natürlich nicht dass die Relais nach ein paar Monaten zu kleben anfangen.

    Hallo ihr lieben
    Auch auf die Gefahr hin der x. zu sein der das fragt. Ich suche eine Möglichkeit um viele Relais mit dem Raspi anzusteuern.
    Was ich finde sind Relaiskarten mit 8 oder auch 16 kleinen blauen Relais. Das geht schon in die richtige Richtung ich suche aber etwas um Relais auf der Hutschiene anzusteuern. Also nur die Verstärker ohne Relais. Gibts sowas oder muss ich das selber löten?


    Außerdem brauche ich wirklich VIELE Ausgänge, so etwa 80 vielleicht. Welche Möglichkeiten habe ich da? Das einzige was ich bei dieser Anzahl finde sind Schieberegister die man vom Raspi aus selbst füllt.
    Perfekt wäre natürlich wenns das alles schon fertig gäbe, wo man etliche Ausgänge steuern kann und schon genügen Strom für ein externes Relais abgreifen kann. Ich weiß dass ich eine der vorher genannten Relaiskarten nehmen könnte und daran meine richtigen Relais hängen. Gefällt mir aber nicht.


    Wenn jemand noch Ideen hat wie man viele Eingänge erreichen könnte wäre ich auch danbkar. Schieberegister andersherum?


    Ich such da schon einige Zeit nach verschiedenen Begriffen aber scheint nichts in größerer Anzahl zu geben. Mit dem Boom der Hauscontrolsysteme bin ich sicher nicht der einzige der sowas sucht??


    Aber welchen Sinn macht es beim Pi beide Verbindungen gleichzeitig zu nutzen?


    Keinen großen das stimmt schon. Ich bin erst mal per eth drauf um wlan einzustellen. Nutzen will ich dann WLAN.
    Inzwischen hab ich beides am laufen. Per eth klappt es, wenn ich das abstöpsel ist wlan aktiv. eth muss natürlich falls eingesteckt auch noch gehen, damit ich im Notfall drauf komme. Nur ist das wlan eben ziemlich mau. Damit kann ich so nichts anfangen. Auch wenn es alleine betrieben wird, ich hab schon die eth ausgeschaltet und dann nur über wlan betrieben, da ist es genauso.
    Den Thread hab ich mir durchgesehen. Da geht es unter anderem um die Stromversorgung. Ich hab ein 1,2 A Netzteil am Pi, außer dem WLAN Stick hängt sonst gar nichts dran. Der Stick zieht laut einer Seite die ich gefunden hab 130 mA.



    Hey ihr seid ja schnell

    Quote

    arp -a zeigt die MAC-Adresse des Zielsystems an.


    Ja das meinte ich. Mein Laptop hat die MACs unterschiedlich angezeigt. Dabei dachte ich der weiß doch gar nichts davon dass beide auf dem gleichen Gerät liegen.

    Grafische Oberfläche hab ich leider keine drauf. Soll später nicht laufen deswegen ist gar keine aktiv.
    Inzwischen geht es. Aber stinklangsam und unzuverlässig ist es. Luftlinie zum Router ca. 3 m ohne Unterbrechungen. Hab auch schon verschiedene Ausrichtungen probiert, damit der Stick nicht zufällig im toten Winkel steht. Aber ssh kackt schnell wieder ab und reagiert unglaublich träge.
    Wo muss ich denn da schon wieder angreifen?

    Ihr seid so geil!
    Die Links haben was passendes enthalten. Ich habe zum einen die Reihenfolge von wlan und eth vertauscht und zum anderen metric eingeführt. Jetzt scheint es zu passen.
    Auf sowas wäre ich nie gekommen, bisher hab ich davon noch nirgends was gelesen.




    Nein, das hat mit USB nichts zu tun. Das ist ganz normal, wenn zwei Netzwerkkarten von einem Rechner im gleichen Netz hängen aber nicht als 'Bündel' oder auf getrennte VLans konfiguriert sind.


    Oha und wie kommt das zustande?
    Ich dachte mir das WLAN meldet sich mit seiner richtigen MAC beim Router an. Wird hier schon die falsche übergeben?
    Selbst der Router dürfte schon nicht mehr wissen dass beide IP auf dem selben System landen. Wer mich hier aufklären kann, bitte schonungslos :)



    Dann noch eine ernste Frage. Wer soll sowas von sich aus finden können? Muss man da wirklich stundenlang rumprobieren und auf Glück hoffen damit man das irgendwann richtig macht? Oder wo kann man sich im Voraus Infos über solche extrem komplexen Vorhaben wie "WLAN und Linux" holen? Ich krieg richtig Angst vor Linux wenn schon diese Installation so ausartet.

    Hallo Forum
    Erst mal servus, ich bin neu hier und hoffe ich passe gut zu euch dazu :)
    Ich habe einen Raspberry, auf dem ich WLAN in Gang bringen möchte. Ein anscheinend leidiges Problem, ich habe schon etliche Suchergebnisse durch, leider hat noch keines den Erfolg gebracht.
    Ich habe den LogiLink WL0084B dran, speziell für den gibt es auch einige Anleitungen, die aber nicht passen.


    Mein grundsätzliches Problem wäre, ich weiß ehrlich gesagt gar nicht was da genau unter der Haube passiert. Zusammenreimen kann ich mir das schon so ungefähr, aber warum dann doch nichts klappt?!


    Ich lass euch mal ein paar Ausgaben da.
    * lsusb
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 001 Device 002: ID 0424:9512 Standard Microsystems Corp.
    Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
    Bus 001 Device 004: ID 148f:5370 Ralink Technology, Corp. RT5370 Wireless Adapter


    Stick ist also erkannt.


    * ifconfig
    eth0 ...
    lo ...
    wlan0 Link encap:Ethernet HWaddr <meine WLAN MAC>
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:28 errors:0 dropped:1 overruns:0 frame:0
    TX packets:18 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:3756 (3.6 KiB) TX bytes:3576 (3.4 KiB)


    daraus schließe ich: ist noch nicht gescheit eingerichtet?! Woher die übertragenen Bytes stammen weiß ich nicht genau, evtl. auch vom LAN? Siehe weiter unten, der scheint über die LAN Schnittstelle zu gehen?



    * meine /etc/network/interfaces Datei
    auto lo


    iface lo inet loopback
    iface eth0 inet dhcp


    allow-hotplug wlan0
    iface wlan0 inet dhcp
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
    #wpa-ssid <meine ssid>
    #wpa-psk <mein Passwort>
    #address 192.168.1.117
    #netmask 255.255.255.0
    #network 192.168.1.1
    #gateway 192.168.1.1


    meine/etc/wpa_supplicant/wpa_supplicant.conf Datei
    ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
    ctrl_interface_group=root
    update_config=1
    ap_scan=1



    ssid="<meine ssid>"
    proto=WPA
    group=CCMP
    pairwise=CCMP
    key_mgmt=WPA-PSK
    psk="<mein Passwort>"
    }


    laut einer Anleitung müsste das oberhalb von network schon drin stehen. Bei mir gab es allerdings die ganze Datei noch nicht!


    LAN hat die IP 192.168.1.116 und funktioniert.
    Ohne die wpa_supplicant.conf (und dafür ohne die # in interfaces) habe ich geschafft, dass ifup wlan0 "irgendwas" tut. Die IP 192.168.1.117 war daraufhin per ping erreichbar. Seltsamerweise hat mein Laptop (mit arp -a) unter beiden IPs die selbe MAC Adresse angezeigt, nämlich die des eth0 Anschlusses. Irgendwas läuft hier also gründlich schief.


    apt-get install firmware-ralink sowie apt-get install wpasupplicant sagen: ist bereits auf dem neuesten Stand.
    Ich habe die soft float Version (armel?) drauf, da ich Mono verwenden will und die hard float Version da Probleme machen soll.
    Ich habe keine GUI laufen, kann nur per ssh drauf.



    Was könnte ich da jetzt als erstes tun?
    Ich bin da echt ratlos, habe schon etliche Anleitungen durch. Es gibt ja praktisch nur zwei Wege, mit der wpa_supplicant.conf oder alles in der interfaces Datei.
    Gibt es ein Diagnoseprogramm das mir da helfen könnte? Vielleicht sogar eines das mir beim einrichten hilft bis es klappt und mir sagt was ich im Fehlerfall sonst noch versuchen könnte?