Posts by DaMusikant

    Okey, danke für den Tipp.

    Nach restart und dem ganzen kommt -- Logs begin at Wed 2021-10-13 19:46:47 CEST, end at Wed 2021-10-13 21:49:57 CEST. --

    -- No entries --


    Aber ein neues Phänomen ist in Erscheinung getreten. Wenn ich mittlerweile den Dienst starten will kommt Failed to start service.service: Unit service.service not found.. Laut google ist das aber wohl was ganz wildes, was sont keiner als Problem hat. Ich werd zum Esel...

    Hi,

    klingt nach nem einfachen Problem, was aber einfach nicht will.

    Zur Sache: Ich habe einen Raspberry Pi 1B aus der Schublade gekramt. Dieser soll per Bluetooth Musik empfangen und die abspielen.


    Sooo, Bluetoothdongle lag da auch noch rum, am Laptop eingesteckt, läuft wunderbar. Aber nicht mit dem Pi.


    Stand der Dinge.


    Bei Abfrage von lsusb:

    Bus 001 Device 005: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)

    Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter

    Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub

    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


    Erkannt wird er. Installiert sind sämtliche Bluetooth relevanten Pakete wie pi-bluetooth, bluez, blueman und und und.


    Bei Abfrage von hciconfig:

    hci0: Type: Primary Bus: USB

    BD Address: 00:11:22:98:76:54 ACL MTU: 1021:4 SCO MTU: 180:1

    UP RUNNING

    RX bytes:974 acl:0 sco:0 events:39 errors:0

    TX bytes:147 acl:0 sco:0 commands:3


    Scheint mir also auch zu laufen.


    Als nächstes kommt dann systemctl status bluetooth.service:

    ● bluetooth.service - Bluetooth service

    Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; vendor preset: enabled)

    Active: inactive (dead)

    Docs: man:bluetoothd(8)


    Und da fangen die Probleme an. Wenn ich sudo systemctl start bluetooth.service aufrufe kann er stundenlang rattern, aber es passiert nichts. Das Komando muss ich irgendwann per ctrl+c abbrechen, da er in irgendeiner Schleife fest hängt.


    Kann es sein das der Pi 1B einfach kein Bluetooth mag? Oder übersehe ich etwas grundlegendes?


    Danke für eure Hilfe

    Hi,


    das mit dem Bluetooth und automatisch Relais starten habe ich bereits erfolgreich gemeistert.


    Das Problem sind andere Dienst, eben wie Raspotify und Co. die nicht über Bluetooth sondern in dem Fall über Netzwerk laufen

    Hi,

    danke für deine Antwort.

    Wie die Wiedergabe gestartet wird ist mir ehrlich gesagt unklar.

    Was ich weis, ist dass das ganze im Hintergrund geschieht ohne mein zutun. Will heißen, wenn ich per Spotify meine Musik streame kann ich das Gerät trennen und nahezu gleichzeitig über Bluetooth Musik abspielen.


    Bluetooth läuft über BlueAlsa, Spotify über ein Package namens Raspotify.


    Das ganze habe ich hier gefunden: https://github.com/nicokaiser/rpi-audio-receiver. Wirklich nutzen tu ich eigentlich nur die beiden oben genannten, aber wer weiß, wenn ich auf den Geschmack gekommen bin ;)


    Ich bin ziemlich neu hier, daher ist das eher Glaskugelgerate fürchte ich. Sorry dafür...

    Hi,


    ich würde gerne, wenn mein Pi Musik abspielt, ein Relais schalten sodass die Lautsprecher mit eingeschalten werden.


    Das Problem dabei ist, das ich verschiedene Quellen (Raspotify, Netzwerk und Bluetooth) habe. Jetzt könnte ich einerseits alle Quellen abfragen oder ihr wisst eine Möglichkeit, bspw. ALSA dazu zu bringen, deren aktuellen Status preis zu geben. Also ob aktuell eine Wiedergabe statt findet. Oder ich sehe das völlig falsch, ich bin ein Pi Neuling, vll gibts ja einen deutlich leichteren weg.


    Danke :)