Posts by inspector

    Alles sicher ganz einfach wenn man weiß, wie man mit cardreader am pc die config.txt findet. Ich fand sie nicht. Allerdings mit dem pi 2 (Raspian) über den Eintrag sudo nano /boot/ config.txt. in die Konsole. Nur, wie lassen sich die Lizenzen dort eintragen?


    Plump gesagt "schreiben" und "speichern". Wenn du die Lizenz eingeben hast, danach F2 und "j" drücken wenn nano Deutsch ist, sonst F2 und "y". Wie die Lizenz geschrieben wird, habe ich ja zuvor erklärt.



    Dann hatte ich auf der 32GB-Karte mit noobs light neben raspian auch noch openelec installiert. Da es ein autonomes Programm ist, vermute ich, dass die beiden Lizenzen dort extra installiert werden müssen, oder?


    Hier kann ich nur vermuten, da ich noobs nie benutzt habe. Aber in jeder Umgebung(raspbian/openelec) muss das eingetragen werden. Jedoch ist openelec sehr speziell, dort geht es auch über das Menu.



    Aber wie das ohne Konsole, die es dort nicht gibt?


    Bei openelec? Oder wo?


    ja, ich weiß,bereits erklärt aber:
    Wo ich auch suchte heißt es nur immer: " In die config.txt eingeben". Nur funktioniert das bei Raspian nicht mit copy & past bzw setzt es sich damit an den Anfang der config.txt. Keine Ahnung, wie man den Anfang innerhalb der config.txt zum Einfügen der Lizenz bestimmt.
    Bei Kodi gibt es keine Konsole. Wie funktioniert es dort vom raspberry pi2 aus?


    (micro)SD-Karte ins Lesegerät rein, und dann unter Windows/OS-X etc. den Inhalt der Karte anzeigen, dann die config.txt Datei mit einem Editor bearbeiten (unter Windows Notepad++) und dann die Stelle suchen:

    Code
    ################################################################################
    # License keys to enable GPU hardware decoding for various codecs
    # to obtain keys visit the shop at http://www.raspberrypi.com
    ################################################################################
    # decode_MPG2=0x00000000
    # decode_WVC1=0x00000000
    # decode_DTS=0x00000000
    # decode_DDP=0x00000000


    Hier nimmst Du das "#" weg und fügst den per eMail erhaltenden Freischaltcode ein. So steht es ja auch in der eMail die mal erhalten hat drin. Zumindest will sie das aussagen.
    Ich hoffe, Dir nun damit geholfen zu haben?


    Auch hier sind keine Bilder mehr zu finden. So ist es nun in allen Beiträgen von Dir. Mit Bilder ist es für alle Verständlicher :-)

    Soweit so gut, habe ich hier auch so gemacht. Nur kommt ja bei einigen diese Fehlermeldung:

    Code
    FATAL: Module ads7846_device not found.

    ZUmindest ist es bei mir ab 3.18.7 so gewesen. Nun habe ich Erfolgreich 3.18.10 mit folgender Config am laufen:


    Code
    sudo nano /boot/config.txt
    dtoverlay=ads7846,speed=1000000,penirq=17,swapxy=1


    Jetzt klappt es auch mit dem Touchscreen und der Kalibrierung. Kannst ja an Deinen Beitrag anpinnen, dann ist das wirklich komplett, gut und hilfreich.


    Ja mit dem Befehl kann man das Updaten eines Paketes verhindern.
    Der Befehl passt nicht, und sollte so bei Dir eingesetzt worden sein:

    Code
    sudo apt-mark hold linux-headers-3.18.0
    linux-headers-3.18.0-trunk-all auf Halten gesetzt.
    linux-headers-3.18.0-trunk-rpi2 auf Halten gesetzt.
    linux-headers-3.18.0-trunk-rpi auf Halten gesetzt.
    linux-headers-3.18.0-trunk-all-armhf auf Halten gesetzt.
    linux-headers-3.18.0-trunk-common auf Halten gesetzt.


    So wird es bei mir gemeldet, scheinbar bei Dir ja auch. Will ich einen Einzelnen Kernel auf hold setzen, dann folgt so etwas:

    Code
    sudo apt-mark hold linux-headers-3.18.10+
    linux-headers-3.18.10+ auf Halten gesetzt.


    Leider steht zur Zeit kein Update an, daher kann ich es nicht nachprüfen, ob "apt-mark hold xxx" klappt.

    Code
    sudo rmmod ads7846_device
    sudo modprobe ads7846_device speed=500000 gpio_pendown=17 swap_xy=1
    FATAL: Module ads7846_device not found.


    Gerade gefunden im bekannten link
    sudo nano /boot/config.txt

    Code
    dtoverlay=ads7846,speed=1000000,penirq=17,swapxy=1


    Werde ich sofort mal testen :-)
    Nachtrag: Es klappt! Nun geht das ja recht einfach zu updaten, yeah!

    Das wird so nicht ohne weiteres gehen. Denn bisher war es immer so, das man vor Kernel-Updates geschützt worden ist

    Code
    Prevent the FBTFT kernel from being overwritten
    sudo apt-mark hold raspberrypi-bootloader

    und das nur umgehen kann mit

    Code
    sudo apt-mark unhold raspberrypi-bootloader


    Nur muss man dann eben alle Treiber/Module neu übersetzen. Wie das mit dem "neuen Image" gemacht wird, habe ich bisher nicht geprüft. Denke aber, es wird genau so "festgesetzt" sein wie bisher. Du wirst es merken. Einige Dinge klappen, warum auch immer, nicht beim ersten Versuch. Ein Backup des Image hilft da oft.

    Wie mir scheint, stören sich die Linux-Header am WLAN-Stick den Du verbaut hast.

    Quote

    dpkg-query: Paket »acx-mac80211-dkms« ist nicht installiert und es ist keine Information verfügbar
    Verwenden Sie dpkg --info (= dpkg-deb --info) zum Untersuchen von Archiven
    und dpkg --contents (= dpkg-deb --contents) zum Auflisten ihres Inhalts.
    /usr/sbin/dpkg-reconfigure: acx-mac80211-dkms ist nicht installiert
    dpkg: Fehler beim Bearbeiten von linux-headers-3.18.5+ (--configure):
    Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück


    Dennoch wird weiter unten geschrieben, das Fbi installiert wird.

    Und das wird auch nicht das Problem sein, spi und i2c wird ja erkannt/geladen. Es muss an einer udev regel liegen, denn die werden nicht mehr gesetzt. Hatte mir mal das hier notiert:

    dmesg wirft dazu raus:

    Code
    [ 311.247663] ads7846: unknown parameter 'speed' ignored
    [ 311.247788] ads7846: unknown parameter 'gpio_pendown' ignored
    [ 311.247808] ads7846: unknown parameter 'swap_xy' ignored


    Hmm, musste man nicht auch wiringPi installieren? Nein, das war es nicht :-(

    Tja, und genau da hänge ich auch weiter ...
    Es klappt auch mit der anderen Anleitung nicht. Hänge wie immer an gleicher Stelle:

    Code
    sudo rmmod ads7846_device
    Error: Module ads7846_device is not currently loaded
    sudo modprobe ads7846_device speed=500000 gpio_pendown=17 swap_xy=1
    FATAL: Module ads7846_device not found.


    Ein lsmod sagt gleiches. Das Touch ist aber nicht defekt, weil andere Images klappen. Nur dort ist der Kernel Älter.

    Der erste Link ist hier fest gespeichert :-) Hat aber nur das Display am laufen gebracht, jedoch nicht das Touch. Den zweiten Link habe ich die Tage gefunden, werde ich Heute ausprobieren!
    Danke für beide Links.

    Shit! Nicht gut. Gib mir einen Tip, wie ich die Treiber in den Kernel bekomme, und ich mache das dann. Habe schon einige Anleitungen dazu gefunden, die bei mir nicht klappen :-(