Posts by Weihnachtsmann

    Hallo liebe Raspberry-Liebhaber,

    Ich nutze nun schon seit ca. 2 Jahren einen Raspi als PiHole, anfangs noch einen 3er, jetzt einen 4er.


    Setup:

    • Fritzbox 6660, DHCP deaktiviert, keinen DNS Server eingetragen, WLAN deaktiviert, IPv6 deaktiviert
    • PiHole auf RPi4, inkl. Docker und Nginx Reverse Proxy
      • DHCP aktiviert
      • Konfiguration: Bild1, Bild2
      • DHCP ist gerade auf dem PiHole deaktiviert, da meine Frau mir langsam Probleme macht..^^, soll aber wieder laufen
      • IPv6 auch deaktiviert
    • Verschiedene NAS (inkl. Docker), Macs und iPhones im Netzwerk, sowie einen Ubiquiti AP


    Mein Problem ist jetzt folgendes:

    Immer mal wieder tritt ein Fehler auf, dass von jetzt auf gleich der Internetzugriff nicht mehr gegeben ist.

    Kein Gerät von intern kann mehr eine Verbindung nach draußen aufrufen, doch der interne Verkehr läuft ohne Probleme weiter.

    Mir ist aufgefallen, dass das PiHole keine DNS-Anfragen, auch über mehrere Stunden nicht, mehr zur Bearbeitung bekommt, auch nach einem Neustart des Pis nicht.

    Ich muss alle (!) meine Geräte für ca. 12h komplett ausschalten damit das Netzwerk wieder läuft.

    Zeitweise war dieses Problem alle 2 Wochen, Sonntag zwischen 9 und 17:00 aufgetreten, über mehrere Monate…

    Alternativ hat ein neu Aufsetzen des Pis manchmal die Probleme behoben.


    Reproduzierbar ist das Problem, wenn ich einem Gerät über den PiHole DHCP-Server eine neue IP (eine nicht bereits Vergebene) zuweise, das Gerät neu starte.

    Dann ist es intern erreichbar und hat auch die neue IP (alte nicht mehr erreichbar), aber der komplette Datenverkehr nach draussen wird nicht mehr verarbeitet, keine Webseite ist mehr aufrufbar und das PiHole erhält keine DNS-Anfragen mehr.

    Schalte ich das Gerät nun aus, funktioniert alles wieder ohne Probleme.

    Oft passiert es auch, dass ich dem Gerät eine neue IP zuweise und überhaupt keine neue IP vergeben wird, sondern immer wieder die Alte.


    Schritte zum Hinzufügen einer statischen IP:

    Settings —> DHCP —> entweder auswählen aus der Liste (IP-Anpassung) oder manuelles vergeben der IP und Eintragen der MAC-Adresse, sowie eines Hostnamen —> Speichern —> Neustart des Gerätes.


    Ohne Probleme funktioniert jedoch der DHCP der Fritzbox, ändern, speichern, Neustart, passt.

    Problem ist nur dann, wenn ich einen eigenen DNS (PiHole) eintrage, steht halt nur noch als anfragender Client: localhost da.

    Somit ist keine genaue Filterung mehr auf die einzelnen Geräte möglich.

    Das ist aber Wichtig, da ich meinen Arbeitslaptop alle Domains erlaube, und meinem privaten deutliche einschränke, genau so dürfen alle meine Geräte nicht auf Facebook/Insta/ usw zugreifen, die meiner Frau jedoch schon.


    Habt ihr eine Idee wo der Fehler liegt?

    Bin langsam echt am Verzweifeln.


    Wichtig ist für mich:

    • Automatische Verteilung der IPs durch den DHCP, ich möchte keine gerätespezifischen festen OPs in den Geräten selbst vergeben
    • Protokollierung und Anzeige der jeweils anfragenden Geräte für die Filterung
    • Zuverlässiges Netzwerk

    Hallo!

    Ich bin gerade dabei mich bei Docker einzuarbeiten, da ich endlich den Umstieg von der nativen Installation auf den Container-Dienst wage.

    Nur bekomme ich es nicht hin mir den Dienst FreshRss einzurichten.

    Einige Anleitungen mit Docker-Compose habe ich schon durchprobiert.

    Der Dienst soll auf einem Raspi4 laufen und von außen über den "Nginx Reverse Proxy" erreichbar sein, damit meine mobilen Geräte auch die Feeds gegenseitig aktuell halten können.

    des Weiteren möchte ich das Plugin Wallabag nutzen.


    Hier mal einen in Ausschnitt:

    ---

    version: "2.1"

    services:

    freshrss:

    image: ghcr.io/linuxserver/freshrss

    container_name: freshrss

    environment:

    - PUID=1001 (wurde mit ID ausgelesen)

    - PGID=100 (wurde mit ID ausgelesen)

    - TZ=Europe/Berlin

    volumes:

    - /var/lib/docker/container/freshrss:/config

    ports:

    - 40502:80

    restart: unless-stopped


    Der Container wird erstellt und er läuft auch, nur kann ich die Webseite nicht aufrufen.

    Es wird ein Fehler in der /config/keys/cert.crt ausgeworfen und ich weiß nicht genau was ich machen könnte.


    Hier habe ich mal die ganze Logfile angehängt:

    Ich bin sehr gespannt und freue mich auf eure Hilfe!

    Vielen Dank!

    Hallo!

    Ich habe mal eine Frage bezüglich der Sicherheit meines Reverse Proxys mittels Nginx Proxy Manager mit GUI.

    Da ich jetzt endlich mal angefangen habe mich etwas mit Docker einzuarbeiten, damit ich meine 3 Raspis auf einen 4er transferieren kann.

    Was mir dabei aber aufgefallen ist, dass viele Container, wie zum Beispiel BitwardenRS, keinen HTTPS-Port 443 (die Ports waren auch der Grund von mehreren Pis) haben.

    Dafür soll ja der Reverse-Proxy herhalten.

    Bis jetzt hängen die Pis direkt am Netz mit offenen Ports, wenn benötigt.


    Kurz zum Setup:

    Ich möchte einen Raspi4 nutzen um Docker, docker-compose, Portainer, Nginx Proxy Manager und u. a. Bitwarden betreiben.

    Wenn mein Setup läuft, möchte ich auch so den Pi meiner Eltern mit dem Passwort Manager umstellen.


    Ich bin noch nicht so gut in Linux eingerichtet, daher bin ich oft auf YT-Videos/Anleitungen angewiesen.

    Den Manager habe ich via Docker-Compose mit diesen Befehlen erstellt:


    nano config.json

    {

    "database": {

    "engine": "mysql",

    "host": "db",

    "name": "npm",

    "user": "npm",

    "password": "npm",

    "port": 3306

    }


    nano docker-compose.yml


    version: '3'

    services:

    app:

    image: 'jc21/nginx-proxy-manager:latest'

    ports:

    - '80:80'

    - '81:81'

    - '443:443'

    volumes:

    - ./config.json:/app/config/production.json

    - ./data:/data

    - ./letsencrypt:/etc/letsencrypt

    db:

    image: 'yobasystems/alpine-mariadb:latest'

    environment:

    MYSQL_ROOT_PASSWORD: 'npm'

    MYSQL_DATABASE: 'npm'

    MYSQL_USER: 'npm'

    MYSQL_PASSWORD: 'npm'

    volumes:

    - ./data/mysql:/var/lib/mysql


    docker-compose up -d



    Nun zu meiner Frage.

    Ich möchte einige sicherheitsrelevante Dienste per Docker, wie zum Beispiel meinen BitwardenRS, realisieren.

    Sind die Dienste jetzt durch den Nginx-Proxy-Manager gut geschützt? Es sind ja nur noch die Ports 80 und 443 auf den Proxy umgeleitet.

    Ist es besser zum Beispiel einen Raspi Zero für den Reverse Proxy zu nutzen welcher dann auf einen Docker Raspi mit den ganzen Diensten weiterleitet?


    Ich bin sehr auf eure Tipps gespannt!


    Danke!

    Ich habe jetzt einiger Apps fürs iPad ausprobiert welches das theoretisch können sollen.

    Für den Arbeitslaptop habe ich nach langem Suchen keine Anleitung gefunden, wie man das mit Bordmitteln machen könnte.

    Software darf ich ja nicht drauf installieren.

    Portable Software wäre möglich, aber da habe ich keine auf Anhieb gefunden.

    Moin!

    So, nun habe ich alles versucht, doch leider hat alles nichts gebracht.

    Das Anpingen aus dem Hotel (und bei AG WLAN aus) klappte nicht.

    Sitze jetzt im Hotel und habe auch den Port auf 443 geändert, aber leider klappte dies auch nicht (Verbindung über Mobilfunk klappt dagegen).


    Vielleicht sollte ich auch noch ein paar Dinge mitteilen:

    Ich habe auf dem Raspi dieses Installationsskript genutzt um WG auf meinen Pi zu bekommen:

    curl -L https://install.pivpn.io | bash

    Eingefügt habe ich die Konfiguration dann über den einblendbare QR Code.


    Hergestellt wird die Verbindung über meine Fritz DNS:

    Xxxxxxxxxxxx.myFritz.net


    Auf dem Raspi selbst ist noch PiHole installiert, welches bestimmte DNS Anfragen wegblockt.


    Sollte ich evtl. Eine andere Installation ohne so ein Skript durchführen?

    Oder ist ein anderes Protokoll ratsamer?

    Wichtig ist für mich ungemein, dass mein iPad/iPhone die Verbindung im Mobilfunknetz und im fremden WLAN automatisch zum heimischen Netz herstellt und im WLAN zu Hause kein VPN genutzt wird.

    Vielen Dank für die schnelle Antwort.

    Clientseitig ist die Konfiguration von WG direkt über die QR-Code Funktion gemacht. Also per SSH-Verbindung für den eingerichteten Nutzer den Code anzeigen lassen und direkt über die App eingelesen.


    Auf dem Arbeitsrechner hat das die IT direkt gemacht. Dann habe ich erst den Laptop erhalten.


    Soweit ich das jetzt nachvollziehen konnte, habe ich einen nativen IP4 Anschluss.

    Ist ein Kabel Anschluss von PYUR (läuft über primacom), dahinter steht eine FB6591 welche ich selbst gekauft habe.

    Hallo liebe RPi‘ler,

    Ich bin Außendienstmitarbeiter und somit recht häufig in Hotels unterwegs.

    zur Zeit bin ich ziemlich häufig in einem Hotel welches ein freies WLAN (PW geschützt) anbietet.

    Doch leider kann ich zu meinem RPI zu Hause keine Verbindung durch das WLAN aufbauen.

    Ich habe nun auch im Netz gelesen, dass dies in einem entsprechend geschützten WLAN auch recht schwierig sein kann.

    Genau so blockiert das Hotel WLAN meine Anfragen auf meine NAS über meinen DynDNS (myFritz).

    Komischerweise läuft das Firmen VPN auf meinem Arbeitsrechner.


    Mein Setup:

    - RPI3 zu Hause, Wireguard installiert

    - auf dem iPad/iPhone ist entsprechend die WG App installiert und eingerichtet

    - Externer Port 443 (Portweiterleitung der FritzBox an internen anderen Port) bereits erfolglos versucht


    Für meine Interesse:

    Hier liegt ein LAN Anschluss (noch nicht auf Funktionalität getestet).

    Könnte man theoretisch auch einen 2. Raspi als Hotspot für alle WLAN Geräte nutzen welcher sich über VPN mit meinem Raspi zu Hause verbindet? Das alle Geräte immer getummelt funken?


    Hättet ihr eine Idee und könnt mir evtl. Helfen?

    Welche interne IP-Adresse hat deine FritzBox und welche interne IP-Adresse hat dein PI/PiHole?

    Meine Fritte hat die IP "192.168.170.1" und das PiHole "192.168.170.35".


    Installiere mal für einen temporären Test, auf deinem PI (mit PiHole):

    Code
    sudo apt-get install iputils-arping
    sudo dpkg --configure -a

    Ok, ich habe das installiert, aber was genau muss ich damit jetzt machen? Wie starte ich einen Test?

    Ich musste oben nochmal etwas ändern in der Beschreibung.
    Es ist so, dass der Pi/PiHole beim ersten Zugriff auf das Internet von einem anderen Gerät aus, 1-2 Minuten braucht um die DNS aufzulösen, so dass sich eine Webseite aufbauen kann.
    Manchmal ist es dann auch so, dass der Raspberry über die IP gar nicht erreichbar ist (offline), aber leider auch gar kein anderes Gerät im LAN, bis auf die FritzBox. Aus dem Grund meldet die Homematic CCU3 dann auch einen Netzwerkausfall durch blinken.

    Nach einem Neustart des PIs läuft dann alles wieder normal und schnell.

    Hallo,

    ich habe mal wieder eine kleine Frage bezüglich PiHole, aber vorher kurz eine Erklärung:

    Vor ein paar Tagen habe ich meinen RPi1 wieder mal reaktiviert und das aktuelle PiHole drauf laufen zu lassen. Auch ohne Logging Funktion war die Performance (per LAN) nicht so der Knaller, meine Frau hat dann per iPad/iPhone nur noch die mobilen Daten genutzt, da das Auflösen der DNS zu lang gedauert hat.

    Aus Frust habe ich dann meinen RPi4 aus dem Schrank geholt und das nochmals installiert, mit der Logging Funktion ist die Performance jetzt super, könnte eigentlich gar nicht besser sein.


    Jetzt kommt aber mein Problem:

    Wenn wir schlafen gegangen,oder auch längere Zeit nicht zu Hause, sind (dabei sind bis auf die NAS alle internetfähigen Geräte ausgeschaltet, es finden also keine DNS-Abfragen in der Zeit statt) und am nächsten Morgen unser Handy anschalten, braucht das PiHole ca. 1-2 Minuten um wieder einsatzbereit zu sein, manchmal hilft sogar nur ein Neustart.

    Es findet kein Webseiten Aufbau am PC, Handy usw statt, sogar meine Homematic Anlage (CCU3. nur offline!) blinkt, dass sie keine Netzwerkverbindung mehr hat.

    Habt ihr hier eine Idee woran es liegen könnte?


    Vielen Dank!

    Ja, dass sind wohl dann IR-LEDs und keine UVs, hab ich mich wohl verschrieben. :D


    Ich möchte damit den Brutraum der Vögel "unsichtbar" beleuchten und mit der NoIR-Kamera sehen, was da drin so abläuft und die Vögel beim Brüten beobachten. So konnen wir schon einige Kohlmeisen beim Aufwachsen und Ausfliegen zusehen. :)

    Außerdem würde sich über extern mein Opa gern aufschalten und von seinem zu Hause aus zusehen.


    @ Hyle, dann werde ich mir das noch einmal genau ansehen, vielen Dank! :)

    Hi, also es ist eine spezielle Software: "RPi Cam Control" LINK

    Das Bild ist nicht meins, aber nur zur Oberflächen Übersicht. Im Hintergrund läuft ein Raspbian Lite.

    Da hatte ich mir vorgestellt, sozusagen einen Button für ein Hotkey für die Beleuchtung einfügen zu können.

    Oder gibt hat jemand eine bessere Idee?

    Das Schöne an der Software ist vor allem die "Motion Detection". Gerade am Anfang des Jahres, wenn noch keine Vögel da sind und dann vorbeischauen ist diese Funktion ganz nett, dass man auch mal sehen kann, dass jemand da gewesen ist. =)

    Erstmal danke für die Info mit der Verlängerung! :)
    Dann werde ich das mal versuchen. :)


    Also, die UV-Dioden sind normale LEDs, die halt UV-Licht erzeugen.

    Beim aktuellen Pi hängen diese einfach an den 5V Pins zur dauerhaften Stromversorgung., sie benötigen nach meiner Erinnerung ca. 3V, laufen aber mit etwas weniger, ich denke moit 2,5V, da sich 2 LEDs einen Pin teilen.

    Hallo liebe RPi-Gemeinde,

    vor 3 Jahren habe ich meinem Vater ein RPi-Cam Vogelhaus gebaut inkl. UV-Licht Beleuchtung für die Dunkelheit. Wir konnten auch einige Jahre bereits Kohlmeisen beim Nisten zusehen.

    Ich hätte aber Frage, ich würde gern das erste Häuschen in Rente schicken und ein neues mit dem Zero W bauen.

    Da ich letztens gelesen habe, dass die Meisen für UV-Licht sensibel sind, möchte ich gern einen Button implementieren, dass die UV-Beleuchtung nur für ca. 30 Sekunden angeht, wenn man einen Kopf auf der RPi-Oberfläche drückt.

    Gibt es eine solche Funktion? Oder wie könnte ich so etwas realisieren (meine Programmierkenntnisse gehen gleich gegen 0)?

    Habt ihr Ideen?


    Letztes Jahr ist dann das BS mal abgeschmiert und ich musste ein Backup einspielen.

    Habt ihr auch Erfahrungen mit einem solchen Haus? Wie könnte ich so ein "ServiceSchacht" implenentieren, dass ich einfach an das Haus ran komme ohne die Vögel zu stören?

    Würde evtl. sowas helfen? Ist das zuverlässig?

    LINK - SD-Kartenverlangerung (Affiliate-Link)