Posts by DavidS.94.


    Zu deiner Frage. Ja der Pi hatte bei mir schon immer die bzw. eine IPv6 Adresse.


    Ich habe heute mein Problem mal von hinten her angegangen und geschaut ob Homeassistant überhaupt IPv6 kompatibel ist. Scheinbar ist er es nämlich nicht ::(
    Das bedeutet also für mich, dass viele Stunden arbeit für eine Sackgasse drauf gegangen sind. Sehr ärgerlich. Momentan versuche ich das ganze über ein Tunnelprogramm (ngrok) zu managen. einfacher ist das leider auch nicht....


    Ich habe den ganzen Abend weiter daran gearbeitet und folgendes herausgefunden:


    Zu testzwecken habe ich den Apache2 Webserver installiert. Dieser arbeitet ja bekanntlich über den Port 80.
    Wenn ich http://[xxxx:xxx:xxx:xxxx:xxxx:xxxx:xxxx:xxxx]:80/ oder auch nur http://[xxxx:xxx:xxx:xxxx:xxxx:xxxx:xxxx:xxxx] im Browser eingebe,
    werde ich auch zu der Startseite von Apache weitergeleitet. Dies funktioniert sowohl lokal als auch global.
    Über den Konsolen-Befehl netstat -lnpt kan ich mir alle horchenden Teilnehmer anzeigen lassen. Dort ist aber nicht aufgeführt, dass über den Port
    8123 jemand horcht.
    [Blocked Image: http://up.picr.de/30138734vl.jpg]


    Wenn ich dann den Homaessistant über IPv4 öffne ergänzt sich allerdings folgende Zeile:
    tcp 0 0 0.0.0.0:8123 0.0.0.0:* LISTEN -


    Kann es sein, dass der Homeassistant einfach nicht mittels IPv6 aufgerufen werden kann?



    Das ist übrigens die Anleitung mit welcher ich gearbeitet habe:

    External Content www.youtube.com
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.


    Zu deinen Fragen:


    1-> Ja, sowohl Pc als auch Pi haben eine IPv6. Und seit zurzem kann ich auch über den Port 80 auf Apache zugreifen.
    2-> Ich glaube nicht.
    3-> Über den Port 8123 funktioniert es auch intern nicht (nur über IPv4)

    Guten Tag.

    Ich habe eine allgemeine Frage zu IPv6.
    Wenn ich im lokalen Netz die IPv6 Adresse und anschließend den Port eingebe (http://[xxxx:xxx:xxx:xxxx:xxxx:xxxx:xxxx:xxxx]:8123/)
    erhalte ich folgende Fehlermeldung:
    ___________________________________________________________________________________
    Diese Website ist nicht erreichbar
    [xxxx:xxx:xxx:xxxx:xxxx:xxxx:xxxx:xxxx] hat die Verbindung abgelehnt.
    ERR_CONNECTION_REFUSED
    ___________________________________________________________________________________


    Demnach erreiche ich doch den Pi nur dieser lehnt die Verbindung ab. Oder verstehe ich das falsch?
    Wie kann ich dieses Problem lösen? Wenn ich die Ipv4 des PI benutze werde ich auf den ganz normal auf den Homeassistant weitergeleitet.



    Notizen:
    - ping6 google.com funktioniert
    - sowohl die lokale als auch globale Ipv6 führen zu dieser Meldung
    - Unitymedia mit DSL-Light über Fritzbox 6490
    - Portweiterleitung eingerichtet (allerdings ja irrelevant bei lokalem Netz)
    - Netzwerkeinstellungen am Rechner auf IPv4 und IPv6

    Guten.
    Ich versuche, wie schon viele vor mir, meinen PI per Voice-Commands zu steuern.


    Meine Soundkarte:
    https://www.amazon.de/gp/product/B002FI7GWK/ref=as_li_tl?ie=UTF8&camp=1638&creative=6742&creativeASIN=B002FI7GWK&linkCode=as2&tag=raspb-pi-21&linkId=XE6YR5ACGFYUY6NQ (Affiliate-Link)



    Ich hatte den Aufbau bereits so weit, dass ich gesprochene Befehle in Text konvertieren konnte. Jetzt funktioniert allerdings nichts mehr. Mein Problem konnte ich bis dahin zurück verfolgen, dass meine Soundkarte nicht richtig erkannt wird.


    Beim Prüfen der USB Geräte wird sie erkannt:


    Der Befehl : lsusb
    Reaktion:
    Bus 001 Device 006: ID 046d:c505 Logitech, Inc. Cordless Mouse+Keyboard Receiver
    Bus 001 Device 005: ID 046d:c52f Logitech, Inc. Unifying Receiver
    Bus 001 Device 009: ID 0d8c:000c C-Media Electronics, Inc. Audio Adapter
    Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
    Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


    Allerdings wird diese bei den Soundkarten nicht aufgeführt...



    Der Befehl : cat /proc/asound/modules
    Reaktion: 0 snd_bcm2835


    Der Befehl : cat /proc/asound/cards
    Reaktion: 0 [ALSA ]: bcm2835 - bcm2835 ALSA
    bcm2835 ALSA




    [hr]
    Geändert hatte ich folgendes:


    Der Befehl : sudo nano /usr/share/alsa/alsa.conf
    ...
    defaults.ctl.card 0
    defaults.pcm.card 0
    defaults.pcm.device 0
    defaults.pcm.subdevice -1
    defaults.pcm.nonblock 1
    defaults.pcm.compat 0
    def...


    Der Befehl : sudo nano /usr/share/alsa/alsa.conf
    # prevent unusual drivers from appearing as the first sound device ###########
    options snd-pcsp index=-2
    options snd-usb-audio index=0


    #options snd_bcm2835 index = -2


    options cx88_alsa index=-2
    options snd-atiixp-modem index=-2
    options snd-intel8x0m index=-2
    options snd-via82xx-modem index=-2


    Danke schon mal für die Hilfe.


    Hallo DavidS.94.,


    ist der Ton an / die Lautstärke eingestellt?

    Code
    sudo alsamixer


    Und hast Du den ersten Link von flo003 gesehen?


    Ja der Ton funktioniert. Ich kann auch Audio Dateien aufnehen und abspielen.
    Ich habe die Links nur überflogen.
    Grüße David


    Dein anderer (gleicher) Thread hat sich wohl erledigt?


    Auf Grund der Tatsache, dass sich in diesem Thread etwas verrannt wurde und ich mein Problem scheinbar etwas wirr geschildert habe, habe ich nochmal probiert mein Problem "einfacher zu schildern.


    Kann es eventuell sein, dass mein Pi über ipv6 arbeitet???
    bei lsmod steht nichts von ipv4 allerdings etwas zu ipv6?!


    Der Webserver zeigt das an, was du konfigurierst.

    Dein Webserver ist offensichtlich Apache. Zur Einrichtung findest du hier sehr viel. Irgendwie dachte ich bei deinem Eingangspost, du wüsstest so grob, was du tust... Du hast geschrieben "Im Lokalen Netzt funktioniert das auch prima". Nur, um nochmal sicherzugehen: Du kannst deine Webseiten, die sich unter /var/www/html befinden aus dem lokalen Netzwerk aufrufen, ohne apache vorher konfiguriert zu haben?
    Soviel ich weiß, zeigt apache standardmäßig /var/www/index.html an...


    Könntest du vielleicht nochmal schreiben, WAS genau funktioniert?


    Ou ja... Ich stand etwas auf dem Schlauch.


    Ja genau. Wenn ich die Lokale IP des Raspberry eingebe kann ich Programme aufrufen.Ich habe lediglich mit "[font="Calibri, sans-serif"]sudo apt-get install apache2[/font]" den Webserver herunter geladen. Konfiguriert habe ich nicht.


    Kann es sein, dass du noch deinen Webserver konfigurieren musst oder so? Standardmäßig wird er wohl nur auf http lauschen. Und da funktioniert es, nehme ich an? Dann musst du ihm jetzt noch beibringen, auch auf https zu lauschen. Tutorials dazu findest du zuhauf.


    Welchen Webserver meinst du und wie soll das gehen?
    Nein es funktioniert beides nicht. Habe es mit Chome und dem Explorer versucht.
    Sowohl mit http als auch https. Am Raspberry muss ich doch nichts mehr einstellen oder?
    Der Browser sollte doch dann eigentlich das Standardmäßige Dokument aus dem Verzeichnis /var/www/html angezeigt werden?


    HTTP Port ist nicht 22, sondern 80.ü
    HTTPS ist 443.


    Je nachdem, was du nutzt, musst du den entsprechenden freigeben


    Danke schon mal für die schnellen Antwotern :)
    Ich habe jetzt mal alle drei Ports geöffnet. Mit der Seite http://www.yougetsignal.com/tools/open-ports/
    habe ich getestet ob sie offen sind. Bei 443 steht komischer weise das er geschlossen ist.


    Wenn es funktionieren würde müsste ich doch einfach in den Browser eingeben:
    https://(no-ip hostname)/(Programm welches in /var/www/html abgelegt ist)


    Kann es sein das ich die Firewall noch konfigurieren muss oder so?

    Guten Tag.
    Ich versuche zur zeit meinen kleinen Roboter über das Internet zu steuern. Dieses versuche ich über ein einfaches PHP Skript zu realisieren, welches meine GPIO Ausgänge steuert. Im Lokalen Netzt funktioniert das auch prima. Über das Internet bekomme ich es allerdings nicht gebacken.


    Was ich getan habe:


    -SSH auf dem PI freigeschaltet (raspi-config)
    => über putty getestet


    -apache2 & php5 installiert
    -wiringPi installiert
    -no ip host angelegt => http://www.directupload.net/file/d/4455/6856mzqg_png.htm
    -noip2 auf dem pi installiert => http://www.directupload.net/file/d/4455/hjsvkvly_png.htm
    -Port 22 am router freigegeben => http://www.directupload.net/file/d/4455/uhmxfs6z_png.htm


    Nach dem ich dies gemacht habe müsste ich doch eigentlich den Hostnamen von noip im Browser eingeben und dann auf die Standard Seite die im /var/www/html Verzeichnis liegt gelangen?!


    Hiho.
    Ich habe ähnliches vor. Wäre es möglich, dass es mir jemand allgemein erklärt?
    Grüße David


    Ich habe (wie auch schon erwähnt) schon einen Port Scanner benutzt. Auch über den Link den Sie geteilt haben wird der Port 22 als offen angezeigt. Ich habe das Gefühl, dass ich irgendwo die falsche IP eingetragen habe.