Beiträge von mauswurstgrille

    Gibt es auch noch andere Beispiele?

    feste-ip.net hatten wir ja bereits angesprochen mit den von mir vermuteten Nachteilen bzgl. der Schleife über deren Server.


    Würde eine eigene Domain inkl. DNS-Einstellungen, MX-Records, etc. (wie gesagt, ich kenne mich prinzipiell gar nicht aus und lese mich gerade intensiv ein) helfen? Gibt es hier die Möglichkeit das Portmapping wie von feste-ip.net angeboten ebenfalls abzubilden?


    Sonstige Alternativen?

    Das Problem ist, daß ich bei fester ipv6 Adresse das Raspi, einem DynDNS-Eintrag, der auf diese feste Adresse zeigt mit subdomain.spdns.de, noch immer nicht auf meinen Server vom Handy aus komme.


    Feste-ip.net wäre eine Alternative, dann kann ich aber keine SSL-Zertifikate mit certbot generieren. Und ich schicke ja dann auch noch alles über die Server von Feste-ip.net, oder? Also jedes Bild, das ich auf meine Nextcloud lade, läuft über deren Server, richtig?

    Hallo,


    nachdem ich mich die Tage noch weiter damit beschäftigt habe, aber noch immer keine Lösung gefunden:


    Wäre feste-ip.net eine Alternative? Ich habe gelesen, so kann ich per ipv4-Geräte auf ipv6 im Heimnetz zugreifen. Allerding funktioniert wohl eine Zertifikatserstellung mit certbot nicht. Also der nächste tote Pfad, den ich dann gar nicht erst begehen möchte.


    Hat mir sonst noch jemand Hinweise?

    Zitat

    Bei welchem Provider hast Du deinen Mobilfunkvertrag? Oder hast Du noch einen 2. Internetanschluss mit DS oder mit DS-lite? Oder hast Du Freunde, die per IPv6 zugreifen sollen?

    --> Ich habe 1 x AldiTalk (also Telefonica) und 2 x Vodafone im Angebot. Alle drei mit test-ipv6.com getestet und überall das Ergebnis erhalten, daß ich nur ipv4 habe. Konkrete Anwort also, nein offensichlich möchte ich dann nur per ipv4 zugreifen.


    Habe mich dann heute etwas mehr in die Theorie (zu ipv4 und ipv6) eingelesen und dachte dann ich hätte es verstanden. Habe ja DS Lite, also nur ipv6 und nicht beides gleichzeitig (DS). Sondern eben nur das "light". Wenn ich von zu Hause aus den Test mit test-ipv6.com mache, habe ich sowohl eine ipv4 als auch ipv6 Adresse. Dann war ich wieder verwirrt, da DS light ja bedeutet ich sollte nur ipv6 haben. Und selbst, wenn ich die Theorie verstünde, hilft mir das noch nicht in der Umsetzung. Hier sind meine Fähigkeiten deutlich begrenzt.


    Deinen Client habe ich wohl bereits installiert. apt-cache show ddclient liefert:



    Eine feste ipv6 Adresse für den Raspi hatte ich ja bereits eingerichtet mit dieser Anleitung.

    Zitat

    Dazu editieren wir $ sudo nano /etc/dhcpcd.conf, suchen die Zeile

    Code
    1. # Generate Stable Private IPv6 Addresses instead of hardware based ones
    2. slaac private

    und kommentieren die slaac private Einstellung aus:

    Code
    1. # Generate Stable Private IPv6 Addresses instead of hardware based ones
    2. #slaac private

    Nach einem Neustart sollte die IPv6-Adresse ($ ip -6 addr show dev wlan0) die MAC-Adresse des WLAN-Adapters ($ ip link show dev wlan0) enthalten (mit der oben beschriebenen Verwurstelung). Ersterer Befehl zeigt zwei Adressen an. Diejenige, die mit fe80: startet ist die lokale Adresse, wie früher 192.168.x.x.

    Hallo,


    zu Edit:

    Ich habe den Portscan mit dem 2. Tool durchgeführt.

    Das Ergebnis, wenn ich die ipv6 der CB nehme ist --> Ports closed

    Das Ergebnis, wenn ich die ipv6 des Raspi nehme ist --> Port 80 open


    zu Edit 2:

    Mit diser Information kann ich leider nichts anfangen. Wenn ich tcpdump in die bash eingebe, kommt eine Fehlermeldung.


    zu Edit 3:

    Code 2 wirft bei mir das Ergibnis, mit der ich unter Edit die Ports gescannt habe. Die ipv6 hatte ich ja bereits lt. Anleitung eingerichtet.


    Hilft Dir das weiter, um mir weiterzuhelfen?

    Ich weiß noch immer nicht was zu tun ist.


    Besten Dank im Voraus.






    Hallo Helfergemeinde,


    ich bin seit Tagen am verzweifeln und auch diverse Google-Suchen und das Forum hier hat keinen Erfolg gebracht. Ich bin kein Experte und immer auf Tutorials angewiesen. Jetzt komme ich nicht gar nicht mehr weiter.


    Ich habe auf meine Raspi einen Apache2 Webserver inkl. PHP7 und MySQL installiert. Darauf läuft auch schon die Nextcloud. Im Heimnetz kann ich auf den Server und die Cloud mit 192.168.0

    .50, also ipv4 zugreifen. Als DynDNS-Anbieter habe ich spdns.de. Problem jetzt wie so oft, der Server ist von außen nicht erreichbar. Auch mit der Unterstützung dieser Anleitung klappt es nicht: https://invisibletower.de/2018…router-ipv6/#comment-6129


    Die Ports 80 und 443 habe ich in der Connect Box geöffnet und auf die ipv6 des Raspi weitergeleitet / freigegeben (öffentliche, nicht die fe80...). (Siehe Anleitung)

    Bei spsdns.de ist ein AAAA-Record für die ipv6-Adresse der Connect Box hinterlegt. Da kommt ein Ping durch. Wenn ich die öffentliche ipv6 des Raspi eingebe, kommt kein Ping durch. Beides getestet vom Handy ohne WLAN, also außerhalb des Heimnetz. Liegt es vielleicht daran, daß das Mobilfunknetz kein ipv6 kann? Ihr seht ich sehe den Wald vor lauter Bäumen nicht.


    Könnt ihr mir hier Hinweise geben? Gerne poste ich hier Euch Ausgaben des Raspis, um das Problem weiter einzugrenzen. Alleine bin ich aufgeschmissen.


    Besten Dank im Voraus.

    Zitat

    Das bedeutet AgenDAV versucht den Baikal unter dyndnsanbieter.de:80 zu finden. Wenn du dies aus Datenschutzgründen nicht verändert hast, existiert diese (Beispiel-)Adresse nicht.


    Das habe ich ja eingangs geschrieben, daß ich eine SSL-Verschlüsselung auf Port 443 verwende.

    Zitat

    Ich habe lighttpd allerdings mit SSL-Verschlüselung versehen.


    Zitat

    Ausserdem ist das so unnötig, da sich baikal und AgenDAV auf einer Maschine befinden. Besser ist nur AgenDAV auf 443 (SSL/TLS) laufen zulassen und dann intern nach localhost:80 umzuleiten.


    Der Webserver lighttpd ist auf Port 443 SSL verschlüsselt. Wie würde die von Dir beschriebene Lösung im Detail aussehen?


    Ich habe diese Anleitung für die Installation von Baikal benutzt. Was könnte Deiner Meinung nach schiefgelaufen sein? Wie kann ich es beheben?

    Hallo Norbert,


    der Pfad heißt bei mir: https://agendav.dyndnsanbieter.de/kalender/cal.php und liefert folgende Antwort:

    Code
    1. Mit dieser XML-Datei sind anscheinend keine Style-Informationen verknüpft. Nachfolgend wird die Baum-Ansicht des Dokuments angezeigt.
    2.      <d:error><s:exception>Sabre\DAV\Exception\NotImplemented</s:exception><s:message>GET is only implemented on File objects</s:message><s:sabredav-version>1.8.7</s:sabredav-version></d:error>


    Ich habe bereits Kalender über Thunderbird eingefügt und bearbeitet. Baikal funktioniert. Jetzt möchte ich noch Agendav als Client übers Internet erreichbar haben.


    Diese Anleitung...

    Zitat

    Darauf setzt dann agendav auf, näheres steht hier:


    https://www.linuxfrickeln.de/howto-insta...-8-jessie/


    ... ist nichts anderes als die von mir initial gepostete Anleitung. Es ist also die Originalanleitung umgeschrieben bzw. übersetzt.
    Ich scheitere an der Rewrite-Regel von Apache nach lighttpd, da ich diesen Webserver verwende.


    Zitat aus von Dir gepostetem Artikel:


    Den Virtual Host habe ich hinbekommen. Aber am Rewrite scheitere ich (auch wenn ich gar nicht weiß, wozu man den in diesem Fall braucht).
    Kannst Du mir diesen von Apache nach lighttpd übersetzten?


    Besten Dank im Voraus.

    Hallo,


    da ich mir nicht sicher war, wo das Thema hingehört (Server oder Allgemein) habe ich es hier platziert und bitte ggf. um Verschiebung, falls ihr es anders seht.
    Ich habe ein großes Problem mit der Installation von Agendav 2.0.0 beta2. Ich habe mich an die Installationsanleitung von der Homepage von Agendav gehalten aber bekomme es nicht zum laufen.


    Ich komme bis zum Punkt bei dem man den Apache vhost und die Rewrite-Funktion einstellen muß. Da ich aber lighttpd verwende, muß ich das anders lösen. Das ist mir bisher aufgrund mangelnder Kenntnis und Erfahrung nicht gelungen.


    Folgendes setting liegt bei mir vor:
    - Webserver = lighttpd
    - Kalenderserver = baikal
    - Dyndns = agendav.dyndnsanbieter.de (root = /var/www/agendav-2.0.0-beta2/web/public) und xxx.dyndnsanbieter.de (root = /var/www/)


    Die lighttpd.conf sieht aktuell so aus (ihr seht, ich habe mich bereits am Rewrite ausprobiert). Den vhost realisiere ich über die mysql_mod_vhost Funktion. Hier habe ich eine Datenbank erstellt, die unter den beiden Dyndns URLs die jeweiligen root-Verzeichnisse abgelegt hat:


    Ich komme aktuell mit dem Browser bis zum Anmeldefenster von Agendav. Nach der Eingabe von Benutzer und Passwort kommt dann entweder eine weiße Seite oder die Meldung "interner Server-Fehler". Die log Datei unter /var/www/agendav-2.0.0-beta2/web/var/log gibt folgendes aus:

    Code
    1. [2016-10-16 12:58:06] myapp.CRITICAL: AgenDAV\Exception\ConnectionProblem: cURL error 7: Failed to connect to xxx.dyndnsanbieter.de port 80: Connection timed out (see http://curl.haxx.se/libcurl/c/libcurl-errors.html) (uncaught exception) at /var/www/agendav-2.0.0-beta2/web/src/Http/Client.php line 184 {"exception":"[object] (AgenDAV\\Exception\\ConnectionProblem(code: 0): cURL error 7: Failed to connect to xxx.dyndnsanbieter.de port 80: Connection timed out (see http://curl.haxx.se/libcurl/c/libcurl-errors.html) at /var/www/agendav-2.0.0-beta2/web/src/Http/Client.php:184)"} []
    2. [2016-10-16 13:21:17] myapp.ERROR: Symfony\Component\HttpKernel\Exception\HttpException: Invalid CSRF token (uncaught exception) at /var/www/agendav-2.0.0-beta2/web/vendor/silex/silex/src/Silex/Application.php line 400 {"exception":"[object] (Symfony\\Component\\HttpKernel\\Exception\\HttpException(code: 0): Invalid CSRF token at /var/www/agendav-2.0.0-beta2/web/vendor/silex/silex/src/Silex/Application.php:400)"} []
    3. [2016-10-16 13:23:54] myapp.CRITICAL: AgenDAV\Exception\ConnectionProblem: cURL error 7: Failed to connect to xxx.dyndnsanbieter.de port 80: Connection timed out (see http://curl.haxx.se/libcurl/c/libcurl-errors.html) (uncaught exception) at /var/www/agendav-2.0.0-beta2/web/src/Http/Client.php line 184 {"exception":"[object] (AgenDAV\\Exception\\ConnectionProblem(code: 0): cURL error 7: Failed to connect to xxx.dyndnsanbieter.de port 80: Connection timed out (see http://curl.haxx.se/libcurl/c/libcurl-errors.html) at /var/www/agendav-2.0.0-beta2/web/src/Http/Client.php:184)"} []

    Daraus geht für mich hervor, daß der Client vergeblich versucht den Server (im falschen root-Verzeichnis, da es sich um das allgemeine und nicht das für agendav handelt) über Port 80 zu erreichen. Ich habe lighttpd allerdings mit SSL-Verschlüselung versehen. Und das Problem kann ich nicht alleine lösen. Ich habe bereits alles versucht.


    Meine Probleme sind also folgende (und vielleicht noch ein paar unbekannte):
    - keine Ahnung, wie ich ein richtiges rewrite hinbekomme, das die Funktionen aus der Anleitung erfüllt
    - Client versucht es über Port 80 soll aber über Port 443 ran


    Falls ihr noch mehr Logs benötigt, erstelle ich diese logischerweise gerne.
    Besten Dank im Voraus für Eure Hilfe.


    Gruß mauswurstgrille

    Wie ich mir die externe IP hole, sieht man in der ddclient.conf.
    use=web, web=checkip.dyndns.org


    Dort kommt als Antwort die externe IP-Adresse zurück.
    Mittlerweile ist das Problem gelöst.


    Des Rätsels Lösung waren die Zugangsdaten. Statt einem "I" handelte es sich um ein "l".
    Da muß man erst einmal drauf kommen. Danke für die Unterstützung.

    Ich habe mittlerweile herausgefunden, daß ich mir die externe IP holen muß, andernfalls gibt er die interne weiter, da ja noch ein Router davorgeschalten ist.


    So sieht die /etc/ddclient.conf aus:

    Code
    1. protocol=dyndns2
    2. use=web, web=checkip.dyndns.org/
    3. server=www.goip.de
    4. login=...
    5. password=...
    6. ....goip.de


    Die Eingabe ddclient -daemon=0 -debug -verbose -noquiet 2 /etc/ddclient.conf liefert folgendes Ergebnis (Auszug):
    Zunächst wird checkip.dyndns.org aufgerufen und die aktuelle externe IP zurückgegeben. Danach bekomme ich folgende Fehlermeldung


    Hallo Gemeinde,


    nachdem ich ja jetzt erfolgreich den Baikal-Server zum laufen gebracht habe möchte ich diesen nun von außen erreichen können.
    Über den DynDNS-Anbieter goip.de habe ich jetzt bereits einen Account.
    Nach erfolgreicher Einrichtung des ddclient kommt dort auch eine IP-Adresse an. Nur handelt es sich hierbei um die (interne) IP des Raspberry 192.168.x.x.
    Und nicht um die (externe) des ISP 78.43.x.x.


    Wenn ich diese händisch bei goip.de eintrage, dann kommt auch von außen eine Verbindung zu stande.
    Woran liegt das?


    Besten Dank im Voraus.

    Habe das Problem gestern Nacht noch selbst hinbekommen.
    Das Problem war, daß der Eintrag des root-Verzeichnis falsch war (wie bereits geschrieben). Dieses habe ich berichtigt aber es ging trotzdem nicht. Warum?
    Ganz einfach der lighttpd service mußte neu gestartet werden!


    Danke an alle, die sich Gedanken gemacht haben.


    Kann mir hier jemand verraten, wie ich eine SSL-Verschlüsselung in meiner aktuellen Konfiguration einrichte?
    Besten Dank.

    Hallo Gemeinde,


    es ist mal wieder soweit. Nach einem kompletten Tag der Frustration muß ich mich zu später Stunde an Euch als letzte Basiton wenden.


    Auch dieser Forenhinweis hat nichts gebracht, obwohl es das selbe Problem ist. Auch ich habe diese Anleitung von PC Welt benutzt.
    http://www.forum-raspberrypi.d…allation?highlight=baikal


    Aktuelle Konfiguration: lighttpd und Baikal
    Ergebnis: Im Browser die IP des Pi liefert die Startseite von lighttpd. "IP/Kalender" liefert Fehler 404.


    Verzeichnis für Baikal ist /var/www/kalender.
    In der lighttpd.conf ist das "root-Verzeichnis" /var/www (habe auch /var/www/kalender versucht)


    Berechtigungen sämtlicher Ordner sind für alle vergeben. Daran kann es also auch nicht liegen.
    Mittlerweile auch sqlite installiert. Heute Mittag hatte ich es bereits mit nginx versucht. Nach dem selben Problem wie hier aber deinstalliert und alles neu versucht.


    Ich weiß nicht mehr weiter.


    Mit der Bitte um Unterstützung.


    Besten Dank im Voraus.

    Hallo,


    was bedeutet:

    Zitat

    Bis auf das Subnetz & Co. und den DHCP-Pool (range), ja.

    ?


    Subnetz bekomme ich ja dann heraus, wenn ich auch den Router zugreife, oder?
    Und DHCP-Pool (range): Ist das der Nummernkreis der durch den Router vergeben wird? Also 0-99 bei der Fritz!Box.

    Hallo rpi444,


    ich nehme übermorgen einen neuen Router (Connect Box) in Betrieb.
    Gelten hierfür dann die gleichen Einstellungen die Du oben beschrieben hast oder muß ich die dann wieder ändern?


    Dann würde ich zunächst den neuen Router in Betrieb nehmen und mich dann nochmals melden.
    Falls es allerdings die selben Einstellungen sind mache ich es gleich.


    Gruß

    Zitat

    Und Du bist dir sicher, dass Du in die /etc/resolvconf.conf-Datei, die 192.168.178.1 und nicht die 192.168.178.188 eingetragen hast?


    Ja, ich habe eben nochmals nachgesehen.


    Hier die Ausgaben:



    Code
    1. rdnssd:
    2.  Installiert:           (keine)
    3.  Installationskandidat: 1.0.1-1
    4.  Versionstabelle:
    5.     1.0.1-1 0
    6.        500 http://mirrordirector.raspbian.org/raspbian/ jessie/main armhf Packages