Posts by Helado

    Hallo,


    eine .desktop-Datei in der Art:

    Code: /home/pi/.config/autostart/VNCviewerAutostart.desktop
    [Desktop Entry]
    Type=Application
    Name=VNCviewerAutostart
    Comment=VNCviewer Autostart Test
    Exec="/usr/bin/vncviewer -fullscreen 192.168.14.14:5900"
    Terminal=false

    funktioniert nicht? :-/ War Deine .desktop-Datei ausführbar?

    Hallo Hyle,


    eine entsprechende und ausführbare *.Desktop Datei liegt in: /home/pi/.config/lxsession/LXDE-pi/

    Diese Datei mit: chmod a+x sowie chmod 777 ausführbar gemacht mit Rootrechten. Leider ohne Erfolg.

    Danke!


    Das heißt also, ich kann das Skript auch in die *.desktop-Datei anlegen bzw. drauf verweisen? Folgendes habe ich auch bereits versucht:


    Code
    nano ~/.config/lxsession/LXDE-pi/autostart
    
    @vncviewer -fullscreen 192.168.14.14:5900

    Ohne Wirkung :-/

    Ein paar Anmerkungen meinerseits:

    - Warum ein eigenes Skript für eine Befehlszeile? Die kannst Du auch direkt in das Skript /etc/init.d/VNC schreiben

    - der Shebang in /etc/init.d/VNC fehlt

    - passen die Dateirechte (-> Ausführen)

    - in der Crontab ist der Start noch zu früh, da gibt es noch keinen Desktop, wo der VNC-Viewer ausgeführt werden könnte

    Erstmal vielen Dank für die Hilfe!


    - Ich habe in der init-Datei das Skript weggelassen (was ausgeführt werden soll) stattdessen habe ich /usr/bin/vncviewer -fullscreen 192.168.14.14:5900 angegeben

    - Im Skript steht doch #!bin/sh..? oder ist das falsch?

    - VNC hat Dateirecht +x

    - Kann ich in der Crontab erst den Desktop starten damit dann VNC ausgeführt wird?

    Hallo zusammen,


    würde gerne auf meinem RPi3 ein selbsterstelltes Skript ausführen lassen nach jedem Neustart.


    Hier mal mein Skript:


    Bash
    #!/bin/sh
    exec /usr/bin/vncviewer -fullscreen 192.168.14.14:5900


    Den Autostart habe ich an folgenden "Orten" hinterlegt, ohne Erfolg:


    /etc/init.d/VNC:


    Hier ein Crontab angelegt:


    Code
    @reboot /etc/init.d/VNC start

    Funktioniert nicht.


    Auch in der ./bashrc funktioniert nur dann, wenn der Terminal geöffnet wird.


    Auch hier: ~/.config/autostart/ habe ich eine *.desktop Datei erstellt, hat leider auch nicht funktioniert.


    Hat jemand eventuell noch eine andere Lösung für mich?


    Hintergrund ist folgendes:


    Ich möchte VNC Viewer autoamtisch starten beim Hochfahren und der soll sich wiederum automatisch mit einem anderen Host verbinden. Hoffe es ist einigermaßen verständlich.


    Vielen Dank im Voraus.

    Dies steht in /var/log/motioneye.log:


    Code
    2017-11-02 20:01:42: [motioneye]  WARNING: 403 GET /login/?_=1509652902377&_username=_&_signature=81b061c4f2f75f5d6a4b4c4421a69df540fca94e (192.168.178.23) 2.34ms
    2017-11-02 20:01:45: [motioneye]  WARNING: 403 GET /login/?_=1509652905027&_username=admin&_login=true&_signature=b9378edbc5afd0674f4225b7fc33b1b54ae488b7 (192.168.178.23) 3.69ms


    Und so sieht meine motioneye.conf in /data/etc/ aus:


    Also ich habe das Image erfolgreich auf meine SD Karte "installiert" und alles funktioniert zu 99% :)



    Ich habe erfolgreich die E-Mail Benachrichtigung eingestellt und habe mir selbst eine Testmail geschickt, leider bekomme ich bei einer Bewegung im Raum keine E-Mail zugeschickt mit einem Bild.


    Einstellungen habe ich wie auf dem Bild vorgenommen.

    MotionEye hat in der Konfig selbst den Port so definiert. Man muss sich mit Admin anmelden und bekommt dann eine Weboberfläche wo man eine Kamera auswählen könnte. Siehe Bild.


    Habe gedacht, man kann hier die Kamera auswählen.


    Egal, ich kaufe einen neuen Raspi und installiere dann das Image, bleibt mir nichts anderes übrig. OMD ist nicht so wichtig.

    So, MotionEye habe ich installiert auf meiner Raspbian Version. Bekomme auch Zugriff via localhost:8765 aber kann die Camera nicht auswählen.


    mit


    Code
    nano /etc/modules habe ich bcm2835-v4l2 


    hinzugefügt und neu gestartet.


    Code
    v4l2-ctl --list-devices 


    besagt folgendes:


    Code
    mmal service 16.1 (platform:bcm2835-v4l2):
    /dev/video0


    Warum wird mir die Kamera nicht angezeigt?

    Wow, das sieht sehr gut aus...


    Das Image, dass du erwähnt hast, welches System ist das? Eventuell kann ich dann OMD danach noch installieren.


    Das Einzige was ich gemacht habe ist alles nach folgender Anleitung:


    1. https://www.pcwelt.de/ratgeber…n-Sicherheit-8638548.html

    2. Postfix versuche ich zu konfigurieren, klappt auch alles, leider kann ich vom raspi keine Mail an meine Mailadresse schicken (noch nicht). Die Maillog zeigt mir an, dass es nicht funktioniert (anderes Thema, was hier auch geöffnet ist)

    Hallo Leroy,


    vielen Dank für die Rückmeldung. Leider dient dieser Raspberry auch als OMD (Nagios/Check_MK) Server.


    Ich muss die Speicherkarte erweitern damit die Bilder nicht die Speicherkarte zumüllen.


    Wenn alles über einen Browser konfigurierbar ist, ist das leichter also eventuell doch besser einen zweiten Raspberry anzuschaffen ^^.


    Ich mache dies das erste mal und muss mal nachschauen, ob die Bilder tatsächlich gespeichert werden. In der Anleitung, die ich befolgt habe, steht folgendes:


    "...

    die mit # External Commands, Warnings and Logging beginnt. Dort könnten Sie bei Erkennung einer Bewegung, sowohl bei Start als auch Ende, bestimmte Befehle ausführen lassen. Denkbar ist zum Beispiel das Senden einer E-Mail oder das Abspielen eines Klangs."


    Wie man einstellt, dass eine E-Mail verschickt wird bei einer Bewegung, steht leider nicht drin...

    Bitte entschuldige...


    Ich habe einen Raspberry Kamera V2 mit einem raspberry Pi3 und habe Motion installiert.


    Raspbian Jessie ist installiert.


    Folgende Änderungen in der /etc/motion/motion.conf habe ich vorgenommen:


    Code
    # Motion Detection Settings
    
    Treshold 1500
    
    Target_dir /home/pi/surveillance

    Das war es bis dato... Hoffe das hilft ein wenig weiter.

    Hallo zusammen,


    ich habe erfolgreich eine Raspberry Pi Kamera abgeschlossen und bekomme auch ein Livebild.


    Ich möchte aber gerne so haben, wenn eine Bewegung vorhanden ist im Raum, dass mir ein Bild per Mail geschickt wird. Ist dies möglich? Oder muss ich hier en Bewegungssensor extern anschließen?


    Danke im Voraus!


    PS. mir fällt immer auf, dass das Livebild nach ca. 5 Minuten weg ist bzw. es erscheint: "Seiten-Ladefehler". Kann ich das einstellen?

    Hallo Community,


    ich bin auf der Suche nach einem geeigneten Installationskandidat für OMD auf meinem Raspberry Pi 3 mit Raspbian.


    Habe OMD mal auf der Arbeit installiert, finde die Anleitung nicht mehr...


    Ich selbst bekomme immer wieder folgende Fehler:



    Wieso bekomme ich immer wieder diese Fehler?
    Automatisch zusammengefügt:[hr]
    Habe ein entsprechendes Paket gefunden ud bekomme beim Befehl:


    Code
    omd setup


    folgenden Fehler:



    Wenn ich mysql-server installieren möchte kommt folgendes:


    Hallo Community,


    seit Kurzem habe ich einen Gert VGA666 Adapter inkl. Board gekauft und entsprechend verlötet. Zu meinem Erstaunen funktionierte alles einwandfrei. Allerdings bekomme ich das Bild nun nicht mehr auf meinem HDMI Ausgang, sondern auf meinem VGA Ausgang nachdem ich folgendes verändert habe:




    Wie kann ich nun den Rpi3 mit beiden Bildschirmen betreiben und mit einer 1920x1080er Auflösung?

    Hallo Community,


    seit geraumer Zeit habe ich in der Firma einen RPi3 im Einsatz mit einem 7" Touchscreen. Läuft alles wunderbar, habe nun einen DHT22 Sensor mit einer SQL Datenbank "programmiert" um die Temperatur von außen auzulesen und in einer Tabelle darzustellen.


    Wenn ich aber Feierabend mache, möchte ich, dass der Bildschirm ausgeschalten wird, automatisch und morgens bevor ich komme wieder eingeschalten wird.


    Ich habe folgendes eingestellt:



    Code
    [size=12][font="courier new,courier"]00 16 * * 1-5 vcgencmd display_power 0[/font][/size]
    
    
    [size=12][font="courier new,courier"]0 7 * * 1-5 vcgencmd display_power 1[/font][/size]




    [font="courier new,courier"]Leider ist dies für den HDMI Port und nicht für das Touchdisplay. Kann mir jemand sagen, wie ich das für mein Touchdisplay hinbekommen könnte?[/font]


    [font="courier new,courier"]Vielen Dank im Voraus![/font]


    [font="courier new,courier"]Ach ja noch nützliche Infos:[/font]


    Code
    pi@ITS-Weather:sudo /home/pi# cat /etc/os-release
    PRETTY_NAME="Raspbian GNU/Linux 8 (jessie)"
    NAME="Raspbian GNU/Linux"
    VERSION_ID="8"
    VERSION="8 (jessie)"
    ID=raspbian
    ID_LIKE=debian
    HOME_URL="http://www.raspbian.org/"
    SUPPORT_URL="http://www.raspbian.org/RaspbianForums"
    BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"
    Code
    pi@ITS-Weather:/home/pi/projects/temp-and-humidity/sensor-values# sudo ls -l *_log_*.csv
    -rw-r--r-- 1 root root 33428 Okt  4 10:59 humidity_living-room_log_2016.csv
    -rw-r--r-- 1 root root 33433 Okt  4 10:59 temperature_living-room_log_2016.csv


    Das wäre die Ausgabe.


    Ich habe irgendwie das Gefühl, dass ich nicht alle benötigten "Programme" oder ähnliches installiert habe. Beispielsweise bei einem Nagios Server bei mir musste ich noch rrdtools installieren.


    Komischerweise habe ich es genau so gemacht, wie beschrieben wurde... Meines Erachtens kann es nichts mit Zugriffsrechte zu tun haben, weil ich ja alles sehe, außer das Diagramm.