Posts by freddyw17

    Hallo zusammen. Ich habe eine über DYNDNS über das Internet erreichbare Homepage auf dem Raspi , die ich aber über htaccess vor Zugriffen Fremder schützen möchte.
    ..jaja ich weiß, SOO sicher ist das über htaccess zwar nicht aber für meine Verhältnisse wäre das ausreichend..
    Trotz gefundender Anleitung komme ich echt nicht mehr weiter.. :wallbash:

    Kann jemand den Fehler finden ?
    Hat jemand eine einfache weitere Anleitung für mich ?

    --------------------------------------------------------------------------------
    Im Verzeichnis html liegt die index.html die ohne htaccess die (ungeschützte) Startseite des Servers ist und über das Internet erreichbar ist.
    Mit nano/var/www/html .htaccess wurde im Verzeichnis html die Datei .htaccess angelegt:
    AuthType Basic
    AuthName "User und Passwort eingeben"
    AuthUserFile /var/.htpasswd
    Require valid-user
    -------------------------------------
    Mit htpasswd -cs /var/.htpasswd testuser wurde die AuthUserFile im Verzeichnis var erzeugt.


    Nun wurde die Virtual Host Datei 000-default.conf im Verzeichnis /etc/apache2/sites-available bearbeitet:
    Hier gibt es die Dateien:

    000-default.conf
    default-ssl.conf
    ssl

    Datei ssl und default-ssl.conf habe ich unverändert gelassen.

    In Datei 000-default.conf habe ich lt. einer Anleitung Zeilen eingefügt:
    Dateiinhalt von 000-default.conf (ohne Kommentare) ist nun:

    <VirtualHost *:80>
    ServerAdmin webmaster@localhost
    DocumentRoot /var/www/

    <Directory />
    Options FollowSymLinks
    AllowOverride None
    </Directory>
    <Directory /var/www/html/>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride All
    Order deny,allow
    deny from all
    allow from http://www.meine-aktuelle-ip.eu
    </Directory>

    ErrorLog ${APACHE_LOG_DIR}/error.log
            CustomLog ${APACHE_LOG_DIR}/access.log combined
    </VirtualHost>

    Nach Änderung der Datei 000-default.conf wurde der apache2 mit
    etc/init.d/apache2 restart
    erneut gestartet

    Eine Passwortabfrage wird bei Aufruf der index.html nicht erzeugt: bei Aufruf der index.html : Index of/


    Auch wenn ich .htpasswd und .htaccess in das Verzeichnis html lege, und .htaccess entsprechend anpasse, erscheint bei Aufruf der index.html : Index of/ ..


    Wahrscheinlich liegt der Fehler aber doch irgendwie in der Lage der beiden Dateien bzw. an der noch falschen 000-default.conf ??
    Kann jemand helfen ?


    :danke_ATDE: