Posts by SteffenatHome

    Ok es funktioniert jetzt doch! :bravo2:


    Habe noch per Bash einen anderen GPIO getestet der dann super funktionierte.
    Dann hab ich den "alten" nochmal probiert und es hat klack gemacht :thumbs1:
    Nach einem Neustart war er dann auch in FHEM schaltbar und tut wie er soll!
    Übrigens zieht das Relais mit GPIO High AN.


    Vielen Dank euch für den tollen support!
    :danke_ATDE:


    Hi,
    wie wär's mal mit der aktuellen Schalte: http://www.forum-raspberrypi.d…inen-schaltplan-erstellen


    cu,
    -ds-


    Mein Schaltplan ist der in #19
    Fritzing schaue ich mir mal an.


    Hast du auch Pullupwiderstände verbaut? Zeige mal deinen aktuellen Schaltplan.


    Nein habe keine Pull-Up/Down Widerstände. Da die Spannung sich nicht ändert bei on/off bzw. High/Low wenn ich den GPIO schalte muss ich vermutlich mal an der Ansteuerung suchen.

    Hallo Jörg,
    Danke für die Ausführung.


    Habe jetzt leider schon ein 8-Kanal von Sainsmart hier liegen und den ULN hab ich auch schon auf ne kleine Platte gebrutzelt.
    Habe gerade mal gemessen was mein Multimeter an Spannung zeigt wenn ich den GPIO schalte. Habe von GND gegen den GPIO gemessen.
    Der hat leider immer 0V gezeigt bei High und Low.
    Denke ich habe hier noch einen Fehler in der Ansteuerung drin.
    Das ganze wird bei mir über FHEM und das Modul RPI_GPIO angesteuert aber das tut wohl nicht.

    Hi flyppo,


    eigentlich sollte der GPIO bei Zustand Low auf Masse schalten und somit den IN vom Relais auch oder läuft das anders bez. dem ULN?


    Vielleicht habe ich noch einen Fehler mit dem GPIO.
    Kann bei Low sollte ich zwischen GND und dem GPIO Pin 0V messen und am ULN Ausgang dann auch oder?

    So, hallo Zusammen. Habe jetzt meine Rev3 ausprobiert. Leider schaltet das Relais nur wenn ich den IN von der Relaisplatine auf Masse lege. Der GPIO macht vermutlich das Gegenteil.

    Das wichtigste ist dass ich mir den Pi nicht bruzel, aber das müsste dann so ja passen.
    Denke mit der Variante 3(2 Netzteile, verbundene Masse aber ohne an die 5V vom Pi zu gehen) werde ich das dann mal versuchen.

    Ihr macht mich fertig :X


    Ich dachte immer man sollte die 2 Versorgungsspannungen getrennt halten zum Schutz des GPIO.
    Naja hab ich wohl irgendwie falsch verstanden.


    Jedenfalls würde ich 2 getrennte Netzteile verwenden.



    Anfangs dachte ich mein Plan wäre realisierbar aber gerade verstehe ich nur noch Bahnhof :lol:


    Achja: bisher habe ich die Relaiskarte noch nicht gekauft! Deshalb kann ich auch keinen Schaltplan dazu liefern sorry.
    sieht jedenfalls so aus wie die SainSmart hier klicken


    [Blocked Image: http://d1j1kxp9fqehmk.cloudfro…e5fb8d27136e95/8/c/8c.jpg]

    Hallo Jar, danke für deine Teilnahme!



    Ich gehe davon aus dass Du nicht MEINEN Plan damit Meintest.


    Da ich meinen Pi selbst mit einem Netzteil versorge habe ich den Plan mal umgestellt.


    Habe die GND-Verbindung zwischen der Relais Karte und dem PI entfernt.
    Die Relais Karte habe ich noch um den GND Anschluss der IN´s erweitert den hatte ich vergessen.
    Verbunden habe ich diesen mit dem GND des 5V Netzteils.


    Ich habe einfach versucht die beiden Netzteile/Spannungen auseinander zu halten aber ob das dann funktioniert.... :s

    Hallo Nochmal,


    ehrlich gesagt bin ich mir jetzt doch nicht mehr so sicher...habe wieder mal noch ein anderes Thema gefunden wo diese Schaltung hier vorgeschlagen wird. So langsam weiß ich jetzt gar nicht mehr was korrekt ist und was nicht. :helpnew:


    Über die Verbindung des GND der Relaisplatine zum Raspi da unterscheiden sich auch die Meinung.
    Außerdem wird in diesem Schaltplan der ULN2803 verwendet und nicht wie bei mir der 2003!


    Ist mein Schaltplan doch nicht so korrekt?


    Die Themen laufen jedes mal ins leere und man ist am ende nach x-Seiten nicht wirklich am Ziel.
    Gibt es irgendwo einen Plan der korrekt ist und ich vlt. übersehen habe?

    Hallo 4zap,


    Danke, das hört sich doch schon mal gut an :-)


    Ja das war nur ein Beispiel. Kann es eigentlich zu Problemen kommen wenn man die GPIO´s der SPI Schnittstellen verwendet?
    Z.B habe ich einen DHT11 an GPIO10 bzw Pin 19 müsste das sein und das ist ja eines der SPI Interfaces oder? Der hat oft richtige Fehlwerte(FHEM zeichnet auf)


    Desweiteren gibt es ja noch den I²C und den UART die werde ich aber nicht anrühren,bzw steck ein Modul dran ;-)

    [font="Verdana, Arial, Helvetica, sans-serif"]Guten Morgen Zusammen,[/font]


    [font="Verdana, Arial, Helvetica, sans-serif"]ich heiße Steffen und [/font][font="Verdana, Arial, Helvetica, sans-serif"]ich denke ich bin hier am besten aufgehoben mit meinem Anliegen :thumbs1: [/font]


    [font="Verdana, Arial, Helvetica, sans-serif"]Ich würde gerne auch mit einem GPIO meines Raspi zusätzlich zu den Tastern den Treppenlichtschalter/Relais in meinem Verteiler ansprechen.[/font]


    [font="Verdana, Arial, Helvetica, sans-serif"]Ich habe schon etwas gestöbert und bin auf die Gefahr gestoßen dass man sich sehr schnell den Raspi abschießen kann wenn man den GPIO´s zu viel Spannung zumutet. Leider habe ich mit den GPIO´s bisher nicht viel am Hut und bin deswegen noch unsicher.[/font]


    [font="Verdana, Arial, Helvetica, sans-serif"]Ich habe mal einen Schaltplan gemacht um zu verdeutlichen wie ich dachte es könnte funktionieren laut meinen bisherigen Nachforschungen.[/font]


    [font="Verdana, Arial, Helvetica, sans-serif"]Der ULN2003 soll integrierte Widerstände zum Schutz des GPIO haben und damit kann [/font][font="Verdana, Arial, Helvetica, sans-serif"]anscheinend [/font][font="Verdana, Arial, Helvetica, sans-serif"]die Jumper- Verbindung zwischen VCC und JD-VCC bestehen bleiben?[/font]


    [font="Verdana, Arial, Helvetica, sans-serif"]Als Relais Platine dachte ich an diese: Relais Karte[/font]


    Was meint ihr dazu?
    Vielen Dank für Eure Rückmeldung !