Posts by raspberryfan

    So sieht das aus.

    Ok ich habe jetzt die Daten von Google.

    Aber youtube-upload --title="$(date '+%d-%b-%Y')" --privacy=private --credentials-file=client_secrets.json "/home/public/picam/timelapse/$(date --date '-1 days' '+%d-%b-%Y').mp4"

    funktioniert nicht.


    Ich habe halt das --credentials-file=client_secrets.json ergäntzt.

    Ja dann kommt nach dem Link zum Anmelden.

    Und dann ein code den man in die Konsole Kopiert und Enter Drückt und der Upload startet.


    Der gleiche Befehl im Cronjob geht aber nicht.


    Kan man irgendwie ein Log vom Cronjob erstellen wie die Ausgabe bei der Konsole ?

    Vieleicht zeigt er mir ja dann den Link an.

    Ja habe ich.

    Nur damit kenne ich mich halt nicht aus.

    Und die Beschreibung passt halt nicht ganz auf die Aktuelle Google Seite.

    Und wenn ich so einen code habe wie muss dann der Befehl aussehen ?

    Kann man den Cronjob nicht einfach anpassen das er wie in der Konsole ausgeführt wird ? Weil das funktioniert ja direkt.

    Hallo

    ich habe https://github.com/tokland/youtube-upload installiert und möchte das jetzt per Cronjob ausführen.

    Dazu habe ich mit

    Code
    crontab -l

    den Cronjob erstellt

    */5 * * * * bash /home/pi/youtube-upload.sh


    Das Problem ist es passiert nichts.

    Bash
    #!/bin/bash
    # Upload Youtube
    youtube-upload --title="$(date '+%d-%b-%Y')" --privacy=private "/home/pi/$(date --date '-1 days' '+%d-%b-%Y').mp4"

    Habe ich in der .sh Datei.

    Wenn ich einen Befehl wie mkdir ubuntu einfüge zum test, wird der Ordner erstellt.

    Also wird der Cronjob ausgeführt.


    Wenn ich die Datei mit sudo sh ./youtube-upload.sh in der Konsole ausführe kommt beim ersten Mal ganz normal Check this link in your browser: https://accounts.google.com und man gibt den Code ein.


    Oder wie kann ich das anders ausführen bzw die Authentication erledigen ?

    Es steht zwar dort was das man sich bei Google anmelden muss usw aber da finde ich mich nicht zurrecht.

    Ich bin schon einer Meinung aber die Wohnung ist nicht zu sehen:

    Und mein Standort ist eh bekannt da ich ein Impressum haben muss.(Leider)


    Hi,

    und genau da ist der Denkfehler vieler Leute. Das kommt dem "Ich habe ja nichts zu verbergen" schon ziemlich nahe. Im Netz gibt es keinen Zebraeffekt, alle kleinsten Details können miteinander verknüpft werden und das "Bild" wird mit jedem Detail klarer. Deine Wetter Webcam verrät Deinen Standort, es wird nicht nur der Einbrecher gefilmt, sondern auch Deine Wohnung. Dann wunderst Du Dich darüber, dass Du plötzlich ständig Werbung von künstlichen Orchideen eingeblendet bekommst, weil die grösste Datenkrake der Welt Dein Fensterbrett hinter dem Einbrecher in Deinem Stream gesehen hat... und das wäre nur das kleinste Problem. Ja, die Bauxitendproduktkopfbedeckung lässt grüssen, aber es icht nicht unbegründet.

    Ach so meinen sie das.

    An Datenschutz hatte ich jetzt nicht gedacht. Normal denke ich schon daran. In meinem Fall wo es eine Wetter Webcam ist kann das eh jeder sehen. In ihrem Fall sieht das dann anders aus. Oder man müsste es so machen das der Stream nur dann gestartet wird wenn eine Bewegung erkannt wird und dies nur dann wenn man nicht im Haus ist den Einbecher kann google dann ruhig kennen.

    Ansonsten für meine Webcam benutze ich http://picam.tgd-consulting.de/de/index.html.


    Der Vorteil von youtube live ist vorallem das du den Stream nur einmal übertragen musst bei mehren Besuchern. Und es ist halt sehr gut das jedes Gerät gut mit youtube zurecht kommt.

    Ich werde das auch bald noch testen.

    Mein Problem bei einer Webcam war immer das man halt mehre Besucher hat und keinen eigenen Server um den Stream zu verteilen.

    Danke

    Ich glaube über das Thema sollte ich mal einen Artikel für meine Webseite schreiben.

    Code
    Block size:               4096
    Fragment size:            4096

    Müsste also jetzt richtig sein.


    Habe auch das jetzt richtig gemacht:

    Wie kann ich das ändern bzw am besten verhindern ?


    Außerdem bin ich stark überrascht weil ich habe mir ganz viele Anleitungen in google angeschaut und alle kopiern das Image einfach rüber und haben keine 4096 Bytes mehr !


    Ich habe jetzt mal 200 als Cylinder gewählt weil es irgdendwo stand keine ahnung ob das richtig ist.

    Aber auch dann scheint die phys. Sektorgrösse falsch zu sein.

    Und auch die Partion immer noch nicht richtig.

    Code
    pi@raspberrypi:~ $ sudo blkid
    /dev/mmcblk0p1: LABEL="boot" UUID="B60A-B262" TYPE="vfat" PARTUUID="7b56e04c-01"
    /dev/mmcblk0p2: UUID="9a7608bd-5bff-4dfc-ac1d-63a956744162" TYPE="ext4" PARTUUID="7b56e04c-02"
    /dev/mmcblk0: PTUUID="7b56e04c" PTTYPE="dos"
    /dev/sda: PTTYPE="sun"


    und Windows sagt Nicht initialisiert.

    Leider immer noch nicht.

    Code
    cylinders (1-1048576): Value out of range


    Leider der Fehler bei resize2fs: Bad magic number in super-block while trying to open /dev/sda2.


    Code
    pi@raspberrypi:~ $ sudo blkid
    /dev/mmcblk0p1: LABEL="boot" UUID="B60A-B262" TYPE="vfat" PARTUUID="a6caaf70-01"
    /dev/mmcblk0p2: UUID="9a7608bd-5bff-4dfc-ac1d-63a956744162" TYPE="ext4" PARTUUID="a6caaf70-02"
    /dev/sda1: LABEL="boot" UUID="B60A-B262" TYPE="vfat" PARTUUID="11eccc69-01"
    /dev/mmcblk0: PTUUID="a6caaf70" PTTYPE="dos"
    /dev/sda2: PARTUUID="11eccc69-02"


    Das ganze natürlich mit einem unveränderten Image das ich vorher auf die Festplatte geschrieben habe mit Etcher.

    Das Raspberry System habe ich von der Speicherkarte gebootet und halt mit angeschlossener Festplatte.


    Ich habe mal in Windows geschaut dort sieht es wie auf dem Bild aus.

    Es scheint so als das die Partion vor der Boot Partion erstellt worden ist.

    Ob das wohl falsch ist ?

    Ich habe schon in dem Post (Link) Raspian auf einer Festplatte installiert. Jetzt muss ich aber noch die Partion vergrößern.

    Da es mit raspi-config nicht funktioniert (keine Speicherkarte) brauche ich Hilfe.


    Ich würde es gerne im laufenden Betrieb per Console am Raspberry erledigen.

    Eine gute Anleitung konnte ich leider auch nicht finden im Web.


    Weil es mit einer boot DVD von GParted nicht funktioniert hat. (bootet wieder nicht mehr)


    Raspbian von Pidrive (USB Festplatte) booten