Posts by Paddy65305

    rpi444

    Es ist ein Raspbian GNU/Linux 10 ohne besondere Konfiguration.

    also meine

    /etc/wpa_supplicant/wpa_supplicant.conf ist recht minimalisitisch:

    Code
    ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
    update_config=1
    
    network={
            ssid="FRITZ****"
            psk="*****************************+"
    }

    Hier mal meine /etc/dhcpcd.conf



    die Zeilen:

    Code
    #slaac private
    slaac hwaddr

    hab ich grade angepasst.

    die IPv4 ist auf jedenfall Fix hinterlegt. aber IPv6 muss auch aktiviert sein das ich den Serve laufen lassen kann.

    Zum Thema Log vergleich da ein Apache drauf läuft kann und das war immer meiner :) Also gehe nicht davon aus das ein fremder Pi mein WLAN gehackt hatte.

    Ich hab auf meinem Raspi ein komisches verhalten.: Jedes mal wenn sich mein PI neu mit WLAN verbindet ändert sich die MAC-Addresse. Da auf MAC ja die Fritz.Box ihre konfigurationen macht.


    Somit bekomme ich gefühlt jeden Tag (der rebootet nächtlich) eine Mail das ein neues Gerät sich eingewählt ins WLAN hat. :conf:


    Von den letzten 12 Änderungen sind nur 3 Duplikate die dann auch korrekt sein müssten von der Hersteller MAC Suche

    E4:5F:01 Raspberry Pi Trading Ltd



    Jmd ne Idee wie das zu Sande kommt? Zumindestens hab ich bewusst nirgends was eingestellt was die MAC

    ändern würde.



    :/

    A-Record auf die IP vom Raspberry oder deine öffentliche IP deiner FritzBox?

    Da man nur in Ausnahmen-Fällen eine feste öffentliche IP hat, meistens gibt bei jedem reconnect eine neue. Also muss die entsprechend aktualisiert werden.

    Vergleiche mal

    nslookup DEINESTRATODNS 8.8.8.8

    mit deiner öffentlich IP https://www.google.com/search?q=wie+ist+meine+ip


    die sollten identisch sein, dann kannst die Port weiterleitung einrichten:

    https://avm.de/service/fritzbo…-in-FRITZ-Box-einrichten/

    Hast du folgende Punkte erledigt:

    Bei der subdomain auf deine öffentliche IP bzw. eine DynDNS verwiesen?

    In deinem Router per NAT zum PI weiter geleitet?

    Evtl. Firewall angepasst?


    Wenn wir nicht raten sollen, muss du das ganze schon genauer erklären!

    Ich hab mir unten aufgeführtes ShellScrip zusammen gebastelt, welches auch funktioniert wenn ich aufrufe. und checkt ob die i2c-Device vorhanden sind und falls nicht ne Mail schickt.

    Wenn ich das allerdings als Crontab laufen lasse sagt mir das log dazu "i2cdetect: Kommando nicht gefunden."

    gleicher Benutzer mit den rechten das auszuführen. hat jmd ne Idee wieso?:helpnew::helpnew:



    Ich hab mein 3D- Drucker an den Pi an erfolgreich angeschlossen. (Pi3 + OctoPi Image)

    Jetzt hab ich mir die Sonoff S20 bestellt diesen nach Anleitung mit der Tasmoota-Firmware geflashed. Jetzt würde ich gerne den Drucker beim booten und beim Shutdown des Pi auch abschalten.

    Bzw. lasse ich bei längeren Druck-Dauer anschließend sofort das System shutdownen dann wäre ja praktisch wenn der Drucker auch aus geht.

    Das Plugin Tasmato-Plugin macht mir nur ein Icon in Navi-Bar mit dem ich an und ausklicken kann, aber nix automatisches vor und nach dem Druck?


    hat da jmd ne Lösung`? ich hab nix gefunden, bzw. falsch gesucht.

    Ist das Problem gelöst worden?

    ich hab mir letzte Woche ebenfalls ein Pi-Cam Rev 1.3 gekauft und das gleiche Problem.

    Getestet auf nem Pi Zero W und gegen Test auf nem ur Raspberry Pi Model A.


    jeweils neustes Raspbian Lite ist installiert.

    Das Bild wird per SSH über console mit raspistill erzeugt.

    Danach kommt die Fehlermeldung und danach hängt der pi sich nach kurzer Zeit auf.

    Der DHT war zu erst mit platine, weil dann nicht mehr lief hab ich einen nackten dran gebaut.

    dran gelötet ist ein 10k Widerstand.

    Kondensator ist keiner dran, da ich nach dem Forumbeitrag zum ersten mal was gelesen hab vom kondensator.

    und bevor ich jetzt die Konstruktion demontiere um nen Kondensator dran zu löten hab ich erst mal mein Freund google und das Forum durch geschaut.^^


    Wo soll der Kondensator dran? Ich hab noch jede Menge 100nF rum liegen.

    Eigentlich wäre die GPIO Lösung einfacher aber falls meine Sensoranzahl steigt hab etwas bedenken mit der maximal Last.

    Ich hab mir zwar mal den Beitrag durch gelesen:

    DHT22-Sensor muss regelmäßig vom Strom getrennt werden, um Werte zu liefern


    Hat hier jmd eine brauchbare Lösung gefunden und vor allem eine Ursache?

    Ich hab das selbe Problem auf meinem "Raspberry Pi 3 Model B Plus Rev 1.3"


    da ist noch BME680 Modul dran und außen hängt ein DHT22 an nem Meter Kabel am Pi.

    Wenn ich den DHT22 abstecke und wieder dran stecke liefert er wieder ne Weile Werte.

    In Unterschiedlicher Dauer, irgendwie lässt sich da keine Regelmäßigkeit erkennen. Scheint aber wirklich am Pi Model zu liegen, mit nem älteren Model hatte ich so Problem nie.


    Ich hab mit Sicherheit irgendwo ein Relais, ich würde die Schaltung um ein Relais erweitern.

    Hat hier jmd eine brauchbare Lösung gefunden?

    Ich hab das selbe Problem auf meinem "Raspberry Pi 3 Model B Plus Rev 1.3"

    da ist noch BME680 Modul dran und außen hängt ein DHT22 an nem Meter Kabel am Pi.

    Wenn ich den DHT22 abstecke und wieder dran stecke liefert er wieder ne Weile Werte.

    In Unterschiedlicher Dauer, irgendwie lässt sich da keine Regelmäßigkeit erkennen. Scheint aber wirklich am Pi Model zu liegen, mit nem älteren Model hatte ich so Problem nie.

    Im Rhein-Neckar Kreis war der Silvester-Peak bei knapp 400µg/m³ auf einem nicht zur Straße zeigenden Balkon.


    Zum Feinstaubmessen nutze ich ebenfalls die openData-Implementierung mit dem ESP, die Daten schicke ich über die "an eigene API senden" an mein PI und verarbeite sie da entsprechend. Der macht alle fünf Minuten eine Messung und sendet sie übers WLan an den Pi.

    du nutz externe Wifi-Boards (Raspi Zero W oder esp8266), die du dann per WLAN ansprechen kannst.

    ich hab das gestern beim ebayen gesehen dht22-wifi shield mit dem esp, hat das jmd schon mal getestet?

    gibts da ne gute Beschreibung?