Posts by s-e-a

    Von der Beschaltung sollte es ok sein, wenn du auf jede Seite des Kabels eine solche Buchse hängst. Aber ich könnte mir vorstellen, dass du Probleme durch Übersprechen bekommst.


    Ich denke eine einfache Lösung wäre einfach einen kleinen Switch dazwischen zu hängen. Da bist du auf der sicheren Seite.

    Das iPad ist in Ruhezustand und antwortet nicht auf ping, sobald iTunes gestartet wird, dann wird das iPad als aktiv an gezeigt und antwortet auch auf ping. Wenn man das iPad einfach liegen lässt, dann ist funktioniert ping kurz danach nicht mehr (Ruhezustand). Wenn man sich die Einstellungen des iPad in iTunes ansieht, dann wird die IP-Verbindung wieder aktiv. Also es muss eine Möglichkeit geben...

    @akunstmann:


    Könnte sein, da avahi das Macbook listet, aber nicht das iPad...




    @framp:


    Leider weiß ich nicht wie die Erkennung erfolgt, darum geht es ja! :) Aber iTunes erkennt ob sich ein iDevice zur Synchronisation im Wlan befindet, egal ob aktiv oder im Ruhezustand...

    Hallo zusammen,


    wie der Titel schon sagt, möchte ich gern überprüfen ob mein iPad im Wlan registriert ist.


    Aktuell löse ich den Hostname auf und pinge das iPad. Das ganze funktioniert allerdings nur dann, wenn das iPad aktiv (sprich der Bildschirm an ist). Wenn das iPad im Sleep-Modus ist, dann ist es nicht per Ping erreichbar. Allerdings kann iTunes das Gerät erkennen, also muss es ja eine Möglichkeit geben nach Geräten zu scannen.


    Hat vielleicht jemand eine Idee wie ich das anstellen kann?


    Danke und Grüße,
    S-E-A

    Hallo zusammen,


    ich wollte mal kurz Fragen, ob jemand seinen Raspberry über den USB-Port der Fritz!Box speist? Ich habe eine 7270 und bin am überlegen ob ich den RPI mal versuche darüber zu betreiben.


    Ehe ich aber meine FB durch das Experiment schädige, wollte ich mal fragen, ob jemand schon Erfahrungen sammeln konnte? Interessieren würde mich folgendes:


    - läuft die FB weiterhin stabil (keine reboots etc.)
    - wird das Netzteil sehr viel wärmer als normal
    - läuft der RPI stabil
    - und alles was ihr sonst noch so zu berichten wisst ;)


    Vielen Dank schon mal! :D


    VG,
    S-E-A

    @eknap:
    Ich steuere das ganze per Infrarot-Fernbedienung. Ich starte mit Lirc ein Python Script, welches die gewüschte Aktion ausführen wird (noch ist es nicht ganz fertig) :) .

    Ich habe auch erst überlegt es direkt mit einem MHz Sender zu machen, den hatte ich aber grad nicht da. ;) Wie ist denn die Reichweite? Vielleicht tausche ich es ja noch aus?

    Hier noch mal grob zusammengefasst. ;)
    (Natürlich ohne Gewehr!)




    Ich verwenden folgenden Steckdosen:


    Elro AB440S/3
    http://www.elro.eu/de/products…rs_met_afstandsbediening3



    Dann habe ich, wie in den Anleitungen geschrieben die Fernbedienung verkabelt:


    • Plus der Fernbedienung an den 5V Port der GPIO (Pin 2 beim RPI V2)
    • Minus der Fernbedienung an den Ground Port der GPIO (Pin 6 beim RPI V2)
    • den in der folgenden Anleitung als P1 gekennzeichneten Pin habe ich an GPIO17 angeschlossen (Pin 11 beim RPI V2)
      siehe Pin P1
    • die Batterie weg lassen, mit 5V kommst du dann noch ca. 7-8 m


    Eigentlich soll laut Anleitung noch ein 8,2kOhm Widerstand zwischen Fernbedienung und Pin 11, allerdings hat es bei mir nicht funktioniert. Ich habe die größte Reichweite mit einen 5,6kOhm Widerstand erzielt.



    Zur Software:


    • wiringPi installieren (siehe hier)



    • rcswitch-pi installieren (siehe hier)



      Code
      git clone https://github.com/r10r/rcswitch-pi


      solltest du dein einen anderen GPIO Port nutzen wollen, dann vorm ./make die send.cpp editieren



      Code
      ./make



    Dosen schalten:



    Code
    ./send [Hauscode] [Dose] [Status]



    Der Hauscode ergibt sich aus den ersten 5 Dippschaltern an der Dose. Ist der Schalter in der unteren Position (off), dann nimmst du eine 0. Wenn er in der oberen Position (on) ist, dann eine 1.


    Das wäre also 00000:


    -----


    °°°°°
    -----



    Und das 01010:


    -----
    ° °
    ° ° °
    -----



    Die Dosennummer wird mit den nächsten 5 Dippschaltern eingestellt. Bei mir sind diese mit A - E gekennzeichnet. Ist also der Dippschalter C auf On gestellt, dann musst du die Dosennummer 3 nehmen.


    Der Status kann entweder aus (0) oder ein (1) sein.


    Mehr fällt mir auf die schnelle nicht ein! :D


    VG,
    S-E-A

    Du installiert und konfigurierst LIRC für deine Fernbedienung. Dabei legst du in der Konfiguration fest, was beim drücken einer Taste passieren soll. LIRC läuft dann im Hintergrund und "überwacht" ob Infrarot-Befehle gesendet werden.


    Brauchst du dazu noch Infos?

    Du brauchst gar nicht den Umweg über XBMC zu gehen, wenn du nur Scripte etc. starten möchtest.


    Ich steuere meine verschiedenen Funksteckdosen (433Mhz aus dem Baumarkt, Intertechno und FS20 über den LightManager) über den RPI mit einer Infrarotfernbedienung.


    Dafür habe ich einfach einen Infrarot-Empfänger an die GPIO Schnittstelle angeschlossen und LIRC installiert. Danach kannst du dir ein fertiges Template für deine Fernbedienung downloaden oder die Tasten-Codes lernen und definieren was beim Tastendruck passieren soll. Und im simpelsten Fall einfach ein Shell-Script starten.

    Du brauchst nicht extra einen Benutzer auf dem RPI einzurichten. Du musst nur wissen mit welchem Benutzer du dich am Share der Fritz!Box anmelden musst.


    Wenn du ein den Share am Laptop öffnen kannst, dann musst wirst du doch sicher einen Benutzer angegeben haben? Oder ist das als Netzlaufwerk direkt in den Explorer eingebunden?



    Hast du mal versucht den Share über die IP-Adresse und nicht über den Namen aufzurufen?

    Guten Morgen,


    ich habe folgendes gefunden:


    https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/218637


    Ich weiß das ist für ein anderes OS, aber der Fehler scheint gleich zu sein:


    Versuche mal über das Terminal folgenden Befehl:


    Code
    setxkbmap -option "nbsp:none"



    Oder optional kannst du auch deine xorg.conf editieren und unter der Sektion [font="monospace"]InputDevice folgendes hinzufügen:[/font]





    Code
    Option "XkbOptions"    "nbsp:none"




    Nicht vergessen... Wenn du vorher ein Backup der Datei machst, bist du auf der sicheren Seite! :D


    Hallo zusammen,


    ich habe noch mal weiter gesucht und bin auf diese Anleitungen gestoßen:


    http://www.jotschi.de/Technik/…ntrolled-power-plugs.html


    http://christian-loef.de/?p=126


    Ich habe es nun ohne Widerstand und nicht am Dout-Pin, sondern an dem im ersten Link mit P1 gekennzeichneten Kontakt versucht. (mit 8,2 kOhm ging es auch nicht...)


    Nun geht es! Die Entfernung beträgt ca. 7-8 m! Ich werde morgen noch mal etwas in Detail gehen und schauen ob ich die Reichweite noch etwas verlängern kann.


    Danke für eure Mühe!

    Quote from JanG80 pid="4616" dateline="1359152138"


    5V ist sehr wenig dafür, dass die Fernbedienung für 12V konzipiert wurde. Hast du es mal mit 12 Volt versucht? Einfach Batterie drin lassen und nur die Massen von Fernbedienung und RPi verbinden. Eventuell stören auch die übrigen Bauteile noch rein. Ich habe schon diverse User gesehen, die die Platine modifizieren mussten.


    Um dies auszugleichen, sollte eigentlich der Widerstand dienen. Laut Homepage von rcswitch... ;)


    Aber ich probiere es noch mal mit 12V! :D


    -----
    Nachtrag:


    Auch mit der Batterie und mit angeschlossener Masse funktioniert es nicht.
    -----


    @honkey:
    In der send.cpp ist Port 0 als init PIN gesetzt. Das Kabel zur Fernbedienung habe ich auf GPIO 17 (Port 11) stecken. Das sollte doch passen?


    Ich kann den Ausschlag auch direkt an den Kontakten messen, also denke ich nicht, dass eine kalte Lötstelle das Problem sein sollte.

    Guten Abend,


    ich hoffe ihr könnt mir helfen.


    Ich versuche, wie im ersten Post beschrieben, meine Funksteckdosen mit rcswitch-pi zu steuern. Leider passiert aber gar nichts... :(


    Bei meinen Steckdosen handelt es sich ebenfalls um die ELRO AB440S/3.


    Was ich bisher getan habe:


    • - Installation von Raspbian
    • - Installation von wiringPI und GPIO
    • - Installation von rcswitch-pi


    Alle Programme wurden ohne Fehler oder Einschränkungen konfiguriert.


    Außerdem habe ich meine Steckdose wie folgt verkabelt:


    • Ground auf Minus der Fernbedinung
    • 5V auf Plus der Fernbedinung
    • GPIO17 auf Dout (inkl. 8,2 kOhm Widerstand)


    Ich habe es auch ohne Widerstand, mit 5,3 kOhm und 10,4kOhm versucht.


    Leider alles ohne Erfolg. Selbst wenn ich Steckdose direkt neben den Sender lege tut sich nichts.


    Alle Dip-Schalter des Hauscodes habe zum testen nach oben (auf on) gesetzt und den Befehl für die erste Steckdose sende ich so:


    Code
    ./send 11111 1 1


    Mit einem Multimeter habe ich folgendes getestet:


    • ca. 5V zwischen Plus und Minus an der Fernbedienung
    • unterschiedliche Spannungen zwischen Dout und Minus an der Fernbedienung (abhängig von Hauscode und Dose)


    Irgendwelche Ideen was ich falsch gemacht haben könnte?


    Danke im Voraus.


    MfG,
    S-E-A

    Ich würde mal vermuten, dass das kein Problem von apt-get ist, sondern ein Problem mit dem Keyboard-Layout.


    Versuch doch mal was passiert, wenn du Putty (oder eine andere SSH Session) verwendest. Wenn es dann geht solltest du dein Keyboard-Layout anpassen. ;)