Posts by KiGaZw

    Tag zusammen!


    Eine Lampe soll blinken ohne dass das Script aufgehalten wird. Also nicht


    GIPO ein

    sleep

    GIPO aus

    slee...


    Sondern sozusagen als "Anweisung" währen das Python-Script weiter läuft und z. B. auf einen Tasterdruck wartet oder ähnliches. Optimal wäre, wenn ich das irgendwie als (wie sagt man dazu?) "Funktion" hätte. Also vorher definiert so etwa:


    $blinklampe1=5x blinken


    Das ich dann an verschiedenen Stellen des Skriptes einsetzen kann.


    Konkret habe ich vor: Ein Taster soll durch blinken auf sich aufmerksam machen und zum drücken animieren.


    Danke!

    Hallo zusammen!


    Ich hänge mich mal hier dran, weil ich das selbe Fotobox-Script verwende.


    Klappt alles so weit, nur das Bild ist spiegelverkehrt. Da habe ich gestern Nacht noch gesucht aber nix gefunden wie und wo man bei dieser Fotobox-Software das Bild dreht. Danke für Eure Hilfe.

    Tag zusammen!


    Diese pixelige Schriftart bei Motion stört mich im Livestream. Kann man da nicht eine schönere nehmen und wenn ja: Wie?


    Ich finde leider nix darüber oder suche ich nur falsch?


    Danke!

    daran glaube ich noch nicht bei mir :lol:

    Ich bin ja seit etwa 2003 in dem anderen Forum das sich nur mit Heimkino beschäftigt. Dort gibt es eindeutig die "Gucker", die bauen ein Mal und haben dann Spaß dran. Veränderungen selten. Dazu gehöre ich.


    Und dann gibt es die "Tüftler", diese bauen nur und gucken wenig. Die optimieren und messen und diskutieren...


    Egal, Hauptsache man hat ein schönes Hobby!

    Freut mich, wenn du zufrieden bist. Aber mit dem was du schreibst, erweckt es bei mir den Eindruck, dass du die Beere nur per Lichtschalter bedienst und nicht ordnungsgemäß runter fährst. Wenn das so ist, solltest du darüber nachdenken, das zu ändern.

    Über warm werden oder "zu schwere Relais" sag ich nichts mehr, ich erinnere nur an eine gute Versicherung.

    Da kann ich Dich beruhigen!


    Der Raspberry fährt brav runter, wenn ich einen weiteren Taster drücke. Erst schaltet er alle Relais wieder in den Ursprungszustand zurück (=aus), dann fährt er brav runter. In der Zwischenzeit habe ich Getränke weggeräumt und aufgeräumt, und ich kann danach den Raspberry vom Stromnetz trennen (mit eben dem von Dir genannten Schalter).


    In der Praxis: Bei hochfahren ein "Autostart-Shellscript" das alles einschaltet. Dann zwei weitere im Hintergrund die ständig die Taster abfragen.


    Der Ganze 230V-Teil wurde nun von einem Elektromeister geprüft und für gut befunden, im Sicherungskasten des Hauses selbst komplett neu angeschlossen/abgesichert. Rauchmelder sind vorhanden, FI usw. alles auf neuestem Stand. In der Versicherung ist das Heimkino auch extra aufgeführt. Sollte also alles passen. Danke trotzdem dass Du Dir Sorgen um meine Sicherheit machst.

    Ja, ich habe tatsächlich die Bodenplatte entfernt um den großen Subwoofer unter zu bringen, die Position dort ist alles andere als zufällig. Man sitzt auf einem entkoppeltem, versenkten Podest. Bei Bassgewittern/Schüssen etc. hat man deutlich spürbaren Körperschall weil das Podest angeregt wird (Podest sitzt auf Federn/Dämpfer und kann entkoppelt frei schwingen)... :shy:


    Das Ganze hatte immer schon ein durchdachtes Konzept, nur die Ansprüche/Möglichkeiten/Technik ändert sich mit den Jahren.


    Die Fotos auf der genannten Seite sind schon länger nicht mehr aktuell, inzwischen haben wir schon mehrere tausend Stunden auf der Beamerlampe. Ich will nur noch die letzten Details fertigstellen, bevor ich das das mal abschließe.


    Bild und Sound bekommt man zu Hause deutlich besser hin als es die großen "echten" Kinos bieten können. Vorausgesetzt natürlich man hat einen Raum und die Nachbarn weit genug weg. :lol:


    Macht auf jeden Fall Spaß so ein eigenes Kino und wird auch so gut wie täglich genutzt.

    Hallihallo!


    So, schön dass das Forum hier wieder funktioniert. Und danke Euch!


    Also ich habe das Ganze korrekt verlötet, habe den Plan verstanden. Trotzdem waren die GIPOs von Raspberry zu schwach die schweren Relais zu schalten. Das habe ich inzwischen gelöst, denn ich hatte noch genügend "Billig Relais" frei, diese schalten nun einen separaten 5V-Kreislauf der dann die "großen" Relais schaltet. Alles kein Problem, funktioniert sehr gut. Ein altes USB-Netzteil erledigt das.


    Probleme hatte ich nur mit mehreren 10 Meter langen LED-Lichterketten. Diese ziehen auch relativ viel Saft, bei einem Versuch habe ich damit sofort so ein "kleines Relais" zerstört. Bei großen Relais dann hatte ich immer wieder ein kurzes aufblitzen der Lichterkette, weil diese SSR nicht ganz trennen.


    Die Lösung war auch ziemlich einfach: Einfach das Billig-Stecker-Netzteil (das schnell sehr heiss wurde) der Lichterkette durch etwas solideres https://www.amazon.de/gp/product/B00UEUWN06/ref=oh_aui_detailpage_o01_s00?ie=UTF8&psc=1 (Affiliate-Link) (das auch nach einer Stunde noch kalt bleibt) ersetzen. Problem gelöst.


    Es funktioniert nun alles!


    Wenn ich nun in meinem Kinokeller gehe, dann schalte ich nur noch einen stinknormalen Lichtschalter ein. Dieser startet den Raspberry und dieser wiederum schaltet mir die ganze Musikanlage, Beamer, Beleuchtung und Lüftungsanlage ein. Sinnvoll der Reihe nach.


    Im Kino selber habe ich einen Fußtaster zum Beleuchtung hochfahren/herunterfahren, es startet sich ein kleines Shellscript das die Lampen von vorne nach hinten ein- bzw. ausschaltet. Sehr edel!


    Ich möchte mich bei Euch ganz herzlich bedanke, ihr habt mir sehr geholfen.


    Und wen das Kellerkino interessiert, ich baue da schon Jahre dran rum, demnächst gibt es dann neue Fotos: https://www.beisammen.de/index…hts-ist-so-gut-wie-ein-p/


    :wink:

    Hallo ich bin es noch einmal mit gleich 2 Problemen und 3 Fragen:

    1.

    Wie gesagt: Ich habe insgesamt 6 Stück dieser Relais hier gekauft: https://www.reichelt.de/RA-242…=22691&START=0&OFFSET=16&


    Mein erstes Problem: Diese Relais trennen gar nicht zu 100%. Als Testaufbau habe ich auf der einen Seite 230V, dann das Relais und dann eine Lampe https://www.amazon.de/s/ref=nb…ield-keywords=gu10+3+watt


    Die Lampe glimmt halbwegs obwohl das Relais doch trennen sollte? Ist bei allen 6 Relais so. Ist das Normal? Die Lampe sollte doch komplett "aus" sein?

    2.

    Das Relais schaltet nicht. Hier habe ich wohl den falschen Code für den Raspberry, denn ich nehme den selben wie für die Billig-Dinger. https://www.ebay.de/itm/8Kanal…id=p2045573.c100505.m3226



    Quelle: http://nicht-traeumen-sondern-…ais_Schalten.php?anker=a2


    Mit dem Code funktionieren die Billig-Dinger super. Ich schalte damit mehrfach 230V 9 Watt ein/aus. Ich bräuchte also für diese "schweren Relais" einen anderen Code?


    Frage 2 ist vielleicht überflüssig, denn meine dritte Frage lautet:

    Ist es grundsätzlich sinnvoller es ganz anders anzugehen? Soll ich mit den kleinen Relais aus China die großen schalten? ist das besser? Also z. B. mit den kleinen Relais 12V an/aus schalten und damit die großen Relais ansteuern?


    Danke für Eure Hilfe.



    Nö, einfach weder Fachmann noch Klugscheisser. Dank Dir noch einmal für Deine Hilfe. So werde ich es vermutlich machen.


    Quote

    Evtl. noch ein Pulldown zwischen GPIO und GND in die Ansteuerung.

    Was empfiehlst Du? Wie würdest Du es machen und warum?

    Ich habe mich falsch ausgedrückt. Die Geräte vertragen auch etwas mehr als 220V. Ich wollte nur ungefähr die Dimensionen beschreiben was so ein Relais aushalten muss und habe mich schlampig ausgedrückt. Entschuldige bitte diese Verwirrung!

    Danke für die Anregungen. Der Sicherungskasten vom Haus ist in unmittelbarer Nähe und ich habe genügend Leerrohre zur Kinosteuerung. An das, die eh schon vorhandenen Sicherungen mit Stromstoßschalter zu ergänzen bin ich selbst nicht gekommen. Ich denke das ist ein guter Vorschlag! Vielen Dank!


    Als "Nicht gelernter" rühre ich den Sicherungskasten nicht an. Da lass ich den Profi aus dem Haus ran.

    Der Vollständigkeit halber, weil ich selber das immer blöd finde wenn Themen nicht zu Ende gebracht werden: Projekt lief letztes Jahr problemlos durch. Livestream war 24 Stunden täglich online.


    https://pollenhoeschen.de/nistkasten-kamera/


    Hier das Ergebnis:


    External Content www.youtube.com
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.