Posts by chuCKY187

    Hallo chuCKY187,


    was passiert, wenn Du Control-D drückst? Kannst Du Dich dann normal einloggen? Sorry für die blöde Frage, aber ich hatte den emergency mode (zum Glück) noch nicht.


    Falls Du es irgendwie hinbekommen solltest die fstab bearbeiten und speichern zu können, dann füge bitte die Option nofail ein, dadurch wird bei nicht verfügbar sein eines Laufwerks der Bootvorgang zumindest nicht unterbrochen.

    Hallo hyle,


    das hab ich dann auch getan. Unter /etc hab ich mir dann den Inhalt ausgeben lassen und siehe da, es gab eine fstab und eine fstab.save. Die fstab war die mehr der oben beschriebenen Fehlermeldung. Ich habe dann die fstab's umbenannt/getauscht.

    Merkwürdig war nur, dass er nach ein paar Sekunden immer den Bildschirm abgeschaltet hat. Warum kA, aber nach ein paar Versuchen war ich dann schnell genug die defekte in fstab.old um zu benennen und die neue in nur fstab.

    Jetzt funktioniert es wieder! Und sogar das NAS hat er gemountet. Was ein Schreck zu der späten Stunde....


    Allerdings funktioniert jetzt meine Mini-Tastatur nicht mehr

    https://www.amazon.de/Sonderangebotswoche-drahtlose-Leelbox-Port%EF%BC%88deutschem-Tastaturlayout/dp/B01M0T71NF/ref=sr_1_5?ie=UTF8&qid=1524086228&sr=8-5&keywords=mini+tastatur (Affiliate-Link)


    Gestern hat sie noch problemlos funktioniert und jetzt weder direkt per Kabel noch mit Funk.


    Und ich befürchte dass das Problem mit dem NAS auch noch nicht geklärt ist, da ich ja noch nichts geändert habe.

    Hi,


    ich hab gerade dein Änderungs Vorschlag umgesetzt und seitdem funktioniert gar nichts mehr... Nach dem Neustart bootet er zwar noch aber ganz am ende kommt:

    "You are in emergency mode. After logging in...

    try again to boot into default mode.

    Give root password for maintenance

    (or press Control-D to continue):"


    wenn ich mich dann mit dem Root einlogge und die fstab in den alten Status zurück ändern möchte kommt immer

    "Fehler beim Lesem der Sperrdatei /etc/fstab.wp Nicht genügend Daten gelesen"


    Was ist jetzt bitte passiert?

    Hallo zusammen,


    mein Plan war es mit meinem PIs auf mein NAS zuzugreifen und dann mit Hilfe von KODI Videos etc. zusehen. Mithilfe der ersten Google Treffern und einigen Anpassungen meinerseits, habe ich es auch mit den folgenden Eintrag in der Fstab geschafft das der PI mein NAS nach einen Neustart findet/mountet:

    Code
    //192.168.XXX.YYY/video /home/pi/NAS cifs username=NAME,password=PASSWORT,uid=pi,gid=pi,vers=2.0 0 0


    Natürlich habe ich XXX.YYY, NAME und PASSWORT durch die korrekte Daten ersetzt.

    Den NAS Ordner unter /home/pi habe ich natürlich auch erstellt.


    Anschließend hat auch alles wie gewünscht funktioniert. Allerdings nur bis zum nächstens Neustart...dann hat der PI das NAS wieder nicht gefunden. Ich hatte nichts geändert, weder am PI OS noch am NAS. Da es auch nach mehrfachen Neustarten nicht mehr funktioniert hat, habe ich erneut ein wenig recherchiert und es in die Folgende Zeile geändert:

    Code
    //192.168.XXX.YYY/video /home/pi/NAS cifs x-systemd.automount,username=NAME,password=PASSWORT,uid=pi,gid=pi,vers=2.0 0 0

    Auch hier hat der PI das NAS nach einem neustart gefunden und gemountet.


    Allerdings findet er es (nach einen Neustart) jetzt natürlich wieder nicht. Und ich glaube langsam nicht mehr, dass es an einen Fehlerhaften Eintrag in der Fstab liegt.

    Anderen Geräte wie mein Laptop und Desktop PC finden das NAS problemlos nach jedem neustart. Die IP des NAS ist statisch, daran kann es also auch nicht liegen.


    Hat jemand eine Idee woran es liegt bzw. was ich falsch mache?


    :danke_ATDE:

    Hallo,


    wie sich mittlerweile herausgestellt habe benötigt das Programm nur ".NET prerequisites.


    Edit2: Die".NET prerequisites" konnte ich mitlerweile auch installieren.

    Nun bekomme ich sobald ich das Programm ausführen die Fehlermeldung:

    Speicherzugriffsfehler


    Wie kann ich nun das beheben?


    Danke & Gruß

    Hallo zusammen,


    Edit: Bitte direkt in meinen zweiten Post hier schauen.


    heute habe ich auf meinen Pi auf Debian 9 (Stretch) aktualisiert und das hat nach ein paar kleineren Schwierigkeiten auch problemlos funktioniert.

    Nun benötige ich für ein Programm allerdings .Net Core und habe folgende Anleitung dafür verwendet:

    https://docs.microsoft.com/en-…requisites?tabs=netcore2x

    und habe die Schritte unter "Install .NET Core for Debian 8 or Debian 9 (64 bit)" der Reihe nach eingegeben.

    Es funktioniert auch alles (jedenfalls gibt es keine Fehler) bis zum Schritt 5 und den Befehl "sudo apt-get install dotnet-sdk-2.0.0".


    Dann kommt bei mir folgende Fehlermeldung:

    Code
    root@raspberrypi:/etc/apt# sudo apt-get install dotnet-sdk-2.0.0
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut.       
    Statusinformationen werden eingelesen.... Fertig
    E: Paket dotnet-sdk-2.0.0 kann nicht gefunden werden.
    E: Mittels des Musters »dotnet-sdk-2.0.0« konnte kein Paket gefunden werden.
    E: Mittels regulärem Ausdruck »dotnet-sdk-2.0.0« konnte kein Paket gefunden werden.

    Was mir aber auch aufgefallen ist, das bei Schritt 4 wo der Befehl eine Adresse zur Source-Liste hinzufügen soll (jedenfalls denke ich das), das nicht passiert. Deshalb habe ich händisch die ziele :

    Code
    deb [arch=amd64] https://packages.microsoft.com/repos/microsoft-debian-jessie-prod jessie main

    in die Source-List eingetragen, hoffe das war richtig so.


    Meine Vermutung: Der Fehler liegt bei "[arch=amd64]" bin mir aber nicht sicher, was man ändern muss.


    Danke schon einmal im voraus.


    Grüße

    Hallo,


    entschuldigt die späte Rückmeldung.


    Ich denke wie ich an das i386 gekommen bin war als ich vorher versucht habe Teamviewer zu installieren.
    Da z.B. wird das vorausgesetzt, jedenfalls stand es so in der Anleitung, ebenso wie beim Steam-Client.


    Was mach ich eigentlich falsch das ich bei manchen/vielen versuchen Software zu installieren immer noch:

    Quote

    E: Paket XYZkann nicht gefunden werden.


    bekomme?


    Besten Dank :)


    Hi dreamshader,


    ich habe gerade deine Befehle ausprobiert und siehe da, es funktioniert :).


    Jetzt stellt sich mir nur eine Frage, was mache ich wenn ich diese Architectur benötige, da diese bei vielen Programme vorausgesetzt wird?


    Vielen Dank an alle! :danke_ATDE:

    Das "="-Zeichen hast Du, manuell hinzugefügt?


    Eigentlich sollte bei "--print-foreign-architectures" keine Ausgabe erfolgen. D. h., dass Du etwas Anderes installiert hast.


    Hallo,
    Ja, das = hatte ich selber eingefügt, habe es aber jetzt nochmal geändert.
    Ich habe den Befehl jetzt nochmal eingegeben und es kommt wieder:

    Code
    root@raspberrypi:/home/pi# dpkg --print-foreign-architectures
    
    
    i386

    Hallo rpi444,


    Von: dpkg --print-architecture
    armhf


    Von: dpkg --print-foreign-architectures
    i386


    Von: cat /etc/apt/sources.list:
    deb http://mirrordirector.raspbian.org/raspbian/ jessie main contrib non-free rpi
    # Uncomment line below then 'apt-get update' to enable 'apt-get source'
    deb-src http://archive.raspbian.org/raspbian/ jessie main contrib non-free rpi


    Edit:
    von: ls -la /etc/apt/apt.conf.d:
    insgesamt 32
    drwxr-xr-x 2 root root 4096 Mai 27 18:33 .
    drwxr-xr-x 6 root root 4096 Mai 29 19:46 ..
    -rw-r--r-- 1 root root 643 Dez 13 23:38 01autoremove
    -rw-r--r-- 1 root root 904 Mai 27 18:33 01autoremove-kernels
    -rw-r--r-- 1 root root 141 Okt 13 2014 20listchanges
    -rw-r--r-- 1 root root 1040 Dez 14 2014 20packagekit
    -rw-r--r-- 1 root root 161 Apr 10 11:27 50raspi
    -rw-r--r-- 1 root root 182 Mär 19 2015 70debconf



    Besten Dank

    Hallo hyle,


    vielen Dank für deine Rückmeldung.


    Ich kann mich nicht erinnern "rpi-update" eingegeben zu haben, kann es allerdings auch nicht ausschließen :/.


    Bei deinen Befehl sieht meine Ausgabe wie folgt aus:

    Quote

    Linux raspberrypi 4.9.30-v7+ #1001 SMP Fri May 26 16:09:18 BST 2017 armv7l GNU/Linux


    Gruß

    Hallo zusammen,


    seit kurzen bin ich Besitzer eines Raspberry Pi's 3b.
    Als OS habe ich mir Raspbian Jessie installiert.
    Nun habe ich folgende Probleme, jedes mal wenn ich z.b.

    Code
    sudo apt-get install XYZ

    eingebe kommt:
    "E: Paket XYZ kann nicht gefunden werden."
    Egal was ich probiere zu installieren. Und bei meiner recherche war die Antwort immer "sudo apt-get update"


    Bei

    Code
    sudo apt-get update

    bekomme ich allerdings folgendes:
    "W: Fehlschlag beim Holen von http://mirrordirector.raspbian…an/dists/jessie/InRelease Erwarteter Eintrag »main/binary-i386/Packages« konnte in Release-Datei nicht gefunden werden (falscher Eintrag in sources.list oder missgebildete Datei).


    E: Einige Indexdateien konnten nicht heruntergeladen werden. Sie wurden ignoriert oder alte an ihrer Stelle benutzt."


    Ich kann also quasi nichts mit "apt-get" machen....



    Meine Source list habe ich so gelassen wie sie nach der Installation aussah:
    deb http://mirrordirector.raspbian.org/raspbian/ jessie main contrib non-free rpi
    # Uncomment line below then 'apt-get update' to enable 'apt-get source'
    deb-src http://archive.raspbian.org/raspbian/ jessie main contrib non-free rpi


    Ich hab lediglich die "#" vor der 3. Zeile entfernt (ändert aber auch nichts).


    Ich hoffe hier kann mir jemand helfen. Falls weitere Informationen benötigt werden, einfach schreiben.
    Besten Dank & Gruß