Posts by MadM4x

    Guten Morgen,


    ich habe zwar schon einige Beiträge gelesen allerdings würde ich mein Projekt gerne klein halten, daher brauche ich mal ne Kaufempfehlung.


    Ursprünglich dachte ich zu erst daran mir folgenden Digitalen Bilderrahmen zu holen:

    Braun Digiframe 1518 wifi


    Angesichts des Preises und der "eingeschränkten" Funktionen bin ich dann auch die Idee gestoßen dass man das ganze ja vielleicht auch mit nem RPi umsetzen könnte. Allerdings stell ich mir gerade die Frage welche Variante am Sinnvollsten ist bzw. wie "eingeschränkt" man bei dem HDMI Display ist?

    HDMI-LCD-H-mit-Gehaeuse-1920x1080-IPS


    Den Digiframe Bilderrahmen kann man ja, denke ich zumindest, auch relativ frei irgendwo an die Wand hängen und muss ihn nicht zwingend Aufstellen. Wie sieht's da mit dem HDMI Display aus? Hat da schon jemand Erfahrung gemacht? Beim Digiframe habe ich ja nur das Kabel vom Netzteil was man wahrscheinlich relativ einfach Verlängern kann. Beim Display sollte das im Vergleich aber nicht so einfach gehen oder?


    Einen RPi 2 und 3b habe ich sogar noch hier rumliegen so daß ich "nur" das Display bestellen müsste...

    Wie würdet ihr das machen? bzw. was haltet ihr für Sinnvoller?


    Im Moment kann ich mich nicht zwischen "eingeschränkte" Funktionen, einfacher was den Ort des Aufstellen oder Aufhängen

    angeht und "wesentlich" mehr Funktionen auf langer Sicht, eingeschränkt bei der Auswahl des Standorts entscheiden.



    VG und Danke an alle

    Hostnamen Rückwärts auflösen geht auch?

    DNS Server ist ja nicht gleich DNS Server oder? ;)
    Router intern geht das DNS ins Internet...


    Und Testweise kann @Snoopy1986 ja mal in beiden DHCP´s den Standard DNS Server eintragen um zu sehen ob das

    Gast-WLAN ins Internet kommt.


    So ist dann sichergestellt ob es am Pi-Hole DNS liegt oder nicht.
    Und man kann die Fehlersuche weiter eingrenzen.

    DNS geht (zumindest Standardmäßig bzw. auf normalen weg) nicht über Subnetze hinaus.
    Dafür müsstest du einen eigenen DNS Server einrichten.

    Deswegen sieht man im Pi-Hole WebGui unter Netzwerk auch nur die Geräte die im selben Subnetz liegen wie der Pi-Hole selbst.

    In deinem Fall dürfte die fehlende Internetverbindung aber daran liegen das du keine statische Route vom 192.168.1 zum 192.168.2

    eingerichtet hast. Kann mich aber auch Irren .... ist schon ne ganze Weile her dass ich mich damit Beschäftigt habe wie das ganze direkt auf nem Router eingerichtet wird bzw. ob man "intern" überhaupt eine statische Route braucht.


    Testen kannst du es ja trotzdem mal.

    Danke für den Link.


    Hab gerade mal das Tut überflogen.

    Sieht doch mal wirklich gut aus. Strukturiert, Informativ und Ausführlich.


    Ich hätte an dieser Stelle auch noch einen weiteren Punkt, falls ChristianWilhelm das TuT wirklich in Angriff nimmt,

    der bestimmt Interessant wäre. IPv6 Hostname und Namenauflösung. :D :D

    Finde das TuT auch gar nicht so verkehrt.


    Schlicht, einfach und Übersichtlich.

    Allerdings vermisse ich komplett das Thema LAN und WLAN!

    - Einrichte,DHCP und/oder Static IP

    - WLAN Einrichten, ebenso DHCP und Static IP
    - Konfigurieren von WPA-Supplicant (1 Wlan und/oder Multi Wlan mit mehreren SSID und verschiedenen Prio´s)

    - Energiesparmodus WLAN Stick

    - SSH aktivieren, Passwörter ändern, Standard Bash Befehle

    - Bash Befehle zur Fehler suche


    Mit deinem TuT kann ich einen RPi "nur" Einrichten wenn dieser an einem Monitor hängt
    und ich eine Tastatur habe die auch auf anhieb Erkannt wird und Funktioniert.


    Gibt es mal Probleme zeigt dein TuT keinerlei Möglichkeiten wie ich Fehler erkenne und diese Beseitige.


    UND GANZ WICHTIG:
    Das soll keine Kritik sein oder dein TuT schlecht machen, denn ich finde es wirklich gut.

    Vor allem da es schlicht und Strukturiert ist.


    Das sind lediglich Punkte die mir sofort ins Auge gesprungen sind oder mich an meine Anfangszeit erinnert haben.

    Ich kenne zwar dein Tutorial noch nicht *sorry* .... bin aber der selben Meinung wie die meisten hier.

    Ein klar strukturiertes HowTo kann wirklich nicht schaden.

    Allerdings bin ich mir Aufgrund der doch vielen unterschiedlichen Anforderungen und Firmware unterschiede der Fritzbox

    nicht so sicher ob man so ein TuT überhaupt allgemein erstellen kann.


    Umso mehr würde es mich Interessieren wie eins von dir Aussieht.


    Und bevor nun die Frage auf kommt "Welche Unterschiede oder Anforderungen"

    - Die zur Zeit genutzten Fritzbox unterscheiden sich ja nun doch recht groß von Firmware zu Firmware

    - Hinzu kommen die Unterschiede durch die verschiedenen Internetanbieter sowie "gehackten" Firmware einiger Fritten

    - IPv6 und DS-Lite spielt ebenfalls eine Rolle und die meisten Beschäftigen sich zu wenig damit


    Ich selbst hab mich damit auch erst und auch nur um Pi-Hole zum laufen zu bringen beschäftigt.

    Da das Thema durch meine Fritzbox und dem Unitymedia Anschluss leider dazu gehörte.


    Letztendlich kommt dann auch noch das Thema "DNS Anbieter/Server (Cloudflare usw.)" hinzu sowohl ins Internet als auch vielleicht fürs
    Heimnetzwerk.


    Der Thread ist nicht ohne Grund stellenweise so Unübersichtlich.

    Wenn du das ganze Thema in einem vernünftigem Tutorial zur Verfügung stellst wäre das definitiv eine geile Sache und nen "Like" Wert.

    Ich befürchte das du die Treiber nach jedem Kernel Update manuell kopieren/installieren musst.

    Liest sich nämlich so als wenn der TP-Link USB Wlan-Adaper nicht zu den standardmäßig unterstützten Geräte gehört

    und daher nach dem Kernel Update nicht mehr läuft.


    Das gleiche "Problem" habe ich mit meinem EW-7811UTC (Edimax AC600 Dual-Band) Usb Stick.

    Mit dem normalen "Treiberpaket" funktioniert der USB Stick nicht bzw. wird nicht erkannt/installiert.

    Und daher ist auch nach jedem Kernel Update eine "reinstallation" notwendig.

    Das waren keine normalen bzw. allgemeine Ratschläge zu Linux (zumindest nicht von mir)
    sondern Vorschläge die man bei einer schnellen Suche mit google gefunden hat.


    Die häufigsten Ursachen für die Ausgabe bzw. dem Problem mit:

    "You are in Emergency Mode. After loggin in, type Journalist-xb to view

    System Logs....

    Can not Open console, root account is locked"


    in Verbindung mit noob.
    Denn in den meisten Fällen lag es daran dass durch das dist-upgrade die Root-Boot Partition fehlerhaft
    eingetragen war oder man durch einige Änderungen an der cmdline.txt wenigstens wieder soweit
    Zugreifen konnte um das System zu retten und/oder das Update/Upgrade fehlerfrei Abschließen zu können.


    Oder wenigstens an die Logfiles kommt um mögliche Fehler und Ursachen zu finden.


    Aber Aufgrund der Tatsache wie du auf manche Beiträge reagierst oder Antwortest und deiner Aussage

    das der Thread geschlossen werden kann..... Bin ich dann auch raus.

    Kommst du den gar nicht mehr auf die Konsole?
    Also auch nicht als User: pi?

    Fährt der RPi direkt nach "Press Enter to continue." herunter?

    Falls ja, bleibt dir eigentlich nur noch die Möglichkeit die SD Karte mal

    unter Windows zu öffnen.


    Dann öffne/editiere mal folgende Dateien /boot/cmdline.txt und /etc/fstab

    und postest hier im Forum mal den Inhalt beider Dateien.


    Alternativ kannst du aber auch unterm Windoof Editor mal schauen was

    in /var/log/ in den Log-Dateien steht vielleicht findest du dort selbst den Fehler.

    Allerdings hab ich die SD Karte immer wieder Formatiert und dann neu mit noobs aufgesetzt.

    Dann wird genau da der Fehler liegen bzw. liegt der Grund für die Fehlermeldung bei noobs (hab ich zum Glück noch nie benutzt und werde ich wohl auch so beibehalten)

    zu dem Thema noobs oder nicht noobs hat STF sich Gedanken gemacht. (Meine Meinug: man braucht es nicht und es erhöht die Zahl der möglichen Fehler.)

    Dem kann ich nur Zustimmen und wenn ich mich richtig Erinnere gibt es doch mittlerweile sogar bessere Möglichkeiten.

    ich hab jetzt ne neue sd und nen anderen usb adapter bestellt, vielleicht liegt es auch an der Kombination

    Es wird eher an der Kombination Image / noobs / und Dingen die man nur vermuten kann liegen.

    Wenn du dir allerdings bei dem ganzen rum testen mal die Mühe gemacht hättest nur Volumio einfach mal

    auf eine neue SD zu flashen ohne noobs usw.

    (Dann könnte man wenigstens schon mal Eingrenzen ob es am Image liegt / ob es an noobs liegt / ob es am Raspberry liegt)

    oder einfach mal bei Google nach deinem Fehler zu Suchen.


    Noobs


    Hättest du diverse Links gefunden in denen es anscheinend bei einigen anderen ebenfalls durch noobs zu diesem Fehler gekommen ist.

    Und mit welchen Möglichkeiten man das vielleicht beheben kann.


    Könnte man das ganze ebenfalls weiter Eingrenzen.

    ...Image installier ich mit Etcher auf der SD Karte soweit so gut...

    Mal Versucht das Image zb mit Win32DiskImager oder ähnlichem?

    Gerät ist ein RAsperry 3b+

    Ist das ein nagelneuer RPi???

    Oder war der schonmal in gebrauch mit Raspbian oder Noobs usw.?

    Falls der vorher in Gebrauch war, hattest du zu diesem Zeitpunkt irgendwelche Hardware an den GPIO´s angeschlossen?

    Oder vielleicht auch Übertaktet??

    ...dann versuche mal den Pi ohne das 5" Display über HDMI an einen normalen Monitor ohne weitere Periferiegeräte außer den Eingabegeräten anzuschließen.

    Hast du den Tipp von mark-aus-51 überhaupt versucht?
    Und die Volumio Installation ohne irgendwelche Hardware an die GPIO´s zu starten?


    Hast du mal bei Google nach der Fehlermeldung gesucht?

    Guckst_du_hier


    und die Möglichkeiten mal versucht?

    Hab es zwar nur überflogen und ist zwar auch etwas OT.


    Hat das besagte Handy von dem du hier redest ebenfalls eine feste IP?
    Oder bekommt es diese per DHCP von der Fritzbox?

    Falls du dort eine feste IP Adresse vergeben hast, hast du auch darauf geachtet

    das du in den DNS Einstellungen am Handy die IP Adresse vom Pi-Hole als DNS Server

    eingetragen hast?

    In der DNS Einstellung steht bei "Interface listing behavior" Listen on all interfaces.

    Wenn ich mich nicht Irre musst du dort bzw. reicht es dort wenn du es auf "interface eth0" stellst.

    Dein RPi ist ja der Lan mit der Fritte verbunden und die DNS Anfragen kommen ja auch per LAN von der Fritte zum

    RPi.

    und den beim DNS-Rebind-Schutz
    beiden IP´s des Pi eingetragen.

    Meinst du damit den DNS-Rebind-Schutz unter den Einstellungen in der Fritzbox?
    Dort dürfen keine IP Adressen eingetragen werden sondern nur Domains/Hostnamen.


    Für die Fritzbox wäre das dann fritz.box und/oder vielleicht noch *fritz.box und für

    Pi-Hole wäre das dann öhhh pi.hole und/oder *pi.hole (wenn ich mich nicht Irre)


    Und sicherheitshalber solltest du, jedes mal wenn du an den DNS Einstellungen was änderst,

    in der Pi-Hole Adminoberfläche unter Settings den DNS Neustarten oder per ssh mit:

    sudo pihole restartdns



    VG

    ;)

    Naja wer weiß wozu Sal9000 die 45 Listen und 5,2 Mio Domains braucht....


    Aber 68-70 Grad scheint für mich eher andere Ursachen zu haben.
    Selbst mein RPi mit Kodi 18.2 inkl. Emby for Kodi schafft das nicht.

    Was machst du? Mein Pi1 wurde nackig wie er ausgeliefert wurde in meinen Server(Schuh)schrank geworfen. Der Atom-Pc, der da drinne NAS spielt, hat den verfügbaren Raum schön aufgeheizt und trotzdem hat mein Pi nur 51 Grad.

    Ist zwar nur ne Vermutung, da ich Pi-Hole auch erst seit kurzem nutzen und ich mich noch nicht so Intensiv damit befasst habe,

    aber gibt dat bei 5,2 Mio Domains nicht extremes Overblocking? So das der RPi im Hintergrund am Limit arbeitet?

    Mein RPi steht zwischen nem TV Gerät und ner Fritzbox und läuft neben Pi-Hole noch als (r)syslog Server und einigen anderen

    Dingen und kommt selbst bei Aktuellen Temperatur auch nicht über 50 Grad (Im FLIRC Raspberry Pi Case).

    Meistens pendelt der zwischen 40-46 Grad.....

    Läuft seit ein paar Wochen auch endlich mal bei mir.


    Queries Blocked = zwischen 6.000 und 9.000

    Percent Blocked = ImSchnitt 25% / Regelfall 16% bis 30%

    Domains on Blocklist = ca. 1,5 Mio *lol*


    Spontan behaupte ich sogar das die Geschwindigkeit bei "schwächeren" System schneller geworden ist was den Seiten Aufbau betrifft.

    Moin,


    habs zwar nur Überflogen... aber wenn es um die Fritzbox Einstellungen geht,

    streiten sich die Geister. ;)

    Im Pi-Hole Forum gibts dazu nen mittlerweile extrem langen Beitrag und trotzdem

    noch keine "Allgemeine und für alle und jeden Nutzbare Anleitung" :D

    Aber mal zum Groben:

    Erstmal sollte geklärt werden ob du von deinem Internet Anbieter nen

    reinen IPv4 Anschluss hast oder wie z.B.: bei Unitymedia nen DS-Lite und somit

    auch eine öffentliche IPv6 Adresse von deinem Provider vorliegt.

    (Ist nämlich "wichtig" bzw. "nötig" für die IPv6 Einstellungen)


    Wenn wir jetzt mal davon ausgehen das du Pi-Hole als "Standard" User nutzen möchtest

    und daher nicht zwingend DNSSEC einsetzen möchtest stellst du in der Fritzbox unter

    Internet -> IPv4 Einstellungen den DNS Server auf Automatisch.

    Heimnetzwerk -> IPv4 Einstellungen -> Hier trägst du beim DNS Server die IP Adresse

    von deinem Pi-Hole ein.

    Falls du eine öffentliche IPv6 Adresse von deinem Anbieter bekommst muss du unter den

    IPv6 Einstellungen (weiß leider gerade nicht genau wo) die Einstellungen wählen das

    ULA immer Zugewiesen wird und den Punkt das IPv6 nur als DHCP-Server bekannt gemacht wird.

    (Oder so ähnlich, siehst du aber wenn du in dem Bereich bist.

    Falls du eine IPv6 hast, solltest du in der Fritzbox noch beim IPv6 DNS Server die IPv6 Adresse von deinem

    Pi-Hole eintragen. Hiermit ist dann Sichergestellt das die DNS Anfragen von der Fritzbox zum bzw. über den Pi-Hole gehen.


    In den Pi-Hole Settings bei DNS trägst du dann für Custom IPv4 und IPv6 trägst du die IP Adressen deiner Fritzbox ein.

    Dann noch nen Haken bei Use Conditional Forwarding und unter IPv4 die IP Adresse deiner Fritzbox und Local Domain

    fritz.box.


    Damit sollten dann deine Geräte über die Pi-Hole laufen.

    Wichtig ist halt noch das du daran denkst, falls du mal bei irgendeinem Gerät eine feste bzw.

    statische IP Adresse einstellst, immer auch als DNS Server manuell Einstellst und dort

    die IP Adresse deines Pi-Hole nimmst und nicht die der Fritzbox.


    Falls die das auch nicht weiterhilft kann ich dir nur Raten dich im Pi-Hole Forum anzumelden

    und dort im Deutschsprachigen Hilfebereich den Beitrag zur Fritzbox durchliest.

    Der ist auch mit Screenshots usw.



    VG