Posts by Piimp

    sorry hatte nicht ganz verstanden was du mit standalone gemeint hast.
    hab es jetzt wie befohlen gemacht. :)
    jetzt hab ich zumindest eine /etc/init/boblight-dispmanx.conf Datei, aber ich vermute mal an so ner Dateiendung soll es nicht scheitern.
    Leider leuchtet immer noch nix, habe ein 5V 2,5A Netzteil.


    Bin eigentlich auch der Meinung das ich richtig rum verkabelt habe. :daumendreh2:


    [Blocked Image: http://www.bilderhoster.net/thumbs/c6jjc717.jpg]


    [Blocked Image: http://www.bilderhoster.net/thumbs/c2fpvhf7.jpg]


    :helpnew:

    Kann ich irgendwie testen obs vlt schon an der Kette oder dem Netzteil scheitert?
    Habs grad mit ner neuen Noobs Installation versucht, leider auch ohne Erfolg.
    Kann ich die dispmanx irgendwo anders herkriegen?

    hab heute endlich auch meine kette von ali express bekommen und bin dann brav schritt für schritt das tutorial durchgegangen.
    leider leuchtet bei mir nix. :(
    ich vermute das es daran liegt das ich die dispmanx config datei nicht habe. aber wo krieg ich die her?
    als boblight.conf hab ich für den ersten test die aus dem tutorial genommen.


    jemand ne idee warum mir die dispmanx fehlt, bzw wo ich die her kriege?


    Ich nutze Raspbmc mit XBMC 12.2


    dbv du hättest nen deal mit aliexpress aushandeln sollen, bin sicher nicht der einzige hier der deinem link gefolgt ist :)

    Hallo zusammen,


    seit geraumer Zeit kann ich mich nicht mehr im Youtube Addon einloggen. Vorher hat das immer funktioniert und er hat mich damals auch nach meinem Authentifizierungs Code gefragt.


    Hatte jemand das selbe Problem und hat ne Lösung dafür gefunden?

    bin echt beeindruckt. fand es echt schwer zu lesen, auf grund der vielen sonderzeichen. danke, habs mir gleich mal gespeichert.
    das kenn ich aus meine programmiersprachen nciht so extrem :) (abap, java, cobol)
    find es auch irgendwie witzig das ein if mit fi beendet wird :)


    funktioniert nur leider nicht, interessant finde ich auch das am anfang das echo und synch noch gemacht werden



    [hr]
    wenn das am anfang funktioniert müsste es ja eigentlich am crontab liegen, aber da hab ich bis auf den namen nix geändert seit dem letzten mal.


    Code
    # m h dom mon dow user  command
    17 *    * * *   root    cd / && run-parts --report /etc/cron.hourly
    25 6    * * *   root    test -x /usr/sbin/anacron || ( cd / && run-parts --repo$
    47 6    * * 7   root    test -x /usr/sbin/anacron || ( cd / && run-parts --repo$
    52 6    1 * *   root    test -x /usr/sbin/anacron || ( cd / && run-parts --repo$
    #
    */3 10-23 * * * root    /home/pi/anti_idle.sh > /home/pi/anti_idle.log 2>&1
    */3 0-1 * * *   root    /home/pi/anti_idle.sh > /home/pi/anti_idle.log 2>&1

    danke, werd ich dann gleich mal probieren.


    aber damit ich auch was dabei lerne was genau bedeutet das alles?


    Der hintere Teil aktualisiert den Timestamp, aber was macht der vordere Teil?
    Und was macht das fi? Den rest kann ich mir erklären?

    Code
    ...
    [ ! -f /tmp/.hdd ] && touch /tmp/.hdd
    ...
    fi
    ...

    Nein ich schalte das Pi schon zwischen durch auch aus. Versteh nur nicht wie eine angelegte Datei ein Skript pausieren kann.


    Ich schalte mein Pi abends irgendwann an, gucke paar Videos online und dann will ich vlt mal was von der Platte gucken, dann hab ich bisher das Pi neugestartet damit die Platte wieder erkannt wird. Das will ich jetzt nur noch machen müssen wenn das Anschalten 4 Stunden her ist. Wenn ich irgendwo hin gehe oder längere Zeit nicht vorhabe das Pi zu nutzen schalte ich es auch generell aus.

    Es funktioniert wirklich. Klappt genau so wie ich es mir vorgestellt habe.
    Habe auch sowohl echo als auch touch probiert und es hat beides geklappt.
    Ein ls allerdings reicht nicht aus.


    Nachdem ich gestern eingeschlafen bin während das pi noch lief, hab ich mir heute überlegt ob es eine möglichhkeit gibt das das script nur 3-4 Stunden lang läuft.
    Entweder Zeit basiert oder vlt auch per Zähler, dann müsste ich halt ausrechnen wie oft das Script laufen soll.


    Hat jemand ne idee ob das geht?

    Quote


    Bist du sicher das du das Script ausführbar gemacht hast? -> chmod +x /home/pi/script.sh


    Ich glaub daran lags.
    Hab das grad gemacht und jetzt funktioniert das Script. Jetzt muss ich nur noch sehen ob mein Plan jetzt auch klappt und die Platte weiter funktioniert.


    Riesen Dank erstmal.

    Ah Ok, das erklärt warum die MTA Meldung bei der WEiterleitung in die log Datei nicht mehr kommt.


    Code
    root@raspbmc:~# ls -la /media/Kelly/cron_files
    total 4
    drwx------ 1 pi pi    0 Sep 20 17:32 .
    drwx------ 1 pi pi 4096 Sep 20 17:32 ..



    .sh benutze ich da das in dem Cronjob Tutorial hier im Forum benutzt wurde. :)

    So ich hab jetzt mal in das syslog geguckt und es scheint als würde mir MTA fehlen. Was auch immer das bedeutet

    Code
    Oct 11 18:35:59 raspbmc cron[1478]: (CRON) INFO (pidfile fd = 3)
    Oct 11 18:35:59 raspbmc cron[1484]: (CRON) STARTUP (fork ok)
    Oct 11 18:35:59 raspbmc cron[1484]: (CRON) INFO (Running @reboot jobs)
    Oct 11 18:36:01 raspbmc CRON[1486]: (root) CMD (   /home/pi/script.sh)
    Oct 11 18:36:01 raspbmc CRON[1485]: (CRON) info (No MTA installed, discarding output)
    Oct 11 18:36:06 raspbmc kernel: bcm2708 watchdog, heartbeat=10 sec (nowayout=0)
    Oct 11 18:38:01 raspbmc CRON[1510]: (root) CMD (   /home/pi/script.sh)
    Oct 11 18:38:01 raspbmc CRON[1509]: (CRON) info (No MTA installed, discarding output)


    Wie führe ich denn ein Script manuell aus?




    Mit echo

    Bash
    #!/bin/bash
    
    
    echo 1 > /media/Kelly/cron_files/temp.txt && sync
    
    
    exit 0



    krieg ich folgende Meldung

    Code
    /bin/sh: 1: /home/pi/script.sh: Permission denied

    Vielen Dank für die schnellen Antworten.
    Habe jetzt erstmal das Leerzeichen rausgenommen. Funktioniert aber weiterhin nicht.
    Konnte aber auch noch nicht in die logdatei gucken was dort steht. Trotzdem hätte ja eine Datei da sein müssen.
    Werde morgen Nachmittag den Echo Befehl probieren.
    Wie muss der synch Befehl aussehen und muss der gemacht nur beim Echo gemacht werden?

    Hallo zusammen,


    ich hatte das vor paar Tagen schon mal in nem erleidigten Thema angefragt, aber da gabs keine Reaktionen, da ich mir eh nicht sicher war obs noch zu dem Thema gehört also hier nen neues Thema.


    Ich hab das Problem das sich meine Toshiba Store Basic nach sehr kurzer Zeit in Standby geht und das Pi dann nicht mehr drauf zugreifen kann. Beim Versuch zu zugreifen hängt sich das Pi dann auf.
    Nach diversen Versuchen die Standby Zeit zu ändern war meine Idee ein Cronjob zu machen der alle paar Minuten ne Datei auf die Platte schreibt und somit der Standby verhindert wird.


    [font="Tahoma, Verdana, Arial, sans-serif"]Leider funktioniert mein Versuch nicht und ich weiß auch nicht so richtig was ich anders machen soll.[/font]


    Mein Crontab sieht so aus




    Und mein Script sieht so aus



    Code
    GNU nano 2.2.6           File: /home/pi/script.sh
    
    
    #!/bin/bash
    
    
    touch /media/Kelly/cron_files/temp.txt
    
    
    exit 0


    Ich hoffe ihr könnt mir hier weiterhelfen.

    Jetzt bin ich endlich mal dazu gekommen mich weiter um mein Pi zu kümmern und mich endlich mal mit Cronjobs auseinander zusetzen. Leider funktioniert mein Versuch nicht und ich weiss auch nicht so richtig was ich anders machen soll.


    Mein Crontab sieht so aus



    Und mein Script so


    Code
    GNU nano 2.2.6           File: /home/pi/script.sh
    
    
    #!/bin/bash
    
    
    touch /media/Kelly/cron_files/temp.txt
    
    
    exit 0