Posts by Kai-Benjamin

    Hallo,


    ich habe ein kleines Problem.


    Auf meinem Raspberry Pi mit Raspbian läuft FHEM im Hintergrund. Nun kann ich FHEM über Chromium am TouchDisplay im Kiosk Modus anzeigen lassen. Das klappt auch alles super. Nun soll aber folgendes funktionieren:


    Ich möchte durch einen Tastendruck auf eine GPIO-Taste immer wieder auf eine Webseite zurück: http://192.168.178.77:8083 (im Heimnetz hinterlegtes FHEM).


    1. Mein Raspberry Pi wird hochgefahren (funktioniert super)

    2. Chromium wird im Kiosk Modus mir dem Webinterface von FHEM (http://192.168.178.77:8083) angezeigt (funktioniert super)

    3. Ich klicke auf einen Link auf der FHEM Oberfläche --> eine andere, von mir nicht veränderbare Seite wird geöffnet (http://www.irgendwas.de/was/weis/denn/ich.htm) (funktioniert super)

    Jetzt das was nicht funktioniert:

    4. Ich möchte ohne Tastatur und ohne Maus (aber dafür ggf. mit GPIO) wieder zurück zur Ausgangsseite (http://192.168.178.77:8083) (klappt noch nicht)


    Chromium soll also durch einen Button (GPIO) gestern werden.


    Wie kann ich das realisieren? Das würde mich brennend interessieren und ich würde mich sehr freuen, wenn sich jemand meinem Problem annehmen könnte.


    Ich danke Euch schon mal im Voraus.


    Kai aus Oberfranken.

    Hallo zusammen,


    ich habe eine Frage zu meinem neuen 7" TouchDisplay, das ich mit meinem Raspberry Pi verbunden habe. Das TouchDisplay ist original von Raspberry Pi und für Diesen. In meinem Vorhaben möchte ich eine Heimautomatisierung für unser kleines Haus realisieren. Dazu eignet sich dieses wunderbare Gerät hervorragend.

    Ich habe bereits die notwendige Software installiert eingerichtet und programmiert. Also das Display funktioniert soweit auch ganz gut.

    Nun möchte ich über den Befehl

    Code
    echo 0 > /sys/class/backlight/rpi_backlight/bl_power

    das Display einschalten und über

    Code
    echo 1 > /sys/class/backlight/rpi_backlight/bl_power

    das Display wieder ausschalten können. Auch das geht, solange bis das Display nicht in den Stromspaarmodus geschickt wird. Dies passiert nach ein paar Minuten (ca. 10 bis 20Minuten) dann bekomme ich das Display über die angegebenen Befehle nicht mehr an.


    Ich habe bereits in der Datei "

    sudo nano /home/pi/.config/lxsession/LXDE-pi/autostart" folgende Änderung vorgenommen:

    Leider ohne Erfolg.


    Kann mir jemand helfen, dass mein tolles neues 7"TouchDisplay von Raspberry Pi nicht immer wieder aus geht, sondern einfach mal abbleibt? Damit wäre mir sehr viel geholfen, und mein Vorhaben gerettet.


    Ich bin sehr dankbar für jeden Hinweis.

    Eine Frage am Rande: Nach jedem Neustart muss ich, bevor ich die beiden oben genannten Befehle für DisplayEIN und DisplayAUS verwenden kann, folgenden Befehl in das Terminal eingeben:

    Code
    sudo chmod 777 /sys/class/backlight/rpi_backlight/bl_power

    kann ich diese Eingabe automatisieren, sodass ich diese Zeilen nicht mehr eingeben muss, und direkt mit den Befehlen


    Code
    echo 0 > /sys/class/backlight/rpi_backlight/bl_power

    und

    Code
    echo 1 > /sys/class/backlight/rpi_backlight/bl_power

    arbeiten kann?


    Aber das nur am Rande.



    Vielen herzlichen Dank für alle Hinweise, Hilfestellungen und weiterführenden Gedanken.


    KBLc