Beiträge von zackdvd

    Möchtest du jetzt eine allgemeine Auskunft oder gezielt deinen Fall behandelt haben?

    Hallo, danke für eure Antworten.

    Ich denke dass muss man von beiden Seiten anpacken. Das Problem ist ja, dass es nicht so einfach reproduzierbar ist, was ein einfaches Testen erschwert.


    Generell kenne ich die Hintergründe zu Schäden bei SD-Karten (häufiges schreiben) und Dateisystemschäden. Mich wunderte aber, dass nach einem Monat die Sd-Karte schon Probleme machte. Meiner Meinung nach kann das nicht von zu vielen Schreibzugriffen kommen. Denn auf dem System passiert doch ziemlich wenig. Wenn es von der normalen Nutzung kommen würde hätten einfach viel viel mehr User auch diese Probleme mit.


    Aus diesem Grund wollte ich hören, was es für allgemeine Probleme neben vielem Schreiben geben kann, wie z.B. Spannungsschwankungen.

    Vielleicht sollte ich es nochmal mit einem "normalen" micro-SD Steckernetzteil probieren und beobachten.


    Wie gesagt, die erste Karte ist ganz defekt, nicht nur das Dateisystem, und nun bei der zweiten neuen Karte nach einem Monat schon Dateisystemfehler, ohne dass es zum Absturz oder hartem Abschalten gekommen ist.


    Dank euch.

    Ja das passt schon. Viel mehr geht es mir aber darum rauszufinden was dazu führen kann.

    Ich hätte ja gedacht, dass hier solche Fehler schon mal aufgetreten wären und dann an Spannungsschwankungen, äußere Einwirkungen oder sowas was gelegen haben.

    Aber davon habt ihr ja noch nichts erwähnt. D.h. zusammengefasst kann man sagen, dass wenn es Probleme gab es an zu vielen Schreibzugriffen lag?

    Hi, also fsck hab ich händisch laufen lassen und er hat haufenweise inodes korrigiert. Ob er alles richtig korrigiert hat, weiß ich nicht.

    Das meinte ich mit meiner Aussage.


    Tatsächlich sind zwei Dateien im lost+found, zwei c files.

    rpi-firmware/triangle2.c und firmware/Makefile at master · raspberrypi/firmware konnte ich rausfinden.

    "kleinkram"... Zufällig irgend etwas was ständig auf der SD herumschreibt und sei es nur temporärer Müll?

    homebridge schreibt zumindest Logfiles und das nicht zu knapp, je nach installierten Plugins sogar noch mehr.


    Nein nein, ich hätte das schon erwähnt. Aber es kann doch wohl nicht sein, dass nach einem Monat die SD Karte defekt ist nur weil homebridge loggt? Da wären aber nun schon mehrere Foren Beiträge über sowas zu lesen.

    Ich meine ich hätte alle Fragen beantwortet, was fehlt dir noch an Infos zur Analyse?

    Hilft es hier die Paketliste zu posten? Installiert hab ich es per netinst image, standard-Einstellungen.


    Gibt es sowas wie top für Schreibzugriffe, oder kann top das?


    hyle : die erste Karte war defekt, die zweite hatte jetzt "nur" Dateisystemfehler. Bin nicht sicher, ob die alle repariert werden konnten. Gibt es einen Paketcheck oder sowas?

    Danke für eure Rückmeldungen, anbei noch ein paar Infos:


    Karte:

    Kingston SDC10G2/16GB microSD Klasse 10, UHS-1

    Schrott? Die vorherige muss ich nochmal schauen, was das war.


    An Prozessen kann ich nix ausmachen, wie gesagt frisch installiert, Net-image raspbian stretch.

    Dann noch homebridge und kleinkram. Kann mir nicht vorstellen, dass es daher rühren würde.


    Warm wird die Karte nicht, ist alles gut belüftet. Pi ist meistens im Leerlauf.

    Ausgeschaltet wird der fast nie, wenn dann nach poweroff.

    Hallo zusammen,

    ich habe es schon in einem anderen Thread beschrieben, aber es macht wohl mehr sinn einen eigenen dafür zu starten.


    Bei mir sind in den letzten 6 Monaten zwei Karten hinüber.

    Die letzte war irgendwann so defekt, dass man nicht mehr schreiben konnte. Also das Betriebssystem dachte es kann schreiben, es wurde aber nichts geschrieben. Einhergehend mit defekten inodes etc.


    Nun ist vor ein paar Tagen ähnliches passiert: Beim starten eines Programms kamen Fehlermeldungen, dass libs nicht gefunden werden können. Ohne relevante google Ergebnisse. Ein Reboot brachte das System dann zum stillstand, der Kernel wurde noch geladen, aber ab dem init Prozess gab es Fehler ala smbol fileno, version not defined in GLIBC_2.4 mit anschließender kernel panic.


    Auf einem anderen System konnte ich fsck laufen lassen, der zich inode Fehler beseitigt hat. Und jetzt läuft es auch lange nicht rund.

    Apt funktioniert nicht mehr richtig etc.


    Da muss also irgendwas systematisch nicht in Ordnung sein. Das System habe ich vor einem Monat von raspbian stretch neu auftesetzt und jetzt meiner Meinung nach keine kuriosen Packete installiert, die auf der SD rumhacken.


    Kann es vielleicht an der Stromversorung liegen? Habe ein größeres Netzteil und keine zusätzlichen Verbraucher (https://www.pollin.de/p/schalt…l-voltek-spec7188b-350012).

    Gibt es damit Probleme?

    Kann es anderen Störeinflüsse geben? Habt ihr Erfahrung damit gemacht, dass sich das auf die SD Karte auswirken kann?

    Die SD Karte war neu und lief anfangs ohne Probleme.


    Irgendwelche Ideen?


    Danke!

    Auch wenn du ein ähnliches Problem hast wäre es höflich (und besser) einen eigenen Thread zu erstellen.

    Wenn in einem Thread mehrere "ähnliche" Themen behandelt werden entsteht schnell Chaos.

    OK klar, wollte jetzt extra nicht ein Duplikat eröffnen um so den Unmut auf mich zu ziehen, hat nicht geklappt :-D

    Dann mache ich es jetzt gleich.

    Hallo zusammen,


    ich habe ein ähnliches Problem und bin nun auf den Beitrag gestoßen. Bei mir sind auch in den letzten 6 Monaten zwei Karten die Übeltäter gewesen.

    Die letzte war irgendwann so defekt, dass man nicht mehr schreiben konnte. Also das Betriebssystem dachte es kann schreiben, es wurde aber nichts geschrieben. Einhergehend mit defekten inodes etc.


    Nun ist vor ein paar Tagen ähnliches passiert: Beim starten eines Programms kamen Fehlermeldungen, dass libs nicht gefunden werden können. Ohne relevante google Ergebnisse. Ein Reboot brachte das System dann zum stillstand, der Kernel wurde noch geladen, aber ab dem init Prozess gab es Fehler ala smbol fileno, version not defined in GLIBC_2.4 mit anschließender kernel panic.


    Auf einem anderen System konnte ich fsck laufen lassen, der zich inode Fehler beseitigt hat. Und jetzt läuft es auch lange nicht rund.

    Apt funktioniert nicht mehr richtig etc.


    Da muss also irgendwas systematisch nicht in Ordnung sein. Das System habe ich vor einem Monat von raspbian stretch neu auftesetzt und jetzt meiner Meinung nach keine kuriosen Packete installiert, die auf der SD rumhacken.


    Kann es vielleicht an der Stromversorung liegen?

    jolanda-anne : was hast du für eine Stromversorung?


    Kann es anderen Störeinflüsse geben? Habt ihr Erfahrung damit gemacht, dass sich das auf die SD Karte auswirken kann?


    Danke!