Posts by Beatfussel

    rpi444

    Das war dann wohl des Rätzels Lösung :thumbup::bravo2::thumbup:


    Somit sollte man folgendes beachten wenn man ein WLAN mit hidden SSID nutzt.


    Vor dem Update

    Code
    scan_ssid=1

    in die wpa_supplicant.conf eingetragen.


    Dann Update durchführen


    apt-get update

    apt-get dist-upgrade

    reboot


    und nach dem Neustart bleibt der Pi nicht hängen.

    Code
    pi@homepizabbix:~ $ uname -a
    Linux homepizabbix 4.9.59-v7+ #1047 SMP Sun Oct 29 12:19:23 GMT 2017 armv7l GNU/Linux


    Code
    ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
    update_config=1
    country=DE
    
    network={
            ssid="***********"
            psk="************"
            scan_ssid=1
    }

    Vielen Dank!

    Habe eine Fritzbox 7490.


    Bei meinem zweite Pi habe ich folgende Konfiguration erfolgreich laufen.


    Code
    pi@homepizabbix:~ $ uname -a
    Linux homepizabbix 4.9.59-v7+ #1047 SMP Sun Oct 29 12:19:23 GMT 2017 armv7l GNU/Linux
    Code
    ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
    update_config=1
    country=DE
    
    network={
            ssid="***********"
            psk="************"
    }

    Update wurde noch nicht durch geführt. Anbei die Simulation.


    D. h., ein "rpi-update" war gar nicht erforderlich?

    Doch es war erforderlich das ich den Pi wieder benutzen konnte ohne das WLAN Interface down nehmen zu müssen. Sorry ich dachte Deine Frage bezog sich darauf wie ich das Update gemacht hatte das zu dem Problem führte.


    Anbei die Ausgabe:

    Code
    pi@homepi:~ $ sudo apt-get -s dist-upgrade
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut.
    Statusinformationen werden eingelesen.... Fertig
    Paketaktualisierung (Upgrade) wird berechnet... Fertig
    0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.


    Ist aber auch der neue Kernel.


    Code
    pi@homepi:~ $ uname -a
    Linux homepi 4.14.18-v7+ #1093 SMP Fri Feb 9 15:33:07 GMT 2018 armv7l GNU/Linux

    Hallo zusammen,


    sorry hatte Gestern leider keine Zeit um zu testen. Habe übrigens die gleiche WLAN Konfiguration wie coyotelinux . Also mit versteckte SSID.


    Mein Problem konnte mit

    Code
    scan_ssid=1

    behoben werden.


    Vielen Dank an coyotelinux und rpi444!


    Evtl. sollte man hier (d. h. ohne "rpi-update" bzw. ohne den neuen Kernel) weiter suchen. War es ein "upgrade" oder ein "dist-upgrade"?

    Ich habe das Update mit apt-get upgrade durchgeführt. Siehe Auszug aus dem history.log

    Code
    Start-Date: 2018-02-07  20:01:26
    Commandline: apt-get upgrade
    Requested-By: pi (1000)
    Upgrade: firmware-realtek:armhf (1:20161130-3+rpi2, 1:20161130-3+rpt1), pi-bluetooth:armhf (0.1.6, 0.1.7), firmware-atheros:armhf (1:20161130-3+rpi2, 1:20161
    130-3+rpt1), firmware-libertas:armhf (1:20161130-3+rpi2, 1:20161130-3+rpt1), firmware-brcm80211:armhf (1:20161130-3+rpi2, 1:20161130-3+rpt1), firmware-misc-n
    onfree:armhf (1:20161130-3+rpi2, 1:20161130-3+rpt1)
    End-Date: 2018-02-07  20:01:35   

    Danke nochmal!

    Ey cool, das ist ja ein richtiger Fortschritt. scnr (Jaja, ich halt ja schon die Klappe, ist ja ein TestPi...)

    Bitte spare dir doch diese Kommentare wenn Du nicht helfen möchtest. Finde das ziemlich unangebracht. Aber das nur am Rande.


    Ich dachte das ist hier ein Forum in dem Hilfe von anderen bekommen kann und man sich nicht für sein handeln rechtfertigen muss.

    Sieht bei mir ähnlich aus. Bis auf der verbundene Adapter

    Code
    pi@homepi:~ $ uname -a
    Linux homepi 4.14.18-v7+ #1093 SMP Fri Feb 9 15:33:07 GMT 2018 armv7l GNU/Linux
    Code
    pi@homepi:~ $ dmesg | grep brcm
    [    3.823421] brcmfmac: F1 signature read @0x18000000=0x1541a9a6
    [    3.829148] brcmfmac: brcmf_fw_map_chip_to_name: using brcm/brcmfmac43430-sdio.bin for chip 0x00a9a6(43430) rev 0x000001
    [    3.829374] usbcore: registered new interface driver brcmfmac
    [    4.123226] brcmfmac: brcmf_c_preinit_dcmds: Firmware version = wl0: Oct 23 2017 03:55:53 version 7.45.98.38 (r674442 CY) FWID 01-e58d219f
    [    4.124137] brcmfmac: brcmf_c_preinit_dcmds: CLM version = API: 12.2 Data: 7.11.15 Compiler: 1.24.2 ClmImport: 1.24.1 Creation: 2014-05-26 10:53:55 Inc Data: 9.10.39 Inc Compiler: 1.29.4 Inc ClmImport: 1.36.3 Creation: 2017-10-23 03:47:14
    [    5.320044] brcmfmac: power management disabled
    Code
    pi@homepi:~ $ iwconfig wlan0
    wlan0     IEEE 802.11  ESSID:off/any
              Mode:Managed  Access Point: Not-Associated   Tx-Power=31 dBm
              Retry short limit:7   RTS thr:off   Fragment thr:off
              Power Management:on

    Hallo zusammen,


    ich habe seit dem letzten Update auf meinem Raspberry Pi 3 folgendes Problem. Sobald der WIFI Interface in den "up" Status geht hängt sich der Pi auf und ich kann nicht mehr drauf zugreifen. Momentan deaktiviere ich nach dem Starten das WLAN mit sudo ifconfig wlan0 down. Somit kann ich zu mindestens per LAN arbeiten. Würde gerne aber wieder das WLAN nutzen. Daher meine Bitte um Hilfe.


    Bis jetzt habe ich meinen WLAN Adapter zurückgesetzt und neu eingerichtet. Aber bisher alles ohne Erfolg.


    Anbei das Update History log:


    Start-Date: 2018-02-07 20:01:26

    Commandline: apt-get upgrade

    Requested-By: pi (1000)

    Upgrade: firmware-realtek:armhf (1:20161130-3+rpi2, 1:20161130-3+rpt1), pi-bluetooth:armhf (0.1.6, 0.1.7), firmware-atheros:armhf (1:20161130-3+rpi2, 1:20161

    130-3+rpt1), firmware-libertas:armhf (1:20161130-3+rpi2, 1:20161130-3+rpt1), firmware-brcm80211:armhf (1:20161130-3+rpi2, 1:20161130-3+rpt1), firmware-misc-n

    onfree:armhf (1:20161130-3+rpi2, 1:20161130-3+rpt1)

    End-Date: 2018-02-07 20:01:35


    Da hier die Treiber upgedatet wurden vermute ich eine Zusammenhang.


    Vielen Dank!