Posts by mtacki

    Das bestätigt meine Vermutung, Dein Reader wird als /dev/ttyUSB0 eingebunden. Probier doch mal ein cat /dev/ttyUSB0 (ggfs. mit sudo, falls Du einen Fehler wegen fehlender Rechte bekommst, und zieh dann mal einen RFID-chip drüber. Dann sollte eigentlich zumindest irgendwas passieren.


    Welchen Reader hast Du denn genau und hast Du eine Anleitung oder ein Datenblatt dazu?

    nee - dann passiert auch nix.

    Terminal bleibt dann in diesem Zustand...



    Das sieht für mich so aus, als würde Dein Reader nicht eine Tastatur, sondern eine serielle Schnittstelle emulieren. Kannst Du denn mal die Ausgabe von tail -f /var/log/messages posten, während Du den Reader einstöpselst?

    Hier hat jemand einen Raspberry-Treiber für den verwendeten USB-Serial-Konverter gepostet, ist allerdings schon zwei Jahre alt.

    Das kommt dabei heraus...


    Feb 27 18:25:57 raspberrypi kernel: [ 27.983310] usb 1-1.2: New USB device found, idVendor=1a86, idProduct=7523

    Feb 27 18:25:57 raspberrypi kernel: [ 27.983325] usb 1-1.2: New USB device strings: Mfr=0, Product=2, SerialNumber=0

    Feb 27 18:25:57 raspberrypi kernel: [ 27.983333] usb 1-1.2: Product: USB2.0-Serial

    Feb 27 18:25:57 raspberrypi mtp-probe: checking bus 1, device 4: "/sys/devices/platform/soc/3f980000.usb/usb1/1-1/1-1.2"

    Feb 27 18:25:57 raspberrypi mtp-probe: bus: 1, device: 4 was not an MTP device

    Feb 27 18:25:57 raspberrypi kernel: [ 28.053891] usbcore: registered new interface driver usbserial

    Feb 27 18:25:57 raspberrypi kernel: [ 28.053981] usbcore: registered new interface driver usbserial_generic

    Feb 27 18:25:57 raspberrypi kernel: [ 28.054073] usbserial: USB Serial support registered for generic

    Feb 27 18:25:57 raspberrypi kernel: [ 28.056753] usbcore: registered new interface driver ch341

    Feb 27 18:25:57 raspberrypi kernel: [ 28.056856] usbserial: USB Serial support registered for ch341-uart

    Feb 27 18:25:57 raspberrypi kernel: [ 28.056936] ch341 1-1.2:1.0: ch341-uart converter detected

    Feb 27 18:25:57 raspberrypi kernel: [ 28.059028] usb 1-1.2: ch341-uart converter now attached to ttyUSB0

    ich glaube auch -

    ich habe den Reader jetzt mal der Vollständigkeit halber an einen Raspi II angeschlossen...

    gleiches Resultat.


    Habe den Verkäufer angeschrieben...

    dummerweise nicht von Amazon direkt sondern einem "Shop"

    Mal schauen ob die auch so kulant sind :-/

    Vielen Dank für die rasche Antwort !


    Habe diese Anleitung hier gefunden:

    https://forum-raspberrypi.de/a…icz-flor-mit-buttons-pdf/


    Leider komme ich gar nicht so weit, den Reader im Skript anzumelden.

    In allen Anleitungen steht dass man den Reader per USB einsteckt und ab dann sollte er jedes Mal wenn man eine Karte darüber zieht piepen.

    Er würde als "keyboard" angemeldet und daher quasi den Zeichenstring und "Enter" in ein z.B. offenes Textfeld etc. schicken.

    Mein Kartenleser piept aber nicht wenn ich eine Karte dagegenhalte.

    Und er wird beim Raspi auch nicht als Keyboard registriert sonder so:


    Bus 001 Device 004: ID 1a86:7523 QinHeng Electronics HL-340 USB-Serial adapter

    Device Descriptor:

    bLength 18

    bDescriptorType 1

    bcdUSB 1.10

    bDeviceClass 255 Vendor Specific Class

    bDeviceSubClass 0

    bDeviceProtocol 0

    bMaxPacketSize0 8

    idVendor 0x1a86 QinHeng Electronics

    idProduct 0x7523 HL-340 USB-Serial adapter


    Ist das Teil defekt ??

    USB Kabel hab ich schon getauscht.

    Beim "PowerOn" piept er einmal - danach leuchtet die kleine LED konstant rot als würde er auf Input warten...


    LG,

    Mark

    Hallo zusammen !

    Ich habe das gleiche Setup wie bereits beschrieben - und in dem Beitrag von Dellex fotografiert.


    Das Setup klappt soweit problemlos - nur werde ich nicht ganz schlau aus dem RFID Kartenleser...

    Ich habe auch das Modell M302 (USB-Anschluss)


    Er piept auch brav wenn er Strom über den USB Port bekommt.

    Die Diode am Reader leuchtet daraufhin konstant rot.


    Nur, wenn ich eine Karte dagegen halte passiert nichts.

    Laut anderer Beschreibungen sollte er den gleichen Piepton von sich geben !?


    Oder muss er zunächst "installiert" werden ?


    Die Karten sind mit dem Reader zusammen geliefert werden - sollten also kompatibel sein !


    Ich bin gespannt auf Eure Antworten und freue mich auf das Projekt ! :-)


    NACHTRAG...

    bei weiterer Recherche ist mir etwas aufgefallen...


    $ sudo lsusb -v liefert :


    Bus 001 Device 004: ID 1a86:7523 QinHeng Electronics HL-340 USB-Serial adapter

    Device Descriptor:

    bLength 18

    bDescriptorType 1

    bcdUSB 1.10

    bDeviceClass 255 Vendor Specific Class

    bDeviceSubClass 0

    bDeviceProtocol 0

    bMaxPacketSize0 8

    idVendor 0x1a86 QinHeng Electronics

    idProduct 0x7523 HL-340 USB-Serial adapter

    bcdDevice 2.62

    iManufacturer 0

    iProduct 2 USB2.0-Serial

    iSerial 0

    bNumConfigurations 1

    Configuration Descriptor:

    bLength 9

    bDescriptorType 2

    wTotalLength 39

    bNumInterfaces 1

    bConfigurationValue 1

    iConfiguration 0

    bmAttributes 0x80

    (Bus Powered)

    MaxPower 98mA

    Interface Descriptor:

    bLength 9

    bDescriptorType 4

    bInterfaceNumber 0

    bAlternateSetting 0

    bNumEndpoints 3

    bInterfaceClass 255 Vendor Specific Class

    bInterfaceSubClass 1

    bInterfaceProtocol 2

    iInterface 0

    Endpoint Descriptor:

    bLength 7

    bDescriptorType 5

    bEndpointAddress 0x82 EP 2 IN

    bmAttributes 2

    Transfer Type Bulk

    Synch Type None

    Usage Type Data

    wMaxPacketSize 0x0020 1x 32 bytes

    bInterval 0

    Endpoint Descriptor:

    bLength 7

    bDescriptorType 5

    bEndpointAddress 0x02 EP 2 OUT

    bmAttributes 2

    Transfer Type Bulk

    Synch Type None

    Usage Type Data

    wMaxPacketSize 0x0020 1x 32 bytes

    bInterval 0

    Endpoint Descriptor:

    bLength 7

    bDescriptorType 5

    bEndpointAddress 0x81 EP 1 IN

    bmAttributes 3

    Transfer Type Interrupt

    Synch Type None

    Usage Type Data

    wMaxPacketSize 0x0008 1x 8 bytes

    bInterval 1

    Device Status: 0x0000

    (Bus Powered)



    Das ist der RFID Reader... wenn ich den abnabele verschwindet er auch aus der USB-Liste...

    Nur wird der nicht - wie erwartet als Reader identifiziert...

    Irgendwas ist da komisch !??



    LG,

    Mark