Posts by Mateusz224

    Hej danke für die schnelle Antwort aber chromium braucht beim booten 1-2 Sekunden länger :)


    übertaktet auf 800MHz
    mein memory split ist 128 GPU.. was wäre zu empfehlen?
    im Hintergrund läuft eigentlich kein Prozess vielleicht mein C Programm, dieses ist aber auf eine feste CPU Zeit von 1% reduziert
    Mein Pogramm schließt immer wieder X11 und somit auch midori und startet es neu, also vermute ich, dass die Informationen sich noch im RAM befinden müssten, (nach dem ersten Aufruf) und so die SD karte keine Rolle mehr spielen dürfte oder liege ich da falsch?


    Kann man sonst noch irgendwie irgendwo etwas einsparen?
    bin dankbar für jeden Tip :)

    Hi,
    ich brauche einen ultra schnelln Webbrowser dierser sollte vor allem sehr schnell booten bzw. starten. Viel schneller als Midor. Sonst keine großen Anforderungen, ausser dass er .jpg dateien darstellen kann (ich kenne mich in diesem Gebiet nicht sonderlich aus, ob das alle können).


    Kann mir jemand da weiterhelfen?



    Beste Grüße aus dem Norden

    Hej ne das ist leider nicht das was ich brauch mein Programm soll später in der Datei:


    /usr/share/X11/xorg.conf.d/10-evdev.conf


    die konfiguartion ändern/überschreiben und dazu muss diese Datei neu eingelesen werden.



    wenn mein Programm ausserhalb von X11 gestartet wird also nicht im LXterminal dann ist das kein Kind prozess mehr und dürfte das dann funktionieren? Oder kann das auch an was anderem liegen?



    Und noch eine grundsätzliche Frage:
    Wenn ich mein Programm mit sudo aufrufe und dann system("xxx") irgendwo stehen habe wird dieser Befehl auch als administrator Befehl ausgeführt? und wenn ja wie kann ich in meinem Programm, Programme starten mit Admin rechten und ohne admin rechte?

    Hej,
    also mein Problem ist, dass ich versuche meinen Xserver neu zu starten. Im Programm habe das erstmal ganz simple verucht mit:


    Code
    system ("killall /usr/bin/lxsession");
    system("startx");


    die erste Zeile Code führt er auch aus und ich muss mich dann auf einer Gui anmelden mit Benutzernamen und passwort. Aber er startet den Xserver nicht neu (bzw erst nach dem anmelden und das möchte ich nicht).
    Liegt das daran, dass ich das im LXterminal gestartet habe und mit killall lxsession auch den kindprocess lxterminal "gekillt" habe bevor er den befehl ausgeführt hat?
    oder muss ich mich neu anmelden und irgendwie mein Passwort und benutzernamen übergeben?
    Letzendlich möchte ich den Xserver sauber schließen und neu starten. Der Lösungsweg ist egal.


    Und als zweites:
    ich würde gerne midori offen lassen so das der Xserver nicht jedes mal diesen neu starten muss... jedoch ist midori ja auch ein Kindprocess von lxsession gibt es da eine Möglichkeiten?


    PS: Betriebssystem Rasbian


    Beste Grüße aus dem Norden ;)

    Noch eine Frage wie könnte ich den eventuell noch schneller zum drehen bekommen mehr GPU? schnellere SD Card?
    Und gibt es eine Möglichkeit dass ich den Bildschirm zu drehe ohne dass ich Midori neu starten muss? Denn das kostet wieder Zeit...

    Hej
    er dreht tatsächlich den XServer nach dem Booten im Uhrzeigersinn und wenn ich jetzt xrandr eintippe bekomme ich:


    Code
    pi@raspberrypi ~$ xrandr
    Randr extension missing


    also mit CW und CWW ändern und den X11 neu starten funktioniert jetzt... etwas langsam ( 5 Sekunden bei max. Übertaktung) aber es funktioniert :D .

    Gibt es sonst jemanden der Interesse hätte so etwas zu Programmieren? Oder kann mir jemand weiterhelfen wo ich jemanden finden würde? Denn Teamdevel ist leider anscheinend zu beschäftigt.
    Freue mich auch über jeden Tipp wo wie ich jemanden finden kann...

    Super, danke für deine Einschätzung! Trotzdem würde ich mich mal kurz mit dem Framebuffer auseinandersetzen, auch wenn das nicht funktionieren sollte, ist das sicherlich interessant. Kannst du mir dazu ein Buch oder irgendwelche Seiten empfehlen?

    kann das der Grund sein, dass xrandr nicht funktioniert?



    Code
    pi@raspberrypi ~ $ xrandr --output default --rotate left
    
    
    xrandr: output default cannot use rotation "left" reflection "none"

    danke, aber mein Programm soll dynamisch den Bildschirm drehen können (innerhalb von 1 - 1,5 Sekunden). In der config geänderte Daten muss ein Neustart folgen, was viel zu lange dauert...

    Hmmm hört sich interessant an... habe auch vom Teamdevel den Tipp erhalten mit xrandr die zu rotieren. Auf meinem Ubuntu funktioniert das auch aber wenn ich das aufm raspi eingebe bekomme ich folgende Fehlermeldung:


    Code
    pi@raspberrypi ~ $ xrandr --output default --rotate left
    xrandr: output default cannot use rotation "left" reflection "none"


    woran kann das liegen?

    Hi ich suche jemanden der sich mit der Kernel Programmierung auskennt. Es geht darum eine Schnittstelle zu implementieren, wodurch mein Programm den Bildschirm um 90,180 bzw 270 grad dreht. Denn zur Zeit, kann man dies nur beim Booten festsetzen, was meinen Anforderungen nicht ausreicht (Betriebssystem: Raspbian). Wenn jemand sich das zutraut und Lust dazu hat, würde ich um eine Privat Nachricht mit vorgestelltem Entgelt freuen.


    Beste Grüße :)

    hmm.. aber "i2c-dev" kann er nicht finden...



    Code
    pi@raspberrypi ~/Desktop/Projekte/I2C $ sudo apt-get install i2c-dev
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut.       
    Statusinformationen werden eingelesen.... Fertig
    E: Paket i2c-dev kann nicht gefunden werden.
    pi@raspberrypi ~/Desktop/Projekte/I2C $

    Hej,
    Cool nach sowas suche ich. Aber kannst du mir nochmal bei deinem Code Helfen? Habe noch einige Fehler und bin nicht sonderlich fit darin. Vermute mir fehlt eine Libary oder?



    Fehlermeldung:
    /tmp/ccnohmB7.o: In function `pcf8591_read_value':
    I2Cpcf8591.c:(.text+0x100): undefined reference to `i2c_smbus_read_byte_data'
    /tmp/ccnohmB7.o: In function `pcf8591_write_value':
    I2Cpcf8591.c:(.text+0x14c): undefined reference to `i2c_smbus_write_byte_data'
    collect2: ld returned 1 exit status

    Hej danke ich schau mir das in Ruhe mal an,
    und die Lösung zu meinem Problem war, dass ich das falsche Kommando anscheinend benutzt habe mit xset s reset funktioniert das, wie ich mir es vorstelle.


    Habe aber noch eine Frage wenn ich den Bildschirmschoner (Rasbian) anschalte ohne Animationen. Dürfte dieser doch auch weniger Strom verbrauchen, jedenfalls habe ich das im Internet gelesen. Trifft das auch auf den Respberry zu? Und wenn ja, liegt das daran, dass dieser weniger Rechenaufwand für den XServer hat? Oder woran?


    Beste Grüße