Posts by EKopi

    Ja, das wäre schön, das 'apt-get upgrade' geht sonst im Moment bei allen anderen außer mir?undefined
    Also was ich gemacht habe:
    Raspi3 gekauft, eine SD Karte entsprechend
    https://www.raspberrypi.org/do…nstalling-images/linux.md
    dd bs=4M if=2016-05-27-raspbian-jessie.img of=/dev/sdd
    dd bs=4M if=/dev/sdd of=from-sd-card.img
    truncate --reference 2016-05-27-raspbian-jessie.img from-sd-card.img
    diff -s from-sd-card.img 2016-05-27-raspbian-jessie.img


    mit dem Raspbian Image versehen.
    Läuft bis jetzt super, ist aber nicht aktuell, also


    apt-get update (ok)
    apt-get upgrade -> dkpg Fehler (1) bei perl-modules
    nach einer Wiederholung mit -f -> SD Karte nicht mehr ansprechbar


    - beim ersten Versuch habe ich mit einem Monitor über HDMI gerabeitet
    - bei dem dritten Versuch war nur das Netzwerk angeschlossen, kein Monitor / Tastatur / Maus (ssh),
    das upgrade lief wesentlich weiter, die Fehler kamen später.


    Könnte es ein Resourcenproblem beim Upgrade sein? Ich werde mal sehen, ob ich das in einer virtuellen Maschine reproduzieren kann.
    Automatisch zusammengefügt:[hr]
    P.S. die SD Karte ist eine Intenso SDHC 8GB class 10

    leider kann ich mit dem Raspi nichts mehr machen, ein Neustart geht nicht mehr, und damit sind auch die Raspi Fehlermeldungen weg. Es waren immer wieder Meldungen vom dpkg Fehler (1) oder Fehler(2) und am Schluß mit dpkg und 'broken pipe' Ich hatte ein apt-get upgrade -f als letztes ausgeführt.


    Die SD Karte war im PC (Ubuntu 16.04) als /dev/sdd lesbar, jetzt scheint es das device /dev/sdd noch zu geben, es ist aber in gparted nicht sichtbar und ich kann nichts drauf schreiben:



    ekopiske@Ursa1604:~$ df -h
    Dateisystem Größe Benutzt Verf. Verw% Eingehängt auf
    udev 7,4G 0 7,4G 0% /dev
    tmpfs 1,5G 9,5M 1,5G 1% /run
    /dev/sdc2 444G 25G 397G 6% /
    tmpfs 7,4G 220K 7,4G 1% /dev/shm
    tmpfs 5,0M 4,0K 5,0M 1% /run/lock
    tmpfs 7,4G 0 7,4G 0% /sys/fs/cgroup
    /dev/sdb2 96M 29M 68M 30% /boot/efi
    tmpfs 1,5G 4,0K 1,5G 1% /run/user/108
    tmpfs 1,5G 44K 1,5G 1% /run/user/1000


    ekopiske@Ursa1604:~$ ls /dev/sd*
    /dev/sda /dev/sdb1 /dev/sdb3 /dev/sdb5 /dev/sdc1 /dev/sdc3
    /dev/sdb /dev/sdb2 /dev/sdb4 /dev/sdc /dev/sdc2 /dev/sdd


    ekopiske@Ursa1604:~/Downloads$ sudo dd bs=1M if=2016-05-27-raspbian-jessie.img of=/dev/sdd
    dd: konnte '/dev/sdd' nicht öffnen: Kein Medium gefunden


    Ich werde mir Morgen mal noch eine dritte SD Karte besorgen, die kosten ja nicht mehr viel...
    Viele Grüße

    Habe gerade einen Raspi 3 mit einem Raspian neu installiert.
    Das geht alles super, der Raspi läuft glatt. Aber um ein 7" Display anzuschließen habe ich folgendes gemacht:


    Code
    apt-get update 
    
    
    apt-get upgrade


    Das update der Quellen war OK, aber bei dem Update der perl-modules auf von ...8u4 auf ...8u6 gibt es immer wieder einen dpkg Fehler (1)



    Vor dem Upgrade sieht es so aus:

    Code
    apt search perl-modules
    
    
    perl-base/stable 5.20.2-3+deb8u6 armhf [upgradable from: 5.20.2-3+deb8u4]
     minimal Perl system
    
    
    perl-modules/stable 5.20.2-3+deb8u6 all [upgradable from: 5.20.2-3+deb8u4]
     Core Perl modules


    jede weitere Installation klappt dann nicht mehr (gleicher dpkg Fehler).
    Dies habe ich zwei Mal mit dem gleichen Ergebnis probiert.
    Beim dritten Versuch liefen diese Sachen durch, aber der Raspi erkennt keine Kommandos mehr und ich kann mich auch nicht mehr per SSH einloggen.
    Jetzt schient die SD Karte scheint defekt zu sein, ich kann sie im PC nicht mehr sehen, weder mit Linux noch mit Windows.
    Das ist mir jetzt schon mit der zweiten Karte passiert.


    (Die SD Karte hat 8GB, die sind laut 'df-h' zu 50% verfügbar, Raspi3 1GB RAM)


    Hat vielleicht jemand eine Idee, was da schiefgeht?
    Besten Dank für die Hilfe, undefined
    EKopi

    In dem Fritz Box Web Frontend gibt's ein Fenster Internet->MyFritz
    Dort mit einer Mailadresse bei MyFritz anmelden.
    Der Status sollte nach einiger Zeit auf "angemeldet" gehen.
    Bestimmt ist aus Sicherheitsgründen der Zugriff für die Konfiguration über https sinnvoll.
    Die Funktion habe ich aber noch nicht so ganz durchschaut, ich hatte immer eine unverschlüsselte Verbindung zur Fritz Box Konfiguration.
    Aber ich habe es nur aus meinem internen Netz probiert.


    Dann unter MyFritz!-Freigaben den RaspBerry Pi als http Server hinzufügen (Port 80).
    Dafür muss der Raspberry im LAN oder WLAN der Fritzbox eingestöpselt sein


    Es gibt dann eine etwas kryptische http://.......myfritz.net:80/ Adresse
    Über die kannst Du aus dem Netz auf den RaspBerry zugreifen.
    Für andere Protokolle wie ssh müssen andere Ports freigegeben werden.


    viel Spaß,
    Ekopi

    Hallo Snorri,


    genau das habe ich gestern mal probiert,...
    Es klappte eigentlich ohne größere Probleme.
    Wie die Turael beschrieben hat gibt's sehr gute Tutorials,..[Blocked Image: http://www.forum-raspberrypi.d…lies_green/icon_smile.gif]
    Ich habe einen SSH Server eingerichtet: SSH Zugang auf dem Raspberry Pi einrichten
    Dann den Apache2: Raspberry Pi als Webserver - Apache 2 Installation
    Und noch PHP: Raspberry Pi als Webserver - PHP 5 Installation
    Um einfach Dateien auf den RPi übertragen zu können noch den Raspberry Pi als Webserver - FTP-Server Installation


    Die Konfiguration lief jeweils genau wie im Tutorial beschrieben und funktionierte promt![Blocked Image: http://www.forum-raspberrypi.d…ies_green/icon_bravo2.gif]


    Den Zugang habe ich nicht über DynDNS sondern über MyFritz gemacht, da DynDns unbedingt meine Kreditkartennummer bei der NSA hinterlegen wollte (auch wenn es einen gratis Account gibt). Außerdem muss man sich jeden Monat einmal auf seinem DynDNS Account einloggen.
    Ich hoffe, bei MyFritz geht das besser. Der Anfang sah sehr gut aus! Die Anmeldung ist unkompliziert über das Web Frontend der Fritz Box.
    Vielen Dank noch mal allen, die an den hervorragenden Tutorials mitgeschreiben haben!
    [Blocked Image: http://www.forum-raspberrypi.d…green/icon_danke_ATDE.gif]
    Ekopi