Posts by jovo0911

    Hallo Peppy.Player,


    ich denke ich habe ein grundlegendes Problem mit dem darunterliegenden Debian! Nach upgrade auf die "Monet Edition" läuft der player. D.h. ich kann Radio und Audio benutzen - aber ich kann ihn nicht mehr ausschalten! - weder per gui noch per touch.
    Somit werde ich wohl ein komplett neues Image aufspielen müssen. Demnächst ;-))
    Ich danke Dir für die Unterstützung bis hierher.


    Jochen

    Hi Peppy.player,


    Ist so ziemlich alles Standard. Ich füge die config.txt mal an ...

    Können Sie mir erklären, wie ich das Problem mit den aktivierten Schaltflächen reproduzieren kann?


    uh, wie soll ich das beschreiben - ich versuche es.

    wenn ich z.b. die Lautstärke im Webinterface ändere (dazu faße ich den Regler mit der maus an) bewege ihn in die gewünschte Richtung) und lasse ich dann die Maus los - bleibt der Regler aktiv. Berühre ich dann den Touchscreen oder klicke in das Webinterface - springt der Regler (für mich unkontrolliert) irgendwo hin.

    Da ich hier so etwas noch nicht gelesen habe, denke ich das dieser Effekt nur bei mir auftritt, also an meinen Einstellungen liegen muss.

    Hi Peppy.Player,


    ich werde in der nächsten Zeit auf "Renoir" updaten.

    Zu meinem Problem mit den aktivierten schaltflächen: kann es sein das es daran liegt das ich "Web" UND "Touchscreen" benutze"


    ------------------------------------------------------------------------------

    Hi Peppy.Player,


    I will update to "Renoir" in the near future.

    Regarding my problem with the activated buttons: Could it be because I use "Web" AND "Touchscreen"?

    Hi peppy.player,

    vielen Dank für deine Unterstützung.

    Du hast recht es sind eine menge Einstellmöglichkeiten :conf: Ich habe die von dir vorgeschlagenen mal genommen. Das sieht gut aus - aber wie Du schon geschrieben hast ändert sich auch der Audiobereich. Ich hatte schwarzen Bildschirm sowohl in web und auf den TFT. Aber nach mehrmaligen Versuchen (Wechsel zwischen Radio und Audio Bereich) wurde der Audiobereich dann auch angezeigt. Cache? oder umrechnen der "Icon's" aus den .mp3 Dateien?

    Beeinflußen die Einstellungen auch die Klick oder Touchflächen? der Lautstärkeregler bliebt nämlich aktiviert! Erst durch klick auf den TFT wurde er wieder deaktiviert.

    Ein Problem habe ich noch - ich verliere die Favoriten Markierung der Station wenn ich die Station in der Favoritenliste anklicke. Ich denke der Parameter "long.press.time.ms" ist dafür zuständig. Er steht auf Standardwert 700.
    Aber wie Du sicherlich bemerkt hast benutze ich den Player "nur" zumindest das letzte und dieses Jahr - OK it's tinkertime ;)


    Jochen

    Hallo Peppy.Player,


    der player läuft nu seit einigen Jahren ;) letzter Post von mir war #76 ... Kurzer Zwischenbericht.

    In der gesamten Laufzeit eigentlich keine größeren Abstürze oder sonstige Aussetzer, wenn - dann selbst verursacht!
    Hardware ist ein RPi3+, 5" 800x600 kapazitives Display die soundausgabe erfolgt per bluetooth(Flip4) BS ist nun ein Debian Buster.

    Ich bin nun beim Release "Monet Edition" angekommen. Auch diese Edition läuft zuverlässig.

    Kritik oder Wünsche gibt es ebenfalls ... So fand ich persönlich die Stationsauswahl per Kachel besser.
    Mit der jetzigen Listenauswahl verliert er öfters den Favoritstatus (zu lange oder ungenau gewählt).
    Naja und ich vermisse eine Stationssuche per Player.... aber wie schon erwähnt - meine persönliche ... ;)
    Bitte versuche weiter an dem Player zu arbeiten ...

    Vielen Dank :danke_ATDE:

    Jochen


    Hello peppy.player,


    vielen Dank für diesen tollen Player. Ich benutze nun "Goya" seit Anfang November aus den Github - ohne irgendwelche Probleme.

    Ich benutze ihn "headless" - ohne Display (Display ist kaputt)

    Der Player läuft bis zu 12 stunden am tag - in der ganzen Zeit habe ich 2 - 3 mal den Stream verloren.

    :danke_ATDE:

    --


    thank you for this great player. I use now "goya" from first day's from github in November without any problem.

    I use it headless - without display (display was damaged).

    The player run up to 12 hour per day - in the whole time I've only 2-3 times lost the stream.

    peppy.player  kle


    OK habe nun den "vlc" als player - mit Bluetooth JBL Flip 4 :danke_ATDE:


    Musste den "alsamixer" einmal starten damit es funktioniert. :cursing:

    Aber es spielt mit deutlich geringerer Lautstärke wie mit dem "mpd" oder "mplayer".

    Mal schauen ob man da noch was konfigurieren kann.


    @peppyplayer

    vlc liest die ID3 ID's der audiodateien aus und speichert sie im cache. ;)

    /home/pi/.cache/vlc/art/artistalbum/Dj\ Miray/Dance\ Megamix\ August\ 2018/art.jpg

    das ist das Coverbild der mp3 audiodatei "Dance Megamix August 2018 mixed by Dj Miray.mp3"

    kle


    grummelt "alsamixer" ist der Grund warum VLC nicht lief!

    Einmal aufgerufen - und klack nu läuft VLC. Nur leider tut er sich schwer mit Bluetooth - will "noch" nicht.

    Hallo jovo0911,

    zu den bereitgestellten Images kann ich nichts sagen. Auch besitze ich keine Hdmi-Displays, aber bei mir funktioniert der Lautstärkeregler.


    Es gab mal einen Fehler, daß man erst leise und dann wieder laut stellen mußte, weil der Slider auf ein größeres/kleineres Display eingestellt war und erst bei Bedienung des Sliders sich "justierte".

    Den Punkt habe ich nicht ausprobiert, werde ich aber gleich nachholen ;)

    Ansonsten bin ich ebenfalls nach der Anleitung vorgegangen.


    peppy.player schreibt ja das er "vlc" bevorzugen möchte - na dann werde ich mich mal dran machen - bis dato wollte der nicht.

    Da "mpd" und "mplayer" funktionierten hatte "vlc" keine große prio ...

    peppy.player


    Hi,


    zuerst - es ist kein Problem das einige Sachen nicht funktionieren. Dafür tauschen wir uns ja aus.


    Ich benutze ein 3,5" Quinta MP3508. Es waren nur wenige Änderungen nötig.


    Code: /boot/config.txt
    hdmi_drive=2
    hdmi_force_hotplug=1
    hdmi_group=2
    hdmi_mode=87
    hdmi_cvt 720 480 60 6 0 0 0
    dtoverlay=ads7846,cs=1,penirq=25,penirq_pull=2,speed=50000,keep_vref_on=0,swapxy=0,pmax=255,xohms=150,xmin=200,xmax=3900,ymin=200,ymax=3900
    Code: /etc/udev/rules.d/95-ads7846.rules
    SUBSYSTEM=="input", KERNEL=="event[0-9]*", ATTRS{name}=="ADS7846 Touchscreen", SYMLINK+="input/touchscreen"


    Das zum Display gehörende "LCD-Show" starten.

    Touchscreen calibrieren (ts_calibrate und ts_test)


    In meinem Fall "raspi-config -> Advanced Options -> Audio -> HDMI"

    Das Display hat einen eigenen Audio-Ausgang (headphone jack)


    Ich denke mehr war es nicht


    Deine Frage "warum nicht vlc" ist einfach zu beantworten - kein Sound!

    Weder am "Audio jack raspi" noch am "HDMI Display jack" war Sound zu hören.

    Da mpd sofort funktionierte .... ;)


    Ok dann werde ich mal versuchen "vlc" zur Mitarbeit zu bewegen ...


    regards

    @peppy.player

    ich habe nun "peppy" ein paar Tage am laufen, war bis dahin sehr viel "trail and error"


    ich benutze das "Waveshare 5.0" HDMI LCD (Affiliate-Link)" Image allerdings mit einem 3,5" HDMI Display und Bluetooth Lautsprecher(JBL)

    Als player verwende ich nun "mpd"

    In "mplayer" funktioniert der Lautstärkeregler nicht mit der Bluetooth Device zusammen.


    mit "mld" funktionierten die Audiodateien nicht - erst nach einem manuellen "mpc update" war es möglich die Dateien abzuspielen.

    in der "mpd.conf" sind die Punkte "auto_update "yes"" und "auto_update_depth "0"" gesetzt.

    Auch wird der Musik Titel nicht korrekt angezeigt (ist der letzte Radio Titel der angezeigt wird)

    "Album Cover Art" wird ebenfalls nicht angezeigt ( bei switch zurück auf Radio ist das Cover zusehen bis es vom "Radio" überschrieben wird.


    Ist es möglich das "Cover" aus dem ID3 Tag anzuzeigen?


    thx for helping ...