Posts by migoelo

    Sorry, habe erst jetzt deine Nachfrage in #6 gesehen wegen der geänderten IP 10.8.0.1 zu 10.8.0.2. Ich hatte unter #1 geschrieben das dies für den Client 10.8.0.2 (oder andere) gelten sollte. Deswegen dachte ich hier liegt ein Typo vor. Ich hatte auch vor --dport 445 noch ein Leerzeichen gesetzt. Da mich die ganze Logik dahinter immer mehr verwirrt, hier jetzt mal die Grundeinträge in der iptables wie es derzeit ohne Enschränken funktioniert für alle Clients. Es sei noch erwähnt das der OpenVPN-Server und Pihole als DNS-Server auf dem Raspberry mit der IP 192.168.0.37 läuft, und als solcher in der FB eingetragen ist.

    iptables -S:


    Meines Wissens nach ist die IP 10.8.0.1 für den Server reserviert. In der /etc/openvpn/server.conf steht:

    Code
    server 10.8.0.0 255.255.255.0
    # Set your primary domain name server address for clients
    push "dhcp-option DNS 10.8.0.1"
    push "block-outside-dns"


    Ich möchte erreichen:

    10.8.0.2 (Eingeschränkter Nutzer -> Client 1 nur LAN-Zugriff auf 192.168.0.1, und Internet über eigenen (z.B. Handy-Provider)

    10.8.0.3 (Vollzugriff -> Client 2 LAN-Zugriff auf 192.168.0.1 und ebenso Internet)

    10.8.0.4 (Vollzugriff -> Client 3 LAN-Zugriff auf 192.168.0.1 und ebenso Internet)

    .

    .

    .

    sudo iptables -nvx -L sagt


    und bei deinem zweiten Eintrag weiß ich nicht wie ich das von einem iPhone (oder testweise PC) machen kann. Ist mtr ein Tool?

    Mit diesen drei Einträgen scheint wieder alles offen zu sein, Internet und LAN ist so erreichbar.


    Das sagt hier übrigens iptables -L

    Ich habe das mal getestet, und es scheint für http/https Anfragen zu funktionieren (ich teste das mit iPhone über Mobilnetz). Läßt sich das erweiteren für SMB Anfragen? Habe vergessen zu erwähnen das nur die FritzNAS (192.168.0.1) für diesen Client ausschließlich per SMB port 445 erreichbar sein soll, alle anderen SMB Server nicht. Danke nochmal.

    Hallo zuammen,


    da meine vorherige Frage bezüglich OpenVPN Split-Tunnel noch nicht beantwortet wurde, wollte ich fragen ob das generelle sperren über die Firewall IPTABLES der bessere Weg ist. Derzeit sieht der Inhalt meiner v4 rules folgendermaßen aus.

    Was müßte ich denn eintragen, damit der OpenVPN Client mit der IP 10.8.0.2 (oder mehr Clients) nur Zugriff auf meine FritzNAS mit der IP 192.168.0.1 hat, also kein Internetzugriff, und kein Zugriff auf andere LAN-Addressen? Danke


    Gruss

    Hallo zusammen,


    ich habe auf meinem Raspi4 einen OpenVPN-Server laufen. Alle Clients (Windows 10/iPhone) können von extern auf mein Heimnetzwerk zugreifen, und verwenden beim Zugriff auf das Internet meinen Provider (auch wegen PiHole). Jetzt würde ich gerne die Möglichkeit dahingegen einschränken, dass manche Clients nur über einen OpenVPN Splitted-Tunnel zugreifen können, d.h. es soll möglich sein auf mein Netzwerk 192.168.178.0/24, oder besser nur auf die Fritz!NAS zuzugreifen, der Internetzugriff soll aber nur über den eigenen Provider möglich sein.

    Kann ich dies über einen passenden Eintrag in der Konfig-Datei *.ovpn umsetzen?

    Vielen Dank


    Grüße

    Ich konnte übrigens inzwischen ein eigenes Paket tvheadend_4.3-1964~g637844055_armhf.deb mit der Reddit Anleitung kompilieren. Es läuft inzwischen auf meinem Raspberry Pi 3, muss aber erstmal eine Zeit lang beobachten ob der RAM hier auch gefressen, und nicht wieder hergegeben wird.

    Hallo zusammen,


    da die per apt install installierbare TVHeadEnd Version 4.2.8 bei mir mir der Zeit den RAM frisst, und nicht mehr freigibt, wollte ich versuchen die Version 4.3 selber auf meinem Raspberry Pi 3 kompilieren. Das Speicher Problem scheint übrigens nicht unbekannt, mit der Empfehlung die 4.3 zu testen. Es gibt zwar hier im Forum Tutorials (sehr alt), die aber nicht zum Erfolg geführt haben. Da ich ein absoluter Anfänger bin, wäre ein Copy&Paste Anleitung natürlich am schönsten. Am Ende hätte ich gerne ein .deb Paket vorliegen, das ich anschließen installieren könnte. In Reddit habe ich folgendes gefunden Reddit Anleitung, und weiß nicht ob das so funktioniert. Beim Paket libcurl14-gnutls-dev wird z.B. schon gemeckert. Danke schonmal.

    Ich weiß nicht ob ich den Punkt mit der Filmkodierung richtig verstanden habe, aber die Quelle ist der Server TVHeadEnd auf dem Raspi (3 oder 4) wo immer die selbe original DVB-C Kodierung verwendet wird, also ohne Umkodierung. Dazu fehlt dem Raspi die Power. Auf der anderen Seite ist es der Client von TvhClient einmal auf dem ApplelTV oder dem iPhone oder iPad aber auch VLC auf dem Win Rechner. Die Quelle ist also immer die selbe, und das kann auch zur selben Zeit sein. Ich versuche mal die Netzteile zu tauschen oder auch den Standort des Raspi

    Das weiter testen muss ich auf das nächste WE schieben, die Raspi3 Konfiguration funktioniert ja. Wenn ich per htop die Auslastung prüfe, sieht es übrigens so aus als ob sich der Raspi3 langweilt, und das trotz Aufnahme von 2 HD-Streams dabei auf unterschiedlichen Clients sehen. Zu den Vorschlägen aber noch:

    Kodi direkt für das AppleTV gibt es glaube ich nicht, da die Möglichkeit (böse) Plugins zu nutzen nicht gewünscht ist. Allerdings gibt es eingeschränkte Forks wie MRMC die auch das TVHeadEnd Plugin nutzen, und keinen Unterschied zeigen. BTW. ich mag TvhClient, eine Aussage über MRMC verkneife ich mir.

    Zum deaktivieren von BT/WLAN, hatte ich auch schon probiert, ohne Verbesserung. Es wird allerdings hier auch erwähnt Elektronik Kompendium , dass das abschalten nicht dazu führt das weitergefunkt wird.

    Der Vorschlag mit ethtool und mit sysctl zu suchen bedeutet wohl ein weiteres male viele Stunden zu investieren :-|.

    Ich werde auch noch testen ob der Wechsel der Strom-Steckdose etwas bringt, vermute aber das im Zimmer alles über die selbe Leitung geht.

    Also,

    • Das verwendete Netzteil ist ein Original, so sieht es von außen zumindest aus :) . Hier der Link Achtung hier gehts zum Amazon (Affiliate-Link). Es ist übrigens am Raspi lediglich folgender USB DVB-C Tuner von Hauppauge (WinTV dualHD) angesteckt Achtung hier geht es wieder zum Amazon (Affiliate-Link). lsusb -v gibt als maxpower 500mA aus.
    • Habe vergessen zu erwähnen, AppleTV und raspi4 oder 3 sind immer per LAN mit der FritzBox oder auch mal testweise per Switch verbunden.
    • Es wurde keine Sicherung vom Raspi3 zurückgespielt, sondern für den raspi4 alles neu installiert.
    • hyle hat mich richtig verstanden, nur über den AppleTV abgespielte Streams zeigen Störungen. Wenn ich zur selben Zeit parallel an einem anderen Client z.B. Windows 10/VLC den selben Sender sehe, sehe ich keine Störungen.

    Da der AppleTV schon getauscht wurde, und ebenso die LAN Kabel, habe ich die Vermutung das der raspi 4 zwar den Stream richtig ins LAN schickt, aber der AppleTV währendessen über andere Wege durch den raspi4 gestört wird (EMV ??).

    Hallo zusammen,


    ich habe hier ein sonderbares Problem mit einem Raspberry Pi 4 beim TV-Stream sehen auf einem AppleTV (App TvhClient). Das TV-Bild bricht dabei in regelmäßigen Abständen (ca. alle 20 Sekenden) mit Blockbildung zusammen, und ist dann nach 1-2 Sekunden wieder da. Wenn ich den selben Stream zeitgleich am iPhone oder iPad oder Win10 Laptop sehe gibt es keine Probleme. Eine Aufzeichnung zeigt auch keine Probleme. Bei gleicher Software-Konfiguration aber auf einem Raspberry Pi 3 habe ich auch keine Probleme. Der Raspberry Pi steht dabei immer ca. 20 cm neben dem AppleTV. Der AppleTV wurde übrigens deshalb schonmal getauscht ohne Änderung. Kann es sein das der Raspberry Pi in den AppleTV rein stört, und wie kann ich das lösen ohne Standortwechsel? Als nicht Aluhut Träger habe ich übrigens auch mal den Raspberry Pi 4 mit Alufolie soweit möglich vom AppleTV getrennt ;( , hat aber nichts gebracht. Danke

    Hallo


    melde mich spät, was aber nicht bedeutet das mich das Thema nicht mehr interessiert ;) . Ich habe als Firewall ufw aufgegeben, und probiere die letzten Tage immer wieder mit iptables zum Ziel zu kommen. Grundsätzlich stellt sich mir die Frage ob ich auf dem Raspberry überhaupt eine Firewall benötige, da er ja hinter einer FritzBox hängt, und lediglich der Port 1194 udp an den Raspi weitergeleitet wird. Trotzdem habe ich mich ran gewagt, und es scheint fast alles so zu funktionieren wie ich das will. Da ich aber nicht sagen kann das meine Rules wirklich sauber sind, wollte ich hier nochmal nachfragen?


    fur ipv4

    für ipv6

    Vielen Dank erstmal für die Unterstützung! Läßt sich das auch auf UFW übertragen und testen? Ich muß gestehen, dass ist mir zu kryptisch. Meine derzeitigen UFW Freigaben sind


    Nachtrag:

    Ich habe mal folgende zwei Regeln hinzugefügt, erschien mir irgendwie loglisch. Der Client kommt so zwar nicht mehr ins Internet (schonmal gut), aber im eigenen Netzwerk kommt er schon durch, also nicht nur auf ..100.50 .


    Code
    Anywhere                   DENY IN     10.8.0.17
    192.168.100.50             ALLOW IN    10.8.0.17