Posts by Alex_2101

    Wenn Du auch späteren Benutzern dieser Webseite Deine gefundene Lösung nicht vorenthalten willst, sagst Du auch, wie Du den Fehler behoben hast, und markiere den Thread als erledigt (rechts oben).


    Für andere Probleme erstelle lieber einen neuen Thread in dem dafür vorgesehenen Bereich.


    Servus !

    Werde ich machen, danke

    Morgen,


    Ich habe in MySQL DB jeden Benutzer das Bild hinzugefügt, nun hapert es mit der Ausgabe .


    Was mache ich falsch? Könntet ihr mir auf die schnelle helfen?



    <?php

    // Abfrage des Benutzers mit der ID 1

    $pdo = new PDO('mysql:host=localhost;dbname=mydb', 'root', 'mypassword');


    $sql = "SELECT * FROM TAB_PHP WHERE kunde_id = ?";

    foreach ($pdo->query($sql) as $row) {

    echo $row['vorname']." ".$row['nachname']." ".$row['images']. "<br />";

    }

    ?>

    Mit dem folgenden Script hat es geklappt.


    <?php


    $pdo = new PDO('mysql:host=localhost;dbname=mydb', 'root', 'mypassword');


    $sql = "SELECT * FROM TAB_PHP WHERE kunde_id = 25788227";

    foreach ($pdo->query($sql) as $row) {

    echo $row['vorname']." ".$row['nachname']."<br />";


    }

    ?>


    Habe 2 weitere Fragen:


    1) Ich habe für Jedes Kunden ID einen Bild, wie kann ich das Bild den Kunden zuweisen.

    Die Bilder habe ich in /var/www/html abgespeichert.


    2) Das wird wahrscheinlich das schwierigste , wie bringe ich RFID in PHP script zum laufen. Ich möchte ja, dass die Chip ID gelesen wird mit DB verglichen und dann wenn es erfolgt die Ausgabe auf der Webseite erstellt. Muss wahrscheinlich den Script komplett umbauen um an nötigen Ergebnis zu kommen :(

    Morgen Zusammen,


    Habe folgendes Script in Index.php erstellt , leider funktioniert er nicht. :(

    Ich versuche damit, dass sobald ich den Chip auf dem RFID-RC522 Sensor lege, der die Daten von Chip abliest und mit den Daten in der Datenbank(MySQL) abgleicht(Die Datenbank habe ich erstellt),und wenn die Daten stimmen einen Ergebnis auf der Seite anzeigt.

    In Form Kunden ID, Name, Vorname und das Foto von der Person(habe ich noch nicht hinbekommen).


    Datenbank beinhaltet: Kunden Id, Name, Vorname.


    Erst mal danke an alle für die Unterstützung. :)


    Kurze frage: ich habe index.html in index.php geändert, also den Inhalt mit PHP klammern versehen, leider will der Server die Index.php nicht ausführen.

    Die Datei Info.php kann ich ausführen.


    Muss ich an rechten was verändern, damit ich die Datei ausführen kann?

    Ich brauche PHP für die Datenbank Einbindung.



    Vielen Dank, hat alles geklappt

    Ich kann user "ich" nicht einfügen,


    adduser: Der Benutzer »ich« existiert nicht.



    ls -al /var/www

    drwxr-sr-x 5 pi www-data 4096 Apr 25 09:23 .

    drwxr-xr-x 12 root root 4096 Feb 6 11:18 ..

    drwxr-sr-x 2 pi www-data 4096 Apr 25 09:24 cognition

    drwxr-sr-x 2 pi www-data 4096 Apr 24 08:03 go4cognition_game

    drwxr-sr-x 2 pi www-data 4096 Apr 24 13:26 html

    -rwxr-sr-x 1 pi www-data 942 Apr 24 08:02 index.html

    -rwxr-sr-x 1 pi www-data 26 Apr 24 09:38 phpinfo.php

    lrwxrwxrwx 1 pi www-data 22 Feb 6 12:33 phpmyadmin -> /usr/share/phpmyadmin/

    Nochmal, Der User "ich" ist in /etc/passwd nicht eingetragen. Siehe < tac /etc/passwd > [im Terminal ohne <> eingegeben]. Der kann sich nichtmal einloggen, geschweige denn Dateien erzeugen, oder verschieben.


    Und ab /var/www/ abwärts gehören alle Dateien und Verzeichnisse dem User www-data der Gruppe www-data. Das sollen sie zumindest, damit der Webserver in seiner "Sandbox" läuft.


    Servus !

    Hallo zusammen,


    habe Unser pi erstellt.

    bei (sudo apache2ctl -S) den Fehler korregiert in apache2.conf() habe ich ServerName localhost eingefügt.


    Die Ausgabe sieht danach so aus.


    VirtualHost configuration:

    *:80 localhost (/etc/apache2/sites-enabled/000-default.conf:1)

    ServerRoot: "/etc/apache2"

    Main DocumentRoot: "/var/www/html"

    Main ErrorLog: "/var/log/apache2/error.log"

    Mutex default: dir="/var/run/apache2/" mechanism=default

    Mutex mpm-accept: using_defaults

    Mutex watchdog-callback: using_defaults

    PidFile: "/var/run/apache2/apache2.pid"

    Define: DUMP_VHOSTS

    Define: DUMP_RUN_CFG

    User: name="www-data" id=33

    Group: name="www-data" id=33



    Die Ausgabe bei dem Befehl tac /etc/passwd


    saned:x:116:121::/var/lib/saned:/bin/false

    colord:x:115:120:colord colour management daemon,,,:/var/lib/colord:/bin/false

    postgres:x:114:117:PostgreSQL administrator,,,:/var/lib/postgresql:/bin/bash

    mysql:x:113:116:MySQL Server,,,:/nonexistent:/bin/false

    ftp:x:112:65534::/srv/ftp:/bin/false

    proftpd:x:111:65534::/run/proftpd:/bin/false

    xrdp:x:110:115::/var/run/xrdp:/bin/false

    lightdm:x:109:113:Light Display Manager:/var/lib/lightdm:/bin/false

    avahi:x:108:112:Avahi mDNS daemon,,,:/var/run/avahi-daemon:/bin/false

    sshd:x:107:65534::/run/sshd:/usr/sbin/nologin

    statd:x:106:65534::/var/lib/nfs:/bin/false

    messagebus:x:105:109::/var/run/dbus:/bin/false

    pi:x:1000:1000:,,,:/home/pi:/bin/bash

    _apt:x:104:65534::/nonexistent:/bin/false

    systemd-bus-proxy:x:103:106:systemd Bus Proxy,,,:/run/systemd:/bin/false

    systemd-resolve:x:102:105:systemd Resolver,,,:/run/systemd/resolve:/bin/false

    systemd-network:x:101:104:systemd Network Management,,,:/run/systemd/netif:/bin/false

    systemd-timesync:x:100:103:systemd Time Synchronization,,,:/run/systemd:/bin/false

    nobody:x:65534:65534:nobody:/nonexistent:/usr/sbin/nologin

    gnats:x:41:41:Gnats Bug-Reporting System (admin):/var/lib/gnats:/usr/sbin/nologin

    irc:x:39:39:ircd:/var/run/ircd:/usr/sbin/nologin

    list:x:38:38:Mailing List Manager:/var/list:/usr/sbin/nologin

    backup:x:34:34:backup:/var/backups:/usr/sbin/nologin

    www-data:x:33:33:www-data:/var/www:/usr/sbin/nologin

    proxy:x:13:13:proxy:/bin:/usr/sbin/nologin

    uucp:x:10:10:uucp:/var/spool/uucp:/usr/sbin/nologin

    news:x:9:9:news:/var/spool/news:/usr/sbin/nologin

    mail:x:8:8:mail:/var/mail:/usr/sbin/nologin

    lp:x:7:7:lp:/var/spool/lpd:/usr/sbin/nologin

    man:x:6:12:man:/var/cache/man:/usr/sbin/nologin

    games:x:5:60:games:/usr/games:/usr/sbin/nologin

    sync:x:4:65534:sync:/bin:/bin/sync

    sys:x:3:3:sys:/dev:/usr/sbin/nologin

    bin:x:2:2:bin:/bin:/usr/sbin/nologin

    daemon:x:1:1:daemon:/usr/sbin:/usr/sbin/nologin

    root:x:0:0:root:/root:/bin/bash



    Kommen wir zur meinen Fragen:


    Kann es dadran liegen dass ich die Ordner Struktur nicht sehe, weil in info.php(die Datei liegt auf Apache Server und wird als einzige erkannt)

    weil in der Datei DOCUMENT_ROOT /var/www/html oder CONTEXT_DOCUMENT_ROOT /var/www/html?




    P.S. Danke an alle für die Hilfe, hat mich schon einwenig weiter gebracht.

    Ich habe eine kleine Webseite erstellt, Index.php, ganzes Inhalt(CSS und andere Sache) habe ich in den Ordner gepackt.

    Dann habe ich den Ordner nach var/www verschoben.

    Nun will ich die Seite Starten, aber da der Ordner nicht erkannt wird, kann ich dadrauf nicht zugreifen.


    Meine Frage: wie kann ich es lösen?

    Die Ordner die im WWW Verzeichnis, werden beim aufrufen von Web Server nicht angezeigt.

    habe versucht die JS zu starten, es kommt immer wieder die Fehlermeldung:


    module.js:339

    throw err;

    ^


    Error: Cannot find module 'node-hid'

    at Function.Module._resolveFilename (module.js:337:15)

    at Function.Module._load (module.js:287:25)

    at Module.require (module.js:366:17)

    at require (module.js:385:17)

    at Object.<anonymous> (/home/pi/Desktop/node-rfid-master/rfid.js:4:11)

    at Module._compile (module.js:435:26)

    at Object.Module._extensions..js (module.js:442:10)

    at Module.load (module.js:356:32)

    at Function.Module._load (module.js:311:12)

    at Module.require (module.js:366:17)


    Wies jemand wie ich die beheben kann?

    Morgen,


    bin neue auf diesem Forum .

    ich brauche Hilfe bei meinem Projekt.

    Aufgabe: Die Daten von RFID Chip abzulesen, dann als Formular auf der Webseite anzeigen.


    Probleme: Habe de JS Script an HTML5 eingebunden, leider funktioniert er nicht. :(


    Habe folgende Fehlermeldung:


    module.js:339

    throw err;

    ^


    Error: Cannot find module 'node-hid'

    at Function.Module._resolveFilename (module.js:337:15)

    at Function.Module._load (module.js:287:25)

    at Module.require (module.js:366:17)

    at require (module.js:385:17)

    at Object.<anonymous> (/home/pi/Desktop/node-rfid-master/rfid.js:4:11)

    at Module._compile (module.js:435:26)

    at Object.Module._extensions..js (module.js:442:10)

    at Module.load (module.js:356:32)

    at Function.Module._load (module.js:311:12)

    at Module.require (module.js:366:17)



    Weis jemand wie ich die beheben kann?